6fa2f55b27
- Remove gdb-6.3-bt-past-zero-20051201.patch, gdb-archer-ada.patch and gdb-6.3-framepczero-20040927.patch already removed from .spec before. - Remove gdb-6.5-dwarf-stack-overflow.patch, upstreamed (Tom Tromey). - Remove gdb-6.6-bz225783-gdb-debuginfo-paths.patch, upstreamed (Tom Tromey). - Remove gdb-6.6-readline-system.patch, reimplemented upstream (Tom Tromey). - Remove gdb-bz642879-elfread-sigint-stale.patch, upstreamed (Jan Kratochvil). - Remove gdb-next-over-throw.patch, upstreamed (Tom Tromey).
73 lines
2.8 KiB
Diff
73 lines
2.8 KiB
Diff
We may abort the process of detaching threads with multiple SIGINTs - which are
|
|
being sent during a testcase terminating its child GDB.
|
|
|
|
Some of the threads may not be properly PTRACE_DETACHed which hurts if they
|
|
should have been detached with SIGSTOP (as they are accidentally left running
|
|
on the debugger termination).
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/defs.h
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/defs.h 2011-01-01 01:00:29.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/defs.h 2011-01-01 01:09:17.000000000 +0100
|
|
@@ -165,6 +165,7 @@ extern char *python_libdir;
|
|
extern char *debug_file_directory;
|
|
|
|
extern int quit_flag;
|
|
+extern int quit_flag_cleanup;
|
|
extern int immediate_quit;
|
|
extern int sevenbit_strings;
|
|
|
|
@@ -178,7 +179,7 @@ extern void quit (void);
|
|
needed. */
|
|
|
|
#define QUIT { \
|
|
- if (quit_flag) quit (); \
|
|
+ if (quit_flag && !quit_flag_cleanup) quit (); \
|
|
if (deprecated_interactive_hook) deprecated_interactive_hook (); \
|
|
}
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/event-top.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/event-top.c 2011-01-01 01:07:37.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/event-top.c 2011-01-01 01:09:39.000000000 +0100
|
|
@@ -904,7 +904,7 @@ async_request_quit (gdb_client_data arg)
|
|
is no reason to call quit again here, unless immediate_quit is
|
|
set. */
|
|
|
|
- if (quit_flag || immediate_quit)
|
|
+ if ((quit_flag || immediate_quit) && !quit_flag_cleanup)
|
|
quit ();
|
|
}
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/top.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/top.c 2011-01-01 01:00:29.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/top.c 2011-01-01 01:09:17.000000000 +0100
|
|
@@ -1254,7 +1254,9 @@ quit_force (char *args, int from_tty)
|
|
qt.args = args;
|
|
qt.from_tty = from_tty;
|
|
|
|
- /* We want to handle any quit errors and exit regardless. */
|
|
+ /* We want to handle any quit errors and exit regardless but we should never
|
|
+ get user-interrupted to properly detach the inferior. */
|
|
+ quit_flag_cleanup = 1;
|
|
catch_errors (quit_target, &qt,
|
|
"Quitting: ", RETURN_MASK_ALL);
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/utils.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/utils.c 2011-01-01 01:00:29.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/utils.c 2011-01-01 01:09:17.000000000 +0100
|
|
@@ -121,6 +121,11 @@ int job_control;
|
|
|
|
int quit_flag;
|
|
|
|
+/* Nonzero means we are already processing the quitting cleanups and we should
|
|
+ no longer get aborted. */
|
|
+
|
|
+int quit_flag_cleanup;
|
|
+
|
|
/* Nonzero means quit immediately if Control-C is typed now, rather
|
|
than waiting until QUIT is executed. Be careful in setting this;
|
|
code which executes with immediate_quit set has to be very careful
|