6fa2f55b27
- Remove gdb-6.3-bt-past-zero-20051201.patch, gdb-archer-ada.patch and gdb-6.3-framepczero-20040927.patch already removed from .spec before. - Remove gdb-6.5-dwarf-stack-overflow.patch, upstreamed (Tom Tromey). - Remove gdb-6.6-bz225783-gdb-debuginfo-paths.patch, upstreamed (Tom Tromey). - Remove gdb-6.6-readline-system.patch, reimplemented upstream (Tom Tromey). - Remove gdb-bz642879-elfread-sigint-stale.patch, upstreamed (Jan Kratochvil). - Remove gdb-next-over-throw.patch, upstreamed (Tom Tromey).
99 lines
4.0 KiB
Diff
99 lines
4.0 KiB
Diff
2004-11-18 Andrew Cagney <cagney@gnu.org>
|
|
|
|
* dwarf2read.c: Include "top.c".
|
|
(dwarf2_has_info): Check for readnever_symbol_files.
|
|
* symfile.c (readnever_symbol_files): Define.
|
|
* top.h (readnever_symbol_files): Declare.
|
|
* main.c (captured_main): Add --readnever option.
|
|
(print_gdb_help): Ditto.
|
|
|
|
2004-11-18 Andrew Cagney <cagney@gnu.org>
|
|
|
|
* gdb.texinfo (File Options): Document --readnever.
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/doc/gdb.texinfo
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/doc/gdb.texinfo 2010-12-29 09:01:31.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/doc/gdb.texinfo 2011-01-01 00:54:07.000000000 +0100
|
|
@@ -1007,6 +1007,12 @@ Read each symbol file's entire symbol ta
|
|
the default, which is to read it incrementally as it is needed.
|
|
This makes startup slower, but makes future operations faster.
|
|
|
|
+@item --readnever
|
|
+@cindex @code{--readnever}
|
|
+Do not read each symbol file's symbolic debug information. This makes
|
|
+startup faster but at the expense of not being able to perform
|
|
+symbolic debugging.
|
|
+
|
|
@end table
|
|
|
|
@node Mode Options
|
|
Index: gdb-7.2.50.20101231/gdb/main.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/main.c 2011-01-01 00:53:09.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/main.c 2011-01-01 00:54:07.000000000 +0100
|
|
@@ -391,6 +391,7 @@ captured_main (void *data)
|
|
{"xdb", no_argument, &xdb_commands, 1},
|
|
{"dbx", no_argument, &dbx_commands, 1},
|
|
{"readnow", no_argument, &readnow_symbol_files, 1},
|
|
+ {"readnever", no_argument, &readnever_symbol_files, 1},
|
|
{"r", no_argument, &readnow_symbol_files, 1},
|
|
{"quiet", no_argument, &quiet, 1},
|
|
{"q", no_argument, &quiet, 1},
|
|
@@ -993,6 +994,7 @@ Options:\n\n\
|
|
fputs_unfiltered (_(" file.\n\
|
|
--quiet Do not print version number on startup.\n\
|
|
--readnow Fully read symbol files on first access.\n\
|
|
+ --readnever Do not read symbol files.\n\
|
|
"), stream);
|
|
fputs_unfiltered (_("\
|
|
--se=FILE Use FILE as symbol file and executable file.\n\
|
|
Index: gdb-7.2.50.20101231/gdb/symfile.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/symfile.c 2010-11-23 01:59:58.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/symfile.c 2011-01-01 00:54:07.000000000 +0100
|
|
@@ -80,6 +80,7 @@ static void clear_symtab_users_cleanup (
|
|
|
|
/* Global variables owned by this file */
|
|
int readnow_symbol_files; /* Read full symbols immediately */
|
|
+int readnever_symbol_files; /* Never read full symbols. */
|
|
|
|
/* External variables and functions referenced. */
|
|
|
|
Index: gdb-7.2.50.20101231/gdb/dwarf2read.c
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/dwarf2read.c 2011-01-01 00:41:51.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/dwarf2read.c 2011-01-01 00:54:07.000000000 +0100
|
|
@@ -57,6 +57,7 @@
|
|
#include "vec.h"
|
|
#include "c-lang.h"
|
|
#include "valprint.h"
|
|
+#include "top.h"
|
|
|
|
#include <fcntl.h>
|
|
#include "gdb_string.h"
|
|
@@ -1345,8 +1346,9 @@ dwarf2_has_info (struct objfile *objfile
|
|
bfd_map_over_sections (objfile->obfd, dwarf2_locate_sections, NULL);
|
|
dwarf2_per_objfile->objfile = objfile;
|
|
}
|
|
- return (dwarf2_per_objfile->info.asection != NULL
|
|
- && dwarf2_per_objfile->abbrev.asection != NULL);
|
|
+ return (! readnever_symbol_files
|
|
+ && (dwarf2_per_objfile->info.asection != NULL
|
|
+ && dwarf2_per_objfile->abbrev.asection != NULL));
|
|
}
|
|
|
|
/* When loading sections, we can either look for ".<name>", or for
|
|
Index: gdb-7.2.50.20101231/gdb/top.h
|
|
===================================================================
|
|
--- gdb-7.2.50.20101231.orig/gdb/top.h 2010-12-29 01:58:14.000000000 +0100
|
|
+++ gdb-7.2.50.20101231/gdb/top.h 2011-01-01 00:54:21.000000000 +0100
|
|
@@ -61,6 +61,7 @@ extern void set_prompt (char *);
|
|
|
|
/* From random places. */
|
|
extern int readnow_symbol_files;
|
|
+extern int readnever_symbol_files;
|
|
|
|
/* Perform _initialize initialization. */
|
|
extern void gdb_init (char *);
|