89 lines
2.9 KiB
Diff
89 lines
2.9 KiB
Diff
2008-06-18 Jan Kratochvil <jan.kratochvil@redhat.com>
|
|
|
|
* configure.ac (--enable-tui): AC_MSG_ERROR for explicit --enable-tui.
|
|
* configure: Regenerated.
|
|
|
|
--- ./gdb/configure.ac 9 Jun 2008 15:03:59 -0000 1.70
|
|
+++ ./gdb/configure.ac 18 Jun 2008 17:14:21 -0000
|
|
@@ -260,11 +260,11 @@ fi
|
|
AC_ARG_ENABLE(tui,
|
|
[ --enable-tui enable full-screen terminal user interface (TUI)],
|
|
[case $enableval in
|
|
- yes | no)
|
|
+ yes | no | auto)
|
|
;;
|
|
*)
|
|
AC_MSG_ERROR([bad value $enableval for --enable-tui]) ;;
|
|
- esac],enable_tui=yes)
|
|
+ esac],enable_tui=auto)
|
|
|
|
# Enable gdbtk.
|
|
AC_ARG_ENABLE(gdbtk,
|
|
@@ -1576,7 +1576,7 @@ AC_PATH_X
|
|
|
|
# Check whether we should enable the TUI, but only do so if we really
|
|
# can.
|
|
-if test x"$enable_tui" = xyes; then
|
|
+if test x"$enable_tui" != xno; then
|
|
if test -d $srcdir/tui; then
|
|
if test "$ac_cv_search_waddstr" != no; then
|
|
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_TUI_OBS)"
|
|
@@ -1589,7 +1589,11 @@ if test x"$enable_tui" = xyes; then
|
|
CONFIG_INSTALL="${CONFIG_INSTALL} install-tui"
|
|
CONFIG_UNINSTALL="${CONFIG_UNINSTALL} uninstall-tui"
|
|
else
|
|
- AC_MSG_WARN([no enhanced curses library found; disabling TUI])
|
|
+ if test x"$enable_tui" = xyes; then
|
|
+ AC_MSG_ERROR([no enhanced curses library found; disable TUI])
|
|
+ else
|
|
+ AC_MSG_WARN([no enhanced curses library found; disabling TUI])
|
|
+ fi
|
|
fi
|
|
fi
|
|
fi
|
|
--- ./gdb/configure 9 Jun 2008 15:03:58 -0000 1.250
|
|
+++ ./gdb/configure 18 Jun 2008 17:14:12 -0000
|
|
@@ -7540,7 +7540,7 @@ fi
|
|
if test "${enable_tui+set}" = set; then
|
|
enableval="$enable_tui"
|
|
case $enableval in
|
|
- yes | no)
|
|
+ yes | no | auto)
|
|
;;
|
|
*)
|
|
{ { echo "$as_me:$LINENO: error: bad value $enableval for --enable-tui" >&5
|
|
@@ -7548,7 +7548,7 @@ echo "$as_me: error: bad value $enableva
|
|
{ (exit 1); exit 1; }; } ;;
|
|
esac
|
|
else
|
|
- enable_tui=yes
|
|
+ enable_tui=auto
|
|
fi;
|
|
|
|
# Enable gdbtk.
|
|
@@ -28324,7 +28324,7 @@ fi
|
|
|
|
# Check whether we should enable the TUI, but only do so if we really
|
|
# can.
|
|
-if test x"$enable_tui" = xyes; then
|
|
+if test x"$enable_tui" != xno; then
|
|
if test -d $srcdir/tui; then
|
|
if test "$ac_cv_search_waddstr" != no; then
|
|
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_TUI_OBS)"
|
|
@@ -28337,8 +28337,14 @@ if test x"$enable_tui" = xyes; then
|
|
CONFIG_INSTALL="${CONFIG_INSTALL} install-tui"
|
|
CONFIG_UNINSTALL="${CONFIG_UNINSTALL} uninstall-tui"
|
|
else
|
|
- { echo "$as_me:$LINENO: WARNING: no enhanced curses library found; disabling TUI" >&5
|
|
+ if test x"$enable_tui" = xyes; then
|
|
+ { { echo "$as_me:$LINENO: error: no enhanced curses library found; disable TUI" >&5
|
|
+echo "$as_me: error: no enhanced curses library found; disable TUI" >&2;}
|
|
+ { (exit 1); exit 1; }; }
|
|
+ else
|
|
+ { echo "$as_me:$LINENO: WARNING: no enhanced curses library found; disabling TUI" >&5
|
|
echo "$as_me: WARNING: no enhanced curses library found; disabling TUI" >&2;}
|
|
+ fi
|
|
fi
|
|
fi
|
|
fi
|