34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=225783
|
|
|
|
|
|
Index: gdb-6.8.50.20081128/gdb/Makefile.in
|
|
===================================================================
|
|
--- gdb-6.8.50.20081128.orig/gdb/Makefile.in 2008-12-02 23:06:16.000000000 +0100
|
|
+++ gdb-6.8.50.20081128/gdb/Makefile.in 2008-12-02 23:28:02.000000000 +0100
|
|
@@ -1490,8 +1490,10 @@ po/$(PACKAGE).pot: force
|
|
|
|
.SUFFIXES: .y .l
|
|
.y.c:
|
|
- $(SHELL) $(YLWRAP) $< y.tab.c $@.tmp -- $(YACC) $(YFLAGS)
|
|
- -sed -e '/extern.*malloc/d' \
|
|
+ rm -f $@ $@.tmp
|
|
+ $(SHELL) $(YLWRAP) $< y.tab.c $@ -- $(YACC) $(YFLAGS) && mv $@ $@.tmp \
|
|
+ || (rm -f $@; false)
|
|
+ sed -e '/extern.*malloc/d' \
|
|
-e '/extern.*realloc/d' \
|
|
-e '/extern.*free/d' \
|
|
-e '/include.*malloc.h/d' \
|
|
@@ -1500,9 +1502,9 @@ po/$(PACKAGE).pot: force
|
|
-e 's/\([ \t;,(]\)free\([ \t]*[&(),]\)/\1xfree\2/g' \
|
|
-e 's/\([ \t;,(]\)free$$/\1xfree/g' \
|
|
-e '/^#line.*y.tab.c/d' \
|
|
- < $@.tmp > $@.new
|
|
- -rm $@.tmp
|
|
- mv $@.new ./$*.c
|
|
+ -e "s/^\(#line.*\)`basename $<`/\1`echo $<|sed 's/\//\\\\\//g'`/" \
|
|
+ < $@.tmp > $@
|
|
+ rm -f $@.tmp
|
|
.l.c:
|
|
if [ "$(FLEX)" ] && $(FLEX) --version >/dev/null 2>&1; then \
|
|
$(FLEX) -o$@ $< && \
|