83 lines
2.9 KiB
Diff
83 lines
2.9 KiB
Diff
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
|
From: Fedora GDB patches <invalid@email.com>
|
|
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
|
Subject: gdb-fedora-libncursesw.patch
|
|
|
|
FileName: gdb-fedora-libncursesw.patch
|
|
|
|
;; Force libncursesw over libncurses to match the includes (RH BZ 1270534).
|
|
;;=push+jan
|
|
|
|
Fedora: Force libncursesw over libncurses to match the includes.
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1270534
|
|
---
|
|
gdb/configure | 6 ++++--
|
|
gdb/configure.ac | 6 ++++--
|
|
2 files changed, 8 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/gdb/configure b/gdb/configure
|
|
index 6fb5b5b509..db849572b5 100755
|
|
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -9238,6 +9238,7 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
|
|
$as_echo_n "checking for library containing waddstr... " >&6; }
|
|
if test "${ac_cv_search_waddstr+set}" = set; then :
|
|
@@ -9262,7 +9263,7 @@ return waddstr ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' ncursesw ncurses cursesX curses; do
|
|
+for ac_lib in '' ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
@@ -9336,6 +9337,7 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
|
|
$as_echo_n "checking for library containing tgetent... " >&6; }
|
|
if test "${ac_cv_search_tgetent+set}" = set; then :
|
|
@@ -9360,7 +9362,7 @@ return tgetent ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' termcap tinfo curses ncursesw ncurses; do
|
|
+for ac_lib in '' termcap tinfo ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
diff --git a/gdb/configure.ac b/gdb/configure.ac
|
|
index d891c7bccc..4412e25450 100644
|
|
--- a/gdb/configure.ac
|
|
+++ b/gdb/configure.ac
|
|
@@ -755,7 +755,8 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
- AC_SEARCH_LIBS(waddstr, [ncursesw ncurses cursesX curses])
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
+ AC_SEARCH_LIBS(waddstr, [ncursesw])
|
|
|
|
if test "$ac_cv_search_waddstr" != no; then
|
|
curses_found=yes
|
|
@@ -797,7 +798,8 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
-AC_SEARCH_LIBS(tgetent, [termcap tinfo curses ncursesw ncurses])
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
+AC_SEARCH_LIBS(tgetent, [termcap tinfo ncursesw])
|
|
|
|
if test "$ac_cv_search_tgetent" = no; then
|
|
CONFIG_OBS="$CONFIG_OBS stub-termcap.o"
|
|
--
|
|
2.14.3
|
|
|