c296a6a29e
- [testsuite] BuildRequire libmpx for --with testsuite. - Force libncursesw over libncurses to match the includes (RH BZ 1270534).
64 lines
2.7 KiB
Diff
64 lines
2.7 KiB
Diff
Fedora: Force libncursesw over libncurses to match the includes.
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1270534
|
|
|
|
diff -dup -rup gdb-7.10.50.20151113-orig/gdb/configure gdb-7.10.50.20151113/gdb/configure
|
|
--- gdb-7.10.50.20151113-orig/gdb/configure 2015-11-14 16:14:04.404118312 +0100
|
|
+++ gdb-7.10.50.20151113/gdb/configure 2015-11-14 16:17:59.074566047 +0100
|
|
@@ -8463,6 +8463,7 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
|
|
$as_echo_n "checking for library containing waddstr... " >&6; }
|
|
if test "${ac_cv_search_waddstr+set}" = set; then :
|
|
@@ -8487,7 +8488,7 @@ return waddstr ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' ncurses cursesX curses; do
|
|
+for ac_lib in '' ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
@@ -8561,6 +8562,7 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
|
|
$as_echo_n "checking for library containing tgetent... " >&6; }
|
|
if test "${ac_cv_search_tgetent+set}" = set; then :
|
|
@@ -8585,7 +8587,7 @@ return tgetent ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' termcap tinfo curses ncurses; do
|
|
+for ac_lib in '' termcap tinfo ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
diff -dup -rup gdb-7.10.50.20151113-orig/gdb/configure.ac gdb-7.10.50.20151113/gdb/configure.ac
|
|
--- gdb-7.10.50.20151113-orig/gdb/configure.ac 2015-11-14 16:14:04.404118312 +0100
|
|
+++ gdb-7.10.50.20151113/gdb/configure.ac 2015-11-14 16:17:54.898540284 +0100
|
|
@@ -771,7 +771,8 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
- AC_SEARCH_LIBS(waddstr, [ncurses cursesX curses])
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
+ AC_SEARCH_LIBS(waddstr, [ncursesw])
|
|
|
|
if test "$ac_cv_search_waddstr" != no; then
|
|
curses_found=yes
|
|
@@ -813,7 +814,8 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
-AC_SEARCH_LIBS(tgetent, [termcap tinfo curses ncurses])
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
+AC_SEARCH_LIBS(tgetent, [termcap tinfo ncursesw])
|
|
|
|
if test "$ac_cv_search_tgetent" = no; then
|
|
CONFIG_OBS="$CONFIG_OBS stub-termcap.o"
|