5d173531c0
- Simplify .spec: Remove conditional revert of: gdb-6.8-quit-never-aborts.patch
70 lines
2.7 KiB
Diff
70 lines
2.7 KiB
Diff
We may abort the process of detaching threads with multiple SIGINTs - which are
|
|
being sent during a testcase terminating its child GDB.
|
|
|
|
Some of the threads may not be properly PTRACE_DETACHed which hurts if they
|
|
should have been detached with SIGSTOP (as they are accidentally left running
|
|
on the debugger termination).
|
|
|
|
diff -dup -rup gdb-7.10.50.20160106-orig/gdb/defs.h gdb-7.10.50.20160106/gdb/defs.h
|
|
--- gdb-7.10.50.20160106-orig/gdb/defs.h 2016-01-09 15:06:57.658172875 +0100
|
|
+++ gdb-7.10.50.20160106/gdb/defs.h 2016-01-09 15:07:12.431264378 +0100
|
|
@@ -145,6 +145,9 @@ extern void set_quit_flag (void);
|
|
/* Flag that function quit should call quit_force. */
|
|
extern volatile int sync_quit_force_run;
|
|
|
|
+#ifdef NEED_DETACH_SIGSTOP
|
|
+extern int quit_flag_cleanup;
|
|
+#endif
|
|
extern int immediate_quit;
|
|
|
|
extern void quit (void);
|
|
diff -dup -rup gdb-7.10.50.20160106-orig/gdb/extension.c gdb-7.10.50.20160106/gdb/extension.c
|
|
--- gdb-7.10.50.20160106-orig/gdb/extension.c 2016-01-06 02:48:37.000000000 +0100
|
|
+++ gdb-7.10.50.20160106/gdb/extension.c 2016-01-09 15:07:12.434264396 +0100
|
|
@@ -833,6 +833,11 @@ check_quit_flag (void)
|
|
int i, result = 0;
|
|
const struct extension_language_defn *extlang;
|
|
|
|
+#ifdef NEED_DETACH_SIGSTOP
|
|
+ if (quit_flag_cleanup)
|
|
+ return 0;
|
|
+
|
|
+#endif
|
|
ALL_ENABLED_EXTENSION_LANGUAGES (i, extlang)
|
|
{
|
|
if (extlang->ops->check_quit_flag != NULL)
|
|
diff -dup -rup gdb-7.10.50.20160106-orig/gdb/top.c gdb-7.10.50.20160106/gdb/top.c
|
|
--- gdb-7.10.50.20160106-orig/gdb/top.c 2016-01-06 02:48:38.000000000 +0100
|
|
+++ gdb-7.10.50.20160106/gdb/top.c 2016-01-09 15:07:12.432264384 +0100
|
|
@@ -1557,7 +1557,13 @@ quit_force (char *args, int from_tty)
|
|
qt.args = args;
|
|
qt.from_tty = from_tty;
|
|
|
|
+#ifndef NEED_DETACH_SIGSTOP
|
|
/* We want to handle any quit errors and exit regardless. */
|
|
+#else
|
|
+ /* We want to handle any quit errors and exit regardless but we should never
|
|
+ get user-interrupted to properly detach the inferior. */
|
|
+ quit_flag_cleanup = 1;
|
|
+#endif
|
|
|
|
/* Get out of tfind mode, and kill or detach all inferiors. */
|
|
TRY
|
|
diff -dup -rup gdb-7.10.50.20160106-orig/gdb/utils.c gdb-7.10.50.20160106/gdb/utils.c
|
|
--- gdb-7.10.50.20160106-orig/gdb/utils.c 2016-01-09 15:06:57.654172850 +0100
|
|
+++ gdb-7.10.50.20160106/gdb/utils.c 2016-01-09 15:07:12.433264390 +0100
|
|
@@ -122,6 +122,13 @@ int job_control;
|
|
|
|
int immediate_quit;
|
|
|
|
+#ifdef NEED_DETACH_SIGSTOP
|
|
+/* Nonzero means we are already processing the quitting cleanups and we should
|
|
+ no longer get aborted. */
|
|
+
|
|
+int quit_flag_cleanup;
|
|
+
|
|
+#endif
|
|
/* Nonzero means that strings with character values >0x7F should be printed
|
|
as octal escapes. Zero means just print the value (e.g. it's an
|
|
international character, and the terminal or window can cope.) */
|