45 lines
1.1 KiB
Diff
45 lines
1.1 KiB
Diff
bison-3.0.4-4.fc24.x86_64
|
|
vs.
|
|
bison-2.7-4.el7.x86_64
|
|
|
|
bison:
|
|
8d0b7cef7df7fead44b9574cee342de336008625 tags/v3.0.1~2
|
|
parsers: rename YY_NULL as YY_NULLPTR to avoid conflicts with Flex
|
|
|
|
ada-lex.c:113:0: error: "YY_NULL" redefined [-Werror]
|
|
#define YY_NULL 0
|
|
|
|
ada-exp.c:158:0: note: this is the location of the previous definition
|
|
# define YY_NULL nullptr
|
|
|
|
*-exp.c cp-name-parser.c
|
|
vs.
|
|
ada-lex.c
|
|
|
|
# ifndef YY_NULL
|
|
# if defined __cplusplus && 201103L <= __cplusplus
|
|
# define YY_NULL nullptr
|
|
# else
|
|
# define YY_NULL 0
|
|
# endif
|
|
# endif
|
|
|
|
# ifndef YY_NULLPTR
|
|
# if defined __cplusplus && 201103L <= __cplusplus
|
|
# define YY_NULLPTR nullptr
|
|
# else
|
|
# define YY_NULLPTR 0
|
|
# endif
|
|
# endif
|
|
|
|
--- gdb-clean712/gdb/Makefile.in 2016-08-29 09:16:15.505393928 +0200
|
|
+++ gdb-clean712/gdb/Makefile.in 2016-09-07 13:32:34.744270346 +0200
|
|
@@ -1900,6 +1945,7 @@ po/$(PACKAGE).pot: force
|
|
-e 's/\([ \t;,(]\)free\([ \t]*[&(),]\)/\1xfree\2/g' \
|
|
-e 's/\([ \t;,(]\)free$$/\1xfree/g' \
|
|
-e '/^#line.*y.tab.c/d' \
|
|
+ -e 's/\<YY_NULL\>/YY_NULLPTR/g' \
|
|
< $@.tmp > $@
|
|
rm -f $@.tmp
|
|
.l.c:
|