cc92f09aa1
Make --enablerepo to use '*-debug*' for RHEL compatibility (BZ 781571). On older RHELs make readline bundled again (BZ 701131). Fix build compatibility with RHEL-5 due to false noarch build.
45 lines
1.4 KiB
Diff
45 lines
1.4 KiB
Diff
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -14631,6 +14631,10 @@ rm -f core conftest.err conftest.$ac_objext \
|
|
# Problem does not happen for the recommended libpythonX.Y.so linkage.
|
|
old_CFLAGS="$CFLAGS"
|
|
CFLAGS="$CFLAGS $PYTHON_CFLAGS"
|
|
+ old_CPPFLAGS="$CPPFLAGS"
|
|
+ CPPFLAGS="$CPPFLAGS $PYTHON_CPPFLAGS"
|
|
+ old_LIBS="$LIBS"
|
|
+ LIBS="$LIBS $PYTHON_LIBS"
|
|
if test "$cross_compiling" = yes; then :
|
|
true
|
|
else
|
|
@@ -14657,6 +14661,8 @@ rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
|
fi
|
|
|
|
CFLAGS="$old_CFLAGS"
|
|
+ CPPFLAGS="$old_CPPFLAGS"
|
|
+ LIBS="$old_LIBS"
|
|
fi
|
|
LDFLAGS="$old_LDFLAGS"
|
|
fi
|
|
--- a/gdb/configure.ac
|
|
+++ b/gdb/configure.ac
|
|
@@ -1576,6 +1576,10 @@ if test "${gdb_native}" = yes; then
|
|
# Problem does not happen for the recommended libpythonX.Y.so linkage.
|
|
old_CFLAGS="$CFLAGS"
|
|
CFLAGS="$CFLAGS $PYTHON_CFLAGS"
|
|
+ old_CPPFLAGS="$CPPFLAGS"
|
|
+ CPPFLAGS="$CPPFLAGS $PYTHON_CPPFLAGS"
|
|
+ old_LIBS="$LIBS"
|
|
+ LIBS="$LIBS $PYTHON_LIBS"
|
|
AC_RUN_IFELSE(
|
|
AC_LANG_PROGRAM(
|
|
[#include "]${have_libpython}[/Python.h"],
|
|
@@ -1586,6 +1590,8 @@ if test "${gdb_native}" = yes; then
|
|
return err == 0 ? 0 : 1;]),
|
|
[dynamic_list=true], [], [true])
|
|
CFLAGS="$old_CFLAGS"
|
|
+ CPPFLAGS="$old_CPPFLAGS"
|
|
+ LIBS="$old_LIBS"
|
|
fi
|
|
LDFLAGS="$old_LDFLAGS"
|
|
fi
|