gdb/gdb-doc-system-readline2.patch

69 lines
2.4 KiB
Diff

http://sourceware.org/ml/gdb-patches/2011-01/msg00002.html
Subject: [patch] make info out-of-src-tree regression on --with-system-readline
On Sat, 01 Jan 2011 02:13:24 +0100, Jan Kratochvil wrote:
> Another issue is that GDBvn.texi and gdb-cfg.texi should not be distributed.
> But that bug is a different one on top of this bug. That bug of a needless
> files distribution is dependent on magic GDB `make dist' I do not know and
> also that dist bug is not serious enough.
This part has a real consequence - the previous patch does not apply for build
trees out of the src tree. It may be even a makeinfo bug.
The change below is not needed for texi2dvi. In fact it even breaks it.
As Fedora does not package texi2roff I did not test it.
Another possibility is to error out if $(srcdir)/GDBvn.texi exists so that no
disambiguities may exist. GDBvn.texi would have to be removed from the
distributed tars.
Comment on this part is more than welcome.
This is a regression.
Thanks,
Jan
gdb/doc/
2011-01-01 Jan Kratochvil <jan.kratochvil@redhat.com>
Fix out-of-src doc build if using --with-system-readline.
* Makefile.in (MAKEINFO): New comment.
(gdb.info, gdb/index.html): Remove $(srcdir)/ from gdb.texinfo.
--- a/gdb/doc/Makefile.in
+++ b/gdb/doc/Makefile.in
@@ -45,6 +45,9 @@ gdbdir = $(srcdir)/..
TEXIDIR=${gdbdir}/../texinfo
# where to find makeinfo, preferably one designed for texinfo-2
+# Call makeinfo always with gdb.texinfo and not $(srcdir)/gdb.texinfo.
+# In the latter case GDBvn.texi would be included also from $(srcdir) even if
+# different GDBvn.texi exists in the current directory.
MAKEINFO=makeinfo
MAKEHTML = $(MAKEINFO) --html
@@ -365,7 +368,7 @@ gdb.pdf: ${GDB_DOC_FILES}
# GDB MANUAL: info file
gdb.info: ${GDB_DOC_FILES}
$(MAKEINFO) $(READLINE_TEXI_INCFLAG) -I ${GDBMI_DIR} -I $(srcdir) \
- -o gdb.info $(srcdir)/gdb.texinfo
+ -o gdb.info gdb.texinfo
# GDB MANUAL: roff translations
# Try to use a recent texi2roff. v2 was put on prep in jan91.
@@ -440,7 +443,8 @@ gdb.mm: $(GDB_DOC_FILES) links2roff
# GDB MANUAL: HTML file
gdb/index.html: ${GDB_DOC_FILES}
- $(MAKEHTML) $(MAKEHTMLFLAGS) $(READLINE_TEXI_INCFLAG) -I ${GDBMI_DIR} -I $(srcdir) $(srcdir)/gdb.texinfo
+ $(MAKEHTML) $(MAKEHTMLFLAGS) $(READLINE_TEXI_INCFLAG) \
+ -I ${GDBMI_DIR} -I $(srcdir) gdb.texinfo
# Clean these up before each run. Avoids a catch 22 with not being
# able to re-generate these files (to fix a corruption) because these