Update dlopen to support map_failed probe of glibc (Gary Benson, BZ 886516).
This commit is contained in:
parent
5f3b63a0d4
commit
f92430a872
30
gdb-dlopen-stap-probe-mapfailed.patch
Normal file
30
gdb-dlopen-stap-probe-mapfailed.patch
Normal file
@ -0,0 +1,30 @@
|
||||
commit 21fd080d18f280c19fdc5489726dcd6c66eb5fbf
|
||||
Author: Gary Benson <gbenson@redhat.com>
|
||||
Date: Tue Jan 8 12:12:14 2013 +0000
|
||||
|
||||
Also stop on "map_failed" where appropriate
|
||||
|
||||
Removed a comment patch hunk.
|
||||
|
||||
diff --git a/gdb/solib-svr4.c b/gdb/solib-svr4.c
|
||||
index 5eb84ba..a46fd74 100644
|
||||
--- a/gdb/solib-svr4.c
|
||||
+++ b/gdb/solib-svr4.c
|
||||
@@ -160,6 +160,7 @@ static const struct probe_info probe_info[] =
|
||||
{ "init_start", NAMESPACE_NO_ACTION },
|
||||
{ "init_complete", NAMESPACE_RELOAD },
|
||||
{ "map_start", NAMESPACE_NO_ACTION },
|
||||
+ { "map_failed", NAMESPACE_NO_ACTION },
|
||||
{ "reloc_complete", NAMESPACE_UPDATE_OR_RELOAD },
|
||||
{ "unmap_start", NAMESPACE_NO_ACTION },
|
||||
{ "unmap_complete", NAMESPACE_RELOAD },
|
||||
@@ -2056,6 +2058,9 @@ svr4_create_solib_event_breakpoints (struct gdbarch *gdbarch,
|
||||
info->probes[i] = find_probes_in_objfile (os->objfile, "rtld",
|
||||
name);
|
||||
|
||||
+ if (!strcmp (name, "rtld_map_failed"))
|
||||
+ continue;
|
||||
+
|
||||
if (!VEC_length (probe_p, info->probes[i]))
|
||||
{
|
||||
free_probes (info);
|
7
gdb.spec
7
gdb.spec
@ -34,7 +34,7 @@ Version: 7.5.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 33%{?dist}
|
||||
Release: 34%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||
Group: Development/Debuggers
|
||||
@ -521,6 +521,7 @@ Patch721: gdb-dlopen-stap-probe-6of7.patch
|
||||
Patch722: gdb-dlopen-stap-probe-7of7.patch
|
||||
Patch619: gdb-dlopen-stap-probe-test.patch
|
||||
Patch723: gdb-dlopen-stap-probe-test2.patch
|
||||
Patch822: gdb-dlopen-stap-probe-mapfailed.patch
|
||||
|
||||
# Work around PR libc/13097 "linux-vdso.so.1" warning message.
|
||||
#=push
|
||||
@ -907,6 +908,7 @@ find -name "*.info*"|xargs rm -f
|
||||
%patch721 -p1
|
||||
%patch722 -p1
|
||||
%patch723 -p1
|
||||
%patch822 -p1
|
||||
%patch619 -p1
|
||||
%patch627 -p1
|
||||
%patch634 -p1
|
||||
@ -1444,6 +1446,9 @@ fi
|
||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||
|
||||
%changelog
|
||||
* Tue Jan 8 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.1-34.fc18
|
||||
- Update dlopen to support map_failed probe of glibc (Gary Benson, BZ 886516).
|
||||
|
||||
* Thu Jan 3 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.1-33.fc18
|
||||
- [ppc*] Fix PowerPC disassembly regression (Alan Modra, Edjunior Machado).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user