Rebase to FSF GDB 8.2.50.20181016 (8.3pre).

Enable and always run the unittests when building the package.
This commit is contained in:
Sergio Durigan Junior 2018-10-16 18:33:39 -04:00
parent d82716127f
commit e18aa17153
12 changed files with 30 additions and 23 deletions

2
.gitignore vendored
View File

@ -1,3 +1,3 @@
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
/v2.0.tar.gz
/gdb-8.2.50.20181010.tar.xz
/gdb-8.2.50.20181016.tar.xz

View File

@ -1 +1 @@
daff3a48c17625ade8b57cf770fc77b4c1815df2
d53eec4ef86cf85841ceaec7db99753827f2beee

View File

@ -723,7 +723,7 @@ diff --git a/gdb/configure b/gdb/configure
enable_targets
enable_64_bit_bfd
enable_gdbmi
@@ -911,6 +917,11 @@ CCC
@@ -912,6 +918,11 @@ CCC
CPP
MAKEINFO
MAKEINFOFLAGS
@ -735,7 +735,7 @@ diff --git a/gdb/configure b/gdb/configure
YACC
YFLAGS
XMKMF'
@@ -1580,6 +1591,8 @@ Optional Packages:
@@ -1583,6 +1594,8 @@ Optional Packages:
[--with-auto-load-dir]
--without-auto-load-safe-path
do not restrict auto-loaded files locations
@ -744,7 +744,7 @@ diff --git a/gdb/configure b/gdb/configure
--with-libunwind-ia64 use libunwind frame unwinding for ia64 targets
--with-curses use the curses library instead of the termcap
library
@@ -1637,6 +1650,13 @@ Some influential environment variables:
@@ -1640,6 +1653,13 @@ Some influential environment variables:
MAKEINFO Parent configure detects if it is of sufficient version.
MAKEINFOFLAGS
Parameters for MAKEINFO.
@ -758,7 +758,7 @@ diff --git a/gdb/configure b/gdb/configure
YACC The `Yet Another Compiler Compiler' implementation to use.
Defaults to the first program found out of: `bison -y', `byacc',
`yacc'.
@@ -6618,6 +6638,494 @@ _ACEOF
@@ -6621,6 +6641,494 @@ _ACEOF
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
$as_echo "$with_auto_load_safe_path" >&6; }

View File

@ -68,7 +68,7 @@ diff --git a/gdb/config.in b/gdb/config.in
diff --git a/gdb/configure b/gdb/configure
--- a/gdb/configure
+++ b/gdb/configure
@@ -15841,6 +15841,64 @@ cat >>confdefs.h <<_ACEOF
@@ -15844,6 +15844,64 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
@ -173,7 +173,7 @@ diff --git a/gdb/gdbserver/config.in b/gdb/gdbserver/config.in
diff --git a/gdb/gdbserver/configure b/gdb/gdbserver/configure
--- a/gdb/gdbserver/configure
+++ b/gdb/gdbserver/configure
@@ -8564,6 +8564,64 @@ if $want_ipa ; then
@@ -8589,6 +8589,64 @@ if $want_ipa ; then
fi
fi
@ -241,7 +241,7 @@ diff --git a/gdb/gdbserver/configure b/gdb/gdbserver/configure
diff --git a/gdb/gdbserver/configure.ac b/gdb/gdbserver/configure.ac
--- a/gdb/gdbserver/configure.ac
+++ b/gdb/gdbserver/configure.ac
@@ -480,6 +480,10 @@ if $want_ipa ; then
@@ -478,6 +478,10 @@ if $want_ipa ; then
fi
fi

View File

@ -9,7 +9,7 @@ Subject: gdb-container-rh-pkg.patch
diff --git a/gdb/remote.c b/gdb/remote.c
--- a/gdb/remote.c
+++ b/gdb/remote.c
@@ -14004,7 +14004,17 @@ remote_target::pid_to_exec_file (int pid)
@@ -14008,7 +14008,17 @@ remote_target::pid_to_exec_file (int pid)
char *annex = NULL;
if (packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)

View File

@ -12,7 +12,7 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1270534
diff --git a/gdb/configure b/gdb/configure
--- a/gdb/configure
+++ b/gdb/configure
@@ -9410,6 +9410,7 @@ if test x"$prefer_curses" = xyes; then
@@ -9413,6 +9413,7 @@ if test x"$prefer_curses" = xyes; then
# search /usr/local/include, if ncurses is installed in /usr/local. A
# default installation of ncurses on alpha*-dec-osf* will lead to such
# a situation.
@ -20,7 +20,7 @@ diff --git a/gdb/configure b/gdb/configure
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
$as_echo_n "checking for library containing waddstr... " >&6; }
if ${ac_cv_search_waddstr+:} false; then :
@@ -9434,7 +9435,7 @@ return waddstr ();
@@ -9437,7 +9438,7 @@ return waddstr ();
return 0;
}
_ACEOF
@ -29,7 +29,7 @@ diff --git a/gdb/configure b/gdb/configure
if test -z "$ac_lib"; then
ac_res="none required"
else
@@ -9508,6 +9509,7 @@ case $host_os in
@@ -9511,6 +9512,7 @@ case $host_os in
esac
# These are the libraries checked by Readline.
@ -37,7 +37,7 @@ diff --git a/gdb/configure b/gdb/configure
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
$as_echo_n "checking for library containing tgetent... " >&6; }
if ${ac_cv_search_tgetent+:} false; then :
@@ -9532,7 +9534,7 @@ return tgetent ();
@@ -9535,7 +9537,7 @@ return tgetent ();
return 0;
}
_ACEOF

View File

@ -9,7 +9,7 @@ Subject: gdb-jit-reader-multilib.patch
diff --git a/gdb/configure b/gdb/configure
--- a/gdb/configure
+++ b/gdb/configure
@@ -9697,10 +9697,12 @@ _ACEOF
@@ -9700,10 +9700,12 @@ _ACEOF

View File

@ -9,7 +9,7 @@ Subject: gdb-linux_perf-bundle.patch
diff --git a/gdb/configure b/gdb/configure
--- a/gdb/configure
+++ b/gdb/configure
@@ -12080,7 +12080,7 @@ else
@@ -12083,7 +12083,7 @@ else
#include <linux/perf_event.h>
#ifndef PERF_ATTR_SIZE_VER5

View File

@ -2758,7 +2758,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
int insert_watchpoint (CORE_ADDR, int, enum target_hw_bp_type,
struct expression *) override;
@@ -10441,7 +10441,7 @@ int remote_hw_watchpoint_length_limit = -1;
@@ -10445,7 +10445,7 @@ int remote_hw_watchpoint_length_limit = -1;
int remote_hw_breakpoint_limit = -1;
int

View File

@ -384,7 +384,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
int can_use_hw_breakpoint (enum bptype, int, int) override;
@@ -10370,7 +10370,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
@@ -10374,7 +10374,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
p = strchr (rs->buf, '\0');
addr = remote_address_masked (addr);
p += hexnumstr (p, (ULONGEST) addr);
@ -393,7 +393,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
putpkt (rs->buf);
getpkt (&rs->buf, &rs->buf_size, 0);
@@ -10390,7 +10390,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
@@ -10394,7 +10394,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
bool
remote_target::watchpoint_addr_within_range (CORE_ADDR addr,
@ -402,7 +402,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
{
CORE_ADDR diff = remote_address_masked (addr - start);
@@ -10419,7 +10419,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
@@ -10423,7 +10423,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
p = strchr (rs->buf, '\0');
addr = remote_address_masked (addr);
p += hexnumstr (p, (ULONGEST) addr);

View File

@ -18,7 +18,7 @@
Name: %{?scl_prefix}gdb
# Freeze it when GDB gets branched
%global snapsrc 20181010
%global snapsrc 20181016
# See timestamp of source gnulib installed into gdb/gnulib/ .
%global snapgnulib 20161115
%global tarname gdb-%{version}
@ -26,7 +26,7 @@ Version: 8.2.50.%{snapsrc}
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 5%{?dist}
Release: 6%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -693,6 +693,9 @@ cp $RPM_BUILD_DIR/%{gdb_src}/gdb/NEWS $RPM_BUILD_DIR/%{gdb_src}
# Initially we're in the %{gdb_src} directory.
cd %{gdb_build}
# We always run the unittests.
(cd gdb; make run GDBFLAGS='-batch -ex "maintenance selftest"')
%if 0%{!?_with_testsuite:1}
echo ====================TESTSUITE DISABLED=========================
%else
@ -1024,6 +1027,10 @@ fi
%endif
%changelog
* Tue Oct 16 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.2.50.20181016-6.fc30
- Rebase to FSF GDB 8.2.50.20181016 (8.3pre).
- Enable and always run the unittests when building the package.
* Wed Oct 10 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.2.50.20181010-5.fc30
- Rebase to FSF GDB 8.2.50.20181010 (8.3pre).
- Remove 'gdb-6.8-sparc64-silence-memcpy-check.patch'.

View File

@ -1,3 +1,3 @@
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
SHA512 (v2.0.tar.gz) = ec63151e842c81cc73ea11ba560b63e005cefbe19d98de24ae5c8caa4de7c9c1d71d1ec5b6214a347592eac675b75a3d2b26d4691ca86f91020ebfea8e912939
SHA512 (gdb-8.2.50.20181010.tar.xz) = 1c7797e87b87de8cbe948b2bb97613a282f066c8c4a262f25f37ecf7d217bdb8cc84da7e147f81b4ebc00ea2f873ac9440c80f6da822a2df2563e57a2c7b9a83
SHA512 (gdb-8.2.50.20181016.tar.xz) = ebf7abc93e08121b4a5e40f860e99251ca138b7b79976d92e834c7f13856dbe736fb545f3617dc29e8b73174fe87e69e8f0f93940cab60d938d65107da941a54