Rebase to FSF GDB 7.11.90.20160829 (pre-7.12 branch snapshot).

This commit is contained in:
Jan Kratochvil 2016-08-29 09:50:02 +02:00
parent 72aed9dc5e
commit d987921748
5 changed files with 55 additions and 52 deletions

2
.gitignore vendored
View File

@ -1,3 +1,3 @@
/gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
/v1.5.tar.gz
/gdb-7.11.90.20160807.tar.xz
/gdb-7.11.90.20160829.tar.xz

View File

@ -1,8 +1,8 @@
Index: gdb-7.10.50.20160121/gdb/breakpoint.c
Index: gdb-7.11.90.20160829/gdb/breakpoint.c
===================================================================
--- gdb-7.10.50.20160121.orig/gdb/breakpoint.c 2016-01-21 21:52:34.243387043 +0100
+++ gdb-7.10.50.20160121/gdb/breakpoint.c 2016-01-21 21:53:00.365542925 +0100
@@ -16139,6 +16139,50 @@
--- gdb-7.11.90.20160829.orig/gdb/breakpoint.c 2016-08-29 09:41:57.054875810 +0200
+++ gdb-7.11.90.20160829/gdb/breakpoint.c 2016-08-29 09:45:04.166612376 +0200
@@ -16176,6 +16176,50 @@
static struct cmd_list_element *enablebreaklist = NULL;
void
@ -34,7 +34,7 @@ Index: gdb-7.10.50.20160121/gdb/breakpoint.c
+ && relocated_address < obj_section_endaddr (osect))
+ {
+ if (bl->inserted)
+ remove_breakpoint (bl, mark_uninserted);
+ remove_breakpoint (bl);
+
+ bl->address += delta_offset;
+ bl->requested_address += delta_offset;
@ -53,11 +53,11 @@ Index: gdb-7.10.50.20160121/gdb/breakpoint.c
_initialize_breakpoint (void)
{
struct cmd_list_element *c;
Index: gdb-7.10.50.20160121/gdb/breakpoint.h
Index: gdb-7.11.90.20160829/gdb/breakpoint.h
===================================================================
--- gdb-7.10.50.20160121.orig/gdb/breakpoint.h 2016-01-21 21:52:34.244387049 +0100
+++ gdb-7.10.50.20160121/gdb/breakpoint.h 2016-01-21 21:53:00.366542931 +0100
@@ -1629,4 +1629,7 @@
--- gdb-7.11.90.20160829.orig/gdb/breakpoint.h 2016-08-29 09:41:57.054875810 +0200
+++ gdb-7.11.90.20160829/gdb/breakpoint.h 2016-08-29 09:42:24.370129320 +0200
@@ -1644,4 +1644,7 @@
UIOUT iff debugging multiple threads. */
extern void maybe_print_thread_hit_breakpoint (struct ui_out *uiout);
@ -65,10 +65,10 @@ Index: gdb-7.10.50.20160121/gdb/breakpoint.h
+ struct section_offsets *delta);
+
#endif /* !defined (BREAKPOINT_H) */
Index: gdb-7.10.50.20160121/gdb/objfiles.c
Index: gdb-7.11.90.20160829/gdb/objfiles.c
===================================================================
--- gdb-7.10.50.20160121.orig/gdb/objfiles.c 2016-01-21 21:52:34.245387055 +0100
+++ gdb-7.10.50.20160121/gdb/objfiles.c 2016-01-21 21:53:00.367542937 +0100
--- gdb-7.11.90.20160829.orig/gdb/objfiles.c 2016-08-29 09:41:57.054875810 +0200
+++ gdb-7.11.90.20160829/gdb/objfiles.c 2016-08-29 09:42:24.370129320 +0200
@@ -916,6 +916,11 @@
obj_section_addr (s));
}

View File

@ -37,13 +37,13 @@ gdb/gdbserver/
(linux_create_inferior, linux_tracefork_child): Call it instead of
direct ptrace.
Index: gdb-7.11.90.20160807/gdb/nat/linux-ptrace.c
Index: gdb-7.11.90.20160829/gdb/nat/linux-ptrace.c
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/nat/linux-ptrace.c 2016-08-07 21:19:29.947833017 +0200
+++ gdb-7.11.90.20160807/gdb/nat/linux-ptrace.c 2016-08-07 21:19:37.650904142 +0200
--- gdb-7.11.90.20160829.orig/gdb/nat/linux-ptrace.c 2016-08-29 09:35:26.798230659 +0200
+++ gdb-7.11.90.20160829/gdb/nat/linux-ptrace.c 2016-08-29 09:35:43.162384100 +0200
@@ -25,6 +25,10 @@
#include "gdb_ptrace.h"
#include "gregset.h"
#include <sys/procfs.h>
+#ifdef HAVE_SELINUX_SELINUX_H
+# include <selinux/selinux.h>
@ -84,10 +84,10 @@ Index: gdb-7.11.90.20160807/gdb/nat/linux-ptrace.c
/* Extract extended ptrace event from wait status. */
int
Index: gdb-7.11.90.20160807/gdb/nat/linux-ptrace.h
Index: gdb-7.11.90.20160829/gdb/nat/linux-ptrace.h
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/nat/linux-ptrace.h 2016-08-07 21:19:29.947833017 +0200
+++ gdb-7.11.90.20160807/gdb/nat/linux-ptrace.h 2016-08-07 21:19:37.650904142 +0200
--- gdb-7.11.90.20160829.orig/gdb/nat/linux-ptrace.h 2016-08-29 09:35:26.798230659 +0200
+++ gdb-7.11.90.20160829/gdb/nat/linux-ptrace.h 2016-08-29 09:35:43.162384100 +0200
@@ -185,6 +185,7 @@
extern char *linux_ptrace_attach_fail_reason_string (ptid_t ptid, int err);
@ -96,10 +96,10 @@ Index: gdb-7.11.90.20160807/gdb/nat/linux-ptrace.h
extern void linux_check_ptrace_features (void);
extern void linux_enable_event_reporting (pid_t pid, int attached);
extern void linux_disable_event_reporting (pid_t pid);
Index: gdb-7.11.90.20160807/gdb/configure.ac
Index: gdb-7.11.90.20160829/gdb/configure.ac
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/configure.ac 2016-08-07 21:19:29.947833017 +0200
+++ gdb-7.11.90.20160807/gdb/configure.ac 2016-08-07 21:19:37.650904142 +0200
--- gdb-7.11.90.20160829.orig/gdb/configure.ac 2016-08-29 09:35:26.799230668 +0200
+++ gdb-7.11.90.20160829/gdb/configure.ac 2016-08-29 09:35:43.163384109 +0200
@@ -2108,6 +2108,10 @@
esac
AC_DEFINE_UNQUOTED(GDBINIT,"$gdbinit",[The .gdbinit filename.])
@ -111,11 +111,11 @@ Index: gdb-7.11.90.20160807/gdb/configure.ac
dnl Handle optional features that can be enabled.
# Support for --with-sysroot is a copy of GDB_AC_WITH_DIR,
Index: gdb-7.11.90.20160807/gdb/gdbserver/configure.ac
Index: gdb-7.11.90.20160829/gdb/gdbserver/configure.ac
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/gdbserver/configure.ac 2016-08-07 21:19:29.948833027 +0200
+++ gdb-7.11.90.20160807/gdb/gdbserver/configure.ac 2016-08-07 21:19:37.651904151 +0200
@@ -458,6 +458,10 @@
--- gdb-7.11.90.20160829.orig/gdb/gdbserver/configure.ac 2016-08-29 09:35:26.799230668 +0200
+++ gdb-7.11.90.20160829/gdb/gdbserver/configure.ac 2016-08-29 09:35:43.163384109 +0200
@@ -472,6 +472,10 @@
fi
fi
@ -126,10 +126,10 @@ Index: gdb-7.11.90.20160807/gdb/gdbserver/configure.ac
AC_SUBST(GDBSERVER_DEPFILES)
AC_SUBST(GDBSERVER_LIBS)
AC_SUBST(srv_xmlbuiltin)
Index: gdb-7.11.90.20160807/gdb/gdbserver/linux-low.c
Index: gdb-7.11.90.20160829/gdb/gdbserver/linux-low.c
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/gdbserver/linux-low.c 2016-08-07 21:19:29.949833036 +0200
+++ gdb-7.11.90.20160807/gdb/gdbserver/linux-low.c 2016-08-07 21:19:37.652904161 +0200
--- gdb-7.11.90.20160829.orig/gdb/gdbserver/linux-low.c 2016-08-29 09:35:26.801230687 +0200
+++ gdb-7.11.90.20160829/gdb/gdbserver/linux-low.c 2016-08-29 09:35:43.165384128 +0200
@@ -933,6 +933,29 @@
return lwp;
}
@ -169,10 +169,10 @@ Index: gdb-7.11.90.20160807/gdb/gdbserver/linux-low.c
setpgid (0, 0);
Index: gdb-7.11.90.20160807/gdb/inf-ptrace.c
Index: gdb-7.11.90.20160829/gdb/inf-ptrace.c
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/inf-ptrace.c 2016-08-07 21:19:29.949833036 +0200
+++ gdb-7.11.90.20160807/gdb/inf-ptrace.c 2016-08-07 21:19:37.653904170 +0200
--- gdb-7.11.90.20160829.orig/gdb/inf-ptrace.c 2016-08-29 09:35:26.801230687 +0200
+++ gdb-7.11.90.20160829/gdb/inf-ptrace.c 2016-08-29 09:35:43.165384128 +0200
@@ -79,7 +79,15 @@
inf_ptrace_me (void)
{
@ -189,10 +189,10 @@ Index: gdb-7.11.90.20160807/gdb/inf-ptrace.c
}
/* Start a new inferior Unix child process. EXEC_FILE is the file to
Index: gdb-7.11.90.20160807/gdb/linux-nat.c
Index: gdb-7.11.90.20160829/gdb/linux-nat.c
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/linux-nat.c 2016-08-07 21:19:29.950833045 +0200
+++ gdb-7.11.90.20160807/gdb/linux-nat.c 2016-08-07 21:19:37.654904179 +0200
--- gdb-7.11.90.20160829.orig/gdb/linux-nat.c 2016-08-29 09:35:26.802230697 +0200
+++ gdb-7.11.90.20160829/gdb/linux-nat.c 2016-08-29 09:35:43.166384137 +0200
@@ -1102,6 +1102,7 @@
{
struct cleanup *restore_personality
@ -231,10 +231,10 @@ Index: gdb-7.11.90.20160807/gdb/linux-nat.c
do_cleanups (restore_personality);
}
Index: gdb-7.11.90.20160807/gdb/config.in
Index: gdb-7.11.90.20160829/gdb/config.in
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/config.in 2016-08-07 21:19:29.950833045 +0200
+++ gdb-7.11.90.20160807/gdb/config.in 2016-08-07 21:19:37.654904179 +0200
--- gdb-7.11.90.20160829.orig/gdb/config.in 2016-08-29 09:35:26.803230706 +0200
+++ gdb-7.11.90.20160829/gdb/config.in 2016-08-29 09:35:43.166384137 +0200
@@ -267,6 +267,9 @@
/* Define if librpm library is being used. */
#undef HAVE_LIBRPM
@ -255,10 +255,10 @@ Index: gdb-7.11.90.20160807/gdb/config.in
/* Define to 1 if you have the `setlocale' function. */
#undef HAVE_SETLOCALE
Index: gdb-7.11.90.20160807/gdb/configure
Index: gdb-7.11.90.20160829/gdb/configure
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/configure 2016-08-07 21:19:29.953833073 +0200
+++ gdb-7.11.90.20160807/gdb/configure 2016-08-07 21:19:37.658904216 +0200
--- gdb-7.11.90.20160829.orig/gdb/configure 2016-08-29 09:35:26.806230734 +0200
+++ gdb-7.11.90.20160829/gdb/configure 2016-08-29 09:35:43.170384175 +0200
@@ -14642,6 +14642,64 @@
_ACEOF
@ -324,10 +324,10 @@ Index: gdb-7.11.90.20160807/gdb/configure
# Support for --with-sysroot is a copy of GDB_AC_WITH_DIR,
# except that the argument to --with-sysroot is optional.
Index: gdb-7.11.90.20160807/gdb/gdbserver/config.in
Index: gdb-7.11.90.20160829/gdb/gdbserver/config.in
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/gdbserver/config.in 2016-08-07 21:19:29.954833082 +0200
+++ gdb-7.11.90.20160807/gdb/gdbserver/config.in 2016-08-07 21:19:37.658904216 +0200
--- gdb-7.11.90.20160829.orig/gdb/gdbserver/config.in 2016-08-29 09:35:26.807230743 +0200
+++ gdb-7.11.90.20160829/gdb/gdbserver/config.in 2016-08-29 09:35:43.170384175 +0200
@@ -120,6 +120,9 @@
/* Define to 1 if you have the `mcheck' library (-lmcheck). */
#undef HAVE_LIBMCHECK
@ -348,11 +348,11 @@ Index: gdb-7.11.90.20160807/gdb/gdbserver/config.in
/* Define to 1 if you have the `setns' function. */
#undef HAVE_SETNS
Index: gdb-7.11.90.20160807/gdb/gdbserver/configure
Index: gdb-7.11.90.20160829/gdb/gdbserver/configure
===================================================================
--- gdb-7.11.90.20160807.orig/gdb/gdbserver/configure 2016-08-07 21:19:29.955833091 +0200
+++ gdb-7.11.90.20160807/gdb/gdbserver/configure 2016-08-07 21:19:37.660904235 +0200
@@ -7530,6 +7530,64 @@
--- gdb-7.11.90.20160829.orig/gdb/gdbserver/configure 2016-08-29 09:35:26.809230762 +0200
+++ gdb-7.11.90.20160829/gdb/gdbserver/configure 2016-08-29 09:35:43.172384194 +0200
@@ -7561,6 +7561,64 @@
fi
fi

View File

@ -23,11 +23,11 @@ Name: %{?scl_prefix}gdb
# See timestamp of source gnulib installed into gdb/gnulib/ .
%global snapgnulib 20150822
%global tarname gdb-%{version}
Version: 7.11.90.20160807
Version: 7.11.90.20160829
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 7%{?dist}
Release: 8%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -1463,6 +1463,9 @@ then
fi
%changelog
* Mon Aug 29 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.90.20160829-8.fc25
- Rebase to FSF GDB 7.11.90.20160829 (pre-7.12 branch snapshot).
* Fri Aug 26 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.90.20160807-7.fc25
- Fix Intel VLA patchset regression: dynamic.exp: p varw filled

View File

@ -1,3 +1,3 @@
131d0dfd20cd6014c168fbcab9be2c43 gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
29efc08219d9d6a0536d58f9807c8722 v1.5.tar.gz
2e52dd8b63eb0a459febbee01221fb10 gdb-7.11.90.20160807.tar.xz
693f1a93282c04f41cd08cb79fbc63c7 gdb-7.11.90.20160829.tar.xz