Fix messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
This commit is contained in:
parent
223268c6f0
commit
d6851d1cc9
@ -1,23 +1,3 @@
|
|||||||
--- gdb-7.11/gdb/linux-thread-db.c.orig 2016-04-06 17:45:10.444062076 +0200
|
|
||||||
+++ gdb-7.11/gdb/linux-thread-db.c 2016-04-06 17:46:16.169615943 +0200
|
|
||||||
@@ -1025,7 +1025,16 @@ check_pid_namespace_match (void)
|
|
||||||
warning (_ ("Target and debugger are in different PID "
|
|
||||||
"namespaces; thread lists and other data are "
|
|
||||||
"likely unreliable. "
|
|
||||||
- "Connect to gdbserver inside the container."));
|
|
||||||
+ "Connect to gdbserver inside the container.\n"
|
|
||||||
+"This version of GDB needs local access to files from the container. It is easier to access the files from the container itself. This RHEL-7 version of GDB does not support such direct container files access.\n"
|
|
||||||
+"The following versions of GDB support the direct access:\n"
|
|
||||||
+"- Upstream version of GDB (unsupported) 7.10 or later\n"
|
|
||||||
+"- Red Hat Developer Toolset (DTS) version of GDB from DTS 4.0 or later (available only for the x86_64 architecture)\n"
|
|
||||||
+"The direct container file access needs to be supported also by gdbserver inside the container:\n"
|
|
||||||
+"- Upstream version of gdbserver (unsupported) 7.10 or later\n"
|
|
||||||
+"- Red Hat Developer Toolset (DTS) version of gdbserver from DTS 4.0 or later (only on x86_64)\n"
|
|
||||||
+"- RHEL-7.3 version of gdbserver (on any architecture)"
|
|
||||||
+));
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
--- gdb-7.11/gdb/remote.c-orig 2016-04-06 17:46:52.428921496 +0200
|
--- gdb-7.11/gdb/remote.c-orig 2016-04-06 17:46:52.428921496 +0200
|
||||||
+++ gdb-7.11/gdb/remote.c 2016-04-06 18:28:26.781923516 +0200
|
+++ gdb-7.11/gdb/remote.c 2016-04-06 18:28:26.781923516 +0200
|
||||||
@@ -13002,7 +13002,17 @@ remote_pid_to_exec_file (struct target_o
|
@@ -13002,7 +13002,17 @@ remote_pid_to_exec_file (struct target_o
|
||||||
@ -32,7 +12,7 @@
|
|||||||
+"The following versions of gdbserver support it:\n"
|
+"The following versions of gdbserver support it:\n"
|
||||||
+"- Upstream version of gdbserver (unsupported) 7.10 or later\n"
|
+"- Upstream version of gdbserver (unsupported) 7.10 or later\n"
|
||||||
+"- Red Hat Developer Toolset (DTS) version of gdbserver from DTS 4.0 or later (only on x86_64)\n"
|
+"- Red Hat Developer Toolset (DTS) version of gdbserver from DTS 4.0 or later (only on x86_64)\n"
|
||||||
+"- RHEL-6.9 and RHEL-7.3 versions of gdbserver (on any architecture)"
|
+"- RHEL-7.3 versions of gdbserver (on any architecture)"
|
||||||
+));
|
+));
|
||||||
+ return NULL;
|
+ return NULL;
|
||||||
+ }
|
+ }
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.11
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 71%{?dist}
|
Release: 72%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1401,6 +1401,9 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 3 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-72.fc24
|
||||||
|
- Fix messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||||
|
|
||||||
* Wed Apr 27 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-71.fc24
|
* Wed Apr 27 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-71.fc24
|
||||||
- Import upstream 7.11 branch stable fixes.
|
- Import upstream 7.11 branch stable fixes.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user