Fix ia64 build, remove gdb-6.3.tar.bz2 from .cvsignore.

This commit is contained in:
aoliva 2006-07-11 08:06:56 +00:00
parent 78483f6257
commit c59c374ffc
3 changed files with 47 additions and 47 deletions

View File

@ -1,2 +1 @@
gdb-6.3.tar.bz2
gdb-6.5.tar.bz2

View File

@ -30,8 +30,8 @@
Index: gdb-6.5/gdb/doc/observer.texi
===================================================================
--- gdb-6.5.orig/gdb/doc/observer.texi 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/doc/observer.texi 2006-07-11 02:29:49.000000000 -0300
--- gdb-6.5.orig/gdb/doc/observer.texi 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/doc/observer.texi 2006-07-11 05:04:06.000000000 -0300
@@ -122,3 +122,13 @@ haven't been loaded yet.
@deftypefun void solib_unloaded (struct so_list *@var{solib})
The shared library specified by @var{solib} has been unloaded.
@ -48,8 +48,8 @@ Index: gdb-6.5/gdb/doc/observer.texi
+@end deftypefun
Index: gdb-6.5/gdb/infrun.c
===================================================================
--- gdb-6.5.orig/gdb/infrun.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/infrun.c 2006-07-11 02:29:55.000000000 -0300
--- gdb-6.5.orig/gdb/infrun.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/infrun.c 2006-07-11 05:04:07.000000000 -0300
@@ -1703,9 +1703,19 @@ handle_inferior_event (struct execution_
single step over a watchpoint without disabling the watchpoint. */
if (HAVE_STEPPABLE_WATCHPOINT && STOPPED_BY_WATCHPOINT (ecs->ws))
@ -155,8 +155,8 @@ Index: gdb-6.5/gdb/infrun.c
stop_signal = TARGET_SIGNAL_0;
Index: gdb-6.5/gdb/breakpoint.c
===================================================================
--- gdb-6.5.orig/gdb/breakpoint.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/breakpoint.c 2006-07-11 02:29:50.000000000 -0300
--- gdb-6.5.orig/gdb/breakpoint.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/breakpoint.c 2006-07-11 05:04:08.000000000 -0300
@@ -748,6 +748,90 @@ insert_catchpoint (struct ui_out *uo, vo
}
}
@ -503,8 +503,8 @@ Index: gdb-6.5/gdb/breakpoint.c
so that a list of breakpoints will come out in order
Index: gdb-6.5/gdb/breakpoint.h
===================================================================
--- gdb-6.5.orig/gdb/breakpoint.h 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/breakpoint.h 2006-07-11 02:29:49.000000000 -0300
--- gdb-6.5.orig/gdb/breakpoint.h 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/breakpoint.h 2006-07-11 05:04:07.000000000 -0300
@@ -426,6 +426,11 @@ struct breakpoint
/* Is breakpoint pending on shlib loads? */
@ -534,8 +534,8 @@ Index: gdb-6.5/gdb/breakpoint.h
/* This function can be used to physically insert eventpoints from the
Index: gdb-6.5/gdb/linux-nat.c
===================================================================
--- gdb-6.5.orig/gdb/linux-nat.c 2006-07-07 04:24:57.000000000 -0300
+++ gdb-6.5/gdb/linux-nat.c 2006-07-11 02:29:49.000000000 -0300
--- gdb-6.5.orig/gdb/linux-nat.c 2006-07-11 02:57:28.000000000 -0300
+++ gdb-6.5/gdb/linux-nat.c 2006-07-11 05:04:06.000000000 -0300
@@ -36,6 +36,7 @@
#include "gdbthread.h"
#include "gdbcmd.h"
@ -585,8 +585,8 @@ Index: gdb-6.5/gdb/linux-nat.c
{
Index: gdb-6.5/gdb/linux-nat.h
===================================================================
--- gdb-6.5.orig/gdb/linux-nat.h 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/linux-nat.h 2006-07-07 04:24:57.000000000 -0300
--- gdb-6.5.orig/gdb/linux-nat.h 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/linux-nat.h 2006-07-11 02:57:28.000000000 -0300
@@ -63,6 +63,18 @@ struct lwp_info
/* Next LWP in list. */
@ -608,8 +608,8 @@ Index: gdb-6.5/gdb/linux-nat.h
/* Attempt to initialize libthread_db. */
Index: gdb-6.5/gdb/Makefile.in
===================================================================
--- gdb-6.5.orig/gdb/Makefile.in 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/Makefile.in 2006-07-11 02:29:50.000000000 -0300
--- gdb-6.5.orig/gdb/Makefile.in 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/Makefile.in 2006-07-11 05:04:08.000000000 -0300
@@ -2113,7 +2113,7 @@ i387-tdep.o: i387-tdep.c $(defs_h) $(dou
$(gdb_assert_h) $(gdb_string_h) $(i386_tdep_h) $(i387_tdep_h)
ia64-linux-nat.o: ia64-linux-nat.c $(defs_h) $(gdb_string_h) $(inferior_h) \
@ -630,8 +630,8 @@ Index: gdb-6.5/gdb/Makefile.in
$(floatformat_h) $(regcache_h) $(trad_frame_h) $(frame_base_h) \
Index: gdb-6.5/gdb/linux-thread-db.c
===================================================================
--- gdb-6.5.orig/gdb/linux-thread-db.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/linux-thread-db.c 2006-07-11 02:29:49.000000000 -0300
--- gdb-6.5.orig/gdb/linux-thread-db.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/linux-thread-db.c 2006-07-11 05:04:08.000000000 -0300
@@ -36,6 +36,7 @@
#include "target.h"
#include "regcache.h"
@ -680,8 +680,8 @@ Index: gdb-6.5/gdb/linux-thread-db.c
Index: gdb-6.5/gdb/i386-linux-nat.c
===================================================================
--- gdb-6.5.orig/gdb/i386-linux-nat.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/i386-linux-nat.c 2006-07-11 02:29:47.000000000 -0300
--- gdb-6.5.orig/gdb/i386-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/i386-linux-nat.c 2006-07-11 05:04:03.000000000 -0300
@@ -619,10 +619,9 @@ i386_linux_dr_get (int regnum)
int tid;
unsigned long value;
@ -712,18 +712,17 @@ Index: gdb-6.5/gdb/i386-linux-nat.c
ptrace (PTRACE_POKEUSER, tid,
Index: gdb-6.5/gdb/ia64-linux-nat.c
===================================================================
--- gdb-6.5.orig/gdb/ia64-linux-nat.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/ia64-linux-nat.c 2006-07-11 02:29:46.000000000 -0300
@@ -41,6 +41,8 @@
#include <asm/ptrace_offsets.h>
#include <sys/procfs.h>
--- gdb-6.5.orig/gdb/ia64-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/ia64-linux-nat.c 2006-07-11 05:05:36.000000000 -0300
@@ -29,6 +29,7 @@
#include "regcache.h"
#include "ia64-tdep.h"
#include "linux-nat.h"
+#include "observer.h"
+#include "linux-nat.h"
/* Prototypes for supply_gregset etc. */
#include "gregset.h"
@@ -561,8 +563,9 @@ is_power_of_2 (int val)
#include <signal.h>
#include <sys/ptrace.h>
@@ -561,8 +562,9 @@ is_power_of_2 (int val)
return onecount <= 1;
}
@ -735,7 +734,7 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
{
int idx;
long dbr_addr, dbr_mask;
@@ -608,8 +611,38 @@ ia64_linux_insert_watchpoint (ptid_t pti
@@ -608,8 +610,38 @@ ia64_linux_insert_watchpoint (ptid_t pti
return 0;
}
@ -775,7 +774,7 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
{
int idx;
long dbr_addr, dbr_mask;
@@ -632,23 +665,74 @@ ia64_linux_remove_watchpoint (ptid_t pti
@@ -632,23 +664,74 @@ ia64_linux_remove_watchpoint (ptid_t pti
return -1;
}
@ -853,7 +852,7 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
return 0;
psr = read_register_pid (IA64_PSR_REGNUM, ptid);
@@ -656,7 +740,7 @@ ia64_linux_stopped_data_address (CORE_AD
@@ -656,7 +739,7 @@ ia64_linux_stopped_data_address (CORE_AD
for the next instruction */
write_register_pid (IA64_PSR_REGNUM, psr, ptid);
@ -862,11 +861,10 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
return 1;
}
@@ -702,3 +786,36 @@ _initialize_ia64_linux_nat (void)
/* Register the target. */
linux_nat_add_target (t);
@@ -685,6 +768,31 @@ ia64_linux_xfer_partial (struct target_o
offset, len);
}
+
+/* Observer function for a new thread attach. We need to insert
+ existing watchpoints on the new thread. */
+static void
@ -892,17 +890,21 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
+ lp->saved_trap_data);
+}
+
+void
+_initialize_ia64_linux_nat (void)
+{
void _initialize_ia64_linux_nat (void);
void
@@ -701,4 +809,7 @@ _initialize_ia64_linux_nat (void)
/* Register the target. */
linux_nat_add_target (t);
+
+ observer_attach_linux_new_thread (ia64_linux_new_thread);
+ observer_attach_sigtrap (ia64_linux_save_sigtrap_info);
+}
+
}
Index: gdb-6.5/gdb/amd64-linux-nat.c
===================================================================
--- gdb-6.5.orig/gdb/amd64-linux-nat.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/amd64-linux-nat.c 2006-07-11 02:29:47.000000000 -0300
--- gdb-6.5.orig/gdb/amd64-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/amd64-linux-nat.c 2006-07-11 05:04:03.000000000 -0300
@@ -234,10 +234,9 @@ amd64_linux_dr_get (int regnum)
int tid;
unsigned long value;
@ -933,8 +935,8 @@ Index: gdb-6.5/gdb/amd64-linux-nat.c
ptrace (PT_WRITE_U, tid, offsetof (struct user, u_debugreg[regnum]), value);
Index: gdb-6.5/gdb/s390-nat.c
===================================================================
--- gdb-6.5.orig/gdb/s390-nat.c 2006-07-07 04:24:43.000000000 -0300
+++ gdb-6.5/gdb/s390-nat.c 2006-07-07 04:24:57.000000000 -0300
--- gdb-6.5.orig/gdb/s390-nat.c 2006-07-11 02:57:24.000000000 -0300
+++ gdb-6.5/gdb/s390-nat.c 2006-07-11 02:57:28.000000000 -0300
@@ -30,6 +30,8 @@
#include "linux-nat.h"

View File

@ -123,7 +123,7 @@ Patch134: gdb-6.3-dtorfix-20050121.patch
Patch136: gdb-6.3-test-movedir-20050125.patch
# Fix to support unwinding syscalls in ia64 corefiles
Patch138: gdb-6.3-ia64-corefile-fix-20050127.patch
# Patch138: gdb-6.3-ia64-corefile-fix-20050127.patch
# Tolerate DW_AT_type referencing <0>.
Patch139: gdb-6.3-dwattype0-20050201.patch
@ -268,7 +268,6 @@ and printing their data.
%patch133 -p1
%patch134 -p1
%patch136 -p1
%patch138 -p1
%patch139 -p1
%patch140 -p1
%patch141 -p1