- Fix false warning: non-absolute filename: <the main exec. file> (BZ 640648).

This commit is contained in:
Jan Kratochvil 2010-10-06 22:44:56 +02:00
parent 8e50e08ea7
commit aeb6a62df2
2 changed files with 59 additions and 38 deletions

View File

@ -1,7 +1,7 @@
Index: gdb-7.1.90.20100806/gdb/event-top.c
Index: gdb-7.2/gdb/event-top.c
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/event-top.c 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/event-top.c 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/event-top.c 2010-06-26 08:44:47.000000000 +0200
+++ gdb-7.2/gdb/event-top.c 2010-10-06 22:39:32.000000000 +0200
@@ -33,6 +33,7 @@
#include "cli/cli-script.h" /* for reset_command_nest_depth */
#include "main.h"
@ -28,10 +28,10 @@ Index: gdb-7.1.90.20100806/gdb/event-top.c
/* Each interpreter has its own rules on displaying the command
prompt. */
if (!current_interp_display_prompt_p ())
Index: gdb-7.1.90.20100806/gdb/elfread.c
Index: gdb-7.2/gdb/elfread.c
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/elfread.c 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/elfread.c 2010-08-06 18:11:49.000000000 +0200
--- gdb-7.2.orig/gdb/elfread.c 2010-10-06 22:39:32.000000000 +0200
+++ gdb-7.2/gdb/elfread.c 2010-10-06 22:39:52.000000000 +0200
@@ -42,6 +42,7 @@
#include "gdbcore.h"
#include "gdbcmd.h"
@ -40,7 +40,7 @@ Index: gdb-7.1.90.20100806/gdb/elfread.c
extern void _initialize_elfread (void);
@@ -1371,8 +1372,357 @@ build_id_to_filename (struct build_id *b
@@ -1371,8 +1372,361 @@ build_id_to_filename (struct build_id *b
return retval;
}
@ -114,6 +114,10 @@ Index: gdb-7.1.90.20100806/gdb/elfread.c
+#endif /* !DLOPEN_LIBRPM */
+
+ gdb_assert (filename != NULL);
+
+ if (strcmp (filename, BUILD_ID_MAIN_EXECUTABLE_FILENAME) == 0)
+ return 0;
+
+ if (filename[0] != '/')
+ {
+ warning (_("Ignoring non-absolute filename: <%s>"), filename);
@ -399,7 +403,7 @@ Index: gdb-7.1.90.20100806/gdb/elfread.c
avoidance. */
struct missing_filepair
@@ -1426,11 +1776,17 @@ missing_filepair_change (void)
@@ -1426,11 +1780,17 @@ missing_filepair_change (void)
/* All their memory came just from missing_filepair_OBSTACK. */
missing_filepair_hash = NULL;
}
@ -417,7 +421,7 @@ Index: gdb-7.1.90.20100806/gdb/elfread.c
missing_filepair_change ();
}
@@ -1497,14 +1853,35 @@ debug_print_missing (const char *binary,
@@ -1497,14 +1857,35 @@ debug_print_missing (const char *binary,
*slot = missing_filepair;
@ -460,22 +464,23 @@ Index: gdb-7.1.90.20100806/gdb/elfread.c
}
static char *
Index: gdb-7.1.90.20100806/gdb/symfile.h
Index: gdb-7.2/gdb/symfile.h
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/symfile.h 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/symfile.h 2010-08-06 17:42:05.000000000 +0200
@@ -577,6 +577,7 @@ extern struct build_id *build_id_addr_ge
--- gdb-7.2.orig/gdb/symfile.h 2010-10-06 22:39:32.000000000 +0200
+++ gdb-7.2/gdb/symfile.h 2010-10-06 22:39:52.000000000 +0200
@@ -577,6 +577,8 @@ extern struct build_id *build_id_addr_ge
extern char *build_id_to_filename (struct build_id *build_id,
char **link_return, int add_debug_suffix);
extern void debug_print_missing (const char *binary, const char *debug);
+extern void debug_flush_missing (void);
+#define BUILD_ID_MAIN_EXECUTABLE_FILENAME _("the main executable file")
/* From dwarf2read.c */
Index: gdb-7.1.90.20100806/gdb/testsuite/lib/gdb.exp
Index: gdb-7.2/gdb/testsuite/lib/gdb.exp
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/testsuite/lib/gdb.exp 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/testsuite/lib/gdb.exp 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/testsuite/lib/gdb.exp 2010-10-06 22:39:32.000000000 +0200
+++ gdb-7.2/gdb/testsuite/lib/gdb.exp 2010-10-06 22:39:32.000000000 +0200
@@ -1359,7 +1359,7 @@ proc default_gdb_start { } {
warning "Couldn't set the width to 0."
}
@ -485,10 +490,10 @@ Index: gdb-7.1.90.20100806/gdb/testsuite/lib/gdb.exp
send_gdb "set build-id-verbose 0\n"
gdb_expect 10 {
-re "$gdb_prompt $" {
Index: gdb-7.1.90.20100806/gdb/testsuite/lib/mi-support.exp
Index: gdb-7.2/gdb/testsuite/lib/mi-support.exp
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/testsuite/lib/mi-support.exp 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/testsuite/lib/mi-support.exp 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/testsuite/lib/mi-support.exp 2010-10-06 22:39:32.000000000 +0200
+++ gdb-7.2/gdb/testsuite/lib/mi-support.exp 2010-10-06 22:39:32.000000000 +0200
@@ -221,7 +221,7 @@ proc default_mi_gdb_start { args } {
}
}
@ -498,10 +503,10 @@ Index: gdb-7.1.90.20100806/gdb/testsuite/lib/mi-support.exp
send_gdb "190-gdb-set build-id-verbose 0\n"
gdb_expect 10 {
-re ".*190-gdb-set build-id-verbose 0\r\n190\\\^done\r\n$mi_gdb_prompt$" {
Index: gdb-7.1.90.20100806/gdb/tui/tui-interp.c
Index: gdb-7.2/gdb/tui/tui-interp.c
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/tui/tui-interp.c 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/tui/tui-interp.c 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/tui/tui-interp.c 2010-05-18 00:21:43.000000000 +0200
+++ gdb-7.2/gdb/tui/tui-interp.c 2010-10-06 22:39:32.000000000 +0200
@@ -30,6 +30,7 @@
#include "tui/tui.h"
#include "tui/tui-io.h"
@ -519,10 +524,10 @@ Index: gdb-7.1.90.20100806/gdb/tui/tui-interp.c
/* Tell readline what the prompt to display is and what function
it will need to call after a whole line is read. This also
displays the first prompt. */
Index: gdb-7.1.90.20100806/gdb/aclocal.m4
Index: gdb-7.2/gdb/aclocal.m4
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/aclocal.m4 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/aclocal.m4 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/aclocal.m4 2010-05-23 02:56:59.000000000 +0200
+++ gdb-7.2/gdb/aclocal.m4 2010-10-06 22:39:32.000000000 +0200
@@ -19,6 +19,162 @@ You have another version of autoconf. I
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.])])
@ -686,10 +691,10 @@ Index: gdb-7.1.90.20100806/gdb/aclocal.m4
# Copyright (C) 2002, 2003, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
#
# This file is free software; the Free Software Foundation
Index: gdb-7.1.90.20100806/gdb/config.in
Index: gdb-7.2/gdb/config.in
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/config.in 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/config.in 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/config.in 2010-10-06 22:39:31.000000000 +0200
+++ gdb-7.2/gdb/config.in 2010-10-06 22:39:32.000000000 +0200
@@ -46,6 +46,9 @@
/* Define to BFD's default target vector. */
#undef DEFAULT_BFD_VEC
@ -710,10 +715,10 @@ Index: gdb-7.1.90.20100806/gdb/config.in
/* Define if libunwind library is being used. */
#undef HAVE_LIBUNWIND
Index: gdb-7.1.90.20100806/gdb/configure
Index: gdb-7.2/gdb/configure
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/configure 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/configure 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/configure 2010-10-06 22:39:31.000000000 +0200
+++ gdb-7.2/gdb/configure 2010-10-06 22:39:32.000000000 +0200
@@ -679,6 +679,9 @@ REPORT_BUGS_TO
PKGVERSION
TARGET_OBS
@ -1247,10 +1252,10 @@ Index: gdb-7.1.90.20100806/gdb/configure
Index: gdb-7.1.90.20100806/gdb/configure.ac
Index: gdb-7.2/gdb/configure.ac
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/configure.ac 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/configure.ac 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/configure.ac 2010-10-06 22:39:31.000000000 +0200
+++ gdb-7.2/gdb/configure.ac 2010-10-06 22:39:32.000000000 +0200
@@ -152,6 +152,198 @@ else
fi
AC_SUBST(pythondir)
@ -1450,10 +1455,10 @@ Index: gdb-7.1.90.20100806/gdb/configure.ac
AC_CONFIG_SUBDIRS(doc testsuite)
Index: gdb-7.1.90.20100806/gdb/acinclude.m4
Index: gdb-7.2/gdb/acinclude.m4
===================================================================
--- gdb-7.1.90.20100806.orig/gdb/acinclude.m4 2010-08-06 17:42:01.000000000 +0200
+++ gdb-7.1.90.20100806/gdb/acinclude.m4 2010-08-06 17:42:05.000000000 +0200
--- gdb-7.2.orig/gdb/acinclude.m4 2010-05-27 05:40:45.000000000 +0200
+++ gdb-7.2/gdb/acinclude.m4 2010-10-06 22:39:32.000000000 +0200
@@ -1,3 +1,5 @@
+# serial 1
+
@ -1469,3 +1474,16 @@ Index: gdb-7.1.90.20100806/gdb/acinclude.m4
# @defmac AC_PROG_CC_STDC
# @maindex PROG_CC_STDC
# @ovindex CC
Index: gdb-7.2/gdb/corelow.c
===================================================================
--- gdb-7.2.orig/gdb/corelow.c 2010-10-06 22:39:39.000000000 +0200
+++ gdb-7.2/gdb/corelow.c 2010-10-06 22:39:52.000000000 +0200
@@ -331,7 +331,7 @@ build_id_locate_exec (int from_tty)
symfile_objfile->flags |= OBJF_BUILD_ID_CORE_LOADED;
}
else
- debug_print_missing (_("the main executable file"), build_id_filename);
+ debug_print_missing (BUILD_ID_MAIN_EXECUTABLE_FILENAME, build_id_filename);
do_cleanups (back_to);

View File

@ -27,7 +27,7 @@ Version: 7.2
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 17%{?_with_upstream:.upstream}%{dist}
Release: 18%{?_with_upstream:.upstream}%{dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and GFDL and BSD and Public Domain
Group: Development/Debuggers
@ -1093,6 +1093,9 @@ fi
%endif
%changelog
* Wed Oct 6 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2-18.fc14
- Fix false warning: non-absolute filename: <the main exec. file> (BZ 640648).
* Thu Sep 30 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2-17.fc14
- New Conflicts: elfutils < 0.149 due to the .gdb_index .debug support.