- Upgrade to the FSF GDB gdb-6.8.50 snapshot.
This commit is contained in:
parent
81783d0ff2
commit
a1707b2aa7
@ -1 +1 @@
|
||||
gdb-6.8.50.20090209.tar.bz2
|
||||
gdb-6.8.50.20090210.tar.bz2
|
||||
|
@ -376,7 +376,7 @@ Index: gdb-6.8.50.20081128/gdb/linespec.c
|
||||
|
||||
/* The parser of linespec itself. */
|
||||
|
||||
@@ -1438,35 +1682,46 @@ find_method (int funfirstline, char ***c
|
||||
@@ -1438,35 +1682,47 @@ find_method (int funfirstline, char ***c
|
||||
struct symbol **sym_arr = alloca (total_number_of_methods (t)
|
||||
* sizeof (struct symbol *));
|
||||
|
||||
@ -422,6 +422,7 @@ Index: gdb-6.8.50.20081128/gdb/linespec.c
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ values.sals = NULL;
|
||||
+ values.nelts = 0;
|
||||
+ }
|
||||
+ return values;
|
||||
|
@ -1,16 +1,16 @@
|
||||
Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
Index: gdb-6.8.50.20090210/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20081128.orig/gdb/dwarf2read.c 2008-12-06 14:06:17.000000000 +0100
|
||||
+++ gdb-6.8.50.20081128/gdb/dwarf2read.c 2008-12-06 21:53:09.000000000 +0100
|
||||
@@ -1825,6 +1825,7 @@ scan_partial_symbols (struct partial_die
|
||||
add_partial_subprogram (pdi, lowpc, highpc, cu);
|
||||
--- gdb-6.8.50.20090210.orig/gdb/dwarf2read.c 2009-02-11 01:25:45.000000000 +0100
|
||||
+++ gdb-6.8.50.20090210/gdb/dwarf2read.c 2009-02-11 01:26:25.000000000 +0100
|
||||
@@ -1845,6 +1845,7 @@ scan_partial_symbols (struct partial_die
|
||||
add_partial_subprogram (pdi, lowpc, highpc, need_pc, cu);
|
||||
break;
|
||||
case DW_TAG_variable:
|
||||
+ case DW_TAG_constant:
|
||||
case DW_TAG_typedef:
|
||||
case DW_TAG_union_type:
|
||||
if (!pdi->is_declaration)
|
||||
@@ -2010,6 +2011,7 @@ add_partial_symbol (struct partial_die_i
|
||||
@@ -2030,6 +2031,7 @@ add_partial_symbol (struct partial_die_i
|
||||
}
|
||||
break;
|
||||
case DW_TAG_variable:
|
||||
@ -18,7 +18,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
if (pdi->is_external)
|
||||
{
|
||||
/* Global Variable.
|
||||
@@ -2864,6 +2866,7 @@ dwarf2_full_name (struct die_info *die,
|
||||
@@ -2895,6 +2897,7 @@ dwarf2_full_name (struct die_info *die,
|
||||
if (!pdi_needs_namespace (die->tag)
|
||||
&& die->tag != DW_TAG_subprogram
|
||||
&& die->tag != DW_TAG_variable
|
||||
@ -26,7 +26,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
&& die->tag != DW_TAG_member)
|
||||
return name;
|
||||
|
||||
@@ -3704,7 +3707,8 @@ dwarf2_add_field (struct field_info *fip
|
||||
@@ -3735,7 +3738,8 @@ dwarf2_add_field (struct field_info *fip
|
||||
fip->non_public_fields = 1;
|
||||
}
|
||||
}
|
||||
@ -36,7 +36,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
{
|
||||
/* C++ static member. */
|
||||
|
||||
@@ -4182,7 +4186,8 @@ read_structure_type (struct die_info *di
|
||||
@@ -4213,7 +4217,8 @@ read_structure_type (struct die_info *di
|
||||
while (child_die && child_die->tag)
|
||||
{
|
||||
if (child_die->tag == DW_TAG_member
|
||||
@ -46,7 +46,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
{
|
||||
/* NOTE: carlton/2002-11-05: A C++ static data member
|
||||
should be a DW_TAG_member that is a declaration, but
|
||||
@@ -4301,6 +4306,7 @@ process_structure_scope (struct die_info
|
||||
@@ -4332,6 +4337,7 @@ process_structure_scope (struct die_info
|
||||
{
|
||||
if (child_die->tag == DW_TAG_member
|
||||
|| child_die->tag == DW_TAG_variable
|
||||
@ -54,7 +54,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
|| child_die->tag == DW_TAG_inheritance)
|
||||
{
|
||||
/* Do nothing. */
|
||||
@@ -5700,6 +5706,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
@@ -5862,6 +5868,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
&& abbrev->tag != DW_TAG_subprogram
|
||||
&& abbrev->tag != DW_TAG_lexical_block
|
||||
&& abbrev->tag != DW_TAG_variable
|
||||
@ -62,7 +62,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
&& abbrev->tag != DW_TAG_namespace
|
||||
&& abbrev->tag != DW_TAG_member)
|
||||
{
|
||||
@@ -5807,6 +5814,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
@@ -5969,6 +5976,7 @@ load_partial_dies (bfd *abfd, gdb_byte *
|
||||
if (load_all
|
||||
|| abbrev->tag == DW_TAG_subprogram
|
||||
|| abbrev->tag == DW_TAG_variable
|
||||
@ -70,7 +70,7 @@ Index: gdb-6.8.50.20081128/gdb/dwarf2read.c
|
||||
|| abbrev->tag == DW_TAG_namespace
|
||||
|| part_die->is_declaration)
|
||||
{
|
||||
@@ -7593,6 +7601,11 @@ new_symbol (struct die_info *die, struct
|
||||
@@ -7759,6 +7767,11 @@ new_symbol (struct die_info *die, struct
|
||||
/* Do not add the symbol to any lists. It will be found via
|
||||
BLOCK_FUNCTION from the blockvector. */
|
||||
break;
|
||||
|
5
gdb.spec
5
gdb.spec
@ -9,7 +9,7 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 6.8.50.20090209
|
||||
Version: 6.8.50.20090210
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
@ -822,6 +822,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 11 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090210-1
|
||||
- Upgrade to the FSF GDB gdb-6.8.50 snapshot.
|
||||
|
||||
* Wed Feb 11 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090209-1
|
||||
- Upgrade to the FSF GDB gdb-6.8.50 snapshot.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user