- Fix false warning: section .gnu.liblist not found in ...
- Fix crash on stale addrinfo->sectindex (more sensitive due to the PIE patch).
This commit is contained in:
parent
7d64017236
commit
991247c843
114
gdb-false-warning-gnu.liblist.patch
Normal file
114
gdb-false-warning-gnu.liblist.patch
Normal file
@ -0,0 +1,114 @@
|
||||
http://sourceware.org/ml/gdb-patches/2010-02/msg00713.html
|
||||
Subject: Re: [patch] Fix false warning: section .gnu.liblist not found in ... [rediffed]
|
||||
|
||||
Hi,
|
||||
|
||||
only a technical rediff.
|
||||
|
||||
------------------------------------------------------------------------------
|
||||
|
||||
On Sat, 13 Feb 2010 23:49:29 +0100, Jan Kratochvil wrote:
|
||||
Hi,
|
||||
|
||||
post-7.0 GDB started to print many false warnings on prelink-ed system:
|
||||
|
||||
$ ./gdb -nx -ex r echo
|
||||
...
|
||||
Reading symbols from /bin/echo...Reading symbols from /usr/lib/debug/bin/echo.debug...
|
||||
warning: section .gnu.liblist not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.conflict not found in /usr/lib/debug/bin/echo.debug
|
||||
done.
|
||||
done.
|
||||
Starting program: /bin/echo
|
||||
warning: section .gnu.liblist not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.conflict not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.liblist not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.conflict not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.liblist not found in /usr/lib/debug/bin/echo.debug
|
||||
warning: section .gnu.conflict not found in /usr/lib/debug/bin/echo.debug
|
||||
|
||||
These sections are from prelink and they are not present in the *.debug files.
|
||||
|
||||
It is formally a regression by:
|
||||
|
||||
commit 3bfec189bb0fa1a2a44f1645dd68a9572e7a841c
|
||||
|
||||
2010-01-07 Tristan Gingold <gingold@adacore.com>
|
||||
|
||||
* symfile.c (build_section_addr_info_from_objfile): New function.
|
||||
(symbol_file_add_separate): Don't use offsets from objfile but
|
||||
built an addr info.
|
||||
|
||||
|
||||
But I think would be unavoidable even for the unification of PIC+PIE handling.
|
||||
|
||||
Found no usable section flag differences for .gnu.liblist vs. for example
|
||||
.text so used just the section name for the exception.
|
||||
|
||||
.gnu.liblist/.gnu.conflict related dumps:
|
||||
|
||||
executable:
|
||||
Section Headers:
|
||||
[Nr] Name Type Address Off Size ES Flg Lk Inf Al
|
||||
[ 6] .gnu.liblist GNU_LIBLIST 00000000004006b8 0006b8 000028 14 A 28 0 4
|
||||
[ 7] .gnu.conflict RELA 00000000004006e0 0006e0 0001c8 18 A 5 0 8
|
||||
Program Headers:
|
||||
Type Offset VirtAddr PhysAddr FileSiz MemSiz Flg Align
|
||||
LOAD 0x000000 0x0000000000400000 0x0000000000400000 0x005254 0x005254 R E 0x200000
|
||||
Dynamic section at offset 0x52c8 contains 24 entries:
|
||||
Tag Type Name/Value
|
||||
0x000000006ffffef9 (GNU_LIBLIST) 0x4006b8
|
||||
0x000000006ffffdf7 (GNU_LIBLISTSZ) 40 (bytes)
|
||||
0x000000006ffffef8 (GNU_CONFLICT) 0x4006e0
|
||||
0x000000006ffffdf6 (GNU_CONFLICTSZ) 456 (bytes)
|
||||
|
||||
library:
|
||||
Section Headers:
|
||||
[Nr] Name Type Address Off Size ES Flg Lk Inf Al
|
||||
[74] .gnu.liblist GNU_LIBLIST 0000000000000000 249940 000014 14 75 0 4
|
||||
|
||||
|
||||
No regressions on {x86_64,x86_64-m32,i686}-fedora12-linux-gnu.
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
|
||||
2010-03-01 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* symfile.c (addr_info_make_relative): New variable sect_name, use it.
|
||||
Do not warn on ".gnu.liblist" and ".gnu.conflict".
|
||||
|
||||
--- a/gdb/symfile.c
|
||||
+++ b/gdb/symfile.c
|
||||
@@ -597,7 +597,8 @@ addr_info_make_relative (struct section_addr_info *addrs, bfd *abfd)
|
||||
|
||||
for (i = 0; i < addrs->num_sections && addrs->other[i].name; i++)
|
||||
{
|
||||
- asection *sect = bfd_get_section_by_name (abfd, addrs->other[i].name);
|
||||
+ const char *sect_name = addrs->other[i].name;
|
||||
+ asection *sect = bfd_get_section_by_name (abfd, sect_name);
|
||||
|
||||
if (sect)
|
||||
{
|
||||
@@ -614,8 +615,16 @@ addr_info_make_relative (struct section_addr_info *addrs, bfd *abfd)
|
||||
}
|
||||
else
|
||||
{
|
||||
- warning (_("section %s not found in %s"), addrs->other[i].name,
|
||||
- bfd_get_filename (abfd));
|
||||
+ /* These two sections are intentionally loaded into memory from
|
||||
+ the DYNAMIC segment and so they have both SEC_ALLOC and SEC_LOAD
|
||||
+ set in the main executable (not in the library files). They
|
||||
+ are not present in the separate debug info file, though. */
|
||||
+
|
||||
+ if (!(strcmp (sect_name, ".gnu.liblist") == 0
|
||||
+ || strcmp (sect_name, ".gnu.conflict") == 0))
|
||||
+ warning (_("section %s not found in %s"), sect_name,
|
||||
+ bfd_get_filename (abfd));
|
||||
+
|
||||
addrs->other[i].addr = 0;
|
||||
|
||||
/* SECTINDEX is invalid if ADDR is zero. */
|
||||
|
112
gdb-stale-sectindex.patch
Normal file
112
gdb-stale-sectindex.patch
Normal file
@ -0,0 +1,112 @@
|
||||
http://sourceware.org/ml/gdb-patches/2010-02/msg00477.html
|
||||
Subject: Re: [patch] Fix crash on stale addrinfo->sectindex
|
||||
|
||||
On Fri, 19 Feb 2010 04:01:05 +0100, Tom Tromey wrote:
|
||||
> >>>>> "Jan" == Jan Kratochvil <jan.kratochvil@redhat.com> writes:
|
||||
> I think you ought to move this comment as well.
|
||||
> It appears to just be hanging at the end of a block after the patch.
|
||||
|
||||
Yes; forgot.
|
||||
|
||||
> This is ok with that change. Thanks.
|
||||
|
||||
Checked-in.
|
||||
|
||||
On Fri, 19 Feb 2010 04:10:30 +0100, Tom Tromey wrote:
|
||||
> Oh, by the way, I think this is reasonable for 7.1. It is
|
||||
> straightforward and fixes a reported crash. If Joel agrees, please put
|
||||
> it on the branch. Thanks.
|
||||
|
||||
OK for the branch?
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
|
||||
http://sourceware.org/ml/gdb-cvs/2010-02/msg00162.html
|
||||
|
||||
### src/gdb/ChangeLog 2010/02/19 00:35:53 1.11380
|
||||
### src/gdb/ChangeLog 2010/02/19 06:19:44 1.11381
|
||||
## -1,3 +1,10 @@
|
||||
+2010-02-19 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
+ * symfile.c (addr_info_make_relative): Extend comment. Move SECT to
|
||||
+ a more inner block. Initialize ADDR by LOWER_OFFSET only if it was
|
||||
+ found by bfd_get_section_by_name.
|
||||
+ * symfile.h (struct section_addr_info) <sectindex>: New comment.
|
||||
+
|
||||
2010-02-19 Joel Brobecker <brobecker@adacore.com>
|
||||
|
||||
* NEWS: Add new "[...] since 7.1" section. Rename the "[...] since
|
||||
--- src/gdb/symfile.c 2010/02/18 19:17:00 1.272
|
||||
+++ src/gdb/symfile.c 2010/02/19 06:19:45 1.273
|
||||
@@ -562,13 +562,13 @@
|
||||
}
|
||||
|
||||
/* Relativize absolute addresses in ADDRS into offsets based on ABFD. Fill-in
|
||||
- also SECTINDEXes there. */
|
||||
+ also SECTINDEXes specific to ABFD there. This function can be used to
|
||||
+ rebase ADDRS to start referencing different BFD than before. */
|
||||
|
||||
void
|
||||
addr_info_make_relative (struct section_addr_info *addrs, bfd *abfd)
|
||||
{
|
||||
asection *lower_sect;
|
||||
- asection *sect;
|
||||
CORE_ADDR lower_offset;
|
||||
int i;
|
||||
|
||||
@@ -597,25 +597,29 @@
|
||||
|
||||
for (i = 0; i < addrs->num_sections && addrs->other[i].name; i++)
|
||||
{
|
||||
- if (addrs->other[i].addr != 0)
|
||||
+ asection *sect = bfd_get_section_by_name (abfd, addrs->other[i].name);
|
||||
+
|
||||
+ if (sect)
|
||||
{
|
||||
- sect = bfd_get_section_by_name (abfd, addrs->other[i].name);
|
||||
- if (sect)
|
||||
+ /* This is the index used by BFD. */
|
||||
+ addrs->other[i].sectindex = sect->index;
|
||||
+
|
||||
+ if (addrs->other[i].addr != 0)
|
||||
{
|
||||
addrs->other[i].addr -= bfd_section_vma (abfd, sect);
|
||||
lower_offset = addrs->other[i].addr;
|
||||
- /* This is the index used by BFD. */
|
||||
- addrs->other[i].sectindex = sect->index;
|
||||
}
|
||||
else
|
||||
- {
|
||||
- warning (_("section %s not found in %s"), addrs->other[i].name,
|
||||
- bfd_get_filename (abfd));
|
||||
- addrs->other[i].addr = 0;
|
||||
- }
|
||||
+ addrs->other[i].addr = lower_offset;
|
||||
}
|
||||
else
|
||||
- addrs->other[i].addr = lower_offset;
|
||||
+ {
|
||||
+ warning (_("section %s not found in %s"), addrs->other[i].name,
|
||||
+ bfd_get_filename (abfd));
|
||||
+ addrs->other[i].addr = 0;
|
||||
+
|
||||
+ /* SECTINDEX is invalid if ADDR is zero. */
|
||||
+ }
|
||||
}
|
||||
}
|
||||
|
||||
--- src/gdb/symfile.h 2010/02/03 14:13:16 1.64
|
||||
+++ src/gdb/symfile.h 2010/02/19 06:19:45 1.65
|
||||
@@ -80,6 +80,8 @@
|
||||
{
|
||||
CORE_ADDR addr;
|
||||
char *name;
|
||||
+
|
||||
+ /* SECTINDEX must be valid for associated BFD if ADDR is not zero. */
|
||||
int sectindex;
|
||||
} other[1];
|
||||
};
|
||||
|
14
gdb.spec
14
gdb.spec
@ -36,7 +36,7 @@ Version: 7.0.50.20100203
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 16%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 17%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -430,9 +430,15 @@ Patch412: gdb-unused-revert.patch
|
||||
# Fix i386+x86_64 rwatch+awatch before run, regression against 6.8 (BZ 541866).
|
||||
Patch417: gdb-bz541866-rwatch-before-run.patch
|
||||
|
||||
# Fix crash on stale addrinfo->sectindex (more sensitive due to the PIE patch).
|
||||
Patch421: gdb-stale-sectindex.patch
|
||||
|
||||
# Remove false gdb_assert on $sp underflow.
|
||||
Patch422: gdb-infcall-sp-underflow.patch
|
||||
|
||||
# Fix false warning: section .gnu.liblist not found in ...
|
||||
Patch425: gdb-false-warning-gnu.liblist.patch
|
||||
|
||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||
Requires: readline%{?_isa}
|
||||
BuildRequires: readline-devel%{?_isa}
|
||||
@ -683,7 +689,9 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch408 -p1
|
||||
%patch412 -p1
|
||||
%patch417 -p1
|
||||
%patch421 -p1
|
||||
%patch422 -p1
|
||||
%patch425 -p1
|
||||
|
||||
%patch415 -p1
|
||||
%patch393 -p1
|
||||
@ -1016,6 +1024,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Feb 28 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100203-17.fc13
|
||||
- Fix false warning: section .gnu.liblist not found in ...
|
||||
- Fix crash on stale addrinfo->sectindex (more sensitive due to the PIE patch).
|
||||
|
||||
* Fri Feb 26 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100203-16.fc13
|
||||
- Fix ia64 part of the bt-clone-stop.exp fix.
|
||||
- Fix gdb.ada/* regressions (Keith Seitz).
|
||||
|
Loading…
Reference in New Issue
Block a user