Import 5 upstream gdb-7.8 branch fixes (async fix by Pedro Alves).

This commit is contained in:
Jan Kratochvil 2014-10-19 18:44:20 +02:00
parent e3bcba8731
commit 8a983520e3
4 changed files with 1729 additions and 21 deletions

View File

@ -35,21 +35,21 @@ Index: gdb-7.8/gdb/data-directory/Makefile.in
===================================================================
--- gdb-7.8.orig/gdb/data-directory/Makefile.in 2014-07-29 19:29:02.665979655 +0200
+++ gdb-7.8/gdb/data-directory/Makefile.in 2014-07-29 19:29:33.053022486 +0200
@@ -66,6 +66,8 @@ PYTHON_FILE_LIST = \
@@ -65,6 +65,8 @@ PYTHON_FILE_LIST = \
gdb/prompt.py \
gdb/xmethod.py \
gdb/command/bound_registers.py \
gdb/command/__init__.py \
+ gdb/command/ignore_errors.py \
+ gdb/command/pahole.py \
gdb/command/xmethods.py \
gdb/command/frame_filters.py \
gdb/command/type_printers.py \
@@ -73,7 +75,10 @@ PYTHON_FILE_LIST = \
gdb/command/prompt.py \
gdb/command/explore.py \
@@ -74,7 +76,10 @@ PYTHON_FILE_LIST = \
gdb/function/__init__.py \
- gdb/function/strfns.py
+ gdb/function/strfns.py \
gdb/function/strfns.py \
gdb/printer/__init__.py \
- gdb/printer/bound_registers.py
+ gdb/printer/bound_registers.py \
+ gdb/function/caller_is.py \
+ gdb/function/in_scope.py \
+ gdb/types.py

View File

@ -1,10 +1,10 @@
https://bugzilla.redhat.com/show_bug.cgi?id=1020004
Index: gdb-7.7.90.20140613/gdb/data-directory/Makefile.in
Index: gdb-7.8/gdb/data-directory/Makefile.in
===================================================================
--- gdb-7.7.90.20140613.orig/gdb/data-directory/Makefile.in 2014-06-13 23:02:37.597115787 +0200
+++ gdb-7.7.90.20140613/gdb/data-directory/Makefile.in 2014-06-13 23:03:21.285163909 +0200
@@ -60,6 +60,8 @@ PYTHON_FILES = \
--- gdb-7.8.orig/gdb/data-directory/Makefile.in 2014-10-19 18:25:34.187110261 +0200
+++ gdb-7.8/gdb/data-directory/Makefile.in 2014-10-19 18:25:51.092121706 +0200
@@ -60,6 +60,8 @@ PYTHON_FILE_LIST = \
gdb/frames.py \
gdb/FrameIterator.py \
gdb/FrameDecorator.py \
@ -13,18 +13,18 @@ Index: gdb-7.7.90.20140613/gdb/data-directory/Makefile.in
gdb/types.py \
gdb/printing.py \
gdb/prompt.py \
@@ -74,6 +76,7 @@ PYTHON_FILES = \
@@ -73,6 +75,7 @@ PYTHON_FILE_LIST = \
gdb/command/pretty_printers.py \
gdb/command/prompt.py \
gdb/command/explore.py \
+ gdb/command/backtrace.py \
gdb/function/__init__.py \
gdb/function/strfns.py \
gdb/function/caller_is.py \
Index: gdb-7.7.90.20140613/gdb/python/lib/gdb/FrameWrapper.py
gdb/printer/__init__.py \
Index: gdb-7.8/gdb/python/lib/gdb/FrameWrapper.py
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-7.7.90.20140613/gdb/python/lib/gdb/FrameWrapper.py 2014-06-13 23:02:37.598115788 +0200
+++ gdb-7.8/gdb/python/lib/gdb/FrameWrapper.py 2014-10-19 18:25:36.808112031 +0200
@@ -0,0 +1,122 @@
+# Wrapper API for frames.
+
@ -148,10 +148,10 @@ Index: gdb-7.7.90.20140613/gdb/python/lib/gdb/FrameWrapper.py
+
+ def __getattr__ (self, name):
+ return getattr (self.frame, name)
Index: gdb-7.7.90.20140613/gdb/python/lib/gdb/backtrace.py
Index: gdb-7.8/gdb/python/lib/gdb/backtrace.py
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-7.7.90.20140613/gdb/python/lib/gdb/backtrace.py 2014-06-13 23:02:37.598115788 +0200
+++ gdb-7.8/gdb/python/lib/gdb/backtrace.py 2014-10-19 18:25:36.808112031 +0200
@@ -0,0 +1,42 @@
+# Filtering backtrace.
+
@ -195,10 +195,10 @@ Index: gdb-7.7.90.20140613/gdb/python/lib/gdb/backtrace.py
+ return iter
+ return old_frame_filter (iter)
+
Index: gdb-7.7.90.20140613/gdb/python/lib/gdb/command/backtrace.py
Index: gdb-7.8/gdb/python/lib/gdb/command/backtrace.py
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-7.7.90.20140613/gdb/python/lib/gdb/command/backtrace.py 2014-06-13 23:02:37.598115788 +0200
+++ gdb-7.8/gdb/python/lib/gdb/command/backtrace.py 2014-10-19 18:25:36.808112031 +0200
@@ -0,0 +1,106 @@
+# New backtrace command.
+

File diff suppressed because it is too large Load Diff

View File

@ -26,7 +26,7 @@ Version: 7.8
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 25%{?dist}
Release: 26%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -722,8 +722,8 @@ find -name "*.info*"|xargs rm -f
# Match the Fedora's version info.
%patch2 -p1
%patch349 -p1
%patch232 -p1
%patch349 -p1
%patch888 -p1
%patch912 -p1
%patch889 -p1
@ -1339,6 +1339,9 @@ then
fi
%changelog
* Sun Oct 19 2014 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.8-26.fc21
- Import 5 upstream gdb-7.8 branch fixes (async fix by Pedro Alves).
* Fri Oct 03 2014 Sergio Durigan Junior <sergiodj@redhat.com> - 7.8-25.fc21
- Fix 'Slow gstack performance' (RH BZ 1103894, Jan Kratochvil).