[vla] New testcase for the unfinished types garbage collector (for BZ 682286).
This commit is contained in:
parent
995b9dcf6c
commit
881338babd
@ -371,3 +371,104 @@
|
||||
observer_attach_mark_used (value_types_mark_used);
|
||||
+#endif
|
||||
}
|
||||
commit b20c7d74a7e132186e7d80525eae8ed08ca4d5b8
|
||||
Author: Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
Date: Tue Mar 8 08:50:33 2011 +0100
|
||||
|
||||
New testcase for the garbage collector MI incompleteness.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.mi/mi2-var-stale-type.c b/gdb/testsuite/gdb.mi/mi2-var-stale-type.c
|
||||
new file mode 100644
|
||||
index 0000000..ebced3c
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.mi/mi2-var-stale-type.c
|
||||
@@ -0,0 +1,26 @@
|
||||
+/* Copyright 2011 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This file is part of GDB.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
+
|
||||
+int
|
||||
+main (int argc, char **argv)
|
||||
+{
|
||||
+ char vla[argc];
|
||||
+
|
||||
+ vla[0] = 0; /* break-here */
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
diff --git a/gdb/testsuite/gdb.mi/mi2-var-stale-type.exp b/gdb/testsuite/gdb.mi/mi2-var-stale-type.exp
|
||||
new file mode 100644
|
||||
index 0000000..74a104e
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.mi/mi2-var-stale-type.exp
|
||||
@@ -0,0 +1,57 @@
|
||||
+# Copyright 2011 Free Software Foundation, Inc.
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 3 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+load_lib mi-support.exp
|
||||
+set MIFLAGS "-i=mi2"
|
||||
+
|
||||
+gdb_exit
|
||||
+if [mi_gdb_start] {
|
||||
+ continue
|
||||
+}
|
||||
+
|
||||
+set testfile "mi2-var-stale-type"
|
||||
+set srcfile ${testfile}.c
|
||||
+set binfile ${objdir}/${subdir}/${testfile}
|
||||
+if {[build_executable ${testfile}.exp $testfile $srcfile] == -1} {
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+mi_delete_breakpoints
|
||||
+mi_gdb_reinitialize_dir $srcdir/$subdir
|
||||
+mi_gdb_load ${binfile}
|
||||
+
|
||||
+mi_gdb_test {-interpreter-exec console "maintenance set internal-error quit yes"} \
|
||||
+ {\^done} \
|
||||
+ "maintenance set internal-error quit yes"
|
||||
+
|
||||
+mi_gdb_test {-interpreter-exec console "maintenance set internal-error corefile yes"} \
|
||||
+ {\^done} \
|
||||
+ "maintenance set internal-error corefile yes"
|
||||
+
|
||||
+set line [gdb_get_line_number "break-here"]
|
||||
+set func "main"
|
||||
+
|
||||
+mi_gdb_test "-break-insert -t $srcfile:$line" \
|
||||
+ "\\^done,bkpt=\{number=\"\[0-9\]+\",type=\"breakpoint\",disp=\"del\",enabled=\"y\",addr=\"$hex\",func=\"$func\(\\\(.*\\\)\)?\",file=\".*\",line=\"$line\",times=\"0\",original-location=\".*\"\}" \
|
||||
+ "breakpoint at $func"
|
||||
+
|
||||
+if { [mi_run_cmd] < 0 } {
|
||||
+ return -1
|
||||
+}
|
||||
+mi_expect_stop "breakpoint-hit" $func ".*" ".*" "\[0-9\]+" { "" "disp=\"del\"" } "stop after initializing vla"
|
||||
+
|
||||
+mi_create_varobj "vla" "vla" "create local variable vla"
|
||||
+
|
||||
+mi_gdb_test "-var-update *" "\\^done,changelist=.*" "-var-update *"
|
||||
|
6
gdb.spec
6
gdb.spec
@ -27,7 +27,7 @@ Version: 7.2
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 46%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 47%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and GFDL and BSD and Public Domain
|
||||
Group: Development/Debuggers
|
||||
@ -744,6 +744,7 @@ Patch573: gdb-core-thread-internalerr-2of3.patch
|
||||
Patch574: gdb-core-thread-internalerr-3of3.patch
|
||||
|
||||
# [vla] Disable the unfinished types garbage collector (BZ 682286).
|
||||
# [vla] New testcase for the unfinished types garbage collector (for BZ 682286).
|
||||
Patch575: gdb-vla-gc-disable.patch
|
||||
|
||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||
@ -1463,6 +1464,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Mar 8 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2-47.fc14
|
||||
- [vla] New testcase for the unfinished types garbage collector (for BZ 682286).
|
||||
|
||||
* Sat Mar 5 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2-46.fc14
|
||||
- [vla] Disable the unfinished types garbage collector (BZ 682286).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user