- Upgrade libstdc++ Python pretty printers to r155978 (Phil Muldoon, BZ
561541).
This commit is contained in:
parent
1af55b59fd
commit
855ae15dd6
@ -1,2 +1,2 @@
|
||||
gdb-7.0.1.tar.bz2
|
||||
libstdc++-v3-python-r151798.tar.bz2
|
||||
libstdc++-v3-python-r155978.tar.bz2
|
||||
|
11
gdb.spec
11
gdb.spec
@ -36,7 +36,7 @@ Version: 7.0.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 39%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 40%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -81,7 +81,7 @@ Source2: gdb-orphanripper.c
|
||||
Source3: gdb-gstack.man
|
||||
|
||||
# libstdc++ pretty printers from GCC SVN HEAD (4.5 experimental).
|
||||
%define libstdcxxpython libstdc++-v3-python-r151798
|
||||
%define libstdcxxpython libstdc++-v3-python-r155978
|
||||
Source4: %{libstdcxxpython}.tar.bz2
|
||||
|
||||
# Work around out-of-date dejagnu that does not have KFAIL
|
||||
@ -386,9 +386,6 @@ Patch360: gdb-6.8-bz457187-largefile-test.patch
|
||||
# Fix compatibility of --with-system-readline and readline-6.0+.
|
||||
Patch375: gdb-readline-6.0.patch
|
||||
|
||||
# Fix python pretty printers lookup on x86_64.
|
||||
Patch376: libstdc++-v3-python-common-prefix.patch
|
||||
|
||||
# New test for step-resume breakpoint placed in multiple threads at once.
|
||||
Patch381: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
|
||||
@ -733,7 +730,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch352 -p1
|
||||
%patch360 -p1
|
||||
%patch375 -p1
|
||||
%patch376 -p1
|
||||
%patch381 -p1
|
||||
%patch382 -p1
|
||||
%ifnarch %{sparc}
|
||||
@ -1093,6 +1089,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Apr 4 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.1-40.fc12
|
||||
- Upgrade libstdc++ Python pretty printers to r155978 (Phil Muldoon, BZ 561541).
|
||||
|
||||
* Sat Apr 3 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.1-39.fc12
|
||||
- Fix dangling displays in separate debuginfo (BZ 574483).
|
||||
|
||||
|
@ -1,18 +0,0 @@
|
||||
On x86_64 host with:
|
||||
pythondir: /usr/lib/python2.6/site-packages/gdb
|
||||
libdir: /usr/lib64
|
||||
|
||||
prefix got set to "/usr/lib" but the code expects a trailing "/" (missing then
|
||||
one "../" path component).
|
||||
|
||||
--- ./libstdc++-v3-python-r151798/hook.in-orig 2009-06-18 21:12:37.000000000 +0200
|
||||
+++ ./libstdc++-v3-python-r151798/hook.in 2009-09-17 23:37:35.000000000 +0200
|
||||
@@ -40,7 +40,7 @@ if gdb.current_objfile () is not None:
|
||||
# In some bizarre configuration we might have found a match in the
|
||||
# middle of a directory name.
|
||||
if prefix[-1] != '/':
|
||||
- prefix = os.path.dirname (prefix)
|
||||
+ prefix = os.path.dirname (prefix) + '/'
|
||||
|
||||
# Strip off the prefix.
|
||||
pythondir = pythondir[len (prefix):]
|
Loading…
Reference in New Issue
Block a user