Suppress librpm non-absolute filename warnings for /^remote:/ filenames.

This commit is contained in:
Jan Kratochvil 2016-01-20 22:22:06 +01:00
parent 65adaa87b1
commit 6f06b1f20c
2 changed files with 45 additions and 39 deletions

View File

@ -1,7 +1,7 @@
Index: gdb-7.10.50.20151113/gdb/event-top.c
Index: gdb-7.10.50.20160106/gdb/event-top.c
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/event-top.c 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/event-top.c 2015-11-14 16:09:19.785362435 +0100
--- gdb-7.10.50.20160106.orig/gdb/event-top.c
+++ gdb-7.10.50.20160106/gdb/event-top.c
@@ -37,6 +37,7 @@
#include "gdbcmd.h" /* for dont_repeat() */
#include "annotate.h"
@ -28,10 +28,10 @@ Index: gdb-7.10.50.20151113/gdb/event-top.c
old_chain = make_cleanup (free_current_contents, &actual_gdb_prompt);
/* Do not call the python hook on an explicit prompt change as
Index: gdb-7.10.50.20151113/gdb/symfile.h
Index: gdb-7.10.50.20160106/gdb/symfile.h
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/symfile.h 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/symfile.h 2015-11-14 16:09:19.786362441 +0100
--- gdb-7.10.50.20160106.orig/gdb/symfile.h
+++ gdb-7.10.50.20160106/gdb/symfile.h
@@ -587,6 +587,8 @@ void map_symbol_filenames (symbol_filena
/* build-id support. */
extern struct bfd_build_id *build_id_addr_get (CORE_ADDR addr);
@ -41,11 +41,11 @@ Index: gdb-7.10.50.20151113/gdb/symfile.h
/* From dwarf2read.c */
Index: gdb-7.10.50.20151113/gdb/testsuite/lib/gdb.exp
Index: gdb-7.10.50.20160106/gdb/testsuite/lib/gdb.exp
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/testsuite/lib/gdb.exp 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/testsuite/lib/gdb.exp 2015-11-14 16:09:19.786362441 +0100
@@ -1640,7 +1640,7 @@ proc default_gdb_start { } {
--- gdb-7.10.50.20160106.orig/gdb/testsuite/lib/gdb.exp
+++ gdb-7.10.50.20160106/gdb/testsuite/lib/gdb.exp
@@ -1642,7 +1642,7 @@ proc default_gdb_start { } {
warning "Couldn't set the width to 0."
}
}
@ -54,10 +54,10 @@ Index: gdb-7.10.50.20151113/gdb/testsuite/lib/gdb.exp
send_gdb "set build-id-verbose 0\n"
gdb_expect 10 {
-re "$gdb_prompt $" {
Index: gdb-7.10.50.20151113/gdb/testsuite/lib/mi-support.exp
Index: gdb-7.10.50.20160106/gdb/testsuite/lib/mi-support.exp
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/testsuite/lib/mi-support.exp 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/testsuite/lib/mi-support.exp 2015-11-14 16:09:19.787362447 +0100
--- gdb-7.10.50.20160106.orig/gdb/testsuite/lib/mi-support.exp
+++ gdb-7.10.50.20160106/gdb/testsuite/lib/mi-support.exp
@@ -204,7 +204,7 @@ proc default_mi_gdb_start { args } {
warning "Couldn't set the width to 0."
}
@ -67,10 +67,10 @@ Index: gdb-7.10.50.20151113/gdb/testsuite/lib/mi-support.exp
send_gdb "190-gdb-set build-id-verbose 0\n"
gdb_expect 10 {
-re ".*190-gdb-set build-id-verbose 0\r\n190\\\^done\r\n$mi_gdb_prompt$" {
Index: gdb-7.10.50.20151113/gdb/tui/tui-interp.c
Index: gdb-7.10.50.20160106/gdb/tui/tui-interp.c
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/tui/tui-interp.c 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/tui/tui-interp.c 2015-11-14 16:09:19.787362447 +0100
--- gdb-7.10.50.20160106.orig/gdb/tui/tui-interp.c
+++ gdb-7.10.50.20160106/gdb/tui/tui-interp.c
@@ -31,6 +31,7 @@
#include "tui/tui-io.h"
#include "infrun.h"
@ -79,10 +79,10 @@ Index: gdb-7.10.50.20151113/gdb/tui/tui-interp.c
static struct ui_out *tui_ui_out (struct interp *self);
Index: gdb-7.10.50.20151113/gdb/aclocal.m4
Index: gdb-7.10.50.20160106/gdb/aclocal.m4
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/aclocal.m4 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/aclocal.m4 2015-11-14 16:09:19.787362447 +0100
--- gdb-7.10.50.20160106.orig/gdb/aclocal.m4
+++ gdb-7.10.50.20160106/gdb/aclocal.m4
@@ -11,6 +11,221 @@
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
# PARTICULAR PURPOSE.
@ -305,10 +305,10 @@ Index: gdb-7.10.50.20151113/gdb/aclocal.m4
# AM_AUX_DIR_EXPAND -*- Autoconf -*-
# Copyright (C) 2001, 2003, 2005 Free Software Foundation, Inc.
Index: gdb-7.10.50.20151113/gdb/config.in
Index: gdb-7.10.50.20160106/gdb/config.in
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/config.in 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/config.in 2015-11-14 16:09:19.787362447 +0100
--- gdb-7.10.50.20160106.orig/gdb/config.in
+++ gdb-7.10.50.20160106/gdb/config.in
@@ -33,6 +33,9 @@
/* Define to BFD's default target vector. */
#undef DEFAULT_BFD_VEC
@ -329,10 +329,10 @@ Index: gdb-7.10.50.20151113/gdb/config.in
/* Define to 1 if you have the <libunwind-ia64.h> header file. */
#undef HAVE_LIBUNWIND_IA64_H
Index: gdb-7.10.50.20151113/gdb/configure
Index: gdb-7.10.50.20160106/gdb/configure
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/configure 2015-11-14 16:09:10.050302377 +0100
+++ gdb-7.10.50.20151113/gdb/configure 2015-11-14 16:09:30.651429470 +0100
--- gdb-7.10.50.20160106.orig/gdb/configure
+++ gdb-7.10.50.20160106/gdb/configure
@@ -705,6 +705,11 @@ PKGVERSION
HAVE_NATIVE_GCORE_TARGET
TARGET_OBS
@ -388,7 +388,7 @@ Index: gdb-7.10.50.20151113/gdb/configure
YACC The `Yet Another C Compiler' implementation to use. Defaults to
the first program found out of: `bison -y', `byacc', `yacc'.
YFLAGS The list of arguments that will be passed by default to $YACC.
@@ -5656,6 +5676,494 @@ _ACEOF
@@ -5655,6 +5675,494 @@ _ACEOF
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
$as_echo "$with_auto_load_safe_path" >&6; }
@ -883,10 +883,10 @@ Index: gdb-7.10.50.20151113/gdb/configure
subdirs="$subdirs testsuite"
Index: gdb-7.10.50.20151113/gdb/configure.ac
Index: gdb-7.10.50.20160106/gdb/configure.ac
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/configure.ac 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/configure.ac 2015-11-14 16:09:19.790362466 +0100
--- gdb-7.10.50.20160106.orig/gdb/configure.ac
+++ gdb-7.10.50.20160106/gdb/configure.ac
@@ -177,6 +177,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escap
[Directories safe to hold auto-loaded files.])
AC_MSG_RESULT([$with_auto_load_safe_path])
@ -1087,10 +1087,10 @@ Index: gdb-7.10.50.20151113/gdb/configure.ac
AC_CONFIG_SUBDIRS(testsuite)
# Check whether to support alternative target configurations
Index: gdb-7.10.50.20151113/gdb/corelow.c
Index: gdb-7.10.50.20160106/gdb/corelow.c
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/corelow.c 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/corelow.c 2015-11-14 16:09:19.791362472 +0100
--- gdb-7.10.50.20160106.orig/gdb/corelow.c
+++ gdb-7.10.50.20160106/gdb/corelow.c
@@ -310,7 +310,7 @@ build_id_locate_exec (int from_tty)
symfile_objfile->flags |= OBJF_BUILD_ID_CORE_LOADED;
}
@ -1100,10 +1100,10 @@ Index: gdb-7.10.50.20151113/gdb/corelow.c
do_cleanups (back_to);
Index: gdb-7.10.50.20151113/gdb/build-id.c
Index: gdb-7.10.50.20160106/gdb/build-id.c
===================================================================
--- gdb-7.10.50.20151113.orig/gdb/build-id.c 2015-11-14 16:08:57.874227260 +0100
+++ gdb-7.10.50.20151113/gdb/build-id.c 2015-11-14 16:09:19.791362472 +0100
--- gdb-7.10.50.20160106.orig/gdb/build-id.c
+++ gdb-7.10.50.20160106/gdb/build-id.c
@@ -35,6 +35,7 @@
#include "elf/common.h"
#include "elf-bfd.h"
@ -1112,7 +1112,7 @@ Index: gdb-7.10.50.20151113/gdb/build-id.c
#define BUILD_ID_VERBOSE_NONE 0
#define BUILD_ID_VERBOSE_FILENAMES 1
@@ -665,8 +666,363 @@ build_id_to_filename (const struct bfd_b
@@ -665,8 +666,366 @@ build_id_to_filename (const struct bfd_b
return result;
}
@ -1190,6 +1190,9 @@ Index: gdb-7.10.50.20151113/gdb/build-id.c
+ if (strcmp (filename, BUILD_ID_MAIN_EXECUTABLE_FILENAME) == 0)
+ return 0;
+
+ if (is_target_filename (filename))
+ return 0;
+
+ if (filename[0] != '/')
+ {
+ warning (_("Ignoring non-absolute filename: <%s>"), filename);
@ -1477,7 +1480,7 @@ Index: gdb-7.10.50.20151113/gdb/build-id.c
avoidance. */
struct missing_filepair
@@ -720,11 +1076,17 @@ missing_filepair_change (void)
@@ -720,11 +1079,17 @@ missing_filepair_change (void)
/* All their memory came just from missing_filepair_OBSTACK. */
missing_filepair_hash = NULL;
}
@ -1495,7 +1498,7 @@ Index: gdb-7.10.50.20151113/gdb/build-id.c
missing_filepair_change ();
}
@@ -791,14 +1153,39 @@ debug_print_missing (const char *binary,
@@ -791,14 +1156,39 @@ debug_print_missing (const char *binary,
*slot = missing_filepair;

View File

@ -27,7 +27,7 @@ Version: 7.10.50.%{snapsrc}
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 43%{?dist}
Release: 44%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -1401,6 +1401,9 @@ then
fi
%changelog
* Wed Jan 20 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160106-44.fc24
- Suppress librpm non-absolute filename warnings for /^remote:/ filenames.
* Sat Jan 16 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160106-43.fc24
- Test clflushopt instruction decode (for RH BZ 1262471).