Fix reported gdb-vla-intel-stringbt-fix.patch regression (SuSE).
Remove gcc-7 compilation compatibility hack.
This commit is contained in:
parent
5b3c4903f6
commit
5e93e40f3c
@ -27,10 +27,10 @@ cannot reproduce it.
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
Index: gdb-7.12.50.20170207/gdb/dwarf2loc.c
|
||||
Index: gdb-7.12.50.20170309/gdb/dwarf2loc.c
|
||||
===================================================================
|
||||
--- gdb-7.12.50.20170207.orig/gdb/dwarf2loc.c 2017-02-16 23:31:53.977893289 +0100
|
||||
+++ gdb-7.12.50.20170207/gdb/dwarf2loc.c 2017-02-16 23:37:44.625522081 +0100
|
||||
--- gdb-7.12.50.20170309.orig/gdb/dwarf2loc.c 2017-04-19 22:04:04.874320326 +0200
|
||||
+++ gdb-7.12.50.20170309/gdb/dwarf2loc.c 2017-04-19 22:09:07.976201875 +0200
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <algorithm>
|
||||
#include <vector>
|
||||
@ -39,29 +39,31 @@ Index: gdb-7.12.50.20170207/gdb/dwarf2loc.c
|
||||
|
||||
extern int dwarf_always_disassemble;
|
||||
|
||||
@@ -2350,6 +2350,18 @@ dwarf2_evaluate_loc_desc_full (struct ty
|
||||
@@ -2350,6 +2351,20 @@
|
||||
ctx.per_cu = per_cu;
|
||||
ctx.obj_address = 0;
|
||||
|
||||
+struct frame_info *old_frame (deprecated_safe_get_selected_frame ());
|
||||
+frame_id old_frame_id (get_frame_id (deprecated_safe_get_selected_frame ()));
|
||||
+class RestoreCall {
|
||||
+private:
|
||||
+ const std::function<void ()> func;
|
||||
+public:
|
||||
+ RestoreCall(std::function<void ()> func_):func(func_) {}
|
||||
+ ~RestoreCall() { func(); }
|
||||
+} restore_frame([&]() {
|
||||
+ select_frame (old_frame);
|
||||
+} restore_frame([=]() {
|
||||
+ frame_info *old_frame (frame_find_by_id (old_frame_id));
|
||||
+ if (old_frame != NULL)
|
||||
+ select_frame (old_frame);
|
||||
+});
|
||||
+if (frame != NULL) select_frame (frame);
|
||||
+
|
||||
scoped_value_mark free_values;
|
||||
|
||||
ctx.gdbarch = get_objfile_arch (objfile);
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90
|
||||
Index: gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90 2017-02-16 23:32:09.546010002 +0100
|
||||
+++ gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90 2017-04-19 22:04:04.922320623 +0200
|
||||
@@ -0,0 +1,24 @@
|
||||
+! Copyright 2010 Free Software Foundation, Inc.
|
||||
+!
|
||||
@ -87,10 +89,10 @@ Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f
|
||||
+ real :: dummy
|
||||
+ dummy = 1
|
||||
+end subroutine bar
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame.exp
|
||||
Index: gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame.exp 2017-02-16 23:32:09.546010002 +0100
|
||||
+++ gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame.exp 2017-04-19 22:04:04.922320623 +0200
|
||||
@@ -0,0 +1,39 @@
|
||||
+# Copyright 2010 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -131,10 +133,10 @@ Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame.exp
|
||||
+}
|
||||
+
|
||||
+gdb_test "bt" {foo \(string='hello'.*}
|
||||
Index: gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame.f90
|
||||
Index: gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame.f90
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.12.50.20170207/gdb/testsuite/gdb.fortran/dynamic-other-frame.f90 2017-02-16 23:32:09.546010002 +0100
|
||||
+++ gdb-7.12.50.20170309/gdb/testsuite/gdb.fortran/dynamic-other-frame.f90 2017-04-19 22:04:04.922320623 +0200
|
||||
@@ -0,0 +1,36 @@
|
||||
+! Copyright 2010 Free Software Foundation, Inc.
|
||||
+!
|
||||
|
8
gdb.spec
8
gdb.spec
@ -26,7 +26,7 @@ Version: 7.12.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1113,8 +1113,6 @@ CFLAGS="$CFLAGS -I$PWD/processor-trace-%{libipt_version}-root%{_includedir}"
|
||||
LDFLAGS="$LDFLAGS -L$PWD/processor-trace-%{libipt_version}-root%{_libdir}"
|
||||
%endif
|
||||
|
||||
# FIXME: gcc-7 compatibility.
|
||||
CFLAGS="$CFLAGS -Wno-implicit-fallthrough"
|
||||
export CXXFLAGS="$CFLAGS"
|
||||
|
||||
# --htmldir and --pdfdir are not used as they are used from %{gdb_build}.
|
||||
@ -1578,6 +1576,10 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Wed Apr 19 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170309-7.fc26
|
||||
- Fix reported gdb-vla-intel-stringbt-fix.patch regression (SuSE).
|
||||
- Remove gcc-7 compilation compatibility hack.
|
||||
|
||||
* Fri Mar 10 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170309-6.fc26
|
||||
- [testsuite] [ppc*,s390*] Do not FAIL rhbz1261564-aarch64-watchpoint.exp
|
||||
(RH BZ 1352563).
|
||||
|
Loading…
x
Reference in New Issue
Block a user