- Upgrade to GDB 6.7.1. Drop redundant patches, forward-port remaining
ones.
This commit is contained in:
parent
eb9d945afa
commit
50dab454bd
@ -1 +1 @@
|
||||
gdb-6.7.tar.bz2
|
||||
gdb-6.7.1.tar.bz2
|
||||
|
@ -1,33 +1,3 @@
|
||||
2007-09-15 Alan Modra <amodra@bigpond.net.au>
|
||||
|
||||
* configure.ac: Correct makeinfo version check.
|
||||
* configure: Regenerate.
|
||||
|
||||
#--- ./configure.ac 14 Sep 2007 14:51:36 -0000 1.25
|
||||
#+++ ./configure.ac 14 Sep 2007 15:47:01 -0000 1.26
|
||||
#@@ -2462,7 +2462,7 @@ changequote(,)
|
||||
# # For an installed makeinfo, we require it to be from texinfo 4.4 or
|
||||
# # higher, else we use the "missing" dummy.
|
||||
# if ${MAKEINFO} --version \
|
||||
#- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
|
||||
#+ | egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
|
||||
# :
|
||||
# else
|
||||
# MAKEINFO="$MISSING makeinfo"
|
||||
--- ./configure 14 Sep 2007 14:51:36 -0000 1.277
|
||||
+++ ./configure 14 Sep 2007 15:47:01 -0000 1.278
|
||||
@@ -6192,7 +6192,7 @@ case " $build_configdirs " in
|
||||
# For an installed makeinfo, we require it to be from texinfo 4.4 or
|
||||
# higher, else we use the "missing" dummy.
|
||||
if ${MAKEINFO} --version \
|
||||
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
|
||||
+ | egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
|
||||
:
|
||||
else
|
||||
MAKEINFO="$MISSING makeinfo"
|
||||
|
||||
|
||||
|
||||
Fix:
|
||||
FAIL: gdb.arch/powerpc-power6.exp: Power6 disassembly dsub
|
||||
FAIL: gdb.arch/powerpc-power6.exp: Power6 disassembly dmul
|
9
gdb.spec
9
gdb.spec
@ -8,14 +8,14 @@ Name: gdb
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 6.7
|
||||
Version: 6.7.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
Source: ftp://ftp.gnu.org/gnu/gdb/gdb-6.7.tar.bz2
|
||||
Source: ftp://ftp.gnu.org/gnu/gdb/gdb-6.7.1.tar.bz2
|
||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
URL: http://gnu.org/software/gdb/
|
||||
|
||||
@ -273,7 +273,7 @@ Patch229: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported post gdb-6.7 release fixups.
|
||||
Patch232: gdb-6.7-upstream.patch
|
||||
Patch232: gdb-6.7.1-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
@ -642,6 +642,9 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Thu Nov 1 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-1
|
||||
- Upgrade to GDB 6.7.1. Drop redundant patches, forward-port remaining ones.
|
||||
|
||||
* Thu Nov 1 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7-1
|
||||
- Upgrade to GDB 6.7. Drop redundant patches, forward-port remaining ones.
|
||||
- Fix rereading of the main executable on its change.
|
||||
|
Loading…
Reference in New Issue
Block a user