- Upgrade to the FSF GDB snapshot: 7.0.50.20100128

- archer-jankratochvil-fedora13 commit:
    39c5a8b75fad3acd7204903db5dee025055a4594
- Fix a regression on "AAA::ALPHA" test due to a merge from FSF GDB.
- Fix a regression of previous release due to false identification as core
    file.
- Move ifunc .patch into the GIT-managed archer-jankratochvil-fedora13
    branch.
- Update gdb.pie/corefile.exp from 2007-01-26 FSF GDB commit by Andreas
    Schwab.
This commit is contained in:
Jan Kratochvil 2010-01-28 22:26:15 +00:00
parent b469073e48
commit 45f79714b9
13 changed files with 1912 additions and 4430 deletions

View File

@ -1,2 +1,2 @@
gdb-7.0.50.20100121.tar.bz2 gdb-7.0.50.20100128.tar.bz2
libstdc++-v3-python-r155978.tar.bz2 libstdc++-v3-python-r155978.tar.bz2

View File

@ -2097,7 +2097,7 @@ Index: gdb-6.8.50.20090909/gdb/testsuite/gdb.pie/corefile.exp
+# test reinit_frame_cache +# test reinit_frame_cache
+ +
+gdb_load ${binfile} +gdb_load ${binfile}
+gdb_test "up" "#\[0-9\]* *\[0-9xa-fH'\]* in .* \\(\\).*" "up in corefile.exp (reinit)" +gdb_test "up" "#\[0-9\]* *\[0-9xa-fH'\]* in .* \\(.*\\).*" "up in corefile.exp (reinit)"
+ +
+gdb_test "core" "No core file now." +gdb_test "core" "No core file now."
Index: gdb-6.8.50.20090909/gdb/testsuite/gdb.pie/Makefile.in Index: gdb-6.8.50.20090909/gdb/testsuite/gdb.pie/Makefile.in

View File

@ -30,11 +30,11 @@ glibc-debuginfo-2.7-2.x86_64: /usr/lib/debug/lib64/libc.so.6.debug:
<81a2> DW_AT_name : (indirect string, offset: 0x280e): __errno_location <81a2> DW_AT_name : (indirect string, offset: 0x280e): __errno_location
<81a8> DW_AT_MIPS_linkage_name: (indirect string, offset: 0x2808): *__GI___errno_location <81a8> DW_AT_MIPS_linkage_name: (indirect string, offset: 0x2808): *__GI___errno_location
Index: gdb-6.8.50.20090802/gdb/gdbtypes.c Index: gdb-7.0.50.20100128/gdb/gdbtypes.c
=================================================================== ===================================================================
--- gdb-6.8.50.20090802.orig/gdb/gdbtypes.c 2009-08-03 09:50:57.000000000 +0200 --- gdb-7.0.50.20100128.orig/gdb/gdbtypes.c 2010-01-28 12:52:17.000000000 +0100
+++ gdb-6.8.50.20090802/gdb/gdbtypes.c 2009-08-03 15:42:51.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/gdbtypes.c 2010-01-28 12:52:48.000000000 +0100
@@ -3769,6 +3769,9 @@ gdbtypes_post_init (struct gdbarch *gdba @@ -3978,6 +3978,9 @@ gdbtypes_post_init (struct gdbarch *gdba
= arch_type (gdbarch, TYPE_CODE_INTERNAL_FUNCTION, 0, = arch_type (gdbarch, TYPE_CODE_INTERNAL_FUNCTION, 0,
"<internal function>"); "<internal function>");
@ -44,11 +44,11 @@ Index: gdb-6.8.50.20090802/gdb/gdbtypes.c
return builtin_type; return builtin_type;
} }
Index: gdb-6.8.50.20090802/gdb/gdbtypes.h Index: gdb-7.0.50.20100128/gdb/gdbtypes.h
=================================================================== ===================================================================
--- gdb-6.8.50.20090802.orig/gdb/gdbtypes.h 2009-08-03 09:50:57.000000000 +0200 --- gdb-7.0.50.20100128.orig/gdb/gdbtypes.h 2010-01-28 12:52:17.000000000 +0100
+++ gdb-6.8.50.20090802/gdb/gdbtypes.h 2009-08-03 15:40:02.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/gdbtypes.h 2010-01-28 12:52:48.000000000 +0100
@@ -1128,6 +1128,8 @@ struct builtin_type @@ -1245,6 +1245,8 @@ struct builtin_type
/* This type is used to represent a GDB internal function. */ /* This type is used to represent a GDB internal function. */
struct type *internal_fn; struct type *internal_fn;
@ -57,11 +57,11 @@ Index: gdb-6.8.50.20090802/gdb/gdbtypes.h
}; };
/* Return the type table for the specified architecture. */ /* Return the type table for the specified architecture. */
Index: gdb-6.8.50.20090802/gdb/parse.c Index: gdb-7.0.50.20100128/gdb/parse.c
=================================================================== ===================================================================
--- gdb-6.8.50.20090802.orig/gdb/parse.c 2009-08-03 09:50:57.000000000 +0200 --- gdb-7.0.50.20100128.orig/gdb/parse.c 2010-01-28 12:52:19.000000000 +0100
+++ gdb-6.8.50.20090802/gdb/parse.c 2009-08-03 15:41:54.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/parse.c 2010-01-28 12:53:20.000000000 +0100
@@ -510,7 +510,11 @@ write_exp_msymbol (struct minimal_symbol @@ -509,7 +509,11 @@ write_exp_msymbol (struct minimal_symbol
case mst_text: case mst_text:
case mst_file_text: case mst_file_text:
case mst_solib_trampoline: case mst_solib_trampoline:
@ -73,12 +73,12 @@ Index: gdb-6.8.50.20090802/gdb/parse.c
+ write_exp_elt_type (objfile_type (objfile)->nodebug_text_symbol); + write_exp_elt_type (objfile_type (objfile)->nodebug_text_symbol);
break; break;
case mst_data: case mst_text_gnu_ifunc:
Index: gdb-6.8.50.20090802/gdb/target.c Index: gdb-7.0.50.20100128/gdb/target.c
=================================================================== ===================================================================
--- gdb-6.8.50.20090802.orig/gdb/target.c 2009-08-03 12:38:47.000000000 +0200 --- gdb-7.0.50.20100128.orig/gdb/target.c 2010-01-28 12:52:29.000000000 +0100
+++ gdb-6.8.50.20090802/gdb/target.c 2009-08-03 12:49:33.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/target.c 2010-01-28 12:52:48.000000000 +0100
@@ -933,6 +933,25 @@ pop_all_targets (int quitting) @@ -1000,6 +1000,25 @@ pop_all_targets (int quitting)
pop_all_targets_above (dummy_stratum, quitting); pop_all_targets_above (dummy_stratum, quitting);
} }
@ -104,7 +104,7 @@ Index: gdb-6.8.50.20090802/gdb/target.c
/* Using the objfile specified in OBJFILE, find the address for the /* Using the objfile specified in OBJFILE, find the address for the
current thread's thread-local storage with offset OFFSET. */ current thread's thread-local storage with offset OFFSET. */
CORE_ADDR CORE_ADDR
@@ -1023,7 +1042,28 @@ target_translate_tls_address (struct obj @@ -1090,7 +1109,28 @@ target_translate_tls_address (struct obj
/* It wouldn't be wrong here to try a gdbarch method, too; finding /* It wouldn't be wrong here to try a gdbarch method, too; finding
TLS is an ABI-specific thing. But we don't do that yet. */ TLS is an ABI-specific thing. But we don't do that yet. */
else else
@ -134,10 +134,10 @@ Index: gdb-6.8.50.20090802/gdb/target.c
return addr; return addr;
} }
Index: gdb-6.8.50.20090802/gdb/testsuite/gdb.dwarf2/dw2-errno.c Index: gdb-7.0.50.20100128/gdb/testsuite/gdb.dwarf2/dw2-errno.c
=================================================================== ===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-6.8.50.20090802/gdb/testsuite/gdb.dwarf2/dw2-errno.c 2009-08-03 12:49:33.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/testsuite/gdb.dwarf2/dw2-errno.c 2010-01-28 12:52:48.000000000 +0100
@@ -0,0 +1,28 @@ @@ -0,0 +1,28 @@
+/* This testcase is part of GDB, the GNU debugger. +/* This testcase is part of GDB, the GNU debugger.
+ +
@ -167,10 +167,10 @@ Index: gdb-6.8.50.20090802/gdb/testsuite/gdb.dwarf2/dw2-errno.c
+ +
+ return 0; /* breakpoint */ + return 0; /* breakpoint */
+} +}
Index: gdb-6.8.50.20090802/gdb/testsuite/gdb.dwarf2/dw2-errno.exp Index: gdb-7.0.50.20100128/gdb/testsuite/gdb.dwarf2/dw2-errno.exp
=================================================================== ===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-6.8.50.20090802/gdb/testsuite/gdb.dwarf2/dw2-errno.exp 2009-08-03 12:49:33.000000000 +0200 +++ gdb-7.0.50.20100128/gdb/testsuite/gdb.dwarf2/dw2-errno.exp 2010-01-28 12:52:48.000000000 +0100
@@ -0,0 +1,67 @@ @@ -0,0 +1,67 @@
+# Copyright 2007 Free Software Foundation, Inc. +# Copyright 2007 Free Software Foundation, Inc.
+ +

View File

@ -58,8 +58,10 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
* exec.c (exec_file_attach): Print a more useful error message if the * exec.c (exec_file_attach): Print a more useful error message if the
user did "gdb core". user did "gdb core".
--- a/gdb/exceptions.h Index: gdb-7.0.50.20100128/gdb/exceptions.h
+++ b/gdb/exceptions.h ===================================================================
--- gdb-7.0.50.20100128.orig/gdb/exceptions.h 2010-01-18 07:25:22.000000000 +0100
+++ gdb-7.0.50.20100128/gdb/exceptions.h 2010-01-28 22:49:00.000000000 +0100
@@ -78,6 +78,9 @@ enum errors { @@ -78,6 +78,9 @@ enum errors {
/* Feature is not supported in this copy of GDB. */ /* Feature is not supported in this copy of GDB. */
UNSUPPORTED_ERROR, UNSUPPORTED_ERROR,
@ -70,39 +72,41 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
/* Add more errors here. */ /* Add more errors here. */
NR_ERRORS NR_ERRORS
}; };
--- a/gdb/exec.c Index: gdb-7.0.50.20100128/gdb/exec.c
+++ b/gdb/exec.c ===================================================================
--- gdb-7.0.50.20100128.orig/gdb/exec.c 2010-01-28 22:48:59.000000000 +0100
+++ gdb-7.0.50.20100128/gdb/exec.c 2010-01-28 22:58:45.000000000 +0100
@@ -34,6 +34,7 @@ @@ -34,6 +34,7 @@
#include "arch-utils.h"
#include "gdbthread.h" #include "gdbthread.h"
#include "progspace.h" #include "progspace.h"
#include "solib.h"
+#include "exceptions.h" +#include "exceptions.h"
#include <fcntl.h> #include <fcntl.h>
#include "readline/readline.h" #include "readline/readline.h"
@@ -253,6 +254,19 @@ exec_file_attach (char *filename, int from_tty) @@ -258,6 +259,17 @@ exec_file_attach (char *filename, int fr
scratch_pathname = xstrdup (scratch_pathname);
cleanups = make_cleanup (xfree, scratch_pathname);
+ /* If the user accidentally did "gdb core", print a useful
+ error message. */
+ if (bfd_check_format (exec_bfd, bfd_core))
+ {
+ /* Make sure to close exec_bfd, or else "run" might try to use
+ it. */
+ exec_close ();
+ throw_error (IS_CORE_ERROR,
+ _("\"%s\" is a core file.\n"
+ "Please specify an executable to debug."),
+ scratch_pathname);
+ }
+
if (!bfd_check_format (exec_bfd, bfd_object))
{
/* Make sure to close exec_bfd, or else "run" might try to use /* Make sure to close exec_bfd, or else "run" might try to use
--- a/gdb/main.c it. */
+++ b/gdb/main.c exec_close ();
@@ -240,6 +240,36 @@ captured_command_loop (void *data) +
+ /* If the user accidentally did "gdb core", print a useful
+ error message. Check it only after bfd_object has been checked as
+ a valid executable may get recognized for example also as
+ "trad-core". */
+ if (bfd_check_format (exec_bfd, bfd_core))
+ throw_error (IS_CORE_ERROR,
+ _("\"%s\" is a core file.\n"
+ "Please specify an executable to debug."),
+ scratch_pathname);
+
error (_("\"%s\": not in executable format: %s"),
scratch_pathname, bfd_errmsg (bfd_get_error ()));
}
Index: gdb-7.0.50.20100128/gdb/main.c
===================================================================
--- gdb-7.0.50.20100128.orig/gdb/main.c 2010-01-28 22:48:59.000000000 +0100
+++ gdb-7.0.50.20100128/gdb/main.c 2010-01-28 22:49:00.000000000 +0100
@@ -241,6 +241,36 @@ captured_command_loop (void *data)
return 1; return 1;
} }
@ -139,7 +143,7 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
static int static int
captured_main (void *data) captured_main (void *data)
{ {
@@ -668,6 +698,8 @@ extern int gdbtk_test (char *); @@ -703,6 +733,8 @@ extern int gdbtk_test (char *);
{ {
symarg = argv[optind]; symarg = argv[optind];
execarg = argv[optind]; execarg = argv[optind];
@ -148,7 +152,7 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
optind++; optind++;
} }
@@ -800,10 +831,25 @@ Excess command line arguments ignored. (%s%s)\n"), @@ -835,10 +867,25 @@ Excess command line arguments ignored. (
&& symarg != NULL && symarg != NULL
&& strcmp (execarg, symarg) == 0) && strcmp (execarg, symarg) == 0)
{ {

View File

@ -56,9 +56,9 @@ Index: gdb-7.0.50.20100115/gdb/exec.c
--- gdb-7.0.50.20100115.orig/gdb/exec.c 2010-01-15 21:35:14.000000000 +0100 --- gdb-7.0.50.20100115.orig/gdb/exec.c 2010-01-15 21:35:14.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/exec.c 2010-01-15 21:47:19.000000000 +0100 +++ gdb-7.0.50.20100115/gdb/exec.c 2010-01-15 21:47:19.000000000 +0100
@@ -35,6 +35,7 @@ @@ -35,6 +35,7 @@
#include "arch-utils.h"
#include "gdbthread.h" #include "gdbthread.h"
#include "progspace.h" #include "progspace.h"
#include "exceptions.h"
+#include "solib.h" +#include "solib.h"
#include <fcntl.h> #include <fcntl.h>

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -1,8 +1,8 @@
Index: gdb-7.0.50.20100115/gdb/dwarf2read.c Index: gdb-7.0.50.20100128/gdb/dwarf2read.c
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/dwarf2read.c 2010-01-15 21:35:15.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/dwarf2read.c 2010-01-28 12:53:37.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/dwarf2read.c 2010-01-15 21:41:32.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/dwarf2read.c 2010-01-28 12:54:34.000000000 +0100
@@ -5811,12 +5811,14 @@ read_set_type (struct die_info *die, str @@ -5818,12 +5818,14 @@ read_set_type (struct die_info *die, str
return set_die_type (die, set_type, cu); return set_die_type (die, set_type, cu);
} }
@ -19,7 +19,7 @@ Index: gdb-7.0.50.20100115/gdb/dwarf2read.c
struct attribute *attr; struct attribute *attr;
struct symbol *sym; struct symbol *sym;
CORE_ADDR base = (CORE_ADDR) 0; CORE_ADDR base = (CORE_ADDR) 0;
@@ -5841,10 +5843,40 @@ read_common_block (struct die_info *die, @@ -5848,10 +5850,40 @@ read_common_block (struct die_info *die,
} }
if (die->child != NULL) if (die->child != NULL)
{ {
@ -60,7 +60,7 @@ Index: gdb-7.0.50.20100115/gdb/dwarf2read.c
attr = dwarf2_attr (child_die, DW_AT_data_member_location, cu); attr = dwarf2_attr (child_die, DW_AT_data_member_location, cu);
if (attr) if (attr)
{ {
@@ -5862,8 +5894,25 @@ read_common_block (struct die_info *die, @@ -5869,8 +5901,25 @@ read_common_block (struct die_info *die,
SYMBOL_VALUE_ADDRESS (sym) = base + byte_offset; SYMBOL_VALUE_ADDRESS (sym) = base + byte_offset;
add_symbol_to_list (sym, &global_symbols); add_symbol_to_list (sym, &global_symbols);
} }
@ -86,7 +86,7 @@ Index: gdb-7.0.50.20100115/gdb/dwarf2read.c
} }
} }
@@ -9052,6 +9101,13 @@ new_symbol (struct die_info *die, struct @@ -9061,6 +9110,13 @@ new_symbol (struct die_info *die, struct
{ {
var_decode_location (attr, sym, cu); var_decode_location (attr, sym, cu);
attr2 = dwarf2_attr (die, DW_AT_external, cu); attr2 = dwarf2_attr (die, DW_AT_external, cu);
@ -99,8 +99,8 @@ Index: gdb-7.0.50.20100115/gdb/dwarf2read.c
+ +
if (attr2 && (DW_UNSND (attr2) != 0)) if (attr2 && (DW_UNSND (attr2) != 0))
{ {
/* Workaround gfortran PR debug/40040 - it uses struct pending **list_to_add;
@@ -9230,6 +9286,11 @@ new_symbol (struct die_info *die, struct @@ -9245,6 +9301,11 @@ new_symbol (struct die_info *die, struct
SYMBOL_DOMAIN (sym) = MODULE_DOMAIN; SYMBOL_DOMAIN (sym) = MODULE_DOMAIN;
add_symbol_to_list (sym, &global_symbols); add_symbol_to_list (sym, &global_symbols);
break; break;
@ -112,11 +112,11 @@ Index: gdb-7.0.50.20100115/gdb/dwarf2read.c
default: default:
/* Not a tag we recognize. Hopefully we aren't processing /* Not a tag we recognize. Hopefully we aren't processing
trash data, but since we must specifically ignore things trash data, but since we must specifically ignore things
Index: gdb-7.0.50.20100115/gdb/f-lang.c Index: gdb-7.0.50.20100128/gdb/f-lang.c
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/f-lang.c 2010-01-15 21:35:16.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/f-lang.c 2010-01-28 12:53:38.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/f-lang.c 2010-01-15 21:35:27.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/f-lang.c 2010-01-28 12:53:46.000000000 +0100
@@ -448,27 +448,3 @@ _initialize_f_language (void) @@ -446,27 +446,3 @@ _initialize_f_language (void)
add_language (&f_language_defn); add_language (&f_language_defn);
} }
@ -144,10 +144,10 @@ Index: gdb-7.0.50.20100115/gdb/f-lang.c
- } - }
- return (NULL); - return (NULL);
-} -}
Index: gdb-7.0.50.20100115/gdb/f-lang.h Index: gdb-7.0.50.20100128/gdb/f-lang.h
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/f-lang.h 2010-01-15 21:35:16.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/f-lang.h 2010-01-28 12:53:38.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/f-lang.h 2010-01-15 21:35:27.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/f-lang.h 2010-01-28 12:53:46.000000000 +0100
@@ -51,36 +51,8 @@ enum f90_range_type @@ -51,36 +51,8 @@ enum f90_range_type
NONE_BOUND_DEFAULT /* "(low:high)" */ NONE_BOUND_DEFAULT /* "(low:high)" */
}; };
@ -185,10 +185,10 @@ Index: gdb-7.0.50.20100115/gdb/f-lang.h
/* When reasonable array bounds cannot be fetched, such as when /* When reasonable array bounds cannot be fetched, such as when
you ask to 'mt print symbols' and there is no stack frame and you ask to 'mt print symbols' and there is no stack frame and
Index: gdb-7.0.50.20100115/gdb/f-valprint.c Index: gdb-7.0.50.20100128/gdb/f-valprint.c
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/f-valprint.c 2010-01-15 21:35:16.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/f-valprint.c 2010-01-28 12:53:38.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/f-valprint.c 2010-01-15 21:35:27.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/f-valprint.c 2010-01-28 12:53:46.000000000 +0100
@@ -34,6 +34,8 @@ @@ -34,6 +34,8 @@
#include "gdbcore.h" #include "gdbcore.h"
#include "command.h" #include "command.h"
@ -371,10 +371,10 @@ Index: gdb-7.0.50.20100115/gdb/f-valprint.c
} }
void void
Index: gdb-7.0.50.20100115/gdb/stack.c Index: gdb-7.0.50.20100128/gdb/stack.c
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/stack.c 2010-01-15 21:35:13.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/stack.c 2010-01-28 12:52:19.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/stack.c 2010-01-15 21:35:27.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/stack.c 2010-01-28 12:53:46.000000000 +0100
@@ -1474,6 +1474,8 @@ print_block_frame_locals (struct block * @@ -1474,6 +1474,8 @@ print_block_frame_locals (struct block *
case LOC_COMPUTED: case LOC_COMPUTED:
if (SYMBOL_IS_ARGUMENT (sym)) if (SYMBOL_IS_ARGUMENT (sym))
@ -384,10 +384,10 @@ Index: gdb-7.0.50.20100115/gdb/stack.c
values_printed = 1; values_printed = 1;
print_variable_and_value (NULL, sym, frame, stream, 4 * num_tabs); print_variable_and_value (NULL, sym, frame, stream, 4 * num_tabs);
break; break;
Index: gdb-7.0.50.20100115/gdb/symtab.h Index: gdb-7.0.50.20100128/gdb/symtab.h
=================================================================== ===================================================================
--- gdb-7.0.50.20100115.orig/gdb/symtab.h 2010-01-15 21:35:16.000000000 +0100 --- gdb-7.0.50.20100128.orig/gdb/symtab.h 2010-01-28 12:52:20.000000000 +0100
+++ gdb-7.0.50.20100115/gdb/symtab.h 2010-01-15 21:35:57.000000000 +0100 +++ gdb-7.0.50.20100128/gdb/symtab.h 2010-01-28 12:53:46.000000000 +0100
@@ -401,7 +401,10 @@ typedef enum domain_enum_tag @@ -401,7 +401,10 @@ typedef enum domain_enum_tag
TYPES_DOMAIN, TYPES_DOMAIN,
@ -400,8 +400,10 @@ Index: gdb-7.0.50.20100115/gdb/symtab.h
} }
domain_enum; domain_enum;
--- /dev/null Index: gdb-7.0.50.20100128/gdb/testsuite/gdb.fortran/common-block.exp
+++ b/gdb/testsuite/gdb.fortran/common-block.exp ===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-7.0.50.20100128/gdb/testsuite/gdb.fortran/common-block.exp 2010-01-28 12:53:46.000000000 +0100
@@ -0,0 +1,101 @@ @@ -0,0 +1,101 @@
+# Copyright 2008 Free Software Foundation, Inc. +# Copyright 2008 Free Software Foundation, Inc.
+ +
@ -504,8 +506,10 @@ Index: gdb-7.0.50.20100115/gdb/symtab.h
+gdb_test "p ix_x" " = 1 *" "p ix_x in" +gdb_test "p ix_x" " = 1 *" "p ix_x in"
+gdb_test "p iy_y" " = 2 *" "p iy_y in" +gdb_test "p iy_y" " = 2 *" "p iy_y in"
+gdb_test "p iz_z2" " = 3 *" "p iz_z2 in" +gdb_test "p iz_z2" " = 3 *" "p iz_z2 in"
--- /dev/null Index: gdb-7.0.50.20100128/gdb/testsuite/gdb.fortran/common-block.f90
+++ b/gdb/testsuite/gdb.fortran/common-block.f90 ===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ gdb-7.0.50.20100128/gdb/testsuite/gdb.fortran/common-block.f90 2010-01-28 12:53:46.000000000 +0100
@@ -0,0 +1,67 @@ @@ -0,0 +1,67 @@
+! Copyright 2008 Free Software Foundation, Inc. +! Copyright 2008 Free Software Foundation, Inc.
+! +!

File diff suppressed because it is too large Load Diff

View File

@ -1,58 +0,0 @@
http://sourceware.org/ml/gdb-patches/2010-01/msg00485.html
Subject: [patch] Fix solib-display.exp crash
[ Made more safe for downstream patch + ported for VLA. ]
Hi,
it is a testsuite regression against gdb-7.0 although the bug was probably
present even in gdb-7.0 (it started to reproduce since one completely
unrelated Daniel J.'s patch). This patch fixes (-lmcheck may be required):
PASS: gdb.base/solib-display.exp: display a_global
PASS: gdb.base/solib-display.exp: display b_global
PASS: gdb.base/solib-display.exp: display c_global
-ERROR: Process no longer exists
-UNRESOLVED: gdb.base/solib-display.exp: after rerun
-WARNING: remote_expect statement without a default case?!
-FAIL: gdb.base/solib-display.exp: Can't run to main (3)
+PASS: gdb.base/solib-display.exp: after rerun
+PASS: gdb.base/solib-display.exp: after rerun
+PASS: gdb.base/solib-display.exp: break 25
+PASS: gdb.base/solib-display.exp: continue
+PASS: gdb.base/solib-display.exp: display main_global
+PASS: gdb.base/solib-display.exp: display a_local
+PASS: gdb.base/solib-display.exp: display a_static
+PASS: gdb.base/solib-display.exp: break 25
+PASS: gdb.base/solib-display.exp: continue
No regressions on {x86_64,x86_64-m32,i686}-fedora12-linux-gnu.
The question is whether SYMBOL_SYMTAB (symbol) can be ever NULL at this point.
IMO not, it can be NULL only temporarily during reading symbols.
Thanks,
Jan
2010-01-20 Jan Kratochvil <jan.kratochvil@redhat.com>
* printcmd.c (display_uses_solib_p): Remove variable section. Access
objfile via SYMBOL_SYMTAB.
Index: gdb-7.0.50.20100121/gdb/parse.c
===================================================================
--- gdb-7.0.50.20100121.orig/gdb/parse.c 2010-01-21 15:16:15.000000000 +0100
+++ gdb-7.0.50.20100121/gdb/parse.c 2010-01-21 15:21:45.000000000 +0100
@@ -1425,6 +1425,10 @@ operator_check_standard (struct expressi
if (section && objfile_func && (*objfile_func) (section->objfile, data))
return 1;
+ /* SYMBOL_OBJ_SECTION (symbol) may be NULL. */
+ if (SYMBOL_SYMTAB (symbol) && objfile_func && (*objfile_func) (SYMBOL_SYMTAB (symbol)->objfile, data))
+ return 1;
+
/* Check objfile where is placed the code touching the variable. */
objfile = block_objfile (block);

View File

@ -1,26 +0,0 @@
[obv] testsuite: Fix gdb.arch/i386-bp_permanent.exp regression
http://sourceware.org/ml/gdb-patches/2010-01/msg00554.html
http://sourceware.org/ml/gdb-cvs/2010-01/msg00203.html
### src/gdb/testsuite/ChangeLog 2010/01/22 17:06:49 1.2099
### src/gdb/testsuite/ChangeLog 2010/01/24 04:29:32 1.2100
## -1,3 +1,8 @@
+2010-01-24 Jan Kratochvil <jan.kratochvil@redhat.com>
+
+ * gdb.arch/i386-bp_permanent.exp (Disassemble function '$function'):
+ Adjust it for DISASSEMBLY_OMIT_FNAME.
+
2010-01-22 Jan Kratochvil <jan.kratochvil@redhat.com>
PR symtab/11199:
--- src/gdb/testsuite/gdb.arch/i386-bp_permanent.exp 2010/01/01 07:32:00 1.3
+++ src/gdb/testsuite/gdb.arch/i386-bp_permanent.exp 2010/01/24 04:29:32 1.4
@@ -62,7 +62,7 @@
set function standard
set retcode [gdb_test_multiple "disassemble $function" "Disassemble function '$function'" {
- -re ".*($hex) <$function\\+0>.*($hex) <$function\\+4>.*($hex) <$function\\+5>.*($hex) <$function\\+6>.*$gdb_prompt $" {
+ -re ".*($hex) <\\+0>.*($hex) <\\+4>.*($hex) <\\+5>.*($hex) <\\+6>.*$gdb_prompt $" {
set function_start $expect_out(1,string);
set address $expect_out(2,string);
set address1 $expect_out(3,string);

View File

@ -32,11 +32,11 @@ Name: gdb%{?_with_debug:-debug}
# Set version to contents of gdb/version.in. # Set version to contents of gdb/version.in.
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3 # NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch). # and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
Version: 7.0.50.20100121 Version: 7.0.50.20100128
# The release always contains a leading reserved number, start it at 1. # The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing. # `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 9%{?_with_upstream:.upstream}%{dist} Release: 10%{?_with_upstream:.upstream}%{dist}
License: GPLv3+ License: GPLv3+
Group: Development/Debuggers Group: Development/Debuggers
@ -242,7 +242,7 @@ Patch229: gdb-6.3-bz140532-ppc-unwinding-test.patch
Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
# Backported fixups post the source tarball. # Backported fixups post the source tarball.
Patch232: gdb-upstream.patch #Patch232: gdb-upstream.patch
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000). # Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
@ -386,9 +386,6 @@ Patch381: gdb-simultaneous-step-resume-breakpoint-test.patch
# Fix GNU/Linux core open: Can't read pathname for load map: Input/output error. # Fix GNU/Linux core open: Can't read pathname for load map: Input/output error.
Patch382: gdb-core-open-vdso-warning.patch Patch382: gdb-core-open-vdso-warning.patch
# Support GNU IFUNCs - indirect functions (BZ 539590).
Patch387: gdb-bz539590-gnu-ifunc.patch
# Fix callback-mode readline-6.0 regression for CTRL-C. # Fix callback-mode readline-6.0 regression for CTRL-C.
Patch390: gdb-readline-6.0-signal.patch Patch390: gdb-readline-6.0-signal.patch
@ -427,15 +424,9 @@ Patch407: gdb-lineno-makeup-test.patch
# Test power7 ppc disassembly. # Test power7 ppc disassembly.
Patch408: gdb-ppc-power7-test.patch Patch408: gdb-ppc-power7-test.patch
# Fix solib-display.exp crash
Patch411: gdb-solib-display.patch
# Revert: Add -Wunused-function to compile flags. # Revert: Add -Wunused-function to compile flags.
Patch412: gdb-unused-revert.patch Patch412: gdb-unused-revert.patch
# Revert FSF GDB gdbserver tracepoints as incomplete now.
Patch413: gdb-gdbserver-tracepoint-revert.patch
# It may crash here but it is not understood why. # It may crash here but it is not understood why.
Patch414: gdb-archer-pie-assert-temp-workaround.patch Patch414: gdb-archer-pie-assert-temp-workaround.patch
@ -573,7 +564,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
%if 0%{!?_with_upstream:1} %if 0%{!?_with_upstream:1}
%patch232 -p1 #patch232 -p1
%patch349 -p1 %patch349 -p1
%patch124 -p1 %patch124 -p1
%patch1 -p1 %patch1 -p1
@ -642,7 +633,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
%patch271 -p1 %patch271 -p1
%patch274 -p1 %patch274 -p1
%patch353 -p1 %patch353 -p1
%patch415 -p1
%patch282 -p1 %patch282 -p1
%patch284 -p1 %patch284 -p1
%patch287 -p1 %patch287 -p1
@ -674,7 +664,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
%patch360 -p1 %patch360 -p1
%patch381 -p1 %patch381 -p1
%patch382 -p1 %patch382 -p1
%patch387 -p1
%patch390 -p1 %patch390 -p1
%patch391 -p1 %patch391 -p1
%patch392 -p1 %patch392 -p1
@ -688,16 +677,20 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
%patch406 -p1 %patch406 -p1
%patch407 -p1 %patch407 -p1
%patch408 -p1 %patch408 -p1
%patch411 -p1
%patch412 -p1 %patch412 -p1
%patch413 -p1
# Always verify its applicability.
%patch414 -p1 %patch414 -p1
%if 0%{!?rhel:1} %patch415 -p1
%patch414 -p1 -R
%endif
%patch393 -p1 %patch393 -p1
%patch335 -p1 %patch335 -p1
# Patch414: gdb-archer-pie-assert-temp-workaround.patch
# It may crash here but it is not understood why.
# Patch415: gdb-6.6-buildid-locate-core-as-arg.patch
# Currently disabled for RHEL as it is a new experimental feature not present
# in FSF GDB and possibly affecting new user scripts.
%if 0%{!?rhel:1}
%patch414 -p1 -R
%patch415 -p1 -R
%endif
%if 0%{!?el5:1} %if 0%{!?el5:1}
%patch393 -p1 -R %patch393 -p1 -R
%patch335 -p1 -R %patch335 -p1 -R
@ -1020,6 +1013,14 @@ fi
%endif %endif
%changelog %changelog
* Thu Jan 28 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100128-10.fc13
- Upgrade to the FSF GDB snapshot: 7.0.50.20100128
- archer-jankratochvil-fedora13 commit: 39c5a8b75fad3acd7204903db5dee025055a4594
- Fix a regression on "AAA::ALPHA" test due to a merge from FSF GDB.
- Fix a regression of previous release due to false identification as core file.
- Move ifunc .patch into the GIT-managed archer-jankratochvil-fedora13 branch.
- Update gdb.pie/corefile.exp from 2007-01-26 FSF GDB commit by Andreas Schwab.
* Mon Jan 25 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100121-9.fc13 * Mon Jan 25 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100121-9.fc13
- Enable loading a core file just as a single argument to /usr/bin/gdb. - Enable loading a core file just as a single argument to /usr/bin/gdb.

View File

@ -1,2 +1,2 @@
fcfbe6ccb36d86bc06891fbd70f1664d gdb-7.0.50.20100121.tar.bz2 057c9d088cd676396e0caae9d3ada879 gdb-7.0.50.20100128.tar.bz2
04e5c4b1b9e633422cc48990fe61958d libstdc++-v3-python-r155978.tar.bz2 04e5c4b1b9e633422cc48990fe61958d libstdc++-v3-python-r155978.tar.bz2