Fix PDF build on Rawhide/F-29.

This commit is contained in:
Jan Kratochvil 2018-03-31 19:34:45 +02:00
parent 35cdcb6a32
commit 4262bf0e32
5 changed files with 65 additions and 1 deletions

View File

@ -527,3 +527,7 @@ Patch126: gdb-ppc64-stwux-tautological-compare.patch
# =fedoratest
Patch127: gdb-rhbz1553104-s390x-arch12-test.patch
# Fix PDF build on Rawhide/F-29.
# =push
Patch128: gdb-texinfo-path.patch

View File

@ -125,3 +125,4 @@
%patch125 -p1
%patch126 -p1
%patch127 -p1
%patch128 -p1

View File

@ -125,3 +125,4 @@ gdb-vla-intel-fix-print-char-array.patch
gdb-rhbz1540559-gdbaddindex-glibcdebug-regression.patch
gdb-ppc64-stwux-tautological-compare.patch
gdb-rhbz1553104-s390x-arch12-test.patch
gdb-texinfo-path.patch

55
gdb-texinfo-path.patch Normal file
View File

@ -0,0 +1,55 @@
http://sourceware.org/ml/gdb-patches/2018-03/msg00635.html
Subject: [patch] Fix gdb/doc/ PDF build on Fedora Rawhide==F-29
--2fHTh5uZTiUOsy+g
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Hi,
on Fedora Rawhide==F-29 PDF build fails with:
https://kojipkgs.fedoraproject.org//work/tasks/2102/26052102/build.log
texi2dvi --pdf -I ../../../gdb/doc/../mi -I ../../../gdb/doc \
../../../gdb/doc/gdb.texinfo
! I can't find file `texinfo.tex'.
TBH I do not see how the file could be found in earlier versions. Also both
F-29 and F-28 have texinfo-tex-6.5-3.fc28.x86_64 while in F-28 it still builds
fine but in F-29 it does not - so apparently it depends on some other package.
But I did not investigate why as IMO the patch below is a logical one.
OK for check-in?
Jan
--2fHTh5uZTiUOsy+g
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline; filename="gdb-texinfo-path.patch"
gdb/ChangeLog
2018-03-31 Jan Kratochvil <jan.kratochvil@redhat.com>
* doc/Makefile.in (TEXI2DVI): Add $(SET_TEXINPUTS).
diff --git a/gdb/doc/Makefile.in b/gdb/doc/Makefile.in
index 0323bc4ecb..fa745b3542 100644
--- a/gdb/doc/Makefile.in
+++ b/gdb/doc/Makefile.in
@@ -63,7 +63,7 @@ MAKEHTMLFLAGS =
TEXI2ROFF=texi2roff
# where to find texi2dvi, ditto
-TEXI2DVI=texi2dvi
+TEXI2DVI=$(SET_TEXINPUTS) texi2dvi
# Package to install the docs under
PACKAGE = @PACKAGE@
--
2.17.0.rc1
--2fHTh5uZTiUOsy+g--

View File

@ -26,7 +26,7 @@ Version: 8.1
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 12%{?dist}
Release: 13%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -1026,6 +1026,9 @@ then
fi
%changelog
* Sat Mar 31 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.1-13.fc28
- Fix PDF build on Rawhide/F-29.
* Fri Mar 23 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.1-12.fc28
- Add test: [s390x] Backport arch12 instructions decoding (RH BZ 1553104).