Fix gdb.gdb/selftest.exp false FAIL.
This commit is contained in:
parent
c16b44507f
commit
3a8cee8e79
@ -1,11 +1,15 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-01/msg00578.html
|
||||
Subject: [testsuite patch]#2 Fix PR threads/19422 regression + Guile regression [Re: [PATCH+doc] Fix PR threads/19422 - show which thread caused stop]
|
||||
http://sourceware.org/ml/gdb-patches/2016-01/msg00580.html
|
||||
Subject: [testsuite patch]#3 Fix PR threads/19422 regression + Guile regression [Re: [PATCH+doc] Fix PR threads/19422 - show which thread caused stop]
|
||||
|
||||
|
||||
--cNdxnHkX5QqsyA0e
|
||||
--r5Pyd7+fXNt84Ff3
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
[ now moved the new test a bit lower ]
|
||||
# "signal SIGINT" could also switch the current thread.
|
||||
On Fri, 22 Jan 2016 18:31:00 +0100, Jan Kratochvil wrote:
|
||||
|
||||
[ now with the patch]
|
||||
On Fri, 22 Jan 2016 18:30:20 +0100, Jan Kratochvil wrote:
|
||||
|
||||
@ -83,7 +87,7 @@ Tested on x86_64-fedora23-linux-gnu.
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
--cNdxnHkX5QqsyA0e
|
||||
--r5Pyd7+fXNt84Ff3
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
@ -95,7 +99,7 @@ gdb/testsuite/ChangeLog
|
||||
(thread 1): New test for backtrace through signal handler.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.gdb/selftest.exp b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
index 4d55cb5..cdcf981 100644
|
||||
index 4d55cb5..da7a80b 100644
|
||||
--- a/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
+++ b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
@@ -436,8 +436,9 @@ proc test_with_self { executable } {
|
||||
@ -109,16 +113,17 @@ index 4d55cb5..cdcf981 100644
|
||||
pass "$description"
|
||||
}
|
||||
-re ".*$gdb_prompt $" {
|
||||
@@ -448,6 +449,9 @@ proc test_with_self { executable } {
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -453,6 +454,10 @@ proc test_with_self { executable } {
|
||||
gdb_test "signal SIGINT" \
|
||||
"Continuing with signal SIGINT.*" \
|
||||
"$description"
|
||||
+
|
||||
+ # Switch back to the GDB thread if Guile support is linked in.
|
||||
+ # "signal SIGINT" could also switch the current thread.
|
||||
+ gdb_test "thread 1" {\[Switching to thread 1 .*\].*}
|
||||
|
||||
set description "send SIGINT signal to child process"
|
||||
gdb_test "signal SIGINT" \
|
||||
# get a stack trace
|
||||
#
|
||||
|
||||
--cNdxnHkX5QqsyA0e--
|
||||
--r5Pyd7+fXNt84Ff3--
|
||||
|
||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.10.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 45%{?dist}
|
||||
Release: 46%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1385,6 +1385,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jan 22 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160121-46.fc24
|
||||
- Fix gdb.gdb/selftest.exp false FAIL.
|
||||
|
||||
* Fri Jan 22 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160121-45.fc24
|
||||
- Rebase to FSF GDB 7.10.50.20160121 (trunk snapshot).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user