- Remove wrong assertion on types objfile (BZ 508406).
This commit is contained in:
parent
a2e704d1bb
commit
382eba1529
18
gdb-bz508406-vla-type-objfile.patch
Normal file
18
gdb-bz508406-vla-type-objfile.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- ./gdb/gdbtypes.c 2009-08-27 10:33:50.000000000 +0200
|
||||||
|
+++ ./gdb/gdbtypes.c 2009-08-27 10:32:56.000000000 +0200
|
||||||
|
@@ -3127,12 +3127,14 @@ copy_type_recursive_1 (struct objfile *o
|
||||||
|
struct type *new_type;
|
||||||
|
|
||||||
|
if (TYPE_OBJFILE (type) == OBJFILE_INTERNAL
|
||||||
|
- || (objfile == OBJFILE_MALLOC && !TYPE_DYNAMIC (type)))
|
||||||
|
+ || (TYPE_OBJFILE (type) == OBJFILE_MALLOC && !TYPE_DYNAMIC (type)))
|
||||||
|
return type;
|
||||||
|
|
||||||
|
+#if 0 /* Backward compatibility only. */
|
||||||
|
/* This type shouldn't be pointing to any types in other objfiles;
|
||||||
|
if it did, the type might disappear unexpectedly. */
|
||||||
|
gdb_assert (TYPE_OBJFILE (type) == objfile);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
pair.old = type;
|
||||||
|
slot = htab_find_slot (copied_types, &pair, INSERT);
|
9
gdb.spec
9
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8.50.20090302
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 37%{?_with_upstream:.upstream}%{?dist}
|
Release: 38%{?_with_upstream:.upstream}%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -394,6 +394,9 @@ Patch376: gdb-python-gdbserver-tp-crash.patch
|
|||||||
# Fix GDB crash/hang on corrupted .debug_aranges (from old GCCs).
|
# Fix GDB crash/hang on corrupted .debug_aranges (from old GCCs).
|
||||||
Patch377: gdb-delayed-symfile-aranges.patch
|
Patch377: gdb-delayed-symfile-aranges.patch
|
||||||
|
|
||||||
|
# Remove wrong assertion on types objfile (BZ 508406).
|
||||||
|
Patch379: gdb-bz508406-vla-type-objfile.patch
|
||||||
|
|
||||||
BuildRequires: ncurses-devel texinfo gettext flex bison expat-devel
|
BuildRequires: ncurses-devel texinfo gettext flex bison expat-devel
|
||||||
Requires: readline
|
Requires: readline
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
@ -595,6 +598,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch374 -p1
|
%patch374 -p1
|
||||||
%patch376 -p1
|
%patch376 -p1
|
||||||
%patch377 -p1
|
%patch377 -p1
|
||||||
|
%patch379 -p1
|
||||||
%patch124 -p1
|
%patch124 -p1
|
||||||
|
|
||||||
find -name "*.orig" | xargs rm -f
|
find -name "*.orig" | xargs rm -f
|
||||||
@ -875,6 +879,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 27 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-38
|
||||||
|
- Remove wrong assertion on types objfile (BZ 508406).
|
||||||
|
|
||||||
* Sat Aug 15 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-37
|
* Sat Aug 15 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-37
|
||||||
- Fix GDB crash/hang on corrupted .debug_aranges (from old GCCs).
|
- Fix GDB crash/hang on corrupted .debug_aranges (from old GCCs).
|
||||||
- Temporarily disabled orphanripper on Fedora 11.
|
- Temporarily disabled orphanripper on Fedora 11.
|
||||||
|
Loading…
Reference in New Issue
Block a user