Rebase to FSF GDB 8.1.90.20180714 (8.2pre).
Backport IPv6 patch (RH BZ 881849, Sergio Durigan Junior).
This commit is contained in:
parent
17183a1d49
commit
2cbda85f1c
@ -504,3 +504,9 @@ Patch120: gdb-vla-intel-fix-print-char-array.patch
|
||||
# =fedoratest
|
||||
Patch121: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
|
||||
# Implement IPv6 support for GDB/gdbserver (RH BZ 881849, Sergio Durigan Junior).
|
||||
Patch122: gdb-rhbz881849-ipv6-1of2.patch
|
||||
|
||||
# Implement IPv6 support for GDB/gdbserver (RH BZ 881849, Sergio Durigan Junior).
|
||||
Patch123: gdb-rhbz881849-ipv6-2of2.patch
|
||||
|
||||
|
@ -119,3 +119,5 @@
|
||||
%patch119 -p1
|
||||
%patch120 -p1
|
||||
%patch121 -p1
|
||||
%patch122 -p1
|
||||
%patch123 -p1
|
||||
|
@ -1 +1 @@
|
||||
0bad166b920254974ad2e35f087e14aa913afe44
|
||||
baa98cb7e6298cd74ad9638e5b02aa192f804659
|
||||
|
@ -119,3 +119,5 @@ gdb-testsuite-readline63-sigint.patch
|
||||
gdb-archer.patch
|
||||
gdb-vla-intel-fix-print-char-array.patch
|
||||
gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
gdb-rhbz881849-ipv6-1of2.patch
|
||||
gdb-rhbz881849-ipv6-2of2.patch
|
||||
|
@ -9,7 +9,7 @@ Subject: gdb-container-rh-pkg.patch
|
||||
diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
--- a/gdb/remote.c
|
||||
+++ b/gdb/remote.c
|
||||
@@ -13901,7 +13901,17 @@ remote_target::pid_to_exec_file (int pid)
|
||||
@@ -13909,7 +13909,17 @@ remote_target::pid_to_exec_file (int pid)
|
||||
char *annex = NULL;
|
||||
|
||||
if (packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)
|
||||
|
@ -2758,7 +2758,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
int insert_watchpoint (CORE_ADDR, int, enum target_hw_bp_type,
|
||||
struct expression *) override;
|
||||
@@ -10405,7 +10405,7 @@ int remote_hw_watchpoint_length_limit = -1;
|
||||
@@ -10413,7 +10413,7 @@ int remote_hw_watchpoint_length_limit = -1;
|
||||
int remote_hw_breakpoint_limit = -1;
|
||||
|
||||
int
|
||||
|
@ -384,7 +384,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
int can_use_hw_breakpoint (enum bptype, int, int) override;
|
||||
|
||||
@@ -10334,7 +10334,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10342,7 +10342,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
p = strchr (rs->buf, '\0');
|
||||
addr = remote_address_masked (addr);
|
||||
p += hexnumstr (p, (ULONGEST) addr);
|
||||
@ -393,7 +393,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
putpkt (rs->buf);
|
||||
getpkt (&rs->buf, &rs->buf_size, 0);
|
||||
@@ -10354,7 +10354,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10362,7 +10362,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
|
||||
bool
|
||||
remote_target::watchpoint_addr_within_range (CORE_ADDR addr,
|
||||
@ -402,7 +402,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
{
|
||||
CORE_ADDR diff = remote_address_masked (addr - start);
|
||||
|
||||
@@ -10383,7 +10383,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10391,7 +10391,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
|
||||
p = strchr (rs->buf, '\0');
|
||||
addr = remote_address_masked (addr);
|
||||
p += hexnumstr (p, (ULONGEST) addr);
|
||||
|
1964
gdb-rhbz881849-ipv6-1of2.patch
Normal file
1964
gdb-rhbz881849-ipv6-1of2.patch
Normal file
File diff suppressed because it is too large
Load Diff
63
gdb-rhbz881849-ipv6-2of2.patch
Normal file
63
gdb-rhbz881849-ipv6-2of2.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Sergio Durigan Junior <sergiodj@redhat.com>
|
||||
Date: Fri, 13 Jul 2018 16:20:34 -0400
|
||||
Subject: gdb-rhbz881849-ipv6-2of2.patch
|
||||
|
||||
;; Implement IPv6 support for GDB/gdbserver (RH BZ 881849, Sergio Durigan Junior).
|
||||
|
||||
Expect for another variant of error message when gdbserver cannot resolve hostname
|
||||
|
||||
I've noticed that on a few hosts, when given an invalid hostname,
|
||||
gdbserver fails with:
|
||||
|
||||
spawn /../../gdb/gdbserver/gdbserver --once tcp8:123:2353 /gdb/build/fedora-s390x/build/gdb/testsuite/outputs/gdb.server/server-connect/server-connect
|
||||
tcp8:123:2353: cannot resolve name: No address associated with hostname
|
||||
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
||||
Exiting
|
||||
|
||||
Unfortunately, this causes a fail on the new
|
||||
gdb.server/server-connect.exp test (introduced by the IPv6 patch):
|
||||
|
||||
FAIL: gdb.server/server-connect.exp: tcp8: start gdbserver: gdbserver should fail but did not
|
||||
|
||||
This happens because we're expecting for another variant of this error
|
||||
message:
|
||||
|
||||
cannot resolve name: Name or service not known
|
||||
|
||||
Therefore, this patch extends the helper function 'gdbserver_start' to
|
||||
also recognize the "No address associated with hostname" message.
|
||||
This "fixes" the testcase on the hosts that use this variant.
|
||||
|
||||
gdb/testsuite/ChangeLog:
|
||||
2018-07-13 Sergio Durigan Junior <sergiodj@redhat.com>
|
||||
|
||||
* lib/gdbserver-support.exp (gdbserver_start): Expect for the
|
||||
message "No address associated with hostname" when gdbserver
|
||||
cannot resolve the hostname.
|
||||
|
||||
diff --git a/gdb/testsuite/ChangeLog b/gdb/testsuite/ChangeLog
|
||||
--- a/gdb/testsuite/ChangeLog
|
||||
+++ b/gdb/testsuite/ChangeLog
|
||||
@@ -1,3 +1,9 @@
|
||||
+2018-07-13 Sergio Durigan Junior <sergiodj@redhat.com>
|
||||
+
|
||||
+ * lib/gdbserver-support.exp (gdbserver_start): Expect for the
|
||||
+ message "No address associated with hostname" when gdbserver
|
||||
+ cannot resolve the hostname.
|
||||
+
|
||||
2018-07-11 Sergio Durigan Junior <sergiodj@redhat.com>
|
||||
Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
Paul Fertser <fercerpav@gmail.com>
|
||||
diff --git a/gdb/testsuite/lib/gdbserver-support.exp b/gdb/testsuite/lib/gdbserver-support.exp
|
||||
--- a/gdb/testsuite/lib/gdbserver-support.exp
|
||||
+++ b/gdb/testsuite/lib/gdbserver-support.exp
|
||||
@@ -326,7 +326,7 @@ proc gdbserver_start { options arguments } {
|
||||
continue
|
||||
}
|
||||
}
|
||||
- -re ".*: cannot resolve name: Name or service not known\r\n" {
|
||||
+ -re ".*: cannot resolve name: \(No address associated with hostname|Name or service not known\)\r\n" {
|
||||
error "gdbserver cannot resolve name."
|
||||
}
|
||||
timeout {
|
8
gdb.spec
8
gdb.spec
@ -18,7 +18,7 @@
|
||||
Name: %{?scl_prefix}gdb
|
||||
|
||||
# Freeze it when GDB gets branched
|
||||
%global snapsrc 20180708
|
||||
%global snapsrc 20180714
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20161115
|
||||
%global tarname gdb-%{version}
|
||||
@ -26,7 +26,7 @@ Version: 8.1.90.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 34%{?dist}
|
||||
Release: 35%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1030,6 +1030,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Jul 14 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.90.20180714-35.fc29
|
||||
- Rebase to FSF GDB 8.1.90.20180714 (8.2pre).
|
||||
- Backport IPv6 patch (RH BZ 881849, Sergio Durigan Junior).
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org>
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user