8.0.90.20180109-2.fc26
Remove gdb-6.3-rh-dummykfail-20041202.patch (RH BZ 1535228). Remove gdb-glibc-vdso-workaround.patch (RH BZ 1535244). Resolves: rhbz#1535228 Resolves: rhbz#1535244
This commit is contained in:
parent
a749f1b208
commit
21011c1e9c
@ -12,304 +12,300 @@ Patch003: gdb-vla-intel-fortran-vla-strings.patch
|
||||
#=push+jan
|
||||
Patch004: gdb-vla-intel-stringbt-fix.patch
|
||||
|
||||
# Work around out-of-date dejagnu that does not have KFAIL
|
||||
#=push: That dejagnu is too old to be supported.
|
||||
Patch005: gdb-6.3-rh-dummykfail-20041202.patch
|
||||
|
||||
# Better parse 64-bit PPC system call prologues.
|
||||
#=push: Write new testcase.
|
||||
Patch006: gdb-6.3-ppc64syscall-20040622.patch
|
||||
Patch005: gdb-6.3-ppc64syscall-20040622.patch
|
||||
|
||||
# Include the pc's section when doing a symbol lookup so that the
|
||||
# correct symbol is found.
|
||||
#=push: Write new testcase.
|
||||
Patch007: gdb-6.3-ppc64displaysymbol-20041124.patch
|
||||
Patch006: gdb-6.3-ppc64displaysymbol-20041124.patch
|
||||
|
||||
# Add a wrapper script to GDB that implements pstack using the
|
||||
# --readnever option.
|
||||
#=push
|
||||
Patch008: gdb-6.3-gstack-20050411.patch
|
||||
Patch007: gdb-6.3-gstack-20050411.patch
|
||||
|
||||
# VSYSCALL and PIE
|
||||
#=fedoratest
|
||||
Patch009: gdb-6.3-test-pie-20050107.patch
|
||||
Patch008: gdb-6.3-test-pie-20050107.patch
|
||||
|
||||
# Get selftest working with sep-debug-info
|
||||
#=fedoratest
|
||||
Patch010: gdb-6.3-test-self-20050110.patch
|
||||
Patch009: gdb-6.3-test-self-20050110.patch
|
||||
|
||||
# Test support of multiple destructors just like multiple constructors
|
||||
#=fedoratest
|
||||
Patch011: gdb-6.3-test-dtorfix-20050121.patch
|
||||
Patch010: gdb-6.3-test-dtorfix-20050121.patch
|
||||
|
||||
# Fix to support executable moving
|
||||
#=fedoratest
|
||||
Patch012: gdb-6.3-test-movedir-20050125.patch
|
||||
Patch011: gdb-6.3-test-movedir-20050125.patch
|
||||
|
||||
# Test sibling threads to set threaded watchpoints for x86 and x86-64
|
||||
#=fedoratest
|
||||
Patch013: gdb-6.3-threaded-watchpoints2-20050225.patch
|
||||
Patch012: gdb-6.3-threaded-watchpoints2-20050225.patch
|
||||
|
||||
# Notify observers that the inferior has been created
|
||||
#=fedoratest
|
||||
Patch014: gdb-6.3-inferior-notification-20050721.patch
|
||||
Patch013: gdb-6.3-inferior-notification-20050721.patch
|
||||
|
||||
# Verify printing of inherited members test
|
||||
#=fedoratest
|
||||
Patch015: gdb-6.3-inheritancetest-20050726.patch
|
||||
Patch014: gdb-6.3-inheritancetest-20050726.patch
|
||||
|
||||
# Add readnever option
|
||||
#=push
|
||||
Patch016: gdb-6.3-readnever-20050907.patch
|
||||
Patch015: gdb-6.3-readnever-20050907.patch
|
||||
|
||||
# Fix debuginfo addresses resolving for --emit-relocs Linux kernels (BZ 203661).
|
||||
#=push+jan: There was some mail thread about it, this patch may be a hack.
|
||||
Patch017: gdb-6.5-bz203661-emit-relocs.patch
|
||||
Patch016: gdb-6.5-bz203661-emit-relocs.patch
|
||||
|
||||
# Support TLS symbols (+`errno' suggestion if no pthread is found) (BZ 185337).
|
||||
#=push+jan: It should be replaced by Infinity project.
|
||||
Patch018: gdb-6.5-bz185337-resolve-tls-without-debuginfo-v2.patch
|
||||
Patch017: gdb-6.5-bz185337-resolve-tls-without-debuginfo-v2.patch
|
||||
|
||||
# Fix TLS symbols resolving for shared libraries with a relative pathname.
|
||||
# The testsuite needs `gdb-6.5-tls-of-separate-debuginfo.patch'.
|
||||
#=fedoratest: One should recheck if it is really fixed upstream.
|
||||
Patch019: gdb-6.5-sharedlibrary-path.patch
|
||||
Patch018: gdb-6.5-sharedlibrary-path.patch
|
||||
|
||||
# Improved testsuite results by the testsuite provided by the courtesy of BEA.
|
||||
#=fedoratest: For upstream it should be rewritten as a dejagnu test, the test of no "??" was useful.
|
||||
Patch020: gdb-6.5-BEA-testsuite.patch
|
||||
Patch019: gdb-6.5-BEA-testsuite.patch
|
||||
|
||||
# Testcase for deadlocking on last address space byte; for corrupted backtraces.
|
||||
#=fedoratest
|
||||
Patch021: gdb-6.5-last-address-space-byte-test.patch
|
||||
Patch020: gdb-6.5-last-address-space-byte-test.patch
|
||||
|
||||
# Fix readline segfault on excessively long hand-typed lines.
|
||||
#=fedoratest
|
||||
Patch022: gdb-6.5-readline-long-line-crash-test.patch
|
||||
Patch021: gdb-6.5-readline-long-line-crash-test.patch
|
||||
|
||||
# Fix bogus 0x0 unwind of the thread's topmost function clone(3) (BZ 216711).
|
||||
#=fedora
|
||||
Patch023: gdb-6.5-bz216711-clone-is-outermost.patch
|
||||
Patch022: gdb-6.5-bz216711-clone-is-outermost.patch
|
||||
|
||||
# Test sideeffects of skipping ppc .so libs trampolines (BZ 218379).
|
||||
#=fedoratest
|
||||
Patch024: gdb-6.5-bz218379-ppc-solib-trampoline-test.patch
|
||||
Patch023: gdb-6.5-bz218379-ppc-solib-trampoline-test.patch
|
||||
|
||||
# Fix lockup on trampoline vs. its function lookup; unreproducible (BZ 218379).
|
||||
#=fedora
|
||||
Patch025: gdb-6.5-bz218379-solib-trampoline-lookup-lock-fix.patch
|
||||
Patch024: gdb-6.5-bz218379-solib-trampoline-lookup-lock-fix.patch
|
||||
|
||||
# Find symbols properly at their original (included) file (BZ 109921).
|
||||
#=fedoratest
|
||||
Patch026: gdb-6.5-bz109921-DW_AT_decl_file-test.patch
|
||||
Patch025: gdb-6.5-bz109921-DW_AT_decl_file-test.patch
|
||||
|
||||
# Update PPC unwinding patches to their upstream variants (BZ 140532).
|
||||
#=fedoratest
|
||||
Patch027: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
Patch026: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
|
||||
# Testcase for exec() from threaded program (BZ 202689).
|
||||
#=fedoratest
|
||||
Patch028: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
Patch027: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
#=fedoratest
|
||||
Patch029: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
Patch028: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
|
||||
# Allow running `/usr/bin/gcore' with provided but inaccessible tty (BZ 229517).
|
||||
#=fedoratest
|
||||
Patch030: gdb-6.6-bz229517-gcore-without-terminal.patch
|
||||
Patch029: gdb-6.6-bz229517-gcore-without-terminal.patch
|
||||
|
||||
# Notify user of a child forked process being detached (BZ 235197).
|
||||
#=push+jan: This is more about discussion if/what should be printed.
|
||||
Patch031: gdb-6.6-bz235197-fork-detach-info.patch
|
||||
Patch030: gdb-6.6-bz235197-fork-detach-info.patch
|
||||
|
||||
# Avoid too long timeouts on failing cases of "annota1.exp annota3.exp".
|
||||
#=fedoratest
|
||||
Patch032: gdb-6.6-testsuite-timeouts.patch
|
||||
Patch031: gdb-6.6-testsuite-timeouts.patch
|
||||
|
||||
# Support for stepping over PPC atomic instruction sequences (BZ 237572).
|
||||
#=fedoratest
|
||||
Patch033: gdb-6.6-bz237572-ppc-atomic-sequence-test.patch
|
||||
Patch032: gdb-6.6-bz237572-ppc-atomic-sequence-test.patch
|
||||
|
||||
# Make upstream `set scheduler-locking step' as default.
|
||||
#=push+jan: How much is scheduler-locking relevant after non-stop?
|
||||
Patch034: gdb-6.6-scheduler_locking-step-is-default.patch
|
||||
Patch033: gdb-6.6-scheduler_locking-step-is-default.patch
|
||||
|
||||
# Test kernel VDSO decoding while attaching to an i386 process.
|
||||
#=fedoratest
|
||||
Patch035: gdb-6.3-attach-see-vdso-test.patch
|
||||
Patch034: gdb-6.3-attach-see-vdso-test.patch
|
||||
|
||||
# Test leftover zombie process (BZ 243845).
|
||||
#=fedoratest
|
||||
Patch036: gdb-6.5-bz243845-stale-testing-zombie-test.patch
|
||||
Patch035: gdb-6.5-bz243845-stale-testing-zombie-test.patch
|
||||
|
||||
# New locating of the matching binaries from the pure core file (build-id).
|
||||
#=push+jan
|
||||
Patch037: gdb-6.6-buildid-locate.patch
|
||||
Patch036: gdb-6.6-buildid-locate.patch
|
||||
|
||||
# Fix loading of core files without build-ids but with build-ids in executables.
|
||||
# Load strictly build-id-checked core files only if no executable is specified
|
||||
# (Jan Kratochvil, RH BZ 1339862).
|
||||
#=push+jan
|
||||
Patch038: gdb-6.6-buildid-locate-solib-missing-ids.patch
|
||||
Patch037: gdb-6.6-buildid-locate-solib-missing-ids.patch
|
||||
|
||||
#=push+jan
|
||||
Patch039: gdb-6.6-buildid-locate-rpm.patch
|
||||
Patch038: gdb-6.6-buildid-locate-rpm.patch
|
||||
|
||||
# Fix displaying of numeric char arrays as strings (BZ 224128).
|
||||
#=fedoratest: But it is failing anyway, one should check the behavior more.
|
||||
Patch040: gdb-6.7-charsign-test.patch
|
||||
Patch039: gdb-6.7-charsign-test.patch
|
||||
|
||||
# Test PPC hiding of call-volatile parameter register.
|
||||
#=fedoratest
|
||||
Patch041: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
Patch040: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
|
||||
# Testsuite fixes for more stable/comparable results.
|
||||
#=fedoratest
|
||||
Patch042: gdb-6.7-testsuite-stable-results.patch
|
||||
Patch041: gdb-6.7-testsuite-stable-results.patch
|
||||
|
||||
# Test ia64 memory leaks of the code using libunwind.
|
||||
#=fedoratest
|
||||
Patch043: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
Patch042: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
||||
# Test hiding unexpected breakpoints on intentional step commands.
|
||||
#=fedoratest
|
||||
Patch044: gdb-6.5-missed-trap-on-step-test.patch
|
||||
Patch043: gdb-6.5-missed-trap-on-step-test.patch
|
||||
|
||||
# Test gcore memory and time requirements for large inferiors.
|
||||
#=fedoratest
|
||||
Patch045: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
Patch044: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
|
||||
# Test GCORE for shmid 0 shared memory mappings.
|
||||
#=fedoratest: But it is broken anyway, sometimes the case being tested is not reproducible.
|
||||
Patch046: gdb-6.3-mapping-zero-inode-test.patch
|
||||
Patch045: gdb-6.3-mapping-zero-inode-test.patch
|
||||
|
||||
# Test a crash on `focus cmd', `focus prev' commands.
|
||||
#=fedoratest
|
||||
Patch047: gdb-6.3-focus-cmd-prev-test.patch
|
||||
Patch046: gdb-6.3-focus-cmd-prev-test.patch
|
||||
|
||||
# Test various forms of threads tracking across exec() (BZ 442765).
|
||||
#=fedoratest
|
||||
Patch048: gdb-6.8-bz442765-threaded-exec-test.patch
|
||||
Patch047: gdb-6.8-bz442765-threaded-exec-test.patch
|
||||
|
||||
# Silence memcpy check which returns false positive (sparc64)
|
||||
#=push: But it is just a GCC workaround, look up the existing GCC PR for it.
|
||||
Patch049: gdb-6.8-sparc64-silence-memcpy-check.patch
|
||||
Patch048: gdb-6.8-sparc64-silence-memcpy-check.patch
|
||||
|
||||
# Test a crash on libraries missing the .text section.
|
||||
#=fedoratest
|
||||
Patch050: gdb-6.5-section-num-fixup-test.patch
|
||||
Patch049: gdb-6.5-section-num-fixup-test.patch
|
||||
|
||||
# Fix register assignments with no GDB stack frames (BZ 436037).
|
||||
#=push+jan: This fix is incorrect.
|
||||
Patch051: gdb-6.8-bz436037-reg-no-longer-active.patch
|
||||
Patch050: gdb-6.8-bz436037-reg-no-longer-active.patch
|
||||
|
||||
# Test the watchpoints conditionals works.
|
||||
#=fedoratest
|
||||
Patch052: gdb-6.8-watchpoint-conditionals-test.patch
|
||||
Patch051: gdb-6.8-watchpoint-conditionals-test.patch
|
||||
|
||||
# Fix resolving of variables at locations lists in prelinked libs (BZ 466901).
|
||||
#=fedoratest
|
||||
Patch053: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
Patch052: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
|
||||
# New test for step-resume breakpoint placed in multiple threads at once.
|
||||
#=fedoratest
|
||||
Patch054: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
Patch053: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
|
||||
# Fix GNU/Linux core open: Can't read pathname for load map: Input/output error.
|
||||
# Fix regression of undisplayed missing shared libraries caused by a fix for.
|
||||
#=fedoratest: It should be in glibc: libc-alpha: <20091004161706.GA27450@.*>
|
||||
Patch055: gdb-core-open-vdso-warning.patch
|
||||
Patch054: gdb-core-open-vdso-warning.patch
|
||||
|
||||
# Fix syscall restarts for amd64->i386 biarch.
|
||||
#=push+jan
|
||||
Patch056: gdb-x86_64-i386-syscall-restart.patch
|
||||
Patch055: gdb-x86_64-i386-syscall-restart.patch
|
||||
|
||||
# Fix stepping with OMP parallel Fortran sections (BZ 533176).
|
||||
#=push+jan: It requires some better DWARF annotations.
|
||||
Patch057: gdb-bz533176-fortran-omp-step.patch
|
||||
Patch056: gdb-bz533176-fortran-omp-step.patch
|
||||
|
||||
# Fix regression by python on ia64 due to stale current frame.
|
||||
#=push+jan
|
||||
Patch058: gdb-follow-child-stale-parent.patch
|
||||
Patch057: gdb-follow-child-stale-parent.patch
|
||||
|
||||
# Workaround ccache making lineno non-zero for command-line definitions.
|
||||
#=fedoratest: ccache is rarely used and it is even fixed now.
|
||||
Patch059: gdb-ccache-workaround.patch
|
||||
Patch058: gdb-ccache-workaround.patch
|
||||
|
||||
#=push+jan: May get obsoleted by Tom's unrelocated objfiles patch.
|
||||
Patch060: gdb-archer-pie-addons.patch
|
||||
Patch059: gdb-archer-pie-addons.patch
|
||||
|
||||
#=push+jan: Breakpoints disabling matching should not be based on address.
|
||||
Patch061: gdb-archer-pie-addons-keep-disabled.patch
|
||||
Patch060: gdb-archer-pie-addons-keep-disabled.patch
|
||||
|
||||
# Testcase for "Do not make up line information" fix by Daniel Jacobowitz.
|
||||
#=fedoratest
|
||||
Patch062: gdb-lineno-makeup-test.patch
|
||||
Patch061: gdb-lineno-makeup-test.patch
|
||||
|
||||
# Test power7 ppc disassembly.
|
||||
#=fedoratest
|
||||
Patch063: gdb-ppc-power7-test.patch
|
||||
Patch062: gdb-ppc-power7-test.patch
|
||||
|
||||
# Fix i386+x86_64 rwatch+awatch before run, regression against 6.8 (BZ 541866).
|
||||
# Fix i386 rwatch+awatch before run (BZ 688788, on top of BZ 541866).
|
||||
#=push+jan: It should be fixed properly instead.
|
||||
Patch064: gdb-bz541866-rwatch-before-run.patch
|
||||
Patch063: gdb-bz541866-rwatch-before-run.patch
|
||||
|
||||
# Workaround non-stop moribund locations exploited by kernel utrace (BZ 590623).
|
||||
#=push+jan: Currently it is still not fully safe.
|
||||
Patch065: gdb-moribund-utrace-workaround.patch
|
||||
Patch064: gdb-moribund-utrace-workaround.patch
|
||||
|
||||
# Fix follow-exec for C++ programs (bugreported by Martin Stransky).
|
||||
#=fedoratest
|
||||
Patch066: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
Patch065: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
|
||||
# Backport DWARF-4 support (BZ 601887, Tom Tromey).
|
||||
#=fedoratest
|
||||
Patch067: gdb-bz601887-dwarf4-rh-test.patch
|
||||
Patch066: gdb-bz601887-dwarf4-rh-test.patch
|
||||
|
||||
#=push+jan
|
||||
Patch068: gdb-6.6-buildid-locate-core-as-arg.patch
|
||||
Patch067: gdb-6.6-buildid-locate-core-as-arg.patch
|
||||
|
||||
# Workaround librpm BZ 643031 due to its unexpected exit() calls (BZ 642879).
|
||||
#=push+jan
|
||||
Patch069: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
Patch068: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
|
||||
# [delayed-symfile] Test a backtrace regression on CFIs without DIE (BZ 614604).
|
||||
#=fedoratest
|
||||
Patch070: gdb-test-bt-cfi-without-die.patch
|
||||
Patch069: gdb-test-bt-cfi-without-die.patch
|
||||
|
||||
# Provide /usr/bin/gdb-add-index for rpm-build (Tom Tromey).
|
||||
#=push: Re-check against the upstream version.
|
||||
Patch071: gdb-gdb-add-index-script.patch
|
||||
Patch070: gdb-gdb-add-index-script.patch
|
||||
|
||||
# Out of memory is just an error, not fatal (uninitialized VLS vars, BZ 568248).
|
||||
#=push+jan: Inferior objects should be read in parts, then this patch gets obsoleted.
|
||||
Patch072: gdb-bz568248-oom-is-error.patch
|
||||
Patch071: gdb-bz568248-oom-is-error.patch
|
||||
|
||||
# Verify GDB Python built-in function gdb.solib_address exists (BZ # 634108).
|
||||
#=fedoratest
|
||||
Patch073: gdb-bz634108-solib_address.patch
|
||||
Patch072: gdb-bz634108-solib_address.patch
|
||||
|
||||
# New test gdb.arch/x86_64-pid0-core.exp for kernel PID 0 cores (BZ 611435).
|
||||
#=fedoratest
|
||||
Patch074: gdb-test-pid0-core.patch
|
||||
Patch073: gdb-test-pid0-core.patch
|
||||
|
||||
# [archer-tromey-delayed-symfile] New test gdb.dwarf2/dw2-aranges.exp.
|
||||
#=fedoratest
|
||||
Patch075: gdb-test-dw2-aranges.patch
|
||||
Patch074: gdb-test-dw2-aranges.patch
|
||||
|
||||
# [archer-keiths-expr-cumulative+upstream] Import C++ testcases.
|
||||
#=fedoratest
|
||||
Patch076: gdb-test-expr-cumulative-archer.patch
|
||||
Patch075: gdb-test-expr-cumulative-archer.patch
|
||||
|
||||
# Fix regressions on C++ names resolving (PR 11734, PR 12273, Keith Seitz).
|
||||
#=fedoratest
|
||||
Patch077: gdb-physname-pr11734-test.patch
|
||||
Patch076: gdb-physname-pr11734-test.patch
|
||||
|
||||
# Fix regressions on C++ names resolving (PR 11734, PR 12273, Keith Seitz).
|
||||
#=fedoratest
|
||||
Patch078: gdb-physname-pr12273-test.patch
|
||||
Patch077: gdb-physname-pr12273-test.patch
|
||||
|
||||
# Toolchain on sparc is slightly broken and debuginfo files are generated
|
||||
# with non 64bit aligned tables/offsets.
|
||||
@ -323,205 +319,201 @@ Patch078: gdb-physname-pr12273-test.patch
|
||||
# While we figure out what's wrong in the toolchain and do a full archive
|
||||
# rebuild to fix it, we need to be able to use gdb :)
|
||||
#=push
|
||||
Patch079: gdb-7.2.50-sparc-add-workaround-to-broken-debug-files.patch
|
||||
Patch078: gdb-7.2.50-sparc-add-workaround-to-broken-debug-files.patch
|
||||
|
||||
# Test GDB opcodes/ disassembly of Intel Ivy Bridge instructions (BZ 696890).
|
||||
#=fedoratest
|
||||
Patch080: gdb-test-ivy-bridge.patch
|
||||
|
||||
# Work around PR libc/13097 "linux-vdso.so.1" warning message.
|
||||
#=push+jan
|
||||
Patch081: gdb-glibc-vdso-workaround.patch
|
||||
Patch079: gdb-test-ivy-bridge.patch
|
||||
|
||||
# Hack for proper PIE run of the testsuite.
|
||||
#=fedoratest
|
||||
Patch082: gdb-runtest-pie-override.patch
|
||||
Patch080: gdb-runtest-pie-override.patch
|
||||
|
||||
# Print reasons for failed attach/spawn incl. SELinux deny_ptrace (BZ 786878).
|
||||
#=push+jan
|
||||
Patch083: gdb-attach-fail-reasons-5of5.patch
|
||||
Patch081: gdb-attach-fail-reasons-5of5.patch
|
||||
|
||||
# Workaround crashes from stale frame_info pointer (BZ 804256).
|
||||
#=push+jan
|
||||
Patch084: gdb-stale-frame_info.patch
|
||||
Patch082: gdb-stale-frame_info.patch
|
||||
|
||||
# Workaround PR libc/14166 for inferior calls of strstr.
|
||||
#=fedora: Compatibility with RHELs (unchecked which ones).
|
||||
Patch085: gdb-glibc-strstr-workaround.patch
|
||||
Patch083: gdb-glibc-strstr-workaround.patch
|
||||
|
||||
# Include testcase for `Unable to see a variable inside a module (XLF)' (BZ 823789).
|
||||
#=fedoratest
|
||||
Patch086: gdb-rhel5.9-testcase-xlf-var-inside-mod.patch
|
||||
Patch084: gdb-rhel5.9-testcase-xlf-var-inside-mod.patch
|
||||
|
||||
# Testcase for `Setting solib-absolute-prefix breaks vDSO' (BZ 818343).
|
||||
#=fedoratest
|
||||
Patch087: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
Patch085: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch088: gdb-rhbz795424-bitpos-20of25.patch
|
||||
Patch086: gdb-rhbz795424-bitpos-20of25.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch089: gdb-rhbz795424-bitpos-21of25.patch
|
||||
Patch087: gdb-rhbz795424-bitpos-21of25.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch090: gdb-rhbz795424-bitpos-22of25.patch
|
||||
Patch088: gdb-rhbz795424-bitpos-22of25.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch091: gdb-rhbz795424-bitpos-23of25.patch
|
||||
Patch089: gdb-rhbz795424-bitpos-23of25.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch092: gdb-rhbz795424-bitpos-25of25.patch
|
||||
Patch090: gdb-rhbz795424-bitpos-25of25.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch093: gdb-rhbz795424-bitpos-25of25-test.patch
|
||||
Patch091: gdb-rhbz795424-bitpos-25of25-test.patch
|
||||
|
||||
# Fix `GDB cannot access struct member whose offset is larger than 256MB'
|
||||
# (RH BZ 795424).
|
||||
#=push
|
||||
Patch094: gdb-rhbz795424-bitpos-lazyvalue.patch
|
||||
Patch092: gdb-rhbz795424-bitpos-lazyvalue.patch
|
||||
|
||||
# Import regression test for `gdb/findvar.c:417: internal-error:
|
||||
# read_var_value: Assertion `frame' failed.' (RH BZ 947564) from RHEL 6.5.
|
||||
#=fedoratest
|
||||
Patch095: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
Patch093: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
|
||||
# Fix crash of -readnow /usr/lib/debug/usr/bin/gnatbind.debug (BZ 1069211).
|
||||
#=push+jan
|
||||
Patch096: gdb-gnat-dwarf-crash-3of3.patch
|
||||
Patch094: gdb-gnat-dwarf-crash-3of3.patch
|
||||
|
||||
# Fix 'memory leak in infpy_read_memory()' (RH BZ 1007614)
|
||||
#=fedoratest
|
||||
Patch097: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
Patch095: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
|
||||
# Fix 'gdb gives highly misleading error when debuginfo pkg is present,
|
||||
# but not corresponding binary pkg' (RH BZ 981154).
|
||||
#=push+jan
|
||||
Patch098: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
Patch096: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
|
||||
#=fedoratest
|
||||
Patch099: gdb-archer-vla-tests.patch
|
||||
Patch097: gdb-archer-vla-tests.patch
|
||||
|
||||
#=fedoratest
|
||||
Patch100: gdb-vla-intel-tests.patch
|
||||
Patch098: gdb-vla-intel-tests.patch
|
||||
|
||||
# Continue backtrace even if a frame filter throws an exception (Phil Muldoon).
|
||||
#=push
|
||||
Patch101: gdb-btrobust.patch
|
||||
Patch099: gdb-btrobust.patch
|
||||
|
||||
# Display Fortran strings in backtraces.
|
||||
#=fedoratest
|
||||
Patch102: gdb-fortran-frame-string.patch
|
||||
Patch100: gdb-fortran-frame-string.patch
|
||||
|
||||
# Fix Python GIL with gdb.execute("continue") (Phil Muldoon, BZ 1116957).
|
||||
#=push
|
||||
Patch103: gdb-python-gil.patch
|
||||
Patch101: gdb-python-gil.patch
|
||||
|
||||
# Testcase for '[SAP] Recursive dlopen causes SAP HANA installer to
|
||||
# crash.' (RH BZ 1156192).
|
||||
#=fedoratest
|
||||
Patch104: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
Patch102: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
|
||||
# Fix jit-reader.h for multi-lib.
|
||||
#=push+jan
|
||||
Patch105: gdb-jit-reader-multilib.patch
|
||||
Patch103: gdb-jit-reader-multilib.patch
|
||||
|
||||
# Fix '`catch syscall' doesn't work for parent after `fork' is called'
|
||||
# (Philippe Waroquiers, RH BZ 1149205).
|
||||
#=fedoratest
|
||||
Patch106: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
Patch104: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
|
||||
# Fix 'backport GDB 7.4 fix to RHEL 6.6 GDB' [Original Sourceware bug
|
||||
# description: 'C++ (and objc): Internal error on unqualified name
|
||||
# re-set', PR 11657] (RH BZ 1186476).
|
||||
#=fedoratest
|
||||
Patch107: gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
Patch105: gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
|
||||
# Test 'info type-printers' Python error (RH BZ 1350436).
|
||||
#=fedoratest
|
||||
Patch108: gdb-rhbz1350436-type-printers-error.patch
|
||||
Patch106: gdb-rhbz1350436-type-printers-error.patch
|
||||
|
||||
# Fix '[ppc64] and [s390x] wrong prologue skip on -O2 -g code' (Jan
|
||||
# Kratochvil, RH BZ 1084404).
|
||||
#=fedoratest
|
||||
Patch109: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
Patch107: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
|
||||
# Never kill PID on: gdb exec PID (Jan Kratochvil, RH BZ 1219747).
|
||||
#=push+jan
|
||||
Patch110: gdb-bz1219747-attach-kills.patch
|
||||
Patch108: gdb-bz1219747-attach-kills.patch
|
||||
|
||||
# Force libncursesw over libncurses to match the includes (RH BZ 1270534).
|
||||
#=push+jan
|
||||
Patch111: gdb-fedora-libncursesw.patch
|
||||
Patch109: gdb-fedora-libncursesw.patch
|
||||
|
||||
# Test clflushopt instruction decode (for RH BZ 1262471).
|
||||
#=fedoratest
|
||||
Patch112: gdb-opcodes-clflushopt-test.patch
|
||||
Patch110: gdb-opcodes-clflushopt-test.patch
|
||||
|
||||
# [rhel6] DTS backward Python compatibility API (BZ 1020004, Phil Muldoon).
|
||||
#=fedora
|
||||
Patch113: gdb-dts-rhel6-python-compat.patch
|
||||
Patch111: gdb-dts-rhel6-python-compat.patch
|
||||
|
||||
# [SCL] Skip deprecated .gdb_index warning for Red Hat built files (BZ 953585).
|
||||
#=push+jan
|
||||
Patch114: gdb-6.6-buildid-locate-rpm-scl.patch
|
||||
Patch112: gdb-6.6-buildid-locate-rpm-scl.patch
|
||||
|
||||
# Work around readline-6.2 incompatibility not asking for --more-- (BZ 701131).
|
||||
#=fedora
|
||||
Patch115: gdb-readline62-ask-more-rh.patch
|
||||
Patch113: gdb-readline62-ask-more-rh.patch
|
||||
|
||||
# [RHEL5,RHEL6] Fix attaching to stopped processes.
|
||||
# [RHEL5] Workaround kernel for detaching SIGSTOPped processes (BZ 809382).
|
||||
#=fedora
|
||||
Patch116: gdb-6.8-attach-signalled-detach-stopped.patch
|
||||
Patch114: gdb-6.8-attach-signalled-detach-stopped.patch
|
||||
|
||||
# Make the GDB quit processing non-abortable to cleanup everything properly.
|
||||
#=fedora: It was useful only after gdb-6.8-attach-signalled-detach-stopped.patch .
|
||||
Patch117: gdb-6.8-quit-never-aborts.patch
|
||||
Patch115: gdb-6.8-quit-never-aborts.patch
|
||||
|
||||
# [aarch64] Fix hardware watchpoints (RH BZ 1261564).
|
||||
#=fedoratest
|
||||
Patch118: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
Patch116: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
|
||||
# Add messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||
#=fedora
|
||||
Patch119: gdb-container-rh-pkg.patch
|
||||
Patch117: gdb-container-rh-pkg.patch
|
||||
|
||||
# New test for Python "Cannot locate object file for block" (for RH BZ 1325795).
|
||||
#=fedoratest
|
||||
Patch120: gdb-rhbz1325795-framefilters-test.patch
|
||||
Patch118: gdb-rhbz1325795-framefilters-test.patch
|
||||
|
||||
# [dts+el7] [x86*] Bundle linux_perf.h for libipt (RH BZ 1256513).
|
||||
#=fedora
|
||||
Patch121: gdb-linux_perf-bundle.patch
|
||||
Patch119: gdb-linux_perf-bundle.patch
|
||||
|
||||
# Fix gdb-headless /usr/bin/ executables (BZ 1390251).
|
||||
#=fedora
|
||||
Patch122: gdb-libexec-add-index.patch
|
||||
Patch120: gdb-libexec-add-index.patch
|
||||
|
||||
# New testcase for: Fix <tab>-completion crash (Gary Benson, RH BZ 1398387).
|
||||
#=fedoratest
|
||||
Patch123: gdb-rhbz1398387-tab-crash-test.patch
|
||||
Patch121: gdb-rhbz1398387-tab-crash-test.patch
|
||||
|
||||
# [testsuite] Fix false selftest.exp FAIL from system readline-6.3+ (Patrick Palka).
|
||||
#=fedoratest
|
||||
Patch124: gdb-testsuite-readline63-sigint.patch
|
||||
Patch122: gdb-testsuite-readline63-sigint.patch
|
||||
|
||||
# Python patches of: http://sourceware.org/gdb/wiki/ProjectArcher
|
||||
#=push
|
||||
Patch125: gdb-archer.patch
|
||||
Patch123: gdb-archer.patch
|
||||
|
||||
# Revert upstream commit 469412dd9ccc4de5874fd3299b105833f36b34cd
|
||||
Patch126: gdb-vla-intel-fix-print-char-array.patch
|
||||
Patch124: gdb-vla-intel-fix-print-char-array.patch
|
||||
|
||||
|
@ -122,5 +122,3 @@
|
||||
%patch122 -p1
|
||||
%patch123 -p1
|
||||
%patch124 -p1
|
||||
%patch125 -p1
|
||||
%patch126 -p1
|
||||
|
@ -2,7 +2,6 @@ gdb-6.3-rh-testversion-20041202.patch
|
||||
gdb-vla-intel-fortran-strides.patch
|
||||
gdb-vla-intel-fortran-vla-strings.patch
|
||||
gdb-vla-intel-stringbt-fix.patch
|
||||
gdb-6.3-rh-dummykfail-20041202.patch
|
||||
gdb-6.3-ppc64syscall-20040622.patch
|
||||
gdb-6.3-ppc64displaysymbol-20041124.patch
|
||||
gdb-6.3-gstack-20050411.patch
|
||||
@ -78,7 +77,6 @@ gdb-physname-pr11734-test.patch
|
||||
gdb-physname-pr12273-test.patch
|
||||
gdb-7.2.50-sparc-add-workaround-to-broken-debug-files.patch
|
||||
gdb-test-ivy-bridge.patch
|
||||
gdb-glibc-vdso-workaround.patch
|
||||
gdb-runtest-pie-override.patch
|
||||
gdb-attach-fail-reasons-5of5.patch
|
||||
gdb-stale-frame_info.patch
|
||||
|
@ -1,40 +0,0 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Elena Zannoni <ezannoni@redhat.com>
|
||||
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
||||
Subject: gdb-6.3-rh-dummykfail-20041202.patch
|
||||
|
||||
FileName: gdb-6.3-rh-dummykfail-20041202.patch
|
||||
|
||||
;; Work around out-of-date dejagnu that does not have KFAIL
|
||||
;;=push: That dejagnu is too old to be supported.
|
||||
|
||||
2003-07-11 Elena Zannoni <ezannoni@redhat.com>
|
||||
|
||||
* lib/gdb.exp (setup_kfail, kfail): Redefine procedures.
|
||||
---
|
||||
gdb/testsuite/lib/gdb.exp | 9 +++++++++
|
||||
1 file changed, 9 insertions(+)
|
||||
|
||||
diff --git a/gdb/testsuite/lib/gdb.exp b/gdb/testsuite/lib/gdb.exp
|
||||
index 7702d9c238..9884f004c5 100644
|
||||
--- a/gdb/testsuite/lib/gdb.exp
|
||||
+++ b/gdb/testsuite/lib/gdb.exp
|
||||
@@ -124,6 +124,15 @@ set valnum_re "\\\$$decimal"
|
||||
|
||||
### Only procedures should come after this point.
|
||||
|
||||
+if {![llength [info procs kfail]]} {
|
||||
+ proc setup_kfail { args } {
|
||||
+ #setup_xfail args
|
||||
+ }
|
||||
+ proc kfail { bugid message } {
|
||||
+ fail $message
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
#
|
||||
# gdb_version -- extract and print the version number of GDB
|
||||
#
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1263,10 +1263,10 @@ index a6dc14e3c9..54a10df155 100644
|
||||
append options " -ex \"b $bpline\""
|
||||
append options " -ex \"run\""
|
||||
diff --git a/gdb/testsuite/lib/gdb.exp b/gdb/testsuite/lib/gdb.exp
|
||||
index 9884f004c5..fe2e79a681 100644
|
||||
index 7702d9c238..a165bf0938 100644
|
||||
--- a/gdb/testsuite/lib/gdb.exp
|
||||
+++ b/gdb/testsuite/lib/gdb.exp
|
||||
@@ -1703,6 +1703,16 @@ proc default_gdb_start { } {
|
||||
@@ -1694,6 +1694,16 @@ proc default_gdb_start { } {
|
||||
warning "Couldn't set the width to 0."
|
||||
}
|
||||
}
|
||||
|
@ -3822,10 +3822,10 @@ index 0000000000..295602d68c
|
||||
+ writeln(s); { set breakpoint 2 here }
|
||||
+end.
|
||||
diff --git a/gdb/testsuite/lib/gdb.exp b/gdb/testsuite/lib/gdb.exp
|
||||
index fe2e79a681..2845035caa 100644
|
||||
index a165bf0938..a13aaf7869 100644
|
||||
--- a/gdb/testsuite/lib/gdb.exp
|
||||
+++ b/gdb/testsuite/lib/gdb.exp
|
||||
@@ -178,6 +178,11 @@ proc gdb_unload {} {
|
||||
@@ -169,6 +169,11 @@ proc gdb_unload {} {
|
||||
send_gdb "y\n"
|
||||
exp_continue
|
||||
}
|
||||
|
@ -1,46 +0,0 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Fedora GDB patches <invalid@email.com>
|
||||
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
||||
Subject: Work around PR libc/13097 "linux-vdso.so.1" #2
|
||||
|
||||
FileName: gdb-glibc-vdso-workaround.patch
|
||||
|
||||
;; Work around PR libc/13097 "linux-vdso.so.1" warning message.
|
||||
;;=push+jan
|
||||
|
||||
http://sourceware.org/ml/gdb-patches/2011-08/msg00331.html
|
||||
|
||||
Hi,
|
||||
|
||||
missed the x86_64-m32 case:
|
||||
|
||||
gdb/
|
||||
2011-08-16 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
Work around PR libc/13097.
|
||||
* solib.c (update_solib_list): Ignore "linux-vdso.so.1".
|
||||
---
|
||||
gdb/solib.c | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gdb/solib.c b/gdb/solib.c
|
||||
index 3dba5eaa8a..17c0a02f27 100644
|
||||
--- a/gdb/solib.c
|
||||
+++ b/gdb/solib.c
|
||||
@@ -884,8 +884,11 @@ update_solib_list (int from_tty)
|
||||
|
||||
TRY
|
||||
{
|
||||
- /* Fill in the rest of the `struct so_list' node. */
|
||||
- if (!solib_map_sections (i))
|
||||
+ /* Fill in the rest of the `struct so_list' node.
|
||||
+ Work around PR libc/13097. */
|
||||
+ if (!solib_map_sections (i)
|
||||
+ && strcmp (i->so_original_name, "linux-vdso.so.1") != 0
|
||||
+ && strcmp (i->so_original_name, "linux-gate.so.1") != 0)
|
||||
{
|
||||
not_found++;
|
||||
if (not_found_filename == NULL)
|
||||
--
|
||||
2.14.3
|
||||
|
6
gdb.spec
6
gdb.spec
@ -26,7 +26,7 @@ Version: 8.0.90.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1017,6 +1017,10 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jan 19 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.0.90.20180109-2.fc26
|
||||
- Remove gdb-6.3-rh-dummykfail-20041202.patch (RH BZ 1535228).
|
||||
- Remove gdb-glibc-vdso-workaround.patch (RH BZ 1535244).
|
||||
|
||||
* Wed Jan 10 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.0.90.20180109-1.fc26
|
||||
- Rebase to pre-FSF GDB 8.1 (8.1.90.20180109).
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user