Simplify .spec: Remove conditional revert of: gdb-readline62-ask-more-rh.patch

This commit is contained in:
Jan Kratochvil 2016-01-09 14:55:47 +01:00
parent 46cc044291
commit 13d2cd5e8a
2 changed files with 16 additions and 8 deletions

View File

@ -1,14 +1,17 @@
--- gdb-7.4.50.20120103-orig/gdb/event-top.c 2012-01-11 15:14:01.426206439 +0100
+++ gdb-7.4.50.20120103/gdb/event-top.c 2012-01-11 15:18:29.766577551 +0100
@@ -982,6 +982,11 @@ set_async_editing_command (char *args, i
diff -dup -rup gdb-7.10.50.20160106-orig/gdb/event-top.c gdb-7.10.50.20160106/gdb/event-top.c
--- gdb-7.10.50.20160106-orig/gdb/event-top.c 2016-01-09 14:51:02.324243506 +0100
+++ gdb-7.10.50.20160106/gdb/event-top.c 2016-01-09 14:51:33.029434121 +0100
@@ -1033,6 +1033,13 @@ set_async_editing_command (char *args, i
void
gdb_setup_readline (void)
{
+#ifdef NEED_RL_STATE_FEDORA_GDB
+ /* 6.2 regression: no longed asks for --more--
+ gdb.base/readline-ask.exp
+ https://bugzilla.redhat.com/show_bug.cgi?id=701131 */
+ RL_SETSTATE (RL_STATE_FEDORA_GDB);
+
+#endif
/* This function is a noop for the sync case. The assumption is
that the sync setup is ALL done in gdb_init, and we would only
mess it up here. The sync stuff should really go away over

View File

@ -27,7 +27,7 @@ Version: 7.10.50.%{snapsrc}
# The release always contains a leading reserved number, start it at 1.
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
Release: 38%{?dist}
Release: 39%{?dist}
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
Group: Development/Debuggers
@ -880,11 +880,8 @@ find -name "*.info*"|xargs rm -f
%patch1070 -p1
%patch848 -p1
%patch833 -p1
%patch642 -p1
%if 0%{?rhel:1} && 0%{?rhel} <= 6
%patch642 -p1 -R
%endif
%patch337 -p1
%patch331 -p1
%patch335 -p1
@ -957,6 +954,11 @@ CFLAGS="$CFLAGS -DDNF_DEBUGINFO_INSTALL"
CFLAGS="$CFLAGS -DGDB_INDEX_VERIFY_VENDOR"
%endif
# Patch642: gdb-readline62-ask-more-rh.patch
%if 0%{!?rhel:1} || 0%{?rhel} > 6
CFLAGS="$CFLAGS -DNEED_RL_STATE_FEDORA_GDB"
%endif
# --htmldir and --pdfdir are not used as they are used from %{gdb_build}.
../configure \
--prefix=%{_prefix} \
@ -1399,6 +1401,9 @@ then
fi
%changelog
* Sat Jan 9 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160106-39.fc24
- Simplify .spec: Remove conditional revert of: gdb-readline62-ask-more-rh.patch
* Sat Jan 9 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160106-38.fc24
- Simplify .spec: Remove conditional revert of: gdb-6.6-buildid-locate-rpm-scl.patch