Update to 3.1.0

This commit is contained in:
Sandro Mani 2020-05-20 22:54:35 +02:00
parent 1118824b6a
commit fb4c3272a4
11 changed files with 83 additions and 88 deletions

2
.gitignore vendored
View File

@ -43,3 +43,5 @@ gdalautotest-1.7.0.tar.gz
/gdal-2.3.2-fedora.tar.xz
/gdalautotest-3.0.1.zip
/gdal-3.0.1-fedora.tar.xz
/gdal-3.1.0-fedora.tar.xz
/gdalautotest-3.1.0.tar.gz

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.0.4-fedora/swig/java/java.opt gdal-3.0.4-fedora-new/swig/java/java.opt
--- gdal-3.0.4-fedora/swig/java/java.opt 2020-01-28 11:13:12.000000000 +0100
+++ gdal-3.0.4-fedora-new/swig/java/java.opt 2020-02-06 00:23:36.321286290 +0100
diff -rupN --no-dereference gdal-3.1.0-fedora/swig/java/java.opt gdal-3.1.0-fedora-new/swig/java/java.opt
--- gdal-3.1.0-fedora/swig/java/java.opt 2020-05-04 11:18:28.000000000 +0200
+++ gdal-3.1.0-fedora-new/swig/java/java.opt 2020-05-18 11:28:48.479899529 +0200
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java

View File

@ -1,7 +1,7 @@
#!/bin/bash
VERSION="3.0.4"
VERSION="3.1.0"
tar xvf gdal-"${VERSION}".tar.xz
tar xvf gdal-"${VERSION}".tar.gz
mv gdal-"${VERSION}"{,-fedora} && pushd gdal-"${VERSION}"-fedora

View File

@ -1,12 +0,0 @@
diff -rupN --no-dereference gdal-3.0.4-fedora/scripts/GNUmakefile gdal-3.0.4-fedora-new/scripts/GNUmakefile
--- gdal-3.0.4-fedora/scripts/GNUmakefile 2020-01-28 11:13:13.000000000 +0100
+++ gdal-3.0.4-fedora-new/scripts/GNUmakefile 2020-02-06 00:23:36.089287463 +0100
@@ -5,6 +5,6 @@ completion:
install:
if test "x`pkg-config --version 2>/dev/null`" != "x" -a "x`pkg-config --variable=compatdir bash-completion`" != "x"; then \
- $(INSTALL_DIR) $(DESTDIR)${prefix}`pkg-config --variable=compatdir bash-completion` ; \
- cp gdal-bash-completion.sh $(DESTDIR)${prefix}`pkg-config --variable=compatdir bash-completion`; \
+ $(INSTALL_DIR) $(DESTDIR)`pkg-config --variable=compatdir bash-completion` ; \
+ $(INSTALL_DATA) gdal-bash-completion.sh $(DESTDIR)`pkg-config --variable=compatdir bash-completion`/gdal; \
fi

View File

@ -9,8 +9,8 @@
#TODO: Consider doxy patch from Suse, setting EXTRACT_LOCAL_CLASSES = NO
# Tests can be of a different version
%global testversion 3.0.4
%global run_tests 0
%global testversion 3.1.0
%global run_tests 1
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -45,8 +45,8 @@
%endif
Name: gdal
Version: 3.0.4
Release: 5%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Version: 3.1.0
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
License: MIT
URL: http://www.gdal.org
@ -61,16 +61,18 @@ Source3: %{name}-cleaner.sh
Source4: PROVENANCE.TXT-fedora
# Fix bash-completion install dir
Patch1: %{name}-completion.patch
# Fedora uses Alternatives for Java
Patch2: %{name}-1.9.0-java.patch
# Ensure rpc/types.h is found by dods driver (indirectly required by libdap/XDRUtils.h)
Patch3: gdal_tirpcinc.patch
# Use libtool to create libiso8211.a, otherwise broken static lib is created since object files are compiled through libtool
Patch4: gdal_iso8211.patch
# Don't pass -W to sphinx, it causes it to error out on warnings
Patch5: gdal_sphinx-warnings.patch
# Fix makefiles installing libtool wrappers instead of actual executables
Patch5: gdal_installapps.patch
Patch6: gdal_installapps.patch
# Don't refer to PDF manual which is not built
Patch7: gdal_nopdf.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -161,12 +163,9 @@ BuildRequires: xz-devel
BuildRequires: zlib-devel
BuildRequires: libtirpc-devel
%if 0%{?rhel} < 8
BuildRequires: /usr/bin/epstopdf
BuildRequires: /usr/bin/latex
BuildRequires: /usr/bin/dvips
BuildRequires: tex(newunicodechar.sty)
%endif
BuildRequires: python3-sphinx
BuildRequires: python3-sphinx_rtd_theme
BuildRequires: python3-breathe
# Run time dependency for gpsbabel driver
Requires: gpsbabel
@ -326,6 +325,9 @@ chmod 644 apps/gnmanalyse.cpp apps/gnmmanage.cpp
# Fix mandir
sed -i "s|^mandir=.*|mandir='\${prefix}/share/man'|" configure.ac
# Delete .doxygen_up_to_date, otherwise doxygen isn't run
rm -f doc/.doxygen_up_to_date
%build
# For future reference:
@ -335,9 +337,9 @@ autoreconf -ifv
%configure \
--with-autoload=%{_libdir}/%{name}plugins \
--datadir=%{_datadir}/%{name}/ \
--includedir=%{_includedir}/%{name}/ \
--prefix=%{_prefix} \
--with-bash-completion \
--with-armadillo \
--with-curl \
--with-cfitsio \
@ -381,15 +383,18 @@ autoreconf -ifv
--with-libkml
%make_build
make man
make docs
# Build some utilities, as requested in BZ #1271906
make -C ogr/ogrsf_frmts/s57 all
make -C frmts/iso8211 all
# Documentation
make man
make docs
# No complete java yet in EL8
%if 0%{?rhel} < 8
# Make Java module and documentation
pushd swig/java
make
@ -410,25 +415,6 @@ pushd swig/perl
%make_build
popd
# --------- Documentation ----------
# No useful documentation in swig
%global docdirs apps doc doc/br doc/ru ogr ogr/ogrsf_frmts frmts/gxf frmts/iso8211 frmts/pcidsk frmts/sdts frmts/vrt ogr/ogrsf_frmts/dgn/
for docdir in %{docdirs}; do
pushd $docdir
if [ ! -f Doxyfile ]; then
doxygen -g
else
doxygen -u
fi
if [ $docdir == "doc/ru" ]; then
sed -i -e 's|^OUTPUT_LANGUAGE|OUTPUT_LANGUAGE = Russian\n#OUTPUT_LANGUAGE |' Doxyfile
fi
rm -rf html
doxygen
popd
done
%install
pushd swig/python
@ -440,16 +426,20 @@ popd
%make_install install-man
# Drop gdal.pdf symlink, as we don't build the pdf documentation
rm doc/build/html/gdal.pdf
install -pm 755 ogr/ogrsf_frmts/s57/s57dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211createfromxml %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211view %{buildroot}%{_bindir}
# Rename for %%files doc below
mv frmts/iso8211/html frmts/iso8211/iso8211_html
# Directory for auto-loading plugins
mkdir -p %{buildroot}%{_libdir}/%{name}plugins
#TODO: Don't do that?
find %{buildroot}%{perl_vendorarch} -name "*.dox" -exec rm -rf '{}' \;
rm %{buildroot}%{perl_archlib}/perllocal.pod
%if %{without python} && %{without python3}
@ -479,21 +469,6 @@ mkdir -p %{buildroot}%{_javadocdir}/%{name}
cp -pr swig/java/java/org %{buildroot}%{_javadocdir}/%{name}
%endif
# Install refmans
for docdir in %{docdirs}; do
pushd $docdir
path=%{_builddir}/%{name}-%{version}-fedora/refman
mkdir -p $path/html/$docdir
cp -r html $path/html/$docdir
popd
done
# Install formats documentation
for dir in gdal_frmts ogrsf_frmts; do
mkdir -p $dir
find frmts -name "*.html" -exec install -p -m 644 '{}' $dir \;
done
#TODO: Header date lost during installation
# Install multilib cpl_config.h bz#430894
install -p -D -m 644 port/cpl_config.h %{buildroot}%{_includedir}/%{name}/cpl_config-%{cpuarch}.h
@ -546,7 +521,7 @@ chmod 755 %{buildroot}%{_bindir}/%{name}-config
#jni-libs and libgdal are also built static (*.a)
#.exists and .packlist stem from Perl
for junk in {*.a,*.la,*.bs,.exists,.packlist} ; do
find %{buildroot} -name "$junk" -exec rm -rf '{}' \;
find %{buildroot} -name "$junk" -delete
done
# Don't duplicate license files
@ -592,7 +567,6 @@ popd
%files
%{bashcompletiondir}/*
%{_bindir}/gdallocationinfo
%{_bindir}/gdal_contour
%{_bindir}/gdal_rasterize
@ -610,12 +584,16 @@ popd
%{_bindir}/gdalsrsinfo
%{_bindir}/gdaltransform
%{_bindir}/nearblack
%{_bindir}/gdal_viewshed
%{_bindir}/gdalmdiminfo
%{_bindir}/gdalmdimtranslate
%{_bindir}/ogr*
%{_bindir}/8211*
%{_bindir}/s57*
%{_bindir}/testepsg
%{_bindir}/gnmanalyse
%{_bindir}/gnmmanage
%{_datadir}/bash-completion/completions/*
%{_mandir}/man1/gdal*.1*
%exclude %{_mandir}/man1/gdal-config.1*
%exclude %{_mandir}/man1/gdal2tiles.1*
@ -630,8 +608,8 @@ popd
%files libs
%doc LICENSE.TXT NEWS PROVENANCE.TXT COMMITTERS PROVENANCE.TXT-fedora
%{_libdir}/libgdal.so.26
%{_libdir}/libgdal.so.26.*
%{_libdir}/libgdal.so.27
%{_libdir}/libgdal.so.27.*
%{_datadir}/%{name}
#TODO: Possibly remove files like .dxf, .dgn, ...
%dir %{_libdir}/%{name}plugins
@ -698,7 +676,7 @@ popd
%endif
%files doc
%doc gdal_frmts ogrsf_frmts refman
%doc doc/build/html frmts/iso8211/iso8211_html
#TODO: jvm
#Should be managed by the Alternatives system and not via ldconfig
@ -709,6 +687,9 @@ popd
#Or as before, using ldconfig
%changelog
* Tue May 12 2020 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
- Update to 3.1.0
* Sat May 09 2020 Markus Neteler <neteler@mundialis.de> - 3.0.4-5
* disabled JAVA and LaTeX support for EPEL8, due to (yet) missing dependencies

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference gdal-3.0.4-fedora/apps/GNUmakefile gdal-3.0.4-fedora-new/apps/GNUmakefile
--- gdal-3.0.4-fedora/apps/GNUmakefile 2020-01-28 11:13:12.000000000 +0100
+++ gdal-3.0.4-fedora-new/apps/GNUmakefile 2020-03-03 23:17:41.032487778 +0100
@@ -216,6 +216,7 @@ gdal-config-inst: gdal-config.in ../GDAL
diff -rupN --no-dereference gdal-3.1.0-fedora/apps/GNUmakefile gdal-3.1.0-fedora-new/apps/GNUmakefile
--- gdal-3.1.0-fedora/apps/GNUmakefile 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/apps/GNUmakefile 2020-05-18 11:28:49.293888148 +0200
@@ -233,6 +233,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default
for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done

View File

@ -1,6 +1,6 @@
diff -rupN gdal-3.0.4-fedora/frmts/iso8211/GNUmakefile gdal-3.0.4-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.0.4-fedora/frmts/iso8211/GNUmakefile 2020-01-28 11:13:11.000000000 +0100
+++ gdal-3.0.4-fedora-new/frmts/iso8211/GNUmakefile 2020-02-06 00:24:10.382117696 +0100
diff -rupN --no-dereference gdal-3.1.0-fedora/frmts/iso8211/GNUmakefile gdal-3.1.0-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.1.0-fedora/frmts/iso8211/GNUmakefile 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/frmts/iso8211/GNUmakefile 2020-05-18 11:28:48.892893749 +0200
@@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR)

12
gdal_nopdf.patch Normal file
View File

@ -0,0 +1,12 @@
diff -rupN gdal-3.1.0-fedora/doc/source/index.rst gdal-3.1.0-fedora-new/doc/source/index.rst
--- gdal-3.1.0-fedora/doc/source/index.rst 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/doc/source/index.rst 2020-05-20 18:56:54.508740758 +0200
@@ -9,8 +9,6 @@ GDAL
.. include:: ./about_no_title.rst
-This documentation is also available as a `PDF file <gdal.pdf>`_.
-
.. toctree::
:maxdepth: 2

View File

@ -0,0 +1,12 @@
diff -rupN --no-dereference gdal-3.1.0-fedora/doc/Makefile gdal-3.1.0-fedora-new/doc/Makefile
--- gdal-3.1.0-fedora/doc/Makefile 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/doc/Makefile 2020-05-18 11:28:49.090890982 +0200
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS = --keep-going -j auto -W
+SPHINXOPTS = --keep-going -j auto
SPHINXBUILD = sphinx-build
SOURCEDIR = source
BUILDDIR = build

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.0.4-fedora/frmts/dods/GNUmakefile gdal-3.0.4-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.0.4-fedora/frmts/dods/GNUmakefile 2020-01-28 11:13:11.000000000 +0100
+++ gdal-3.0.4-fedora-new/frmts/dods/GNUmakefile 2020-02-06 00:23:36.543285168 +0100
diff -rupN --no-dereference gdal-3.1.0-fedora/frmts/dods/GNUmakefile gdal-3.1.0-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.1.0-fedora/frmts/dods/GNUmakefile 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/frmts/dods/GNUmakefile 2020-05-18 11:28:48.686896632 +0200
@@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o
@ -10,9 +10,9 @@ diff -rupN --no-dereference gdal-3.0.4-fedora/frmts/dods/GNUmakefile gdal-3.0.4-
default: $(OBJ:.o=.$(OBJ_EXT))
diff -rupN --no-dereference gdal-3.0.4-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.0.4-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.0.4-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2020-01-28 11:13:11.000000000 +0100
+++ gdal-3.0.4-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2020-02-06 00:23:36.543285168 +0100
diff -rupN --no-dereference gdal-3.1.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.1.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.1.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2020-05-04 11:18:27.000000000 +0200
+++ gdal-3.1.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2020-05-18 11:28:48.687896618 +0200
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o

View File

@ -1,2 +1,2 @@
SHA512 (gdal-3.0.4-fedora.tar.xz) = f880a763cbf3e846789df4c45a68be11121fdc66252dab126d95b79141589435ef7712ed0efcb7d633643f2c82cde88f9663bb15b624e69f362ed2e10a79a110
SHA512 (gdalautotest-3.0.4.tar.gz) = d205c6eba1c68ade3cd55b9ae77c9a885f1ff87f6964ea4e71799bc98393ddcf92081a5319afd3d0d9d0cf8862d140eb59ad2ccf7e70a955cad2732f55c28e72
SHA512 (gdal-3.1.0-fedora.tar.xz) = 8a0c20c39d213c3d8fdf807769c1d376fbdc5a73a215173dd5695e77a356d0788fe61a7722ba7228b74211d7c5466d82b69254b1c279a39037bafb2cde2c8c7f
SHA512 (gdalautotest-3.1.0.tar.gz) = 0b5c4ee4dba19c1c6f12689d72f91f24bf6b435adccfaaa10e56b9953148aee301c698e62b460335db1406b52fe0fa0e51960f100f3032e600e7531d334b730d