Rebuild (jasper)

This commit is contained in:
Sandro Mani 2020-10-16 21:53:03 +02:00
parent 8107c2c0ef
commit f465375f88
8 changed files with 49 additions and 19 deletions

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/swig/java/java.opt gdal-3.1.3-fedora-new/swig/java/java.opt
--- gdal-3.1.3-fedora/swig/java/java.opt 2020-09-01 10:36:31.000000000 +0200
+++ gdal-3.1.3-fedora-new/swig/java/java.opt 2020-09-07 14:41:31.736573017 +0200
+++ gdal-3.1.3-fedora-new/swig/java/java.opt 2020-10-16 21:26:30.860885421 +0200
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java

View File

@ -46,7 +46,7 @@
Name: gdal
Version: 3.1.3
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Release: 2%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
License: MIT
URL: http://www.gdal.org
@ -74,7 +74,8 @@ Patch5: gdal_sphinx.patch
Patch6: gdal_installapps.patch
# Don't refer to PDF manual which is not built
Patch7: gdal_nopdf.patch
# Adapt to jasper 2.0.17
# Adapt to jasper 2.0.21
# See https://github.com/OSGeo/gdal/commit/9ef8e16e27c5fc4c491debe50bf2b7f3e94ed334
Patch8: gdal_jasper.patch
@ -691,6 +692,9 @@ popd
#Or as before, using ldconfig
%changelog
* Fri Oct 16 21:25:24 CEST 2020 Sandro Mani <manisandro@gmail.com> - 3.1.3-2
- Rebuild (jasper)
* Mon Sep 07 2020 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
- Update to 3.1.3

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/apps/GNUmakefile gdal-3.1.3-fedora-new/apps/GNUmakefile
--- gdal-3.1.3-fedora/apps/GNUmakefile 2020-09-01 10:36:31.000000000 +0200
+++ gdal-3.1.3-fedora-new/apps/GNUmakefile 2020-09-07 14:41:33.244545332 +0200
+++ gdal-3.1.3-fedora-new/apps/GNUmakefile 2020-10-16 21:26:31.671884275 +0200
@@ -233,6 +233,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/frmts/iso8211/GNUmakefile gdal-3.1.3-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.1.3-fedora/frmts/iso8211/GNUmakefile 2020-09-01 10:36:30.000000000 +0200
+++ gdal-3.1.3-fedora-new/frmts/iso8211/GNUmakefile 2020-09-07 14:41:32.513558759 +0200
+++ gdal-3.1.3-fedora-new/frmts/iso8211/GNUmakefile 2020-10-16 21:26:31.274884836 +0200
@@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR)

View File

@ -1,21 +1,47 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/frmts/jpeg2000/jpeg2000dataset.cpp gdal-3.1.3-fedora-new/frmts/jpeg2000/jpeg2000dataset.cpp
--- gdal-3.1.3-fedora/frmts/jpeg2000/jpeg2000dataset.cpp 2020-09-01 10:39:25.000000000 +0200
+++ gdal-3.1.3-fedora-new/frmts/jpeg2000/jpeg2000dataset.cpp 2020-10-16 21:26:32.069883712 +0200
@@ -513,7 +513,7 @@ int JPEG2000Dataset::DecodeImage()
for ( iBand = 0; iBand < nBands; iBand++ )
{
JPEG2000RasterBand* poBand = (JPEG2000RasterBand*) GetRasterBand(iBand+1);
- if (poBand->iDepth != jas_image_cmptprec( psImage, iBand ) ||
+ if (poBand->iDepth != static_cast<int>(jas_image_cmptprec( psImage, iBand )) ||
poBand->bSignedness != jas_image_cmptsgnd( psImage, iBand ))
{
CPLError(CE_Failure, CPLE_AppDefined,
diff -rupN --no-dereference gdal-3.1.3-fedora/frmts/jpeg2000/jpeg2000_vsil_io.cpp gdal-3.1.3-fedora-new/frmts/jpeg2000/jpeg2000_vsil_io.cpp
--- gdal-3.1.3-fedora/frmts/jpeg2000/jpeg2000_vsil_io.cpp 2020-09-01 10:39:25.000000000 +0200
+++ gdal-3.1.3-fedora-new/frmts/jpeg2000/jpeg2000_vsil_io.cpp 2020-09-07 14:41:33.957532225 +0200
@@ -96,7 +96,7 @@ typedef struct {
+++ gdal-3.1.3-fedora-new/frmts/jpeg2000/jpeg2000_vsil_io.cpp 2020-10-16 21:26:32.069883712 +0200
@@ -94,22 +94,24 @@ typedef struct {
* File stream object.
\******************************************************************************/
+#if defined(PRIjas_seqent)
// PRIjas_seqent macro is defined since Jasper 2.0.17
-
-#ifndef PRIjas_seqent
+#if 0
static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, int cnt)
#else
-static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, int cnt)
-#else
static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, unsigned cnt)
@@ -106,7 +106,7 @@ static int JPEG2000_VSIL_read(jas_stream
+#else
+static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, char *buf, int cnt)
#endif
{
jas_stream_VSIFL_t *fileobj = JAS_CAST(jas_stream_VSIFL_t *, obj);
return static_cast<int>(VSIFReadL(buf, 1, cnt, fileobj->fp));
}
-#ifndef PRIjas_seqent
+#if 0
static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, int cnt)
#else
-static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, int cnt)
-#else
+#if defined(JAS_INCLUDE_JP2_CODEC)
+// Jasper 2.0.21
+static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, const char *buf, unsigned int cnt)
+#elif defined(PRIjas_seqent)
static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, unsigned int cnt)
+#else
+static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, int cnt)
#endif
{
jas_stream_VSIFL_t *fileobj = JAS_CAST(jas_stream_VSIFL_t *, obj);

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/doc/source/index.rst gdal-3.1.3-fedora-new/doc/source/index.rst
--- gdal-3.1.3-fedora/doc/source/index.rst 2020-09-01 10:36:31.000000000 +0200
+++ gdal-3.1.3-fedora-new/doc/source/index.rst 2020-09-07 14:41:33.605538696 +0200
+++ gdal-3.1.3-fedora-new/doc/source/index.rst 2020-10-16 21:26:31.871883992 +0200
@@ -9,8 +9,6 @@ GDAL
.. include:: ./about_no_title.rst

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/doc/Makefile gdal-3.1.3-fedora-new/doc/Makefile
--- gdal-3.1.3-fedora/doc/Makefile 2020-09-01 10:36:30.000000000 +0200
+++ gdal-3.1.3-fedora-new/doc/Makefile 2020-09-07 14:41:32.887551892 +0200
+++ gdal-3.1.3-fedora-new/doc/Makefile 2020-10-16 21:26:31.476884551 +0200
@@ -2,7 +2,7 @@
#

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.1.3-fedora/frmts/dods/GNUmakefile gdal-3.1.3-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.1.3-fedora/frmts/dods/GNUmakefile 2020-09-01 10:36:30.000000000 +0200
+++ gdal-3.1.3-fedora-new/frmts/dods/GNUmakefile 2020-09-07 14:41:32.127565845 +0200
+++ gdal-3.1.3-fedora-new/frmts/dods/GNUmakefile 2020-10-16 21:26:31.068885127 +0200
@@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o
@ -12,7 +12,7 @@ diff -rupN --no-dereference gdal-3.1.3-fedora/frmts/dods/GNUmakefile gdal-3.1.3-
diff -rupN --no-dereference gdal-3.1.3-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.1.3-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.1.3-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2020-09-01 10:36:31.000000000 +0200
+++ gdal-3.1.3-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2020-09-07 14:41:32.127565845 +0200
+++ gdal-3.1.3-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2020-10-16 21:26:31.068885127 +0200
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o