UPDATE TO NEW VERSION 1.9

- Major overhaul of the spec file
This commit is contained in:
Volker Fröhlich 2012-02-26 09:55:08 +01:00
parent d3337568fa
commit eb72ef7c3e
12 changed files with 554 additions and 644 deletions

2
.gitignore vendored
View File

@ -2,3 +2,5 @@ gdal-1.7.2-fedora.tar.gz
gdalautotest-1.7.0.tar.gz
/gdal-1.7.3-fedora.tar.gz
/gdalautotest-1.7.3.tar.gz
/gdal-1.9.0-fedora.tar.gz
/gdalautotest-1.9.0.tar.gz

View File

@ -1,39 +0,0 @@
diff -Nur gdal-1.7.3-fedora/frmts/png/pngdataset.cpp gdal-1.7.3-fedora-png15/frmts/png/pngdataset.cpp
--- gdal-1.7.3-fedora/frmts/png/pngdataset.cpp 2010-11-07 23:58:47.000000000 +0530
+++ gdal-1.7.3-fedora-png15/frmts/png/pngdataset.cpp 2012-01-10 14:50:25.384124887 +0530
@@ -1296,7 +1296,7 @@
* instead of an int, which is what fread() actually returns.
*/
check = (png_size_t)VSIFReadL(data, (png_size_t)1, length,
- (png_FILE_p)png_ptr->io_ptr);
+ (png_FILE_p)png_get_io_ptr(png_ptr));
if (check != length)
png_error(png_ptr, "Read Error");
@@ -1311,7 +1311,7 @@
{
png_uint_32 check;
- check = VSIFWriteL(data, 1, length, (png_FILE_p)(png_ptr->io_ptr));
+ check = VSIFWriteL(data, 1, length, (png_FILE_p)png_get_io_ptr(png_ptr));
if (check != length)
png_error(png_ptr, "Write Error");
@@ -1322,7 +1322,7 @@
/************************************************************************/
static void png_vsi_flush(png_structp png_ptr)
{
- VSIFFlushL( (png_FILE_p)(png_ptr->io_ptr) );
+ VSIFFlushL( (png_FILE_p)png_get_io_ptr(png_ptr) );
}
/************************************************************************/
@@ -1338,7 +1338,7 @@
// libpng is generally not built as C++ and so won't honour unwind
// semantics. Ugg.
- jmp_buf* psSetJmpContext = (jmp_buf*) png_ptr->error_ptr;
+ jmp_buf* psSetJmpContext = (jmp_buf*) png_get_error_ptr(png_ptr);
if (psSetJmpContext)
{
longjmp( *psSetJmpContext, 1 );

View File

@ -1,13 +0,0 @@
diff -up gdal-1.7.3-fedora/ltmain.sh.xcompiler gdal-1.7.3-fedora/ltmain.sh
diff -up gdal-1.7.3-fedora/swig/ruby/RubyMakefile.mk.xcompiler gdal-1.7.3-fedora/swig/ruby/RubyMakefile.mk
--- gdal-1.7.3-fedora/swig/ruby/RubyMakefile.mk.xcompiler 2011-03-15 23:55:58.000000000 +0100
+++ gdal-1.7.3-fedora/swig/ruby/RubyMakefile.mk 2011-03-15 23:56:11.000000000 +0100
@@ -25,7 +25,7 @@ RUBY_EXTENSIONS_DIR := $(shell ruby -rrb
INSTALL_DIR := $(RUBY_EXTENSIONS_DIR)/gdal
RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR)
-LDFLAGS += -Xcompiler -shared -L$(RUBY_LIB_DIR)
+LDFLAGS += -shared -L$(RUBY_LIB_DIR)
RUBY_LIB := -l$(RUBY_SO_NAME)
build: $(RUBY_MODULES)

View File

@ -1,81 +0,0 @@
Index: /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_middatafile.cpp
===================================================================
--- /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_middatafile.cpp (revision 20796)
+++ /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_middatafile.cpp (revision 20818)
@@ -212,4 +212,8 @@
else
{
+ // skip leading spaces
+ while(pszLine && (*pszLine == ' ' || *pszLine == '\t') )
+ pszLine++;
+
strncpy(m_szLastRead,pszLine,MIDMAXCHAR);
}
Index: /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_miffile.cpp
===================================================================
--- /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_miffile.cpp (revision 20797)
+++ /trunk/gdal/ogr/ogrsf_frmts/mitab/mitab_miffile.cpp (revision 20818)
@@ -471,5 +471,5 @@
int MIFFile::ParseMIFHeader()
{
- GBool bColumns = FALSE, bDataFound = FALSE;
+ GBool bColumns = FALSE, bAllColumnsRead = FALSE;
int nColumns = 0;
GBool bCoordSys = FALSE;
@@ -498,15 +498,7 @@
* Parse header until we find the "Data" line
*----------------------------------------------------------------*/
- while (((pszLine = m_poMIFFile->GetLine()) != NULL))
- {
- while(pszLine && (*pszLine == ' ' || *pszLine == '\t') )
- pszLine++; // skip leading spaces
-
- if( EQUALN(pszLine,"Data",4) && !bColumns )
- {
- bDataFound = TRUE;
- break;
- }
-
+ while (((pszLine = m_poMIFFile->GetLine()) != NULL) &&
+ ((bAllColumnsRead == FALSE) || !EQUALN(pszLine,"Data",4)))
+ {
if (bColumns == TRUE && nColumns >0)
{
@@ -514,6 +506,9 @@
{
nColumns--;
- if (nColumns == 0)
+ if (nColumns == 0)
+ {
+ bAllColumnsRead = TRUE;
bColumns = FALSE;
+ }
}
else
@@ -618,4 +613,10 @@
nColumns = atoi(papszToken[1]);
m_nAttribut = nColumns;
+ if (nColumns == 0)
+ {
+ // Permit to 0 columns
+ bAllColumnsRead = TRUE;
+ bColumns = FALSE;
+ }
}
else
@@ -638,5 +639,14 @@
}
- if ( !bDataFound )
+ if (!bAllColumnsRead)
+ {
+ CPLError(CE_Failure, CPLE_NotSupported,
+ "COLUMNS keyword not found or invalid number of columns read in %s. File may be corrupt.",
+ m_pszFname);
+ return -1;
+ }
+
+ if ((pszLine = m_poMIFFile->GetLastLine()) == NULL ||
+ EQUALN(m_poMIFFile->GetLastLine(),"DATA",4) == FALSE)
{
CPLError(CE_Failure, CPLE_NotSupported,

11
gdal-1.9.0-java.patch Normal file
View File

@ -0,0 +1,11 @@
diff -Nur gdal-1.9.0-fedora/swig/java/java.opt gdal-1.9.0-fedora-java/swig/java/java.opt
--- gdal-1.9.0-fedora/swig/java/java.opt 2012-01-04 08:03:40.000000000 +0100
+++ gdal-1.9.0-fedora-java/swig/java/java.opt 2012-02-03 08:44:55.837978697 +0100
@@ -5,6 +5,6 @@
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java
JAR=$(JAVA_HOME)/bin/jar
-JAVA_INCLUDE=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+JAVA_INCLUDE=-I/usr/lib/jvm/java/include/ -I/usr/lib/jvm/java/include/linux

11
gdal-1.9.0-man.patch Normal file
View File

@ -0,0 +1,11 @@
diff -Nur gdal-1.9.0-fedora/GNUmakefile gdal-1.9.0-fedora-man/GNUmakefile
--- gdal-1.9.0-fedora/GNUmakefile 2012-01-04 08:03:42.000000000 +0100
+++ gdal-1.9.0-fedora-man/GNUmakefile 2012-02-22 17:29:07.565112215 +0100
@@ -129,6 +129,7 @@
cp frmts/wms/frmt_wms_*.xml html
cp frmts/wms/frmt_twms_*.xml html
+.PHONY: man
man:
# Generate man pages
(cat Doxyfile ; echo "ENABLED_SECTIONS=man"; echo "INPUT=apps swig/python/scripts"; echo "FILE_PATTERNS=*.cpp *.dox"; echo "GENERATE_HTML=NO"; echo "GENERATE_MAN=YES") | doxygen -

View File

@ -1,120 +0,0 @@
diff -up gdal-1.7.3-fedora/frmts/dods/dodsdataset2.cpp.AIS gdal-1.7.3-fedora/frmts/dods/dodsdataset2.cpp
--- gdal-1.7.3-fedora/frmts/dods/dodsdataset2.cpp.AIS 2010-04-23 17:21:55.000000000 -0600
+++ gdal-1.7.3-fedora/frmts/dods/dodsdataset2.cpp 2010-07-15 11:32:41.144005186 -0600
@@ -50,7 +50,7 @@
#include <Sequence.h>
#include <Grid.h>
-#include <AISConnect.h>
+#include <Connect.h>
#include <DDS.h>
#include <DAS.h>
#include <BaseTypeFactory.h>
@@ -203,7 +203,7 @@ static int GetDimension( string oCE, con
class DODSDataset : public GDALDataset
{
private:
- AISConnect *poConnect; //< Virtual connection to the data source
+ Connect *poConnect; //< Virtual connection to the data source
string oURL; //< data source URL
double adfGeoTransform[6];
@@ -214,7 +214,7 @@ private:
DDS *poDDS;
BaseTypeFactory *poBaseTypeFactory;
- AISConnect *connect_to_server() throw(Error);
+ Connect *connect_to_server() throw(Error);
static string SubConstraint( string raw_constraint,
string x_constraint,
@@ -242,7 +242,7 @@ public:
static GDALDataset *Open(GDALOpenInfo *);
/// Return the connection object
- AISConnect *GetConnect() { return poConnect; }
+ Connect *GetConnect() { return poConnect; }
/// Return the data source URL
string GetUrl() { return oURL; }
@@ -339,7 +339,7 @@ DODSDataset::~DODSDataset()
/* connect_to_server() */
/************************************************************************/
-AISConnect *
+Connect *
DODSDataset::connect_to_server() throw(Error)
{
// does the string start with 'http?'
@@ -375,7 +375,7 @@ DODSDataset::connect_to_server() throw(E
/* -------------------------------------------------------------------- */
/* Connect, and fetch version information. */
/* -------------------------------------------------------------------- */
- AISConnect *poConnection = new AISConnect(oURL);
+ Connect *poConnection = new Connect(oURL);
string version = poConnection->request_version();
/* if (version.empty() || version.find("/3.") == string::npos)
{
@@ -997,7 +997,7 @@ DODSDataset::Open(GDALOpenInfo *poOpenIn
}
/* -------------------------------------------------------------------- */
-/* Get the AISConnect instance and the DAS and DDS for this */
+/* Get the Connect instance and the DAS and DDS for this */
/* server. */
/* -------------------------------------------------------------------- */
poDS->poConnect = poDS->connect_to_server();
diff -up gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp.AIS gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp
--- gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp.AIS 2010-04-23 17:21:25.000000000 -0600
+++ gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp 2010-07-15 11:31:33.814943203 -0600
@@ -150,7 +150,7 @@ int OGRDODSDataSource::Open( const char
try
{
- poConnection = new AISConnect( oBaseURL );
+ poConnection = new Connect( oBaseURL );
version = poConnection->request_version();
}
catch (Error &e)
diff -up gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogr_dods.h.AIS gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogr_dods.h
--- gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogr_dods.h.AIS 2010-04-23 17:21:25.000000000 -0600
+++ gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogr_dods.h 2010-07-15 11:31:52.649942228 -0600
@@ -61,7 +61,7 @@
#include <Sequence.h>
#include <Grid.h>
-#include <AISConnect.h>
+#include <Connect.h>
#include <DDS.h>
#include <DAS.h>
#include <BaseTypeFactory.h>
@@ -122,7 +122,7 @@ class OGRDODSLayer : public OGRLayer
virtual int ProvideDataDDS();
int bDataLoaded;
- AISConnect *poConnection;
+ Connect *poConnection;
DataDDS *poDataDDS;
BaseType *poTargetVar;
@@ -300,7 +300,7 @@ class OGRDODSDataSource : public OGRData
void AddLayer( OGRDODSLayer * );
public: // Just intended for read access by layer classes.
- AISConnect *poConnection;
+ Connect *poConnection;
DAS oDAS;
DDS *poDDS;
diff -up gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp.AIS gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp
--- gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp.AIS 2010-04-23 17:21:25.000000000 -0600
+++ gdal-1.7.3-fedora/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp 2010-07-15 11:32:06.467945352 -0600
@@ -213,7 +213,7 @@ int OGRDODSLayer::ProvideDataDDS()
bDataLoaded = TRUE;
try
{
- poConnection = new AISConnect( poDS->oBaseURL );
+ poConnection = new Connect( poDS->oBaseURL );
CPLDebug( "DODS", "request_data(%s,%s)",
poDS->oBaseURL.c_str(),
(poDS->oProjection + poDS->oConstraints).c_str() );

View File

@ -1,15 +0,0 @@
Create /usr/bin before attempting to compy anything there.
Lubomir Rintel <lkundrak@v3.sk>
diff -up gdal-1.7.3-fedora/swig/python/GNUmakefile.bindir gdal-1.7.3-fedora/swig/python/GNUmakefile
--- gdal-1.7.3-fedora/swig/python/GNUmakefile.bindir 2009-03-22 23:25:47.582438890 +0100
+++ gdal-1.7.3-fedora/swig/python/GNUmakefile 2009-03-22 23:26:10.465436318 +0100
@@ -60,6 +60,7 @@ else
$(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
endif
+ $(INSTALL_DIR) $(DESTDIR)$(INST_BIN)
for f in $(SCRIPTS) ; do $(INSTALL) ./scripts/$$f $(DESTDIR)$(INST_BIN) ; done
docs:

View File

@ -1,20 +0,0 @@
--- ogr/ogrsf_frmts/mysql/ogr_mysql.h.orig 2008-10-23 03:04:33.000000000 +0300
+++ ogr/ogrsf_frmts/mysql/ogr_mysql.h 2009-02-02 22:47:05.000000000 +0200
@@ -31,6 +31,8 @@
#ifndef _OGR_MYSQL_H_INCLUDED
#define _OGR_MYSQL_H_INCLUDED
+#include "ogrsf_frmts.h"
+
#include <my_global.h>
#include <mysql.h>
@@ -38,8 +40,6 @@
#undef bool
#endif
-#include "ogrsf_frmts.h"
-
/************************************************************************/
/* OGRMySQLLayer */
/************************************************************************/

View File

@ -2,5 +2,5 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.gdal</groupId>
<artifactId>gdal-java-bindings</artifactId>
<version>1.7.3</version>
<version></version>
</project>

880
gdal.spec

File diff suppressed because it is too large Load Diff

View File

@ -1,2 +1,2 @@
c2bf1c67ff6db27e2238c6c3d5feac29 gdal-1.7.3-fedora.tar.gz
0b12bd95c7fb78a6f33a922c24d1b40d gdalautotest-1.7.3.tar.gz
dd3e2da0d7a2915ded972cbdd76f0b10 gdal-1.9.0-fedora.tar.gz
0d1e425b45465f64f6d1f32790d8bea0 gdalautotest-1.9.0.tar.gz