Merge branch 'f22' into f21

Conflicts:
	gdal.spec
This commit is contained in:
Volker Froehlich 2015-10-22 00:39:51 +02:00
commit a2143d8c69
5 changed files with 49 additions and 10 deletions

2
.gitignore vendored
View File

@ -15,3 +15,5 @@ gdalautotest-1.7.0.tar.gz
/gdalautotest-1.11.1.tar.gz
/gdalautotest-1.11.2.tar.gz
/gdal-1.11.2-fedora.tar.xz
/gdalautotest-1.11.3.tar.gz
/gdal-1.11.3-fedora.tar.xz

View File

@ -0,0 +1,11 @@
diff -Nur gdal-2.0.1-fedora/frmts/iso8211/8211createfromxml.cpp gdal-2.0.1-fedora-iso8211/frmts/iso8211/8211createfromxml.cpp
--- gdal-2.0.1-fedora/frmts/iso8211/8211createfromxml.cpp 2015-09-15 16:06:51.000000000 +0200
+++ gdal-2.0.1-fedora-iso8211/frmts/iso8211/8211createfromxml.cpp 2015-10-18 03:04:21.812446373 +0200
@@ -28,6 +28,7 @@
****************************************************************************/
#include "cpl_minixml.h"
+#include "cpl_conv.h"
#include "iso8211.h"
#include <map>
#include <string>

View File

@ -1,6 +1,6 @@
#!/bin/bash
# Volker Fröhlich
VERSION="1.11.2"
VERSION="1.11.3"
tar xvf gdal-"${VERSION}".tar.xz

View File

@ -18,12 +18,11 @@
# Sadly noarch doesn't work in EL 5, see
# http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies
#TODO: EvenR suggested to drop Ruby bindings, as they are unmaintained
# He also suggest to use --with-static-proj4 to actually link to proj, instead of dlopen()ing it.
# Tests can be of a different version
%global testversion 1.11.2
%global testversion 1.11.3
%global run_tests 1
%global with_spatialite 1
@ -40,13 +39,13 @@
Name: gdal
Version: 1.11.2
Release: 4%{?dist}
Version: 1.11.3
Release: 1%{?dist}
Summary: GIS file format library
Group: System Environment/Libraries
License: MIT
URL: http://www.gdal.org
# Source0: http://download.osgeo.org/gdal/gdal-%%{version}.tar.gz
# Source0: http://download.osgeo.org/gdal/%%{version}/gdal-%%{version}.tar.xz
# See PROVENANCE.TXT-fedora and the cleaner script for details!
Source0: %{name}-%{version}-fedora.tar.xz
@ -63,6 +62,9 @@ Patch1: %{name}-g2clib.patch
# Patch for Fedora JNI library location
Patch2: %{name}-jni.patch
# https://trac.osgeo.org/gdal/ticket/6159#ticket
Patch3: %{name}-2.0.1-iso8211-include.patch
# Fedora uses Alternatives for Java
Patch8: %{name}-1.9.0-java.patch
@ -113,6 +115,7 @@ BuildRequires: mysql-devel
BuildRequires: numpy
BuildRequires: pcre-devel
BuildRequires: ogdi-devel
BuildRequires: openjpeg2-devel
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: pkgconfig
BuildRequires: poppler-devel
@ -265,6 +268,7 @@ rm -r frmts/grib/degrib18/g2clib-1.0.4
%patch1 -p1 -b .g2clib~
%patch2 -p1 -b .jni~
%patch3 -p1 -b .iso8211~
%patch8 -p1 -b .java~
# Copy in PROVENANCE.TXT-fedora
@ -372,7 +376,6 @@ export CPPFLAGS="$CPPFLAGS -I%{_includedir}/libgeotiff"
# For future reference:
# epsilon: Stalled review -- https://bugzilla.redhat.com/show_bug.cgi?id=660024
# openjpeg 2.0 necessary, 1.4 is in Fedora
# Building without pgeo driver, because it drags in Java
%configure \
@ -407,7 +410,7 @@ export CPPFLAGS="$CPPFLAGS -I%{_includedir}/libgeotiff"
--with-odbc \
--with-ogdi \
--without-msg \
--without-openjpeg \
--with-openjpeg \
--with-pcraster \
--with-pg \
--with-png \
@ -434,6 +437,15 @@ pushd swig/perl
echo > Makefile.PL;
popd
# Build some utilities, as requested in BZ #1271906
pushd ogr/ogrsf_frmts/s57/
make all
popd
pushd frmts/iso8211/
make all
popd
# Install the Perl modules in the right place
sed -i 's|INSTALLDIRS = site|INSTALLDIRS = vendor|' swig/perl/Makefile_*
@ -488,6 +500,11 @@ make DESTDIR=%{buildroot} \
install \
install-man
install -pm 755 ogr/ogrsf_frmts/s57/s57dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211createfromxml %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211view %{buildroot}%{_bindir}
# Directory for auto-loading plugins
mkdir -p %{buildroot}%{_libdir}/%{name}plugins
@ -695,6 +712,8 @@ popd
%{_bindir}/gdaltransform
%{_bindir}/nearblack
%{_bindir}/ogr*
%{_bindir}/8211*
%{_bindir}/s57*
%{_bindir}/testepsg
%{_mandir}/man1/gdal*.1*
%exclude %{_mandir}/man1/gdal-config.1*
@ -764,6 +783,13 @@ popd
#Or as before, using ldconfig
%changelog
* Wed Oct 21 2015 Volker Froehlich <volker27@gmx.at> - 1.11.3-1
- New release
* Wed Oct 21 2015 Volker Froehlich <volker27@gmx.at> - 1.11.2-5
- Solve BZ #1271906 (Build iso8211 and s57 utilities)
- Support openjpeg2
* Wed Jul 8 2015 José Matos <jamatos@fedoraproject.org> - 1.11.2-4
- Rebuild for armadillo 5(.xxx.y)

View File

@ -1,2 +1,2 @@
f639373d0709858d41997c708ca80c52 gdal-1.11.2-fedora.tar.xz
3d4cb6361005312dc86016b0b7eb57a4 gdalautotest-1.11.2.tar.gz
2b6ba83e78a3ce5ffbed8f14ddd0029a gdalautotest-1.11.3.tar.gz
b07d7f7d1c0032fb8207df477644534a gdal-1.11.3-fedora.tar.xz