- new bugfix release from upstream
- drop large parts from gcc43 patch, some are upstream now - fix building with perl-5.10 swig binding issue Modified Files: devel/.cvsignore devel/gdal-gcc43.patch devel/gdal.spec devel/sources Added Files: devel/gdal-perl510.patch
This commit is contained in:
parent
a17b25d31c
commit
965ccce49a
@ -1,2 +1,2 @@
|
|||||||
gdal-1.5.0-fedora.tar.gz
|
|
||||||
gdalautotest-1.5.0.tar.gz
|
gdalautotest-1.5.0.tar.gz
|
||||||
|
gdal-1.5.1-fedora.tar.gz
|
||||||
|
@ -1,56 +1,3 @@
|
|||||||
--- frmts/ilwis/ilwisdataset.cpp.orig
|
|
||||||
+++ frmts/ilwis/ilwisdataset.cpp
|
|
||||||
@@ -407,5 +407,4 @@
|
|
||||||
{
|
|
||||||
string st = ReadElement("MapStore", "Type", pszFileName.c_str());
|
|
||||||
- transform(st.begin(), st.end(), st.begin(), tolower);
|
|
||||||
|
|
||||||
if( EQUAL(st.c_str(),"byte"))
|
|
||||||
@@ -482,6 +481,4 @@
|
|
||||||
else
|
|
||||||
georef = ReadElement("MapList", "GeoRef", osFileName);
|
|
||||||
-
|
|
||||||
- transform(georef.begin(), georef.end(), georef.begin(), tolower);
|
|
||||||
|
|
||||||
//Capture the geotransform, only if the georef is not 'none',
|
|
||||||
@@ -789,7 +786,6 @@
|
|
||||||
// Fetch coordinate system
|
|
||||||
string csy = ReadElement("GeoRef", "CoordSystem", pszGeoRef);
|
|
||||||
- transform(csy.begin(), csy.end(), csy.begin(), tolower);
|
|
||||||
-
|
|
||||||
string pszProj;
|
|
||||||
+
|
|
||||||
if( (csy.length() != 0) && !EQUAL(csy.c_str(),"unknown.csy"))
|
|
||||||
{
|
|
||||||
@@ -797,5 +793,5 @@
|
|
||||||
//Form the coordinate system file name
|
|
||||||
if( !(EQUALN( csy.c_str(), "latlon.csy", 10 )) &&
|
|
||||||
- !(EQUALN( csy.c_str(), "LatlonWGS84.csy", 15 )))
|
|
||||||
+ !(EQUALN( csy.c_str(), "LatlonWGS84.csy", 15 )))
|
|
||||||
{
|
|
||||||
string pszBaseName = string(CPLGetBasename(csy.c_str()) );
|
|
||||||
@@ -1319,5 +1315,4 @@
|
|
||||||
string domName = ReadElement("BaseMap", "Domain", pszFileName.c_str());
|
|
||||||
string pszBaseName = string(CPLGetBasename( domName.c_str() ));
|
|
||||||
- transform(pszBaseName.begin(), pszBaseName.end(), pszBaseName.begin(), tolower);
|
|
||||||
string pszPath = string(CPLGetPath( pszFileName.c_str() ));
|
|
||||||
|
|
||||||
@@ -1371,5 +1366,4 @@
|
|
||||||
|
|
||||||
string domType = ReadElement("Domain", "Type", pszDomainName.c_str());
|
|
||||||
- transform(domType.begin(), domType.end(), domType.begin(), tolower);
|
|
||||||
if EQUAL(domType.c_str(),"domainvalue")
|
|
||||||
{
|
|
||||||
--- frmts/idrisi/IdrisiDataset.cpp.orig 2008-02-13 22:21:36.000000000 +0200
|
|
||||||
+++ frmts/idrisi/IdrisiDataset.cpp 2008-02-13 22:22:27.000000000 +0200
|
|
||||||
@@ -35,6 +35,7 @@
|
|
||||||
#include "gdal_pam.h"
|
|
||||||
#include "gdal_rat.h"
|
|
||||||
#include "gdal_alg.h"
|
|
||||||
+#include <climits>
|
|
||||||
|
|
||||||
CPL_CVSID( "$Id: IdrisiDataset.cpp 12896 2007-11-20 21:01:46Z rouault $" );
|
|
||||||
|
|
||||||
--- ogr/ogrsf_frmts/geojson/ogrgeojsonlayer.cpp.orig 2008-02-14 02:43:16.000000000 +0200
|
--- ogr/ogrsf_frmts/geojson/ogrgeojsonlayer.cpp.orig 2008-02-14 02:43:16.000000000 +0200
|
||||||
+++ ogr/ogrsf_frmts/geojson/ogrgeojsonlayer.cpp 2008-02-14 13:21:22.000000000 +0200
|
+++ ogr/ogrsf_frmts/geojson/ogrgeojsonlayer.cpp 2008-02-14 13:21:22.000000000 +0200
|
||||||
@@ -26,10 +26,11 @@
|
@@ -26,10 +26,11 @@
|
||||||
|
45
gdal-perl510.patch
Normal file
45
gdal-perl510.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
--- swig/perl/gdal_wrap.cpp.orig 2008-03-25 20:19:03.000000000 +0200
|
||||||
|
+++ swig/perl/gdal_wrap.cpp 2008-03-25 20:19:52.000000000 +0200
|
||||||
|
@@ -1228,8 +1228,11 @@
|
||||||
|
/* Macros for low-level exception handling */
|
||||||
|
#define SWIG_croak(x) { SWIG_Error(SWIG_RuntimeError, x); SWIG_fail; }
|
||||||
|
|
||||||
|
+#ifndef XSPROTO
|
||||||
|
+# define XSPROTO(name) void name(pTHX_ CV* cv)
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
-typedef XS(SwigPerlWrapper);
|
||||||
|
+typedef XSPROTO(SwigPerlWrapper);
|
||||||
|
typedef SwigPerlWrapper *SwigPerlWrapperPtr;
|
||||||
|
|
||||||
|
/* Structure for command table */
|
||||||
|
--- swig/perl/ogr_wrap.cpp.orig 2008-03-25 20:45:42.000000000 +0200
|
||||||
|
+++ swig/perl/ogr_wrap.cpp 2008-03-25 20:48:00.000000000 +0200
|
||||||
|
@@ -1228,8 +1228,11 @@
|
||||||
|
/* Macros for low-level exception handling */
|
||||||
|
#define SWIG_croak(x) { SWIG_Error(SWIG_RuntimeError, x); SWIG_fail; }
|
||||||
|
|
||||||
|
+#ifndef XSPROTO
|
||||||
|
+# define XSPROTO(name) void name(pTHX_ CV* cv)
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
-typedef XS(SwigPerlWrapper);
|
||||||
|
+typedef XSPROTO(SwigPerlWrapper);
|
||||||
|
typedef SwigPerlWrapper *SwigPerlWrapperPtr;
|
||||||
|
|
||||||
|
/* Structure for command table */
|
||||||
|
--- swig/perl/osr_wrap.cpp.orig 2008-03-25 20:49:16.000000000 +0200
|
||||||
|
+++ swig/perl/osr_wrap.cpp 2008-03-25 20:49:33.000000000 +0200
|
||||||
|
@@ -1229,7 +1229,11 @@
|
||||||
|
#define SWIG_croak(x) { SWIG_Error(SWIG_RuntimeError, x); SWIG_fail; }
|
||||||
|
|
||||||
|
|
||||||
|
-typedef XS(SwigPerlWrapper);
|
||||||
|
+#ifndef XSPROTO
|
||||||
|
+# define XSPROTO(name) void name(pTHX_ CV* cv)
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+typedef XSPROTO(SwigPerlWrapper);
|
||||||
|
typedef SwigPerlWrapper *SwigPerlWrapperPtr;
|
||||||
|
|
||||||
|
/* Structure for command table */
|
13
gdal.spec
13
gdal.spec
@ -1,6 +1,6 @@
|
|||||||
Name: gdal
|
Name: gdal
|
||||||
Version: 1.5.0
|
Version: 1.5.1
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: GIS file format library
|
Summary: GIS file format library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -8,6 +8,7 @@ URL: http://gdal.maptools.org
|
|||||||
Source0: %{name}-%{version}-fedora.tar.gz
|
Source0: %{name}-%{version}-fedora.tar.gz
|
||||||
Source1: http://download.osgeo.org/gdal/gdalautotest-1.5.0.tar.gz
|
Source1: http://download.osgeo.org/gdal/gdalautotest-1.5.0.tar.gz
|
||||||
Patch0: %{name}-gcc43.patch
|
Patch0: %{name}-gcc43.patch
|
||||||
|
Patch1: %{name}-perl510.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libtool swig pkgconfig
|
BuildRequires: libtool swig pkgconfig
|
||||||
BuildRequires: doxygen tetex-latex ghostscript
|
BuildRequires: doxygen tetex-latex ghostscript
|
||||||
@ -61,6 +62,7 @@ The GDAL perl modules provides support to handle multiple GIS file formats.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}-fedora
|
%setup -q -n %{name}-%{version}-fedora
|
||||||
%patch0 -p0 -b .gcc43
|
%patch0 -p0 -b .gcc43
|
||||||
|
%patch1 -p0 -b .perl510
|
||||||
|
|
||||||
# unpack test cases olso.
|
# unpack test cases olso.
|
||||||
tar -xzf %{SOURCE1} .
|
tar -xzf %{SOURCE1} .
|
||||||
@ -227,6 +229,7 @@ make DESTDIR=%{buildroot} \
|
|||||||
# move perl modules in the right path
|
# move perl modules in the right path
|
||||||
mkdir -p %{buildroot}%{perl_vendorarch}
|
mkdir -p %{buildroot}%{perl_vendorarch}
|
||||||
mv %{buildroot}%{perl_sitearch}/* %{buildroot}%{perl_vendorarch}/
|
mv %{buildroot}%{perl_sitearch}/* %{buildroot}%{perl_vendorarch}/
|
||||||
|
find %{buildroot}%{perl_vendorarch} -name "*.dox" -exec rm -rf '{}' \;
|
||||||
|
|
||||||
# install pkgconfig file
|
# install pkgconfig file
|
||||||
cat > %{name}.pc <<EOF
|
cat > %{name}.pc <<EOF
|
||||||
@ -288,7 +291,6 @@ rm -rf gdrivers/dods.py # no DODS during test (disabled)
|
|||||||
rm -rf osr/osr_esri.py # ESRI datum absent (disabled)
|
rm -rf osr/osr_esri.py # ESRI datum absent (disabled)
|
||||||
rm -rf ogr/ogr_sql_test.py # crash ugly (mustfix)
|
rm -rf ogr/ogr_sql_test.py # crash ugly (mustfix)
|
||||||
rm -rf gdrivers/dted.py # crash ugly (mustfix)
|
rm -rf gdrivers/dted.py # crash ugly (mustfix)
|
||||||
rm -rf gcore/tiff_write.py # crash ugly on 64bit (mustfix)
|
|
||||||
|
|
||||||
# run tests but force than normal exit
|
# run tests but force than normal exit
|
||||||
./run_all.py || exit 0
|
./run_all.py || exit 0
|
||||||
@ -370,6 +372,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{perl_vendorarch}/*
|
%{perl_vendorarch}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 25 2008 Balint Cristian <rezso@rdsor.ro> - 1.5.1-1
|
||||||
|
- new bugfix release from upstream
|
||||||
|
- drop large parts from gcc43 patch, some are upstream now
|
||||||
|
- fix building with perl-5.10 swig binding issue
|
||||||
|
|
||||||
* Wed Feb 29 2008 Orion Poplawski <orion@cora.nwra.com> - 1.5.0-4
|
* Wed Feb 29 2008 Orion Poplawski <orion@cora.nwra.com> - 1.5.0-4
|
||||||
- Rebuild for hdf5-1.8.0, use compatability API define
|
- Rebuild for hdf5-1.8.0, use compatability API define
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user