Update to 3.4.0

This commit is contained in:
Sandro Mani 2021-11-11 10:16:34 +01:00
parent ca7574ff6f
commit 53151cf9ac
12 changed files with 67 additions and 68 deletions

2
.gitignore vendored
View File

@ -67,3 +67,5 @@ gdalautotest-1.7.0.tar.gz
/gdalautotest-3.3.2.tar.gz /gdalautotest-3.3.2.tar.gz
/gdal-3.3.3-fedora.tar.xz /gdal-3.3.3-fedora.tar.xz
/gdalautotest-3.3.3.tar.gz /gdalautotest-3.3.3.tar.gz
/gdal-3.4.0-fedora.tar.xz
/gdalautotest-3.4.0.tar.gz

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp
--- gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-10-25 13:40:57.000000000 +0200 --- gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-11-04 12:56:51.000000000 +0100
+++ gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-10-29 17:41:24.508850437 +0200 +++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-11-09 11:58:38.117291664 +0100
@@ -34,6 +34,7 @@ @@ -34,6 +34,7 @@
#include <limits> #include <limits>
#include <math.h> #include <math.h>
@ -9,9 +9,9 @@ diff -rupN --no-dereference gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/cad
//------------------------------------------------------------------------------ //------------------------------------------------------------------------------
// CADVector // CADVector
diff -rupN --no-dereference gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-10-25 13:40:56.000000000 +0200 --- gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-11-04 12:56:50.000000000 +0100
+++ gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-10-29 17:41:24.508850437 +0200 +++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-11-09 11:58:38.117291664 +0100
@@ -39,6 +39,7 @@ @@ -39,6 +39,7 @@
#include <limits> #include <limits>
#include <memory> #include <memory>
@ -20,9 +20,9 @@ diff -rupN --no-dereference gdal-3.3.3-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg
#if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__) #if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__)
// gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string // gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string
diff -rupN --no-dereference gdal-3.3.3-fedora/third_party/LercLib/Lerc2.h gdal-3.3.3-fedora-new/third_party/LercLib/Lerc2.h diff -rupN --no-dereference gdal-3.4.0-fedora/third_party/LercLib/Lerc2.h gdal-3.4.0-fedora-new/third_party/LercLib/Lerc2.h
--- gdal-3.3.3-fedora/third_party/LercLib/Lerc2.h 2021-10-25 13:40:08.000000000 +0200 --- gdal-3.4.0-fedora/third_party/LercLib/Lerc2.h 2021-11-04 12:56:01.000000000 +0100
+++ gdal-3.3.3-fedora-new/third_party/LercLib/Lerc2.h 2021-10-29 17:41:24.509850743 +0200 +++ gdal-3.4.0-fedora-new/third_party/LercLib/Lerc2.h 2021-11-09 11:58:38.118291684 +0100
@@ -30,6 +30,7 @@ Contributors: Thomas Maurer @@ -30,6 +30,7 @@ Contributors: Thomas Maurer
#include <limits> #include <limits>
#include <string> #include <string>

View File

@ -8,7 +8,7 @@
#TODO: Consider doxy patch from Suse, setting EXTRACT_LOCAL_CLASSES = NO #TODO: Consider doxy patch from Suse, setting EXTRACT_LOCAL_CLASSES = NO
# Tests can be of a different version # Tests can be of a different version
%global testversion 3.3.3 %global testversion 3.4.0
%global run_tests 1 %global run_tests 1
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion) %global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -43,7 +43,7 @@
%endif %endif
Name: gdal Name: gdal
Version: 3.3.3 Version: 3.4.0
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap} Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library Summary: GIS file format library
License: MIT License: MIT
@ -396,9 +396,6 @@ popd
# Drop gdal.pdf symlink, as we don't build the pdf documentation # Drop gdal.pdf symlink, as we don't build the pdf documentation
rm doc/build/html/gdal.pdf rm doc/build/html/gdal.pdf
# Drop samples, installed through %%doc
rm -rf %{python3_sitearch}/osgeo_utils/samples
install -pm 755 ogr/ogrsf_frmts/s57/s57dump %{buildroot}%{_bindir} install -pm 755 ogr/ogrsf_frmts/s57/s57dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211createfromxml %{buildroot}%{_bindir} install -pm 755 frmts/iso8211/8211createfromxml %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211dump %{buildroot}%{_bindir} install -pm 755 frmts/iso8211/8211dump %{buildroot}%{_bindir}
@ -461,7 +458,7 @@ cat > %{buildroot}%{_includedir}/%{name}/cpl_config.h <<EOF
#endif #endif
EOF EOF
#<<<<<<<<<<<<< #<<<<<<<<<<<<<
touch -r NEWS port/cpl_config.h touch -r NEWS.md port/cpl_config.h
# Multilib gdal-config # Multilib gdal-config
@ -485,7 +482,7 @@ x86_64 | ppc64 | ppc64le | ia64 | s390x | sparc64 | alpha | alphaev6 | aarch64 )
esac esac
EOF EOF
#<<<<<<<<<<<<< #<<<<<<<<<<<<<
touch -r NEWS %{buildroot}%{_bindir}/%{name}-config touch -r NEWS.md %{buildroot}%{_bindir}/%{name}-config
chmod 755 %{buildroot}%{_bindir}/%{name}-config chmod 755 %{buildroot}%{_bindir}/%{name}-config
#jni-libs and libgdal are also built static (*.a) #jni-libs and libgdal are also built static (*.a)
@ -524,15 +521,14 @@ pushd %{name}autotest-%{testversion}
# internet. # internet.
# - `test_osr_erm_1`, `test_ers_4`, `test_ers_8`, and `test_ers_10` as # - `test_osr_erm_1`, `test_ers_4`, `test_ers_8`, and `test_ers_10` as
# they use `ecw_cs.wkt` which was removed due to unclear license. # they use `ecw_cs.wkt` which was removed due to unclear license.
# - `test_jpeg2000_8` and `test_jpeg2000_11` as files don't load, # - `test_jpeg2000_8` and `test_jpeg2000_11` as files don't load,
# perhaps due to buggy Jasper library? # perhaps due to buggy Jasper library?
# - `test_osr_ct_options_area_of_interest` returns the wrong value, but # - `test_osr_ct_options_area_of_interest` returns the wrong value, but
# it's skipped on macOS by upstream for mysteriously failing as well, # it's skipped on macOS by upstream for mysteriously failing as well,
# so do the same here. # so do the same here.
# - `test_ndf_1` because it hangs on i686 and armv7hl # FIXME: Some Tests hang on i686 and armv7hl
# FIXME: Tests hang on i686 and armv7hl
%ifnarch i686 armv7hl %ifnarch i686 armv7hl
%{pytest} -k 'not test_fits_vector and not test_http and not test_jp2openjpeg_45 and not multithreaded_download and not multithreaded_upload and not test_vsis3_no_sign_request and not test_eedai_GOOGLE_APPLICATION_CREDENTIALS and not test_osr_erm_1 and not test_ers_4 and not test_ers_8 and not test_ers_10 and not test_jpeg2000_8 and not test_jpeg2000_11 and not test_osr_ct_options_area_of_interest and not test_ndf_1' || : %{pytest} -v -k 'not test_fits_vector and not test_http and not test_jp2openjpeg_45 and not multithreaded_download and not multithreaded_upload and not test_vsis3_no_sign_request and not test_eedai_GOOGLE_APPLICATION_CREDENTIALS and not test_osr_erm_1 and not test_ers_4 and not test_ers_8 and not test_ers_10 and not test_jpeg2000_8 and not test_jpeg2000_11 and not test_osr_ct_options_area_of_interest' || :
%endif %endif
popd popd
%endif %endif
@ -562,7 +558,6 @@ popd
%{_bindir}/ogr* %{_bindir}/ogr*
%{_bindir}/8211* %{_bindir}/8211*
%{_bindir}/s57* %{_bindir}/s57*
%{_bindir}/testepsg
%{_bindir}/gnmanalyse %{_bindir}/gnmanalyse
%{_bindir}/gnmmanage %{_bindir}/gnmmanage
%{_datadir}/bash-completion/completions/* %{_datadir}/bash-completion/completions/*
@ -580,9 +575,9 @@ popd
%files libs %files libs
%license LICENSE.TXT %license LICENSE.TXT
%doc NEWS PROVENANCE.TXT COMMITTERS PROVENANCE.TXT-fedora %doc NEWS.md PROVENANCE.TXT COMMITTERS PROVENANCE.TXT-fedora
%{_libdir}/libgdal.so.29 %{_libdir}/libgdal.so.30
%{_libdir}/libgdal.so.29.* %{_libdir}/libgdal.so.30.*
%{_datadir}/%{name} %{_datadir}/%{name}
%dir %{_libdir}/%{name}plugins %dir %{_libdir}/%{name}plugins
@ -613,7 +608,6 @@ popd
%if %{with python3} %if %{with python3}
%files -n python3-gdal %files -n python3-gdal
%doc swig/python/README.rst %doc swig/python/README.rst
%doc swig/python/gdal-utils/osgeo_utils/samples
%{python3_sitearch}/GDAL-%{version}-py*.egg-info/ %{python3_sitearch}/GDAL-%{version}-py*.egg-info/
%{python3_sitearch}/osgeo/ %{python3_sitearch}/osgeo/
%{python3_sitearch}/osgeo_utils/ %{python3_sitearch}/osgeo_utils/
@ -641,6 +635,9 @@ popd
#Or as before, using ldconfig #Or as before, using ldconfig
%changelog %changelog
* Mon Nov 08 2021 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
- Update to 3.4.0
* Fri Oct 29 2021 Sandro Mani <manisandro@gmail.com> - 3.3.3-1 * Fri Oct 29 2021 Sandro Mani <manisandro@gmail.com> - 3.3.3-1
- Update to 3.3.3 - Update to 3.3.3

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/m4/lib-link.m4 gdal-3.3.3-fedora-new/m4/lib-link.m4 diff -rupN --no-dereference gdal-3.4.0-fedora/m4/lib-link.m4 gdal-3.4.0-fedora-new/m4/lib-link.m4
--- gdal-3.3.3-fedora/m4/lib-link.m4 2021-10-25 13:41:11.000000000 +0200 --- gdal-3.4.0-fedora/m4/lib-link.m4 2021-11-04 12:57:06.000000000 +0100
+++ gdal-3.3.3-fedora-new/m4/lib-link.m4 2021-10-29 17:41:24.973992816 +0200 +++ gdal-3.4.0-fedora-new/m4/lib-link.m4 2021-11-09 11:58:38.585300818 +0100
@@ -108,8 +108,6 @@ dnl acl_hardcode_direct, @@ -108,8 +108,6 @@ dnl acl_hardcode_direct,
dnl acl_hardcode_minus_L. dnl acl_hardcode_minus_L.
AC_DEFUN([AC_LIB_RPATH], AC_DEFUN([AC_LIB_RPATH],

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/apps/GNUmakefile gdal-3.3.3-fedora-new/apps/GNUmakefile diff -rupN --no-dereference gdal-3.4.0-fedora/apps/GNUmakefile gdal-3.4.0-fedora-new/apps/GNUmakefile
--- gdal-3.3.3-fedora/apps/GNUmakefile 2021-10-25 13:39:46.000000000 +0200 --- gdal-3.4.0-fedora/apps/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/apps/GNUmakefile 2021-10-29 17:41:24.053711120 +0200 +++ gdal-3.4.0-fedora-new/apps/GNUmakefile 2021-11-09 11:58:37.658282683 +0100
@@ -233,6 +233,7 @@ gdal-config-inst: gdal-config.in ../GDAL @@ -232,6 +232,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default install: default
for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/frmts/iso8211/GNUmakefile gdal-3.3.3-fedora-new/frmts/iso8211/GNUmakefile diff -rupN --no-dereference gdal-3.4.0-fedora/frmts/iso8211/GNUmakefile gdal-3.4.0-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.3.3-fedora/frmts/iso8211/GNUmakefile 2021-10-25 13:39:46.000000000 +0200 --- gdal-3.4.0-fedora/frmts/iso8211/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/frmts/iso8211/GNUmakefile 2021-10-29 17:41:23.597571497 +0200 +++ gdal-3.4.0-fedora-new/frmts/iso8211/GNUmakefile 2021-11-09 11:58:37.203273779 +0100
@@ -23,8 +23,7 @@ dist-clean: clean @@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR) rm -rf $(DISTDIR)

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/swig/java/add_javadoc.c gdal-3.3.3-fedora-new/swig/java/add_javadoc.c diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/add_javadoc.c gdal-3.4.0-fedora-new/swig/java/add_javadoc.c
--- gdal-3.3.3-fedora/swig/java/add_javadoc.c 2021-10-25 13:39:48.000000000 +0200 --- gdal-3.4.0-fedora/swig/java/add_javadoc.c 2021-11-04 12:55:39.000000000 +0100
+++ gdal-3.3.3-fedora-new/swig/java/add_javadoc.c 2021-10-29 17:41:23.119425138 +0200 +++ gdal-3.4.0-fedora-new/swig/java/add_javadoc.c 2021-11-09 11:58:36.600261974 +0100
@@ -133,22 +133,22 @@ int main(int argc, char* argv[]) @@ -133,22 +133,22 @@ int main(int argc, char* argv[])
FILE* fDst; FILE* fDst;
JavaDocInstance* instances = (JavaDocInstance*)calloc(sizeof(JavaDocInstance), 3000); JavaDocInstance* instances = (JavaDocInstance*)calloc(sizeof(JavaDocInstance), 3000);
@ -81,9 +81,9 @@ diff -rupN --no-dereference gdal-3.3.3-fedora/swig/java/add_javadoc.c gdal-3.3.3
} while(bFoundOpen == FALSE || nBrackets > 0); } while(bFoundOpen == FALSE || nBrackets > 0);
} }
else else
diff -rupN --no-dereference gdal-3.3.3-fedora/swig/java/javadoc.java gdal-3.3.3-fedora-new/swig/java/javadoc.java diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/javadoc.java gdal-3.4.0-fedora-new/swig/java/javadoc.java
--- gdal-3.3.3-fedora/swig/java/javadoc.java 2021-10-25 13:39:48.000000000 +0200 --- gdal-3.4.0-fedora/swig/java/javadoc.java 2021-11-04 12:55:40.000000000 +0100
+++ gdal-3.3.3-fedora-new/swig/java/javadoc.java 2021-10-29 17:41:23.121425751 +0200 +++ gdal-3.4.0-fedora-new/swig/java/javadoc.java 2021-11-09 11:58:36.602262013 +0100
@@ -11982,12 +11982,12 @@ public interface osrConstants:public fin @@ -11982,12 +11982,12 @@ public interface osrConstants:public fin
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM
@ -99,9 +99,9 @@ diff -rupN --no-dereference gdal-3.3.3-fedora/swig/java/javadoc.java gdal-3.3.3-
* or iterative convergence method failed. * or iterative convergence method failed.
*/ */
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_OUTSIDE_PROJECTION_DOMAIN public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_OUTSIDE_PROJECTION_DOMAIN
diff -rupN --no-dereference gdal-3.3.3-fedora/swig/java/java.opt gdal-3.3.3-fedora-new/swig/java/java.opt diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/java.opt gdal-3.4.0-fedora-new/swig/java/java.opt
--- gdal-3.3.3-fedora/swig/java/java.opt 2021-10-25 13:39:45.000000000 +0200 --- gdal-3.4.0-fedora/swig/java/java.opt 2021-11-04 12:55:38.000000000 +0100
+++ gdal-3.3.3-fedora-new/swig/java/java.opt 2021-10-29 17:41:23.121425751 +0200 +++ gdal-3.4.0-fedora-new/swig/java/java.opt 2021-11-09 11:58:36.602262013 +0100
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc @@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java JAVA=$(JAVA_HOME)/bin/java

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/configure.ac gdal-3.3.3-fedora-new/configure.ac diff -rupN --no-dereference gdal-3.4.0-fedora/configure.ac gdal-3.4.0-fedora-new/configure.ac
--- gdal-3.3.3-fedora/configure.ac 2021-10-25 13:39:46.000000000 +0200 --- gdal-3.4.0-fedora/configure.ac 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/configure.ac 2021-10-29 17:41:24.742922086 +0200 +++ gdal-3.4.0-fedora-new/configure.ac 2021-11-09 11:58:38.356296339 +0100
@@ -64,7 +64,7 @@ dnl warning #2304: non-explicit construc @@ -73,7 +73,7 @@ dnl warning #2304: non-explicit construc
dnl warning #3280: declaration hides member dnl warning #3280: declaration hides member
dnl remark #11074: Inlining inhibited by limit max-size dnl remark #11074: Inlining inhibited by limit max-size
dnl remark #11076: To get full report use -qopt-report=4 -qopt-report-phase ipo dnl remark #11076: To get full report use -qopt-report=4 -qopt-report-phase ipo

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/doc/source/index.rst gdal-3.3.3-fedora-new/doc/source/index.rst diff -rupN --no-dereference gdal-3.4.0-fedora/doc/source/index.rst gdal-3.4.0-fedora-new/doc/source/index.rst
--- gdal-3.3.3-fedora/doc/source/index.rst 2021-10-25 13:39:45.000000000 +0200 --- gdal-3.4.0-fedora/doc/source/index.rst 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/doc/source/index.rst 2021-10-29 17:41:24.277779707 +0200 +++ gdal-3.4.0-fedora-new/doc/source/index.rst 2021-11-09 11:58:37.885287126 +0100
@@ -4,8 +4,6 @@ GDAL @@ -4,8 +4,6 @@ GDAL
.. include:: ./about_no_title.rst .. include:: ./about_no_title.rst

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/doc/Makefile gdal-3.3.3-fedora-new/doc/Makefile diff -rupN --no-dereference gdal-3.4.0-fedora/doc/Makefile gdal-3.4.0-fedora-new/doc/Makefile
--- gdal-3.3.3-fedora/doc/Makefile 2021-10-25 13:39:45.000000000 +0200 --- gdal-3.4.0-fedora/doc/Makefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/doc/Makefile 2021-10-29 17:41:23.827641921 +0200 +++ gdal-3.4.0-fedora-new/doc/Makefile 2021-11-09 11:58:37.435278319 +0100
@@ -2,7 +2,7 @@ @@ -2,7 +2,7 @@
# #

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.3.3-fedora/frmts/dods/GNUmakefile gdal-3.3.3-fedora-new/frmts/dods/GNUmakefile diff -rupN --no-dereference gdal-3.4.0-fedora/frmts/dods/GNUmakefile gdal-3.4.0-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.3.3-fedora/frmts/dods/GNUmakefile 2021-10-25 13:39:45.000000000 +0200 --- gdal-3.4.0-fedora/frmts/dods/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/frmts/dods/GNUmakefile 2021-10-29 17:41:23.363499849 +0200 +++ gdal-3.4.0-fedora-new/frmts/dods/GNUmakefile 2021-11-09 11:58:36.942268671 +0100
@@ -4,7 +4,7 @@ include ../../GDALmake.opt @@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o OBJ = dodsdataset2.o
@ -10,15 +10,15 @@ diff -rupN --no-dereference gdal-3.3.3-fedora/frmts/dods/GNUmakefile gdal-3.3.3-
default: $(OBJ:.o=.$(OBJ_EXT)) default: $(OBJ:.o=.$(OBJ_EXT))
diff -rupN --no-dereference gdal-3.3.3-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.3.3-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2021-10-25 13:39:46.000000000 +0200 --- gdal-3.4.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.3.3-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-10-29 17:41:23.363499849 +0200 +++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-11-09 11:58:36.942268671 +0100
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt @@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \ OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o
-CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL -CPPFLAGS := -iquote .. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL
+CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL -I/usr/include/tirpc +CPPFLAGS := -iquote .. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL -I/usr/include/tirpc
default: $(O_OBJ:.o=.$(OBJ_EXT)) default: $(O_OBJ:.o=.$(OBJ_EXT))

View File

@ -1,2 +1,2 @@
SHA512 (gdal-3.3.3-fedora.tar.xz) = e61105cf2f76a0dc59a32c7c8f0351446cf939ddca9fd9283f7c81312add640cb262ef853d13fecfe635c07944ff8df57cfdaca1fb8c4169be8a52ddc8c85090 SHA512 (gdal-3.4.0-fedora.tar.xz) = b649dc43bbad297482a29e7202a32f57b75f0e9f9aa6e156b9759986660d8f27d5b5e73b6367e088108ceead9b558d552d3560ca7dac7a7b0c944c6509e5e956
SHA512 (gdalautotest-3.3.3.tar.gz) = 942cc4a87653602e718f335bbdd80727475655e1e2a1993fda51df73a8ba5492c8fa365e0c3b61ee4a88d5044922065bf07247597798231d7e11a84249ed52b6 SHA512 (gdalautotest-3.4.0.tar.gz) = b9258b93e2db9cdc2aa0d290272314e4bfad177a51a7f60d40a8bbebbe9f5e31f9e7a7f0f25a3d600357a3db9c02cca0e426970e0057c59d176fedcdc32ef089