New version 2.2.4

This commit is contained in:
Volker Froehlich 2018-03-26 20:16:33 +02:00
parent b22b882d1e
commit 4fd87332ae
7 changed files with 11 additions and 181 deletions

2
.gitignore vendored
View File

@ -35,3 +35,5 @@ gdalautotest-1.7.0.tar.gz
/gdalautotest-2.2.2.tar.gz
/gdalautotest-2.2.3.tar.gz
/gdal-2.2.3-fedora.tar.xz
/gdalautotest-2.2.4.tar.gz
/gdal-2.2.4-fedora.tar.xz

View File

@ -1,13 +0,0 @@
Index: gdal-2.2.3-fedora/swig/python/setup.py
===================================================================
--- gdal-2.2.3-fedora.orig/swig/python/setup.py
+++ gdal-2.2.3-fedora/swig/python/setup.py
@@ -7,7 +7,7 @@
# Howard Butler hobu.inc@gmail.com
-gdal_version = '2.2.2'
+gdal_version = '2.2.3'
import sys
import os

View File

@ -1,131 +0,0 @@
commit 7cab3c2049907fb0be76784c796143fb22dcafea
Author: Björn Esser <besser82@fedoraproject.org>
Date: Mon Dec 11 17:01:20 2017 +0100
geojson: Adaptions for json-c v0.13
Index: gdal-2.2.3-fedora/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
===================================================================
--- gdal-2.2.3-fedora.orig/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
+++ gdal-2.2.3-fedora/ogr/ogrsf_frmts/geojson/ogrgeojsonwriter.cpp
@@ -27,12 +27,18 @@
* DEALINGS IN THE SOFTWARE.
****************************************************************************/
+#define JSON_C_VER_013 (13 << 8)
+
#include "ogrgeojsonwriter.h"
#include "ogrgeojsonutils.h"
#include "ogr_geojson.h"
#include "ogrgeojsonreader.h"
#include <json.h> // JSON-C
+
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
#include <json_object_private.h>
+#endif
+
#include <printbuf.h>
#include <ogr_api.h>
#include <ogr_p.h>
@@ -1381,13 +1387,26 @@ static int OGR_json_double_with_precisio
{
// TODO(schwehr): Explain this casting.
const int nPrecision =
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
static_cast<int>(reinterpret_cast<GUIntptr_t>(jso->_userdata));
+#else
+ static_cast<int>(reinterpret_cast<GUIntptr_t>(json_object_get_userdata(jso)));
+#endif
char szBuffer[75] = {};
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
OGRFormatDouble( szBuffer, sizeof(szBuffer), jso->o.c_double, '.',
(nPrecision < 0) ? 15 : nPrecision );
+#else
+ OGRFormatDouble( szBuffer, sizeof(szBuffer), json_object_get_double(jso), '.',
+ (nPrecision < 0) ? 15 : nPrecision );
+#endif
if( szBuffer[0] == 't' /*oobig */ )
{
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
CPLsnprintf(szBuffer, sizeof(szBuffer), "%.18g", jso->o.c_double);
+#else
+ CPLsnprintf(szBuffer, sizeof(szBuffer), "%.18g", json_object_get_double(jso));
+#endif
}
return printbuf_memappend(pb, szBuffer, static_cast<int>(strlen(szBuffer)));
}
@@ -1417,11 +1436,23 @@ OGR_json_double_with_significant_figures
{
char szBuffer[75] = {};
int nSize = 0;
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
if( CPLIsNan(jso->o.c_double))
+#else
+ if( CPLIsNan(json_object_get_double(jso)))
+#endif
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "NaN");
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
else if( CPLIsInf(jso->o.c_double) )
+#else
+ else if( CPLIsInf(json_object_get_double(jso)) )
+#endif
{
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
if( jso->o.c_double > 0 )
+#else
+ if( json_object_get_double(jso) > 0 )
+#endif
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "Infinity");
else
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer), "-Infinity");
@@ -1429,13 +1460,22 @@ OGR_json_double_with_significant_figures
else
{
char szFormatting[32] = {};
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
const int nSignificantFigures = (int) (GUIntptr_t) jso->_userdata;
+#else
+ const int nSignificantFigures = (int) (GUIntptr_t) json_object_get_userdata(jso);
+#endif
const int nInitialSignificantFigures =
nSignificantFigures >= 0 ? nSignificantFigures : 17;
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
const char* pszDot = NULL;
if( nSize+2 < static_cast<int>(sizeof(szBuffer)) &&
(pszDot = strchr(szBuffer, '.')) == NULL )
@@ -1456,8 +1496,13 @@ OGR_json_double_with_significant_figures
{
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures- i);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
pszDot = strchr(szBuffer, '.');
if( pszDot != NULL &&
strstr(pszDot, "999999") == NULL &&
@@ -1471,8 +1516,13 @@ OGR_json_double_with_significant_figures
{
CPLsnprintf(szFormatting, sizeof(szFormatting),
"%%.%dg", nInitialSignificantFigures);
+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
szFormatting, jso->o.c_double);
+#else
+ nSize = CPLsnprintf(szBuffer, sizeof(szBuffer),
+ szFormatting, json_object_get_double(jso));
+#endif
if( nSize+2 < static_cast<int>(sizeof(szBuffer)) &&
strchr(szBuffer, '.') == NULL )
{

View File

@ -1,6 +1,6 @@
#!/bin/bash
# Volker Fröhlich
VERSION="2.2.3"
VERSION="2.2.4"
tar xvf gdal-"${VERSION}".tar.xz

View File

@ -1,19 +0,0 @@
commit 9128246d1ef1c01ca9ec1d5606b920b59edb8765
Author: Tom Hughes <tom@compton.nu>
Date: Wed Jan 24 09:37:48 2018 +0000
Use panSrcBands when accessing the source data
diff --git a/gdal/alg/gdalwarpoperation.cpp b/gdal/alg/gdalwarpoperation.cpp
index b652506623..791ca67db9 100644
--- a/gdal/alg/gdalwarpoperation.cpp
+++ b/gdal/alg/gdalwarpoperation.cpp
@@ -1776,7 +1776,7 @@ CPLErr GDALWarpOperation::WarpRegionToBuffer(
if( psOptions->nBandCount == 1 )
{
// Particular case to simplify the stack a bit.
- eErr = poSrcDS->GetRasterBand(psOptions->panDstBands[0])->RasterIO(
+ eErr = poSrcDS->GetRasterBand(psOptions->panSrcBands[0])->RasterIO(
GF_Read,
nSrcXOff, nSrcYOff, nSrcXSize, nSrcYSize,
oWK.papabySrcImage[0], nSrcXSize, nSrcYSize,

View File

@ -24,7 +24,7 @@
%global proj_somaj 12
# Tests can be of a different version
%global testversion 2.2.3
%global testversion 2.2.4
%global run_tests 0
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -61,8 +61,8 @@
%endif
Name: gdal
Version: 2.2.3
Release: 14%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Version: 2.2.4
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
Group: System Environment/Libraries
License: MIT
@ -86,20 +86,11 @@ Patch2: %{name}-jni.patch
# Fix bash-completion install dir
Patch3: %{name}-completion.patch
# https://trac.osgeo.org/gdal/changeset/40801/
# Python bindings version was 2.2.2 instead of 2.2.3
Patch5: %{name}-2.2.3-swig-python-version.patch
# Fedora uses Alternatives for Java
Patch8: %{name}-1.9.0-java.patch
Patch9: %{name}-2.2.2-zlib.patch
Patch10: %{name}-2.2.3_json-c_013.patch
# https://github.com/OSGeo/gdal/pull/295
Patch11: %{name}-srcbands.patch
BuildRequires: ant
# No armadillo in EL5
@ -334,11 +325,8 @@ rm -r frmts/grib/degrib18/g2clib-1.0.4
%patch1 -p1 -b .g2clib~
%patch2 -p1 -b .jni~
%patch3 -p1 -b .completion~
%patch5 -p1 -b .python~
%patch8 -p1 -b .java~
%patch9 -p1 -b .zlib~
%patch10 -p1 -b .json-c_013~
%patch11 -p2 -b .srcbands~
# Copy in PROVENANCE.TXT-fedora
cp -p %SOURCE4 .
@ -886,6 +874,9 @@ popd
#Or as before, using ldconfig
%changelog
* Thu Mar 22 2018 Volker Fröhlich <volker27@gmx.at> - 2.2.4-1
- New upstream release
* Fri Mar 23 2018 Adam Williamson <awilliam@redhat.com> - 2.2.3-14
- Rebuild for poppler 0.63.0

View File

@ -1,2 +1,2 @@
SHA512 (gdalautotest-2.2.3.tar.gz) = f38511cbeff87ff1a6a441703d675db5c8b278d508749897d393530e0e7bc9455e6ed01c065c6b011e20a335dca866b24e6d9638ce31a2488290c938a32b76ba
SHA512 (gdal-2.2.3-fedora.tar.xz) = 896e70367c06254b3785bab2c9fc57450a98ffa9aee66b44f75a8755f2afa7b5d2d2dbfd4dc9ce244f2b1d88835017a86f8c7a800fffa4d56a4be9293b7f7d0d
SHA512 (gdalautotest-2.2.4.tar.gz) = c7dd8e007c84b112f7d6384d5e28981a929b81409b41bd02495c4d7b99a72aa4ee92884a90e0246c3b1c8c723b9272979a89f15b00794abebde97a36d6344ee9
SHA512 (gdal-2.2.4-fedora.tar.xz) = a8c878c0b9ea56575eaa72434990a1473a9dfc40dc7794d0a752846b0f945e8f38da02b7a264f7450b44ba3d021ee7af6e1ec6be57e955594f4b33caa4d1ddd0