Update to 3.3.0

This commit is contained in:
Sandro Mani 2021-05-06 10:01:35 +02:00
parent 95a4909377
commit 4a9546778f
14 changed files with 173 additions and 238 deletions

2
.gitignore vendored
View File

@ -59,3 +59,5 @@ gdalautotest-1.7.0.tar.gz
/gdalautotest-3.2.1.tar.gz
/gdalautotest-3.2.2.tar.gz
/gdal-3.2.2-fedora.tar.xz
/gdalautotest-3.3.0.tar.gz
/gdal-3.3.0-fedora.tar.xz

View File

@ -1,40 +0,0 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/m4/geos.m4 gdal-3.2.2-fedora-new/m4/geos.m4
--- gdal-3.2.2-fedora/m4/geos.m4 2021-03-05 12:39:54.000000000 +0100
+++ gdal-3.2.2-fedora-new/m4/geos.m4 2021-03-24 13:44:41.905428811 +0100
@@ -129,6 +129,8 @@ AC_DEFUN([GEOS_INIT],[
LIBS=${GEOS_LIBS}
ax_save_CFLAGS="${CFLAGS}"
CFLAGS="${GEOS_CFLAGS}"
+ ax_save_LDFLAGS="${LDFLAGS}"
+ LDFLAGS=""
AC_CHECK_LIB([geos_c],
[GEOSversion],
@@ -143,6 +145,7 @@ AC_DEFUN([GEOS_INIT],[
CFLAGS="${ax_save_CFLAGS}"
LIBS="${ax_save_LIBS}"
+ LDFLAGS="${ax_save_LDFLAGS}"
fi
diff -rupN --no-dereference gdal-3.2.2-fedora/m4/sfcgal.m4 gdal-3.2.2-fedora-new/m4/sfcgal.m4
--- gdal-3.2.2-fedora/m4/sfcgal.m4 2021-03-05 12:39:52.000000000 +0100
+++ gdal-3.2.2-fedora-new/m4/sfcgal.m4 2021-03-24 13:44:41.905428811 +0100
@@ -128,6 +128,8 @@ AC_DEFUN([SFCGAL_INIT],[
LIBS=${SFCGAL_LIBS}
ax_save_CFLAGS="${CFLAGS}"
CFLAGS="${SFCGAL_CFLAGS}"
+ ax_save_LDFLAGS="${LDFLAGS}"
+ LDFLAGS=""
AC_CHECK_LIB([SFCGAL],
[sfcgal_version],
@@ -143,6 +145,7 @@ AC_DEFUN([SFCGAL_INIT],[
CFLAGS="${ax_save_CFLAGS}"
LIBS="${ax_save_LIBS}"
+ LDFLAGS="${ax_save_LDFLAGS}"
fi

View File

@ -1,84 +0,0 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/m4/geos.m4 gdal-3.2.2-fedora-new/m4/geos.m4
--- gdal-3.2.2-fedora/m4/geos.m4 2021-03-24 13:44:42.101428816 +0100
+++ gdal-3.2.2-fedora-new/m4/geos.m4 2021-03-24 13:44:42.103428816 +0100
@@ -59,7 +59,9 @@ AC_DEFUN([GEOS_INIT],[
elif test x"$with_geos" = x"yes" -o x"$with_geos" = x"" ; then
AC_PATH_PROG(GEOS_CONFIG, geos-config, no)
- ac_geos_config_auto=yes
+ if test x"$with_geos" = x"" ; then
+ ac_geos_config_auto=yes
+ fi
else
@@ -140,7 +142,14 @@ AC_DEFUN([GEOS_INIT],[
)
if test x"$HAVE_GEOS" = "xno"; then
- GEOS_CFLAGS=""
+ if test $ac_geos_config_auto = "yes" ; then
+ AC_MSG_WARN([GEOS was found on your system, but the library could not be linked. GEOS support disabled.])
+ else
+ AC_MSG_ERROR([GEOS library could not be linked])
+ fi
+
+ GEOS_CFLAGS=""
+
fi
CFLAGS="${ax_save_CFLAGS}"
@@ -149,6 +158,12 @@ AC_DEFUN([GEOS_INIT],[
fi
+ else
+
+ if test $ac_geos_config_auto = "no" ; then
+ AC_MSG_ERROR([GEOS support explicitly enabled, but geos-config could not be found])
+ fi
+
fi
])
diff -rupN --no-dereference gdal-3.2.2-fedora/m4/sfcgal.m4 gdal-3.2.2-fedora-new/m4/sfcgal.m4
--- gdal-3.2.2-fedora/m4/sfcgal.m4 2021-03-24 13:44:42.101428816 +0100
+++ gdal-3.2.2-fedora-new/m4/sfcgal.m4 2021-03-24 13:44:42.103428816 +0100
@@ -58,7 +58,9 @@ AC_DEFUN([SFCGAL_INIT],[
elif test x"$with_sfcgal" = x"yes" -o x"$with_sfcgal" = x"" ; then
AC_PATH_PROG(SFCGAL_CONFIG, sfcgal-config, no)
- ac_sfcgal_config_auto=yes
+ if test x"$with_sfcgal" = x"" ; then
+ ac_sfcgal_config_auto=yes
+ fi
else
@@ -140,7 +142,13 @@ AC_DEFUN([SFCGAL_INIT],[
if test x"$HAVE_SFCGAL" = "xno"; then
- SFCGAL_CFLAGS=""
+ if test $ac_sfcgal_config_auto = "yes" ; then
+ AC_MSG_WARN([SFCGAL was found on your system, but the library could not be linked. SFCGAL support disabled.])
+ else
+ AC_MSG_ERROR([SFCGAL library could not be linked])
+ fi
+
+ SFCGAL_CFLAGS=""
fi
CFLAGS="${ax_save_CFLAGS}"
@@ -149,5 +157,11 @@ AC_DEFUN([SFCGAL_INIT],[
fi
+ else
+
+ if test $ac_sfcgal_config_auto = "no" ; then
+ AC_MSG_ERROR([SFCGAL support explicitly enabled, but sfcgal-config could not be found])
+ fi
+
fi
])

View File

@ -1,11 +0,0 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/swig/java/java.opt gdal-3.2.2-fedora-new/swig/java/java.opt
--- gdal-3.2.2-fedora/swig/java/java.opt 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/swig/java/java.opt 2021-03-24 13:44:40.268428769 +0100
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java
JAR=$(JAVA_HOME)/bin/jar
-JAVA_INCLUDE=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+JAVA_INCLUDE=-I/usr/lib/jvm/java/include/ -I/usr/lib/jvm/java/include/linux

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp
--- gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-03-05 12:39:39.000000000 +0100
+++ gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-03-24 13:44:41.499428801 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp
--- gdal-3.3.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-04-26 14:31:00.000000000 +0200
+++ gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-05-03 17:18:20.482677217 +0200
@@ -34,6 +34,7 @@
#include <limits>
#include <math.h>
@ -9,9 +9,9 @@ diff -rupN --no-dereference gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/cad
//------------------------------------------------------------------------------
// CADVector
diff -rupN --no-dereference gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-03-05 12:39:38.000000000 +0100
+++ gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-03-24 13:44:41.499428801 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.3.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-04-26 14:30:59.000000000 +0200
+++ gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-05-03 17:18:20.483677217 +0200
@@ -39,6 +39,7 @@
#include <limits>
#include <memory>
@ -20,9 +20,9 @@ diff -rupN --no-dereference gdal-3.2.2-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg
#if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__)
// gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string
diff -rupN --no-dereference gdal-3.2.2-fedora/third_party/LercLib/Lerc2.h gdal-3.2.2-fedora-new/third_party/LercLib/Lerc2.h
--- gdal-3.2.2-fedora/third_party/LercLib/Lerc2.h 2021-03-05 12:38:57.000000000 +0100
+++ gdal-3.2.2-fedora-new/third_party/LercLib/Lerc2.h 2021-03-24 13:44:41.500428801 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/third_party/LercLib/Lerc2.h gdal-3.3.0-fedora-new/third_party/LercLib/Lerc2.h
--- gdal-3.3.0-fedora/third_party/LercLib/Lerc2.h 2021-04-26 14:30:17.000000000 +0200
+++ gdal-3.3.0-fedora-new/third_party/LercLib/Lerc2.h 2021-05-03 17:18:20.483677217 +0200
@@ -30,6 +30,7 @@ Contributors: Thomas Maurer
#include <limits>
#include <string>

View File

@ -8,7 +8,7 @@
#TODO: Consider doxy patch from Suse, setting EXTRACT_LOCAL_CLASSES = NO
# Tests can be of a different version
%global testversion 3.2.2
%global testversion 3.3.0
%global run_tests 1
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -31,7 +31,6 @@
%global spatialite "--with-spatialite"
%endif
%bcond_with python2
%bcond_without python3
# No ppc64 build for spatialite in EL6
@ -44,7 +43,7 @@
%endif
Name: gdal
Version: 3.2.2
Version: 3.3.0
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
License: MIT
@ -60,8 +59,8 @@ Source3: %{name}-cleaner.sh
Source4: PROVENANCE.TXT-fedora
# Fedora uses Alternatives for Java
Patch2: %{name}-1.9.0-java.patch
# Java build fixes
Patch2: gdal_java.patch
# Ensure rpc/types.h is found by dods driver (indirectly required by libdap/XDRUtils.h)
Patch3: gdal_tirpcinc.patch
# Use libtool to create libiso8211.a, otherwise broken static lib is created since object files are compiled through libtool
@ -77,10 +76,6 @@ Patch7: gdal_nopdf.patch
Patch8: %{name}-gcc11.patch
# Drop -diag-disable compile flag
Patch9: gdal_no-diag-disable.patch
# Fix GEOS and SFCGAL checks:
# https://github.com/OSGeo/gdal/pull/3476
Patch10: 0001-configure-Also-save-LDFLAGS-when-checking-compilabil.patch
Patch11: 0002-configure-Ensure-with-geos-sfcgal-fail-if-unavailabl.patch
BuildRequires: gcc
@ -149,10 +144,6 @@ BuildRequires: poppler-devel
%endif
BuildRequires: libpq-devel
BuildRequires: proj-devel >= 5.2.0
%if %{with python2}
BuildRequires: python2-devel
BuildRequires: python2-numpy
%endif
%if %{with python3}
BuildRequires: python3-devel
BuildRequires: python3-numpy
@ -244,23 +235,6 @@ Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $versi
The GDAL Perl modules provide support to handle multiple GIS file formats.
%if %{with python2}
%package -n python2-gdal
%{?python_provide:%python_provide python2-gdal}
# Remove before F30
Provides: %{name}-python = %{version}-%{release}
Provides: %{name}-python%{?_isa} = %{version}-%{release}
Obsoletes: %{name}-python < %{version}-%{release}
Summary: Python modules for the GDAL file format library
Requires: numpy
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n python2-gdal
The GDAL Python modules provide support to handle multiple GIS file formats.
The package also includes a couple of useful utilities in Python.
%endif
%if %{with python3}
%package -n python3-gdal
%{?python_provide:%python_provide python3-gdal}
@ -275,10 +249,10 @@ The GDAL Python 3 modules provide support to handle multiple GIS file formats.
%endif
%if %{with python2} || %{with python3}
%if %{with python3}
%package python-tools
Summary: Python tools for the GDAL file format library
Requires: %{?with_python3:python3-gdal}%{?!with_python3:python2-gdal}
Requires: python3-gdal
%description python-tools
The GDAL Python package provides number of tools for programming and
@ -295,11 +269,7 @@ This package contains documentation for GDAL.
# We don't want to provide private Python extension libs
%if %{with python2} && %{with python3}
%global __provides_exclude_from ^(%{python2_sitearch}|%{python3_sitearch})/.*\.so$
%elif %{with python2}
%global __provides_exclude_from ^%{python2_sitearch}/.*\.so$
%elif %{with_python3}
%if %{with_python3}
%global __provides_exclude_from ^%{python3_sitearch}/.*\.so$
%endif
@ -325,15 +295,6 @@ cp -p %SOURCE4 .
sed -i 's|with_dods_root/lib|with_dods_root/lib64|' configure.ac
%endif
# Tests expect to be next to gdal source directory, but we extract them within
# it. And putting tests next to the source directory wouldn't account for the
# version in the directory name, anyway, so we need to correct this.
sed -i \
-e 's!../../gdal/swig/python/samples!../../swig/python/samples!' \
%{name}autotest-%{testversion}/gcore/{cog,tiff_write}.py \
%{name}autotest-%{testversion}/gdrivers/{gpkg,jp2lura,jp2openjpeg,test_validate_jp2}.py \
%{name}autotest-%{testversion}/ogr/ogr_gpkg.py
%build
# For future reference:
@ -404,14 +365,13 @@ make docs
# Make Java module and documentation
pushd swig/java
make
ant maven
ANT_OPTS="-Dfile.encoding=utf-8" ant maven
popd
%mvn_artifact swig/java/build/maven/gdal-%version.pom swig/java/build/maven/gdal-%version.jar
%endif
# Make Python modules
pushd swig/python
%{?with_python2:%py2_build}
%{?with_python3:%py3_build}
popd
@ -424,7 +384,6 @@ popd
%install
pushd swig/python
%{?with_python2:%py2_install}
%{?with_python3:%py3_install}
popd
@ -435,6 +394,9 @@ popd
# Drop gdal.pdf symlink, as we don't build the pdf documentation
rm doc/build/html/gdal.pdf
# Drop samples, installed through %%doc
rm -rf %{python3_sitearch}/osgeo_utils/samples
install -pm 755 ogr/ogrsf_frmts/s57/s57dump %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211createfromxml %{buildroot}%{_bindir}
install -pm 755 frmts/iso8211/8211dump %{buildroot}%{_bindir}
@ -448,7 +410,7 @@ mkdir -p %{buildroot}%{_libdir}/%{name}plugins
#TODO: Don't do that?
rm %{buildroot}%{perl_archlib}/perllocal.pod
%if %{without python} && %{without python3}
%if %{without python3}
rm %buildroot%_mandir/man1/{pct2rgb,rgb2pct}.1
%endif
@ -617,8 +579,8 @@ popd
%files libs
%license LICENSE.TXT
%doc NEWS PROVENANCE.TXT COMMITTERS PROVENANCE.TXT-fedora
%{_libdir}/libgdal.so.28
%{_libdir}/libgdal.so.28.*
%{_libdir}/libgdal.so.29
%{_libdir}/libgdal.so.29.*
%{_datadir}/%{name}
%dir %{_libdir}/%{name}plugins
@ -646,23 +608,14 @@ popd
%{perl_vendorarch}/*
%{_mandir}/man3/*.3pm*
%if %{with python2}
%files -n python2-gdal
%doc swig/python/README.rst
%doc swig/python/samples
%{python2_sitearch}/osgeo/
%{python2_sitearch}/GDAL-%{version}-py*.egg-info/
%endif
%if %{with python3}
%files -n python3-gdal
%doc swig/python/README.rst
%doc swig/python/samples
%{python3_sitearch}/osgeo
%doc swig/python/gdal-utils/osgeo_utils/samples
%{python3_sitearch}/GDAL-%{version}-py*.egg-info/
%endif
%{python3_sitearch}/osgeo/
%{python3_sitearch}/osgeo_utils/
%if %{with python2} || %{with python3}
%files python-tools
%_bindir/*.py
%{_mandir}/man1/pct2rgb.1*
@ -686,6 +639,9 @@ popd
#Or as before, using ldconfig
%changelog
* Mon May 03 2021 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
- Update to 3.3.0
* Wed Mar 24 2021 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
- Update to 3.2.2

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/apps/GNUmakefile gdal-3.2.2-fedora-new/apps/GNUmakefile
--- gdal-3.2.2-fedora/apps/GNUmakefile 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/apps/GNUmakefile 2021-03-24 13:44:41.091428790 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/apps/GNUmakefile gdal-3.3.0-fedora-new/apps/GNUmakefile
--- gdal-3.3.0-fedora/apps/GNUmakefile 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/apps/GNUmakefile 2021-05-03 17:18:20.058677207 +0200
@@ -233,6 +233,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/frmts/iso8211/GNUmakefile gdal-3.2.2-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.2.2-fedora/frmts/iso8211/GNUmakefile 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/frmts/iso8211/GNUmakefile 2021-03-24 13:44:40.686428780 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/frmts/iso8211/GNUmakefile gdal-3.3.0-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.3.0-fedora/frmts/iso8211/GNUmakefile 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/frmts/iso8211/GNUmakefile 2021-05-03 17:18:19.611677197 +0200
@@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR)

112
gdal_java.patch Normal file
View File

@ -0,0 +1,112 @@
diff -rupN --no-dereference gdal-3.3.0-fedora/swig/java/java.opt gdal-3.3.0-fedora-new/swig/java/java.opt
--- gdal-3.3.0-fedora/swig/java/java.opt 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/swig/java/java.opt 2021-05-03 17:18:19.173677188 +0200
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java
JAR=$(JAVA_HOME)/bin/jar
-JAVA_INCLUDE=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+JAVA_INCLUDE=-I/usr/lib/jvm/java/include/ -I/usr/lib/jvm/java/include/linux
diff -rupN gdal-3.3.0-fedora/swig/java/add_javadoc.c gdal-3.3.0-fedora-new/swig/java/add_javadoc.c
--- gdal-3.3.0-fedora/swig/java/add_javadoc.c 2021-04-26 14:29:58.000000000 +0200
+++ gdal-3.3.0-fedora-new/swig/java/add_javadoc.c 2021-05-04 00:54:09.480133336 +0200
@@ -133,22 +133,22 @@ int main(int argc, char* argv[])
FILE* fDst;
JavaDocInstance* instances = (JavaDocInstance*)calloc(sizeof(JavaDocInstance), 3000);
int nInstances = 0;
- char szLine[256];
- char szClass[256];
+ char szLine[512];
+ char szClass[512];
char javadoc[16384];
szClass[0] = 0;
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
if (strstr(szLine, "/**") == NULL) continue;
begin:
strcpy(javadoc, szLine);
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
strcat(javadoc, szLine);
if (strstr(szLine, "*/"))
break;
}
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
if (szLine[0] == 10)
continue;
@@ -188,10 +188,10 @@ begin:
fDst = fopen(szDstName, "wt");
if (fDst == NULL) continue;
szClass[0] = 0;
- char szPackage[256];
+ char szPackage[512];
szPackage[0] = 0;
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
char szMethodName[1024];
char* szOriLine = strdup(szLine);
@@ -224,8 +224,10 @@ begin:
if (strstr(szLine, "synchronized "))
{
char* c = strstr(szLine, "synchronized ");
+ char rest[512];
+ strcpy(rest, c + 13);
*c = 0;
- strcat(szLine, c + 13);
+ strcat(szLine, rest);
}
if (strstr(szLine, "public") && !strstr(szLine, "native"))
{
@@ -234,7 +236,7 @@ begin:
strcpy(szMethodName, szLine);
do
{
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
strcpy(szMethodName + strlen(szMethodName) - 1, szLine);
} while (!strchr(szMethodName,')'));
strcpy(szLine, szMethodName);
@@ -261,7 +263,7 @@ begin:
{
do
{
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
} while (!strchr(szLine,'}'));
}
break;
@@ -289,7 +291,7 @@ begin:
nBrackets --;
}
}
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
} while(bFoundOpen == FALSE || nBrackets > 0);
}
else
diff -rupN gdal-3.3.0-fedora/swig/java/javadoc.java gdal-3.3.0-fedora-new/swig/java/javadoc.java
--- gdal-3.3.0-fedora/swig/java/javadoc.java 2021-04-26 14:29:59.000000000 +0200
+++ gdal-3.3.0-fedora-new/swig/java/javadoc.java 2021-05-05 09:08:14.992037179 +0200
@@ -11982,12 +11982,12 @@ public interface osrConstants:public fin
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM
/**
- * Invalid input coordinate. e.g a latitude > 90°.
+ * Invalid input coordinate. e.g a latitude > 90 deg.
*/
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_INVALID_COORD
/**
- * Coordinate is outside of the projection domain. e.g approximate mercator with \|longitude - lon_0\| > 90°,
+ * Coordinate is outside of the projection domain. e.g approximate mercator with \|longitude - lon_0\| > 90 deg,
* or iterative convergence method failed.
*/
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_OUTSIDE_PROJECTION_DOMAIN

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/configure.ac gdal-3.2.2-fedora-new/configure.ac
--- gdal-3.2.2-fedora/configure.ac 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/configure.ac 2021-03-24 13:44:41.701428806 +0100
@@ -61,7 +61,7 @@ dnl warning #2304: non-explicit construc
diff -rupN --no-dereference gdal-3.3.0-fedora/configure.ac gdal-3.3.0-fedora-new/configure.ac
--- gdal-3.3.0-fedora/configure.ac 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/configure.ac 2021-05-03 17:18:20.692677222 +0200
@@ -64,7 +64,7 @@ dnl warning #2304: non-explicit construc
dnl warning #3280: declaration hides member
dnl remark #11074: Inlining inhibited by limit max-size
dnl remark #11076: To get full report use -qopt-report=4 -qopt-report-phase ipo

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/doc/source/index.rst gdal-3.2.2-fedora-new/doc/source/index.rst
--- gdal-3.2.2-fedora/doc/source/index.rst 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/doc/source/index.rst 2021-03-24 13:44:41.294428795 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/doc/source/index.rst gdal-3.3.0-fedora-new/doc/source/index.rst
--- gdal-3.3.0-fedora/doc/source/index.rst 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/doc/source/index.rst 2021-05-03 17:18:20.270677212 +0200
@@ -4,8 +4,6 @@ GDAL
.. include:: ./about_no_title.rst

View File

@ -1,12 +1,12 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/doc/Makefile gdal-3.2.2-fedora-new/doc/Makefile
--- gdal-3.2.2-fedora/doc/Makefile 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/doc/Makefile 2021-03-24 13:44:40.886428785 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/doc/Makefile gdal-3.3.0-fedora-new/doc/Makefile
--- gdal-3.3.0-fedora/doc/Makefile 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/doc/Makefile 2021-05-03 17:18:19.833677202 +0200
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS = --keep-going -j auto -W
+SPHINXOPTS = --keep-going
-SPHINXOPTS ?= --keep-going -j auto -W
+SPHINXOPTS ?= --keep-going
SPHINXBUILD = sphinx-build
SOURCEDIR = source
BUILDDIR = build

View File

@ -1,24 +1,24 @@
diff -rupN --no-dereference gdal-3.2.2-fedora/frmts/dods/GNUmakefile gdal-3.2.2-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.2.2-fedora/frmts/dods/GNUmakefile 2021-03-05 12:38:35.000000000 +0100
+++ gdal-3.2.2-fedora-new/frmts/dods/GNUmakefile 2021-03-24 13:44:40.477428774 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/frmts/dods/GNUmakefile gdal-3.3.0-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.3.0-fedora/frmts/dods/GNUmakefile 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/frmts/dods/GNUmakefile 2021-05-03 17:18:19.398677193 +0200
@@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o
-CPPFLAGS := $(CPPFLAGS) $(DODS_INC)
+CPPFLAGS := $(CPPFLAGS) $(DODS_INC) -I/usr/include/tirpc
-CPPFLAGS := $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC)
+CPPFLAGS := $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -I/usr/include/tirpc
default: $(OBJ:.o=.$(OBJ_EXT))
diff -rupN --no-dereference gdal-3.2.2-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.2.2-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2021-03-05 12:38:36.000000000 +0100
+++ gdal-3.2.2-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-03-24 13:44:40.477428774 +0100
diff -rupN --no-dereference gdal-3.3.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.3.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2021-04-26 14:29:56.000000000 +0200
+++ gdal-3.3.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-05-03 17:18:19.398677193 +0200
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o
-CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) -DDO_NOT_USE_DEBUG_BOOL
+CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) -DDO_NOT_USE_DEBUG_BOOL -I/usr/include/tirpc
-CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL
+CPPFLAGS := -I.. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL -I/usr/include/tirpc
default: $(O_OBJ:.o=.$(OBJ_EXT))

View File

@ -1,2 +1,2 @@
SHA512 (gdalautotest-3.2.2.tar.gz) = 324326f590fcd508e99f4ed5396a0d61065449f44894e2844e464650097c353eaf3c14074afa862c8d0784569e29545d4050ea65ded95cd02e5bb02deed80dc4
SHA512 (gdal-3.2.2-fedora.tar.xz) = 3c3d84c77d93ab6943497571a4e6c1bea4a0b74f897f602abcdd59dda5e0799305d8b9444425593631f2d3852722568740237890c0af72ce3b8533367e04ab00
SHA512 (gdalautotest-3.3.0.tar.gz) = facd8ec0c0743240d6bbdd271ef659182c9d38857a71e2abe153019e27f4adad94f759f007a31472941487ed2d3f588a10412e955f9bd99ea25da2dc97a8924d
SHA512 (gdal-3.3.0-fedora.tar.xz) = ce83c49740f333be17fa9e2287f2c24b79eed67c63fcf975eeda0340010f90b89085d4ee4e30da0105ddc53a2ac19eefaa89879dd27c33706a47546e9350e7ba