Merge remote-tracking branch 'up/master' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-07-31 10:31:00 +03:00
commit 41d449f77b
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
6 changed files with 445 additions and 90 deletions

2
.gitignore vendored
View File

@ -39,3 +39,5 @@ gdalautotest-1.7.0.tar.gz
/gdal-2.2.4-fedora.tar.xz
/gdalautotest-2.3.1.tar.gz
/gdal-2.3.1-fedora.tar.xz
/gdalautotest-2.3.2.tar.gz
/gdal-2.3.2-fedora.tar.xz

View File

@ -0,0 +1,314 @@
--- gdal-2.3.2-fedora/frmts/pdf/pdfdataset.cpp
+++ gdal-2.3.2-fedora/frmts/pdf/pdfdataset.cpp
@@ -165,7 +165,7 @@ class GDALPDFOutputDev : public SplashOu
public:
GDALPDFOutputDev(SplashColorMode colorModeA, int bitmapRowPadA,
- GBool reverseVideoA, SplashColorPtr paperColorA) :
+ bool reverseVideoA, SplashColorPtr paperColorA) :
SplashOutputDev(colorModeA, bitmapRowPadA,
reverseVideoA, paperColorA),
bEnableVector(TRUE),
@@ -227,11 +227,11 @@ class GDALPDFOutputDev : public SplashOu
}
#ifndef POPPLER_0_23_OR_LATER
- virtual GBool deviceHasTextClip(GfxState *state) override
+ virtual bool deviceHasTextClip(GfxState *state) override
{
if (bEnableText)
return SplashOutputDev::deviceHasTextClip(state);
- return gFalse;
+ return false;
}
#endif
@@ -242,8 +242,8 @@ class GDALPDFOutputDev : public SplashOu
}
virtual void drawImageMask(GfxState *state, Object *ref, Stream *str,
- int width, int height, GBool invert,
- GBool interpolate, GBool inlineImg) override
+ int width, int height, bool invert,
+ bool interpolate, bool inlineImg) override
{
if (bEnableBitmap)
SplashOutputDev::drawImageMask(state, ref, str,
@@ -263,8 +263,8 @@ class GDALPDFOutputDev : public SplashOu
#ifdef POPPLER_0_20_OR_LATER
virtual void setSoftMaskFromImageMask(GfxState *state,
Object *ref, Stream *str,
- int width, int height, GBool invert,
- GBool inlineImg, double *baseMatrix) override
+ int width, int height, bool invert,
+ bool inlineImg, double *baseMatrix) override
{
if (bEnableBitmap)
SplashOutputDev::setSoftMaskFromImageMask(state, ref, str,
@@ -283,7 +283,7 @@ class GDALPDFOutputDev : public SplashOu
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- GBool interpolate, int *maskColors, GBool inlineImg) override
+ bool interpolate, int *maskColors, bool inlineImg) override
{
if (bEnableBitmap)
SplashOutputDev::drawImage(state, ref, str,
@@ -305,9 +305,9 @@ class GDALPDFOutputDev : public SplashOu
virtual void drawMaskedImage(GfxState *state, Object *ref, Stream *str,
int width, int height,
GfxImageColorMap *colorMap,
- GBool interpolate,
+ bool interpolate,
Stream *maskStr, int maskWidth, int maskHeight,
- GBool maskInvert, GBool maskInterpolate) override
+ bool maskInvert, bool maskInterpolate) override
{
if (bEnableBitmap)
SplashOutputDev::drawMaskedImage(state, ref, str,
@@ -322,11 +322,11 @@ class GDALPDFOutputDev : public SplashOu
virtual void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,
int width, int height,
GfxImageColorMap *colorMap,
- GBool interpolate,
+ bool interpolate,
Stream *maskStr,
int maskWidth, int maskHeight,
GfxImageColorMap *maskColorMap,
- GBool maskInterpolate) override
+ bool maskInterpolate) override
{
if (bEnableBitmap)
{
@@ -1728,7 +1728,7 @@ CPLErr PDFDataset::ReadPixels( int nReqX
GDALPDFOutputDev *poSplashOut =
new GDALPDFOutputDev(
(nBands < 4) ? splashModeRGB8 : splashModeXBGR8,
- 4, gFalse,
+ 4, false,
(nBands < 4) ? sColor : nullptr);
if (pszRenderingOptions != nullptr)
@@ -1780,7 +1780,7 @@ CPLErr PDFDataset::ReadPixels( int nReqX
iPage,
dfDPI, dfDPI,
0,
- TRUE, gFalse, gFalse,
+ TRUE, false, false,
nReqXOff, nReqYOff,
nReqXSize, nReqYSize);
@@ -2599,7 +2599,7 @@ static void PDFDatasetErrorFunction(CPL_
#else
int nPos,
#endif
- char *pszMsg)
+ const char *pszMsg)
{
CPLString osError;
@@ -3440,16 +3440,15 @@ void PDFDataset::FindLayersPoppler()
}
else
{
- GooList* ocgList = optContentConfig->getOCGs();
- for(int i=0;i<ocgList->getLength();i++)
- {
- OptionalContentGroup* ocg = (OptionalContentGroup*) ocgList->get(i);
- if( ocg != nullptr && ocg->getName() != nullptr )
- {
- const char* pszLayerName = (const char*)ocg->getName()->getCString();
- AddLayer(pszLayerName);
- oLayerOCGMapPoppler[pszLayerName] = ocg;
- }
+ const auto &ocgList = optContentConfig->getOCGs();
+ for (const auto &oc : ocgList) {
+ OptionalContentGroup* ocg = (OptionalContentGroup*) oc.second.get();
+ if( ocg != nullptr && ocg->getName() != nullptr )
+ {
+ const char* pszLayerName = (const char*)ocg->getName()->c_str();
+ AddLayer(pszLayerName);
+ oLayerOCGMapPoppler[pszLayerName] = ocg;
+ }
}
}
@@ -3472,11 +3471,10 @@ void PDFDataset::TurnLayersOnOffPoppler(
{
int i;
int bAll = EQUAL(pszLayers, "ALL");
- GooList* ocgList = optContentConfig->getOCGs();
- for(i=0;i<ocgList->getLength();i++)
- {
- OptionalContentGroup* ocg = (OptionalContentGroup*) ocgList->get(i);
- ocg->setState( (bAll) ? OptionalContentGroup::On : OptionalContentGroup::Off );
+ const auto &ocgList = optContentConfig->getOCGs();
+ for (const auto &oc : ocgList) {
+ OptionalContentGroup* ocg = (OptionalContentGroup*) oc.second.get();
+ ocg->setState( (bAll) ? OptionalContentGroup::On : OptionalContentGroup::Off );
}
char** papszLayers = CSLTokenizeString2(pszLayers, ",", 0);
@@ -4430,7 +4428,7 @@ GDALDataset *PDFDataset::Open( GDALOpenI
#ifdef HAVE_POPPLER
if (bUseLib.test(PDFLIB_POPPLER))
{
- PDFRectangle* psMediaBox = poPagePoppler->getMediaBox();
+ const PDFRectangle* psMediaBox = poPagePoppler->getMediaBox();
dfX1 = psMediaBox->x1;
dfY1 = psMediaBox->y1;
dfX2 = psMediaBox->x2;
@@ -4768,12 +4766,12 @@ GDALDataset *PDFDataset::Open( GDALOpenI
GooString* poMetadata = poCatalogPoppler->readMetadata();
if (poMetadata)
{
- char* pszContent = poMetadata->getCString();
+ const char* pszContent = poMetadata->c_str();
if (pszContent != nullptr &&
STARTS_WITH(pszContent, "<?xpacket begin="))
{
char *apszMDList[2];
- apszMDList[0] = pszContent;
+ apszMDList[0] = (char *) pszContent;
apszMDList[1] = nullptr;
poDS->SetMetadata(apszMDList, "xml:XMP");
}
--- gdal-2.3.2-fedora/frmts/pdf/pdfio.cpp
+++ gdal-2.3.2-fedora/frmts/pdf/pdfio.cpp
@@ -66,7 +66,7 @@ VSIPDFFileStream::VSIPDFFileStream(
poFilename(new GooString(pszFilename)),
f(fIn),
nStart(0),
- bLimited(gFalse),
+ bLimited(false),
nLength(0),
nCurrentPos(VSI_L_OFFSET_MAX),
bHasSavedPos(FALSE),
@@ -80,7 +80,7 @@ VSIPDFFileStream::VSIPDFFileStream(
/************************************************************************/
VSIPDFFileStream::VSIPDFFileStream( VSIPDFFileStream* poParentIn,
- vsi_l_offset startA, GBool limitedA,
+ vsi_l_offset startA, bool limitedA,
vsi_l_offset lengthA,
makeSubStream_object_type dictA) :
#ifdef POPPLER_0_58_OR_LATER
@@ -139,7 +139,7 @@ BaseStream* VSIPDFFileStream::copy()
/************************************************************************/
/* makeSubStream() */
/************************************************************************/
-Stream *VSIPDFFileStream::makeSubStream(makeSubStream_offset_type startA, GBool limitedA,
+Stream *VSIPDFFileStream::makeSubStream(makeSubStream_offset_type startA, bool limitedA,
makeSubStream_offset_type lengthA, makeSubStream_object_type dictA)
{
#ifdef POPPLER_0_58_OR_LATER
@@ -346,7 +346,7 @@ void VSIPDFFileStream::setPos(setPos_off
}
else
{
- if (bLimited == gFalse)
+ if (bLimited == false)
{
VSIFSeekL(f, 0, SEEK_END);
}
@@ -380,7 +380,7 @@ void VSIPDFFileStream::moveStart(moveSta
/* hasGetChars() */
/************************************************************************/
-GBool VSIPDFFileStream::hasGetChars()
+bool VSIPDFFileStream::hasGetChars()
{
return true;
}
@@ -389,7 +389,7 @@ GBool VSIPDFFileStream::hasGetChars()
/* getChars() */
/************************************************************************/
-int VSIPDFFileStream::getChars(int nChars, Guchar *buffer)
+int VSIPDFFileStream::getChars(int nChars, unsigned char *buffer)
{
int nRead = 0;
while (nRead < nChars)
--- gdal-2.3.2-fedora/frmts/pdf/pdfio.h
+++ gdal-2.3.2-fedora/frmts/pdf/pdfio.h
@@ -46,9 +46,9 @@
#define moveStart_delta_type Goffset
#else
#define getPos_ret_type int
-#define getStart_ret_type Guint
-#define makeSubStream_offset_type Guint
-#define setPos_offset_type Guint
+#define getStart_ret_type unsigned int
+#define makeSubStream_offset_type unsigned int
+#define setPos_offset_type unsigned int
#define moveStart_delta_type int
#endif
@@ -64,7 +64,7 @@ class VSIPDFFileStream: public BaseStrea
VSIPDFFileStream(VSILFILE* f, const char* pszFilename,
makeSubStream_object_type dictA);
VSIPDFFileStream(VSIPDFFileStream* poParent,
- vsi_l_offset startA, GBool limitedA,
+ vsi_l_offset startA, bool limitedA,
vsi_l_offset lengthA,
makeSubStream_object_type dictA);
virtual ~VSIPDFFileStream();
@@ -73,7 +73,7 @@ class VSIPDFFileStream: public BaseStrea
virtual BaseStream* copy() override;
#endif
- virtual Stream * makeSubStream(makeSubStream_offset_type startA, GBool limitedA,
+ virtual Stream * makeSubStream(makeSubStream_offset_type startA, bool limitedA,
makeSubStream_offset_type lengthA, makeSubStream_object_type dictA) override;
virtual getPos_ret_type getPos() override;
virtual getStart_ret_type getStart() override;
@@ -99,8 +99,8 @@ class VSIPDFFileStream: public BaseStrea
* This test will be wrong for poppler 0.15 or 0.16,
* but will still compile correctly.
*/
- virtual GBool hasGetChars() override;
- virtual int getChars(int nChars, Guchar *buffer) override;
+ virtual bool hasGetChars() override;
+ virtual int getChars(int nChars, unsigned char *buffer) override;
#else
virtual GBool hasGetChars() ;
virtual int getChars(int nChars, Guchar *buffer) ;
@@ -110,7 +110,7 @@ class VSIPDFFileStream: public BaseStrea
GooString *poFilename;
VSILFILE *f;
vsi_l_offset nStart;
- GBool bLimited;
+ bool bLimited;
vsi_l_offset nLength;
vsi_l_offset nCurrentPos;
--- gdal-2.3.2-fedora/frmts/pdf/pdfobject.cpp
+++ gdal-2.3.2-fedora/frmts/pdf/pdfobject.cpp
@@ -1061,7 +1061,7 @@ const CPLString& GDALPDFObjectPoppler::G
#else
GooString* gooString = m_po->getString();
#endif
- return (osStr = GDALPDFGetUTF8StringFromBytes(reinterpret_cast<const GByte*>(gooString->getCString()),
+ return (osStr = GDALPDFGetUTF8StringFromBytes(reinterpret_cast<const GByte*>(gooString->c_str()),
static_cast<int>(gooString->getLength())));
}
else
@@ -1422,7 +1422,7 @@ char* GDALPDFStreamPoppler::GetBytes()
char* pszContent = (char*) VSIMalloc(m_nLength + 1);
if (pszContent)
{
- memcpy(pszContent, gstr->getCString(), m_nLength);
+ memcpy(pszContent, gstr->c_str(), m_nLength);
pszContent[m_nLength] = '\0';
}
delete gstr;
--- gdal-2.3.2-fedora/frmts/pdf/pdfsdk_headers.h
+++ gdal-2.3.2-fedora/frmts/pdf/pdfsdk_headers.h
@@ -50,7 +50,6 @@
#pragma warning( disable : 4244 ) /* conversion from 'const int' to 'Guchar', possible loss of data */
#endif
-#include <goo/gtypes.h>
#include <goo/GooList.h>
/* begin of poppler xpdf includes */

View File

@ -1,5 +1,5 @@
#!/bin/bash
VERSION="2.3.1"
VERSION="2.3.2"
tar xvf gdal-"${VERSION}".tar.xz

View File

@ -1,6 +0,0 @@
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<modelVersion>4.0.0</modelVersion>
<groupId>org.gdal</groupId>
<artifactId>gdal-java-bindings</artifactId>
<version></version>
</project>

207
gdal.spec
View File

@ -1,5 +1,4 @@
#TODO: g2clib and grib (said to be modified)
#TODO: Python 3 modules should be possible since 1.7
#TODO: Create script to make clean tarball
#TODO: msg needs to have PublicDecompWT.zip from EUMETSAT, which is not free;
# Building without msg therefore
@ -21,10 +20,10 @@
# He also suggest to use --with-static-proj4 to actually link to proj, instead of dlopen()ing it.
# Major digit of the proj so version
%global proj_somaj 12
%global proj_somaj 13
# Tests can be of a different version
%global testversion 2.3.1
%global testversion 2.3.2
%global run_tests 0
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -51,6 +50,9 @@
%global spatialite "--with-spatialite"
%endif
%bcond_with python2
%bcond_without python3
# No ppc64 build for spatialite in EL6
# https://bugzilla.redhat.com/show_bug.cgi?id=663938
%if 0%{?rhel} == 6
@ -61,10 +63,9 @@
%endif
Name: gdal
Version: 2.3.1
Release: 3.0.riscv64%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Version: 2.3.2
Release: 10.0.riscv64%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
Group: System Environment/Libraries
License: MIT
URL: http://www.gdal.org
# Source0: http://download.osgeo.org/gdal/%%{version}/gdal-%%{version}.tar.xz
@ -72,7 +73,6 @@ URL: http://www.gdal.org
Source0: %{name}-%{version}-fedora.tar.xz
Source1: http://download.osgeo.org/%{name}/%{testversion}/%{name}autotest-%{testversion}.tar.gz
Source2: %{name}.pom
# Cleaner script for the tarball
Source3: %{name}-cleaner.sh
@ -94,6 +94,8 @@ Patch9: %{name}-2.3.0-zlib.patch
# https://github.com/OSGeo/gdal/pull/876
Patch10: %{name}-2.3.1-perl-build.patch
Patch11: %{name}-2.3.2-poppler-0.73.0.patch
BuildRequires: gcc gcc-c++
BuildRequires: ant
@ -111,7 +113,7 @@ BuildRequires: fontconfig-devel
# No freexl in EL5
BuildRequires: freexl-devel
BuildRequires: g2clib-static
BuildRequires: geos-devel
BuildRequires: geos-devel >= 3.7.1
BuildRequires: ghostscript
BuildRequires: hdf-devel
BuildRequires: hdf-static
@ -119,7 +121,7 @@ BuildRequires: hdf5-devel
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: jasper-devel
BuildRequires: jpackage-utils
# add_maven_depmap macro moved into this package in F27, it seems like
# For 'mvn_artifact' and 'mvn_install'
BuildRequires: javapackages-local
BuildRequires: json-c-devel
BuildRequires: libgeotiff-devel
@ -146,8 +148,6 @@ BuildRequires: librx-devel
%if 0%{?with_mysql}
BuildRequires: mariadb-connector-c-devel
%endif
BuildRequires: numpy
BuildRequires: python3-numpy
BuildRequires: pcre-devel
BuildRequires: ogdi-devel
BuildRequires: perl-devel
@ -158,10 +158,16 @@ BuildRequires: %{_bindir}/pkg-config
%if 0%{?with_poppler}
BuildRequires: poppler-devel
%endif
BuildRequires: postgresql-devel
BuildRequires: proj-devel
BuildRequires: libpq-devel
BuildRequires: proj-devel >= 5.2.0
%if %{with python2}
BuildRequires: python2-devel
BuildRequires: python2-numpy
%endif
%if %{with python3}
BuildRequires: python3-devel
BuildRequires: python3-numpy
%endif
BuildRequires: sqlite-devel
BuildRequires: swig
%if %{build_refman}
@ -223,7 +229,6 @@ GDAL/OGR is the most widely used geospatial data access library.
%package devel
Summary: Development files for the GDAL file format library
Group: Development/Libraries
# Old rpm didn't figure out
%if 0%{?rhel} < 6
@ -239,7 +244,6 @@ This package contains development files for GDAL.
%package libs
Summary: GDAL file format library
Group: System Environment/Libraries
# https://trac.osgeo.org/gdal/ticket/3978#comment:5
Obsoletes: %{name}-ruby < 1.11.0-1
@ -249,7 +253,6 @@ This package contains the GDAL file format library.
%package java
Summary: Java modules for the GDAL file format library
Group: Development/Libraries
Requires: jpackage-utils
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@ -259,7 +262,6 @@ The GDAL Java modules provide support to handle multiple GIS file formats.
%package javadoc
Summary: Javadocs for %{name}
Group: Documentation
Requires: jpackage-utils
BuildArch: noarch
@ -269,14 +271,13 @@ This package contains the API documentation for %{name}.
%package perl
Summary: Perl modules for the GDAL file format library
Group: Development/Libraries
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description perl
The GDAL Perl modules provide support to handle multiple GIS file formats.
%if %{with python2}
%package -n python2-gdal
%{?python_provide:%python_provide python2-gdal}
# Remove before F30
@ -284,31 +285,42 @@ Provides: %{name}-python = %{version}-%{release}
Provides: %{name}-python%{?_isa} = %{version}-%{release}
Obsoletes: %{name}-python < %{version}-%{release}
Summary: Python modules for the GDAL file format library
Group: Development/Libraries
Requires: numpy
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n python2-gdal
The GDAL Python modules provide support to handle multiple GIS file formats.
The package also includes a couple of useful utilities in Python.
%endif
%if %{with python3}
%package -n python3-gdal
%{?python_provide:%python_provide python3-gdal}
Summary: Python modules for the GDAL file format library
Group: Development/Libraries
Requires: python3-numpy
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Obsoletes: gdal-python3 < 2.3.1
Provides: gdal-python3
Provides: gdal-python3 = %version-%release
%description -n python3-gdal
The GDAL Python 3 modules provide support to handle multiple GIS file formats.
%endif
%if %{with python2} || %{with python3}
%package python-tools
Summary: Python tools for the GDAL file format library
Requires: %{?with_python3:python3-gdal}%{?!with_python3:python2-gdal}
%description python-tools
The GDAL Python package provides number of tools for programming and
manipulating GDAL file format library
%endif
%package doc
Summary: Documentation for GDAL
Group: Documentation
BuildArch: noarch
%description doc
@ -330,12 +342,13 @@ rm -rf frmts/gtiff/libgeotiff \
frmts/gtiff/libtiff
#rm -r frmts/grib/degrib/g2clib
#%patch1 -p1 -b .g2clib~
#%patch2 -p1 -b .jni~
#%%patch1 -p1 -b .g2clib~
#%%patch2 -p1 -b .jni~
%patch3 -p1 -b .completion~
%patch8 -p1 -b .java~
%patch9 -p1 -b .zlib~
%patch10 -p1 -b .perl-build~
%patch11 -p1 -b .poppler-0.73.0
# Copy in PROVENANCE.TXT-fedora
cp -p %SOURCE4 .
@ -381,6 +394,7 @@ sed -i 's|-L\$with_geotiff\/lib -lgeotiff $LIBS|-lgeotiff $LIBS|g' configure
# http://trac.osgeo.org/gdal/ticket/3602
sed -i 's|libproj.so|libproj.so.%{proj_somaj}|g' ogr/ogrct.cpp
%if %{with python3} || %{with python2}
# Fix Python samples to depend on correct interpreter
mkdir -p swig/python3/samples
pushd swig/python/samples
@ -390,6 +404,7 @@ for f in `find . -name '*.py'`; do
sed -i 's|^#!.\+python$|#!/usr/bin/python2|' $f
done
popd
%endif
# Adjust check for LibDAP version
# http://trac.osgeo.org/gdal/ticket/4545
@ -499,13 +514,15 @@ popd
# Make Java module and documentation
pushd swig/java
make
./make_doc.sh
ant maven
popd
%mvn_artifact swig/java/build/maven/gdal-%version.pom swig/java/build/maven/gdal-%version.jar
# Make Python modules
pushd swig/python
%py3_build
%py2_build
%{?with_python2:%py2_build}
%{?with_python3:%py3_build}
popd
# Make Python modules
@ -552,8 +569,8 @@ done
rm -rf %{buildroot}
pushd swig/python
%py3_install
%py2_install
%{?with_python2:%py2_install}
%{?with_python3:%py3_install}
popd
pushd swig/perl
@ -576,26 +593,17 @@ mkdir -p %{buildroot}%{_libdir}/%{name}plugins
find %{buildroot}%{perl_vendorarch} -name "*.dox" -exec rm -rf '{}' \;
rm %{buildroot}%{perl_archlib}/perllocal.pod
%if %{without python} && %{without python3}
rm %buildroot%_mandir/man1/{pct2rgb,rgb2pct}.1
%endif
# Correct permissions
#TODO and potential ticket: Why are the permissions not correct?
find %{buildroot}%{perl_vendorarch} -name "*.so" -exec chmod 755 '{}' \;
find %{buildroot}%{perl_vendorarch} -name "*.pm" -exec chmod 644 '{}' \;
#TODO: JAR files that require JNI shared objects MUST be installed in %%{_libdir}/%%{name}. The JNI shared objects themselves must also be installed in %%{_libdir}/%%{name}.
#Java programs that wish to make calls into native libraries do so via the Java Native Interface (JNI). A Java package uses JNI if it contains a .so
#If the JNI-using code calls System.loadLibrary you'll have to patch it to use System.load, passing it the full path to the dynamic shared object. If the package installs a wrapper script you'll need to manually add %%{_libdir}/%%{name}/<jar filename> to CLASSPATH. If you are depending on a JNI-using JAR file, you'll need to add it manually -- build-classpath will not find it.
touch -r NEWS swig/java/gdal.jar
mkdir -p %{buildroot}%{_javadir}
cp -p swig/java/gdal.jar \
%{buildroot}%{_javadir}/%{name}.jar
# Install Maven pom and update version number
install -dm 755 %{buildroot}%{_mavenpomdir}
install -pm 644 %{SOURCE2} %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
sed -i 's|<version></version>|<version>%{version}</version>|' %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
# Create depmap fragment
%add_maven_depmap JPP-%{name}.pom %{name}.jar
# install Java plugin
%mvn_install -J swig/java/java
# 775 on the .so?
# copy JNI libraries and links, non versioned link needed by JNI
@ -730,33 +738,31 @@ done
pushd %{name}autotest-%{testversion}
# Export test enviroment
export PYTHONPATH=$PYTHONPATH:%{buildroot}%{python_sitearch}
#TODO: Nötig?
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir}
# export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%%{buildroot}%%{_libdir}:$java_inc
# Export test enviroment
export PYTHONPATH=$PYTHONPATH:%{buildroot}%{python_sitearch}
#TODO: Nötig?
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir}
# export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%%{buildroot}%%{_libdir}:$java_inc
export GDAL_DATA=%{buildroot}%{_datadir}/%{name}/
export GDAL_DATA=%{buildroot}%{_datadir}/%{name}/
# Enable these tests on demand
#export GDAL_RUN_SLOW_TESTS=1
#export GDAL_DOWNLOAD_TEST_DATA=1
# Enable these tests on demand
#export GDAL_RUN_SLOW_TESTS=1
#export GDAL_DOWNLOAD_TEST_DATA=1
# Remove some test cases that would require special preparation
rm -rf ogr/ogr_pg.py # No database available
rm -rf ogr/ogr_mysql.py # No database available
rm -rf osr/osr_esri.py # ESRI datum absent
rm -rf osr/osr_erm.py # File from ECW absent
# Remove some test cases that would require special preparation
rm -rf ogr/ogr_pg.py # No database available
rm -rf ogr/ogr_mysql.py # No database available
rm -rf osr/osr_esri.py # ESRI datum absent
rm -rf osr/osr_erm.py # File from ECW absent
# Run tests but force normal exit in the end
./run_all.py || true
# Run tests but force normal exit in the end
./run_all.py || true
popd
%endif #%%{run_tests}
%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%ldconfig_scriptlets libs
%files
@ -816,35 +822,28 @@ popd
# Can I even have a separate Java package anymore?
%files java -f .mfiles
%doc swig/java/apps
%{_jnidir}/%{name}/
%{_jnidir}/%{name}/libgdalalljni.so*
%files javadoc
%{_javadocdir}/%{name}
%files javadoc -f .mfiles-javadoc
%files perl
%doc swig/perl/README
%{perl_vendorarch}/*
%{_mandir}/man3/*.3pm*
%if %{with python2}
%files -n python2-gdal
%doc swig/python/README.txt
%doc swig/python/samples
#TODO: Bug with .py files in EPEL 5 bindir, see http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies
%{_bindir}/*.py
%{_mandir}/man1/pct2rgb.1*
%{_mandir}/man1/rgb2pct.1*
%{_mandir}/man1/gdal2tiles.1*
%{_mandir}/man1/gdal_fillnodata.1*
%{_mandir}/man1/gdal_merge.1*
%{_mandir}/man1/gdal_retile.1*
%{_mandir}/man1/gdal_sieve.1*
%{python2_sitearch}/osgeo
%{python2_sitearch}/GDAL-%{version}-py*.egg-info
%{python2_sitearch}/osr.py*
%{python2_sitearch}/ogr.py*
%{python2_sitearch}/gdal*.py*
%{python2_sitearch}/gnm.py*
%endif
%if %{with python3}
%files -n python3-gdal
%doc swig/python/README.txt
%doc swig/python3/samples
@ -858,6 +857,19 @@ popd
%{python3_sitearch}/__pycache__/gdal*.*.py*
%{python3_sitearch}/gnm.py*
%{python3_sitearch}/__pycache__/gnm.*.py*
%endif
%if %{with python2} || %{with python3}
%files python-tools
%_bindir/*.py
%{_mandir}/man1/pct2rgb.1*
%{_mandir}/man1/rgb2pct.1*
%{_mandir}/man1/gdal2tiles.1*
%{_mandir}/man1/gdal_fillnodata.1*
%{_mandir}/man1/gdal_merge.1*
%{_mandir}/man1/gdal_retile.1*
%{_mandir}/man1/gdal_sieve.1*
%endif
%files doc
%doc gdal_frmts ogrsf_frmts refman
@ -871,9 +883,42 @@ popd
#Or as before, using ldconfig
%changelog
* Thu Aug 30 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.3.1-3.0.riscv64
* Wed Jul 31 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> - 2.3.2-10.0.riscv64
- Add RISC-V (riscv64) to gdal-config
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.2-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Jun 01 2019 Jitka Plesnikova <jplesnik@redhat.com> - 2.3.2-9
- Perl 5.30 rebuild
* Sat Mar 16 2019 Orion Poplawski <orion@nwra.com>
- Rebuild for hdf5 1.10.5
* Tue Feb 05 2019 Miro Hrončok <mhroncok@redhat.com> - 2.3.2-7
- Drop Python 2 subpackage for mass Python 2 packages removal
* Mon Feb 04 2019 Pavel Raiskup <praiskup@redhat.com> - 2.3.2-6
- modernize java packaging (PR#9)
* Mon Feb 04 2019 Devrim Gündüz <devrim@gunduzorg> - 2.3.2-6
- Rebuild for new GeOS and Proj
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jan 26 2019 Marek Kasik <mkasik@redhat.com> - 2.3.2-4
- Additional fixes for the rebuild
* Fri Jan 25 2019 Marek Kasik <mkasik@redhat.com> - 2.3.2-3
- Rebuild for poppler-0.73.0
* Thu Oct 04 2018 Pavel Raiskup <praiskup@redhat.com> - 2.3.2-2
- Python 3 is the default Python now
* Mon Oct 1 2018 Volker Fröhlich <volker27@gmx.at> - 2.3.2-1
- New upstream release
* Mon Aug 27 2018 José Abílio Matos <jamatos@fc.up.pt> - 2.3.1-3
- rebuild for armadillo soname bump (take 2)
@ -1464,7 +1509,7 @@ popd
- Added jnis
- Patches updated with proper version info
- Added suggestions from Ralph Apel <r.apel@r-apel.de>
+ Versionless symlink for gdal.jar
+ Maven2 pom
+ JPP-style depmap
+ Use -f XX.files for ruby and python
+ Versionless symlink for gdal.jar
+ Maven2 pom
+ JPP-style depmap
+ Use -f XX.files for ruby and python

View File

@ -1,2 +1,2 @@
SHA512 (gdalautotest-2.3.1.tar.gz) = acd3bf4fb719b9aa44b41eb14ae1676cde6a3213e14defa91220680ab1411ae9fbcb5227fb64d5c3c12b89b721986e7f93184eb7c5702cbe81a57a57dac1b403
SHA512 (gdal-2.3.1-fedora.tar.xz) = da128e67d505d9e988b6af1255206ed84b491a1ec9fb8ecd13980259b0405d3eb7f9352ae80bd714b5398ec2092206429a3f25ed0211b461d20888bd2e854ef1
SHA512 (gdalautotest-2.3.2.tar.gz) = 7781d48407acb4a643175f5f9ecf625ad463a57c6c69c212d4b273d633b34cc8b9bb18d79a303c4905b345f400947d7952d7c75254db7b2f5fadfee865a98815
SHA512 (gdal-2.3.2-fedora.tar.xz) = d9fc4e3395af00673c3d62c3eed9175886ca9efa706f7712a933176245f73b3f348844fb2e5f4315aa6cb079fbc1cfbc64273aeeac91cc5a0b1d2f7bc1a3bc14