Merge remote-tracking branch 'up/f29' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2018-08-26 06:14:00 +03:00
commit 3efd8f7b5a
Signed by: davidlt
GPG Key ID: 7108702C938B13C1
7 changed files with 132 additions and 67 deletions

2
.gitignore vendored
View File

@ -37,3 +37,5 @@ gdalautotest-1.7.0.tar.gz
/gdal-2.2.3-fedora.tar.xz
/gdalautotest-2.2.4.tar.gz
/gdal-2.2.4-fedora.tar.xz
/gdalautotest-2.3.1.tar.gz
/gdal-2.3.1-fedora.tar.xz

View File

@ -1,13 +0,0 @@
Index: gdal-2.2.3-fedora/frmts/mrf/mrf_band.cpp
===================================================================
--- gdal-2.2.3-fedora.orig/frmts/mrf/mrf_band.cpp
+++ gdal-2.2.3-fedora/frmts/mrf/mrf_band.cpp
@@ -49,7 +49,7 @@
#include <vector>
#include <assert.h>
-#include "../zlib/zlib.h"
+#include <zlib.h>
CPL_CVSID("$Id: mrf_band.cpp 37663 2017-03-09 20:42:19Z lplesea $");

13
gdal-2.3.0-zlib.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/frmts/mrf/mrf_band.cpp b/frmts/mrf/mrf_band.cpp
index d5b3403..0772ec8 100644
--- a/frmts/mrf/mrf_band.cpp
+++ b/frmts/mrf/mrf_band.cpp
@@ -49,7 +49,7 @@
#include <vector>
#include <assert.h>
-#include "../zlib/zlib.h"
+#include <zlib.h>
CPL_CVSID("$Id: mrf_band.cpp 7e07230bbff24eb333608de4dbd460b7312839d0 2017-12-11 19:08:47Z Even Rouault $")

View File

@ -0,0 +1,46 @@
From 33beac3add11101ba09b3261adcd3375f87b51dd Mon Sep 17 00:00:00 2001
From: Pavel Raiskup <praiskup@redhat.com>
Date: Tue, 21 Aug 2018 12:58:49 +0200
Subject: [PATCH] swig-perl: fix make dep graph
Makefile_Geo__GDAL must depend on Makefile.PL, instead of
non-existing gdal_wrap.cc (otherwise the module rebuilds on every
make hit).
Upstream proposal:
https://github.com/OSGeo/gdal/pull/876
Also the 'generate' target should be .PHONY.
---
gdal/swig/perl/GNUmakefile | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/swig/perl/GNUmakefile b/swig/perl/GNUmakefile
index 68d389d..2dfd533 100644
--- a/swig/perl/GNUmakefile
+++ b/swig/perl/GNUmakefile
@@ -20,16 +20,14 @@ generate: ${WRAPPERS}
if [ -f OSR.pm ]; then mv OSR.pm lib/Geo; fi
if [ -f GNM.pm ]; then mv GNM.pm lib/Geo; fi
-build: gdal_wrap.cc Makefile_Geo__GDAL
+build: Makefile_Geo__GDAL
$(MAKE) -f Makefile_Geo__GDAL
$(MAKE) -f Makefile_Geo__GDAL__Const
$(MAKE) -f Makefile_Geo__OSR
if [ -f Makefile_Geo__OGR ]; then $(MAKE) -f Makefile_Geo__OGR; fi
if [ -f Makefile_Geo__GNM ]; then $(MAKE) -f Makefile_Geo__GNM; fi
-gdal_wrap.cc: generate
-
-Makefile_Geo__GDAL: gdal_wrap.cc
+Makefile_Geo__GDAL: Makefile.PL
perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
test: build
@@ -66,3 +64,5 @@ doc: .FORCE
.FORCE:
perl parse-for-doxygen.pl > all.pm; doxygen; rm -f all.pm
+
+.PHONY: generate

View File

@ -1,6 +1,5 @@
#!/bin/bash
# Volker Fröhlich
VERSION="2.2.4"
VERSION="2.3.1"
tar xvf gdal-"${VERSION}".tar.xz

118
gdal.spec
View File

@ -24,7 +24,7 @@
%global proj_somaj 12
# Tests can be of a different version
%global testversion 2.2.4
%global testversion 2.3.1
%global run_tests 0
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -61,8 +61,8 @@
%endif
Name: gdal
Version: 2.2.4
Release: 4.1.riscv64%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Version: 2.3.1
Release: 2.0.riscv64%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
Group: System Environment/Libraries
License: MIT
@ -89,9 +89,13 @@ Patch3: %{name}-completion.patch
# Fedora uses Alternatives for Java
Patch8: %{name}-1.9.0-java.patch
Patch9: %{name}-2.2.2-zlib.patch
Patch9: %{name}-2.3.0-zlib.patch
# https://github.com/OSGeo/gdal/pull/876
Patch10: %{name}-2.3.1-perl-build.patch
BuildRequires: gcc gcc-c++
BuildRequires: ant
# No armadillo in EL5
BuildRequires: armadillo-devel
@ -171,6 +175,7 @@ BuildRequires: texlive-collection-latex
BuildRequires: texlive-epstopdf
BuildRequires: tex(multirow.sty)
BuildRequires: tex(sectsty.sty)
BuildRequires: tex(tabu.sty)
BuildRequires: tex(tocloft.sty)
BuildRequires: tex(xtab.sty)
%endif
@ -288,13 +293,16 @@ The GDAL Python modules provide support to handle multiple GIS file formats.
The package also includes a couple of useful utilities in Python.
%package python3
%package -n python3-gdal
%{?python_provide:%python_provide python3-gdal}
Summary: Python modules for the GDAL file format library
Group: Development/Libraries
Requires: python3-numpy
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Obsoletes: gdal-python3 < 2.3.1
Provides: gdal-python3
%description python3
%description -n python3-gdal
The GDAL Python 3 modules provide support to handle multiple GIS file formats.
@ -320,13 +328,14 @@ rm -rf frmts/jpeg/libjpeg \
frmts/jpeg/libjpeg12
rm -rf frmts/gtiff/libgeotiff \
frmts/gtiff/libtiff
rm -r frmts/grib/degrib18/g2clib-1.0.4
#rm -r frmts/grib/degrib/g2clib
%patch1 -p1 -b .g2clib~
%patch2 -p1 -b .jni~
#%patch1 -p1 -b .g2clib~
#%patch2 -p1 -b .jni~
%patch3 -p1 -b .completion~
%patch8 -p1 -b .java~
%patch9 -p1 -b .zlib~
%patch10 -p1 -b .perl-build~
# Copy in PROVENANCE.TXT-fedora
cp -p %SOURCE4 .
@ -351,15 +360,13 @@ for f in `find . -type f` ; do
done
set -x
# Solved for 2.0
for f in ogr/ogrsf_frmts/gpsbabel ogr/ogrsf_frmts/pgdump port apps; do
for f in apps; do
pushd $f
chmod 644 *.cpp *.h
chmod 644 *.cpp
popd
done
# Replace hard-coded library- and include paths
sed -i 's|@LIBTOOL@|%{_bindir}/libtool|g' GDALmake.opt.in
sed -i 's|-L\$with_cfitsio -L\$with_cfitsio/lib -lcfitsio|-lcfitsio|g' configure
sed -i 's|-I\$with_cfitsio -I\$with_cfitsio/include|-I\$with_cfitsio/include/cfitsio|g' configure
sed -i 's|-L\$with_netcdf -L\$with_netcdf/lib -lnetcdf|-lnetcdf|g' configure
@ -374,9 +381,6 @@ sed -i 's|-L\$with_geotiff\/lib -lgeotiff $LIBS|-lgeotiff $LIBS|g' configure
# http://trac.osgeo.org/gdal/ticket/3602
sed -i 's|libproj.so|libproj.so.%{proj_somaj}|g' ogr/ogrct.cpp
# Fix Python installation path
sed -i 's|setup.py install|setup.py install --root=$DESTDIR|' swig/python/GNUmakefile
# Fix Python samples to depend on correct interpreter
mkdir -p swig/python3/samples
pushd swig/python/samples
@ -463,10 +467,11 @@ export CPPFLAGS="$CPPFLAGS -I%{_includedir}/libgeotiff -I%{_includedir}/tirpc"
--with-webp \
--with-xerces \
--enable-shared \
--with-perl \
--with-python \
--with-libkml
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
# {?_smp_mflags} doesn't work; Or it does -- who knows!
# NOTE: running autoconf seems to break build:
# fitsdataset.cpp:37:10: fatal error: fitsio.h: No such file or directory
@ -482,12 +487,6 @@ make %{?_smp_mflags} $POPPLER_OPTS
make man
make docs
# Make Perl modules
pushd swig/perl
perl Makefile.PL; make;
echo > Makefile.PL;
popd
# Build some utilities, as requested in BZ #1271906
pushd ogr/ogrsf_frmts/s57/
make all
@ -497,22 +496,22 @@ pushd frmts/iso8211/
make all
popd
# Install the Perl modules in the right place
sed -i 's|INSTALLDIRS = site|INSTALLDIRS = vendor|' swig/perl/Makefile_*
# Don't append installation info to pod
#TODO: What about the pod?
sed -i 's|>> $(DESTINSTALLARCHLIB)\/perllocal.pod|> \/dev\/null|g' swig/perl/Makefile_*
# Make Java module and documentation
pushd swig/java
make
./make_doc.sh
popd
# Make Python 3 module
# Make Python modules
pushd swig/python
%{__python3} setup.py build
%py3_build
%py2_build
popd
# Make Python modules
pushd swig/perl
perl Makefile.PL INSTALLDIRS=vendor
%make_build
popd
# --------- Documentation ----------
@ -552,10 +551,13 @@ done
%install
rm -rf %{buildroot}
# Install Python 3 module
# Must be done first so executables are Python 2.
pushd swig/python
%{__python3} setup.py install --skip-build --root %{buildroot}
%py3_install
%py2_install
popd
pushd swig/perl
%make_install
popd
make DESTDIR=%{buildroot} \
@ -572,7 +574,7 @@ mkdir -p %{buildroot}%{_libdir}/%{name}plugins
#TODO: Don't do that?
find %{buildroot}%{perl_vendorarch} -name "*.dox" -exec rm -rf '{}' \;
rm -f %{buildroot}%{perl_archlib}/perllocal.pod
rm %{buildroot}%{perl_archlib}/perllocal.pod
# Correct permissions
#TODO and potential ticket: Why are the permissions not correct?
@ -716,12 +718,6 @@ for f in 'GDAL*' BandProperty ColorAssociation CutlineTransformer DatasetPropert
rm -rf %{buildroot}%{_mandir}/man1/$f.1*
done
# Fix python interpreter
sed -i '1s|^#!/usr/bin/env python$|#!%{__python2}|' %{buildroot}%{_bindir}/*.py
# Cleanup .pyc for now
rm -f %{buildroot}%{_bindir}/*.pyc
#TODO: What's that?
rm -f %{buildroot}%{_mandir}/man1/*_%{name}-%{version}-fedora_apps_*
rm -f %{buildroot}%{_mandir}/man1/_home_rouault_dist_wrk_gdal_apps_.1*
@ -801,8 +797,9 @@ popd
%files libs
%doc LICENSE.TXT NEWS PROVENANCE.TXT COMMITERS PROVENANCE.TXT-fedora
%{_libdir}/libgdal.so.*
%doc LICENSE.TXT NEWS PROVENANCE.TXT COMMITTERS PROVENANCE.TXT-fedora
%{_libdir}/libgdal.so.20
%{_libdir}/libgdal.so.20.*
%{_datadir}/%{name}
#TODO: Possibly remove files like .dxf, .dgn, ...
%dir %{_libdir}/%{name}plugins
@ -848,7 +845,7 @@ popd
%{python2_sitearch}/gdal*.py*
%{python2_sitearch}/gnm.py*
%files python3
%files -n python3-gdal
%doc swig/python/README.txt
%doc swig/python3/samples
%{python3_sitearch}/osgeo
@ -874,12 +871,33 @@ popd
#Or as before, using ldconfig
%changelog
* Tue Jun 26 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.2.4-4.1.riscv64
- Rebuild for poppler (SOVERSION bump)
* Fri Jun 22 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.2.4-4.0.riscv64
* Sun Aug 26 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 2.3.1-2.0.riscv64
- Add RISC-V (riscv64) to gdal-config
* Fri Aug 17 2018 José Abílio Matos <jamatos@fc.up.pt> - 2.3.1-2
- rebuild for armadillo soname bump
* Tue Aug 14 2018 Volker Fröhlich <volker27@gmx.at> - 2.3.1-1
- New upstream release
* Tue Aug 14 2018 Marek Kasik <mkasik@redhat.com> - 2.2.4-10
- Rebuild for poppler-0.67.0
* Wed Jul 25 2018 Devrim Gündüz <devrim@gunduz.org> - 2.2.4-9
- Fix #1606875
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.4-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jul 03 2018 Petr Pisar <ppisar@redhat.com> - 2.2.4-7
- Perl 5.28 rebuild
* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.2.4-6
- Perl 5.28 rebuild
* Fri Jun 22 2018 Orion Poplawski <orion@nwra.com> - 2.2.4-5
- Rebuild for libdap 3.19.1
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.4-4
- Rebuilt for Python 3.7

View File

@ -1,2 +1,2 @@
SHA512 (gdalautotest-2.2.4.tar.gz) = c7dd8e007c84b112f7d6384d5e28981a929b81409b41bd02495c4d7b99a72aa4ee92884a90e0246c3b1c8c723b9272979a89f15b00794abebde97a36d6344ee9
SHA512 (gdal-2.2.4-fedora.tar.xz) = a8c878c0b9ea56575eaa72434990a1473a9dfc40dc7794d0a752846b0f945e8f38da02b7a264f7450b44ba3d021ee7af6e1ec6be57e955594f4b33caa4d1ddd0
SHA512 (gdalautotest-2.3.1.tar.gz) = acd3bf4fb719b9aa44b41eb14ae1676cde6a3213e14defa91220680ab1411ae9fbcb5227fb64d5c3c12b89b721986e7f93184eb7c5702cbe81a57a57dac1b403
SHA512 (gdal-2.3.1-fedora.tar.xz) = da128e67d505d9e988b6af1255206ed84b491a1ec9fb8ecd13980259b0405d3eb7f9352ae80bd714b5398ec2092206429a3f25ed0211b461d20888bd2e854ef1