Update to 3.2.1

This commit is contained in:
Sandro Mani 2021-01-05 10:40:29 +01:00
parent ebee805e37
commit 38fa95eb78
10 changed files with 51 additions and 45 deletions

2
.gitignore vendored
View File

@ -55,3 +55,5 @@ gdalautotest-1.7.0.tar.gz
/gdalautotest-3.1.4.tar.gz
/gdalautotest-3.2.0.tar.gz
/gdal-3.2.0-fedora.tar.xz
/gdal-3.2.1-fedora.tar.xz
/gdalautotest-3.2.1.tar.gz

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/swig/java/java.opt gdal-3.2.0-fedora-new/swig/java/java.opt
--- gdal-3.2.0-fedora/swig/java/java.opt 2020-10-26 14:05:40.000000000 +0100
+++ gdal-3.2.0-fedora-new/swig/java/java.opt 2020-11-12 00:13:52.048881098 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/swig/java/java.opt gdal-3.2.1-fedora-new/swig/java/java.opt
--- gdal-3.2.1-fedora/swig/java/java.opt 2020-12-29 13:15:47.000000000 +0100
+++ gdal-3.2.1-fedora-new/swig/java/java.opt 2021-01-04 21:49:35.504249023 +0100
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java

View File

@ -1,29 +1,30 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.2.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.2.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2020-10-26 14:09:09.000000000 +0100
+++ gdal-3.2.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2020-11-12 00:13:53.604880951 +0100
@@ -38,6 +38,7 @@
#include <iostream>
#include <memory>
#include <string>
+#include <limits>
#if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__)
// gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string
--- gdal-3.2.0-fedora.orig/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2020-10-26 14:09:10.000000000 +0100
+++ gdal-3.2.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2020-12-09 13:25:53.532821589 +0100
@@ -33,6 +33,7 @@
diff -rupN --no-dereference gdal-3.2.1-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp
--- gdal-3.2.1-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2020-12-29 13:19:32.000000000 +0100
+++ gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-01-04 21:49:36.914247237 +0100
@@ -34,6 +34,7 @@
#include <limits>
#include <math.h>
#include <algorithm>
+#include <limits>
//------------------------------------------------------------------------------
// CADVector
diff -ruN gdal-3.2.0-fedora.orig/third_party/LercLib/Lerc2.h gdal-3.2.0-fedora/third_party/LercLib/Lerc2.h
--- gdal-3.2.0-fedora.orig/third_party/LercLib/Lerc2.h 2020-10-26 14:09:38.000000000 +0100
+++ gdal-3.2.0-fedora/third_party/LercLib/Lerc2.h 2020-12-09 13:16:21.573217232 +0100
@@ -29,6 +29,7 @@
#include <cmath>
diff -rupN --no-dereference gdal-3.2.1-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.2.1-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2020-12-29 13:19:31.000000000 +0100
+++ gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-01-04 21:49:36.913247238 +0100
@@ -39,6 +39,7 @@
#include <limits>
#include <memory>
#include <string>
+#include <limits>
#if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__)
// gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string
diff -rupN --no-dereference gdal-3.2.1-fedora/third_party/LercLib/Lerc2.h gdal-3.2.1-fedora-new/third_party/LercLib/Lerc2.h
--- gdal-3.2.1-fedora/third_party/LercLib/Lerc2.h 2020-12-29 13:20:02.000000000 +0100
+++ gdal-3.2.1-fedora-new/third_party/LercLib/Lerc2.h 2021-01-04 21:49:36.914247237 +0100
@@ -30,6 +30,7 @@ Contributors: Thomas Maurer
#include <limits>
#include <string>
#include <typeinfo>
+#include <limits>

View File

@ -8,7 +8,7 @@
#TODO: Consider doxy patch from Suse, setting EXTRACT_LOCAL_CLASSES = NO
# Tests can be of a different version
%global testversion 3.2.0
%global testversion 3.2.1
%global run_tests 1
%global bashcompletiondir %(pkg-config --variable=compatdir bash-completion)
@ -44,7 +44,7 @@
%endif
Name: gdal
Version: 3.2.0
Version: 3.2.1
Release: 1%{?dist}%{?bootstrap:.%{bootstrap}.bootstrap}
Summary: GIS file format library
License: MIT
@ -667,6 +667,9 @@ popd
#Or as before, using ldconfig
%changelog
* Mon Jan 04 2021 Sandro Mani <manisandro@gmail.coM> - 3.2.1-1
- Update to 3.2.1
* Thu Nov 05 2020 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
- Update to 3.2.0

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/apps/GNUmakefile gdal-3.2.0-fedora-new/apps/GNUmakefile
--- gdal-3.2.0-fedora/apps/GNUmakefile 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/apps/GNUmakefile 2020-11-12 00:13:53.083881000 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/apps/GNUmakefile gdal-3.2.1-fedora-new/apps/GNUmakefile
--- gdal-3.2.1-fedora/apps/GNUmakefile 2020-12-29 13:15:46.000000000 +0100
+++ gdal-3.2.1-fedora-new/apps/GNUmakefile 2021-01-04 21:49:36.444247832 +0100
@@ -233,6 +233,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/frmts/iso8211/GNUmakefile gdal-3.2.0-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.2.0-fedora/frmts/iso8211/GNUmakefile 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/frmts/iso8211/GNUmakefile 2020-11-12 00:13:52.575881048 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/frmts/iso8211/GNUmakefile gdal-3.2.1-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.2.1-fedora/frmts/iso8211/GNUmakefile 2020-12-29 13:15:47.000000000 +0100
+++ gdal-3.2.1-fedora-new/frmts/iso8211/GNUmakefile 2021-01-04 21:49:35.992248405 +0100
@@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR)

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/doc/source/index.rst gdal-3.2.0-fedora-new/doc/source/index.rst
--- gdal-3.2.0-fedora/doc/source/index.rst 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/doc/source/index.rst 2020-11-12 00:13:53.348880975 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/doc/source/index.rst gdal-3.2.1-fedora-new/doc/source/index.rst
--- gdal-3.2.1-fedora/doc/source/index.rst 2020-12-29 13:15:47.000000000 +0100
+++ gdal-3.2.1-fedora-new/doc/source/index.rst 2021-01-04 21:49:36.681247532 +0100
@@ -4,8 +4,6 @@ GDAL
.. include:: ./about_no_title.rst

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/doc/Makefile gdal-3.2.0-fedora-new/doc/Makefile
--- gdal-3.2.0-fedora/doc/Makefile 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/doc/Makefile 2020-11-12 00:13:52.828881024 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/doc/Makefile gdal-3.2.1-fedora-new/doc/Makefile
--- gdal-3.2.1-fedora/doc/Makefile 2020-12-29 13:15:46.000000000 +0100
+++ gdal-3.2.1-fedora-new/doc/Makefile 2021-01-04 21:49:36.218248119 +0100
@@ -2,7 +2,7 @@
#

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference gdal-3.2.0-fedora/frmts/dods/GNUmakefile gdal-3.2.0-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.2.0-fedora/frmts/dods/GNUmakefile 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/frmts/dods/GNUmakefile 2020-11-12 00:13:52.314881073 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/frmts/dods/GNUmakefile gdal-3.2.1-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.2.1-fedora/frmts/dods/GNUmakefile 2020-12-29 13:15:47.000000000 +0100
+++ gdal-3.2.1-fedora-new/frmts/dods/GNUmakefile 2021-01-04 21:49:35.758248701 +0100
@@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o
@ -10,9 +10,9 @@ diff -rupN --no-dereference gdal-3.2.0-fedora/frmts/dods/GNUmakefile gdal-3.2.0-
default: $(OBJ:.o=.$(OBJ_EXT))
diff -rupN --no-dereference gdal-3.2.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.2.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.2.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2020-10-26 14:05:39.000000000 +0100
+++ gdal-3.2.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2020-11-12 00:13:52.314881073 +0100
diff -rupN --no-dereference gdal-3.2.1-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.2.1-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2020-12-29 13:15:47.000000000 +0100
+++ gdal-3.2.1-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-01-04 21:49:35.758248701 +0100
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o

View File

@ -1,2 +1,2 @@
SHA512 (gdalautotest-3.2.0.tar.gz) = 8ac8283c10ff397fc7cadceb02871c5c9e25d86d63c1eac8bb0e6e3c45f742c70143b759d20c7fb2e350b09528dad4d9449e863456d6283170637c1fdb7cc65a
SHA512 (gdal-3.2.0-fedora.tar.xz) = 0fa73c1d188646b08b139c85f7b339e638d593e3d58fda8a93183f66dcbf62feba10423cd4a1669bef59aa2bcf423686dec63e2a9e95e173666793eb3492dcd0
SHA512 (gdal-3.2.1-fedora.tar.xz) = bdc0f25c0bec5f9de48ae3ba53c75e2b19da39338d35dcb714948dded4cc5df9f9b951687d8b40205a37f83fbeb20d65d3fd2bcb60e4a5000a115487a01775b2
SHA512 (gdalautotest-3.2.1.tar.gz) = 2cfa364b596bda8e0609fd31da8802f662ef0a3da09ba3a1e9444a855d2271a0d9f2191f4352aae5919d747f355a0573509f8ee5e117aa65bc605eb10d4d2ed8