- Fix problem with to large box boundaries Resolves: #197747
This commit is contained in:
parent
f4776b8e91
commit
5bde41c0a8
22
gd-2.0.33-BoxBound.patch
Normal file
22
gd-2.0.33-BoxBound.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- gd-2.0.33/gdft.c.pom 2004-11-02 22:00:48.000000000 +0100
|
||||
+++ gd-2.0.33/gdft.c 2006-11-21 09:25:49.000000000 +0100
|
||||
@@ -1237,7 +1237,8 @@
|
||||
glyph_min.x = penf.x + slot->metrics.horiBearingX;
|
||||
glyph_min.y = penf.y - slot->metrics.horiBearingY;
|
||||
|
||||
-#if 0
|
||||
+// #if 0 - this version of glyph_max.x setting fixes problem with
|
||||
+// too large bouonding box
|
||||
if (ch == ' ') /* special case for trailing space */
|
||||
{
|
||||
glyph_max.x = penf.x + horiAdvance;
|
||||
@@ -1246,7 +1247,8 @@
|
||||
{
|
||||
glyph_max.x = glyph_min.x + slot->metrics.width;
|
||||
}
|
||||
-#else
|
||||
+//#else
|
||||
+#if 0
|
||||
glyph_max.x = penf.x + horiAdvance;
|
||||
#endif
|
||||
glyph_max.y = glyph_min.y + slot->metrics.height;
|
8
gd.spec
8
gd.spec
@ -1,7 +1,7 @@
|
||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||
Name: gd
|
||||
Version: 2.0.33
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
Group: System Environment/Libraries
|
||||
License: BSD-style
|
||||
URL: http://www.boutell.com/gd/
|
||||
@ -14,6 +14,7 @@ Patch4: gd-loop.patch
|
||||
Patch5: gd-sparc64.patch
|
||||
Patch6: gd-2.0.33-overflow.patch
|
||||
Patch7: gd-2.0.33-AALineThick.patch
|
||||
Patch8: gd-2.0.33-BoxBound.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: freetype-devel, fontconfig-devel, libX11-devel, libXpm-devel
|
||||
BuildRequires: libjpeg-devel, libpng-devel, zlib-devel, pkgconfig
|
||||
@ -61,6 +62,7 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
||||
%patch5 -p1 -b .sparc64
|
||||
%patch6 -p1 -b .overflow
|
||||
%patch7 -p1 -b .AALineThick
|
||||
%patch8 -p1 -b .bb
|
||||
|
||||
%build
|
||||
%configure --disable-rpath
|
||||
@ -100,6 +102,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 21 2006 Ivana Varekova <varekova@redhat.com> 2.0.33-11
|
||||
- Fix problem with to large box boundaries
|
||||
Resolves: #197747
|
||||
|
||||
* Thu Nov 16 2006 Ivana Varekova <varekova@redhat.com> 2.0.33-10
|
||||
- added 'thick' - variable support for AA line (#198042)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user