- Update to 2.2.3
- use -msse -mfpmath=sse build options (x86-32)
This commit is contained in:
parent
ec7807215a
commit
41b3b9e60b
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ gd-2.0.35.tar.bz2
|
||||
/libgd-2.1.1.tar.xz
|
||||
/libgd-2.2.1.tar.xz
|
||||
/libgd-2.2.2.tar.xz
|
||||
/libgd-2.2.3.tar.xz
|
||||
|
@ -1,22 +0,0 @@
|
||||
From a184630682c25e314979b459950ec6c81fa82a5f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ond=C5=99ej=20Sur=C3=BD?= <ondrej@sury.org>
|
||||
Date: Fri, 20 May 2016 10:15:57 +0200
|
||||
Subject: [PATCH] Initialize full_filename in tests/gdimagefile/gdnametest.c
|
||||
|
||||
---
|
||||
tests/gdimagefile/gdnametest.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/gdimagefile/gdnametest.c b/tests/gdimagefile/gdnametest.c
|
||||
index 2be648e..a339e69 100644
|
||||
--- a/tests/gdimagefile/gdnametest.c
|
||||
+++ b/tests/gdimagefile/gdnametest.c
|
||||
@@ -84,7 +84,7 @@ do_test() {
|
||||
for (n = 0; names[n].nm; n++) {
|
||||
gdImagePtr orig, copy;
|
||||
int status;
|
||||
- char *full_filename;
|
||||
+ char *full_filename = NULL;
|
||||
|
||||
/* Some image readers are buggy and crash the program so we
|
||||
* skip them. Bug fixers should remove these from the list of
|
18
gd.spec
18
gd.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||
Name: gd
|
||||
Version: 2.2.2
|
||||
Version: 2.2.3
|
||||
Release: 1%{?prever}%{?short}%{?dist}
|
||||
Group: System Environment/Libraries
|
||||
License: MIT
|
||||
@ -18,7 +18,6 @@ Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/li
|
||||
%endif
|
||||
|
||||
Patch1: gd-2.1.0-multilib.patch
|
||||
Patch2: gd-2.2.1-initialize-full_filename.patch
|
||||
|
||||
BuildRequires: freetype-devel
|
||||
BuildRequires: fontconfig-devel
|
||||
@ -77,7 +76,6 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
||||
%prep
|
||||
%setup -q -n libgd-%{version}%{?prever:-%{prever}}
|
||||
%patch1 -p1 -b .mlib
|
||||
%patch2 -p1 -b .full_filename
|
||||
|
||||
: $(perl config/getver.pl)
|
||||
|
||||
@ -99,6 +97,11 @@ CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
|
||||
/usr/share/X11/fonts/Type1:\
|
||||
/usr/share/fonts/liberation\"'"
|
||||
|
||||
%ifarch %{ix86}
|
||||
# see https://github.com/libgd/libgd/issues/242
|
||||
CFLAGS="$CFLAGS -msse -mfpmath=sse"
|
||||
%endif
|
||||
|
||||
%configure \
|
||||
--with-tiff=%{_prefix} \
|
||||
--disable-rpath
|
||||
@ -112,11 +115,6 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/libgd.a
|
||||
|
||||
|
||||
%check
|
||||
%ifarch %{ix86}
|
||||
# see https://github.com/libgd/libgd/issues/242
|
||||
export XFAIL_TESTS="gdimagerotate/bug00067 $XFAIL_TESTS"
|
||||
%endif
|
||||
|
||||
: Upstream test suite
|
||||
make check
|
||||
|
||||
@ -147,6 +145,10 @@ grep %{version} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gdlib.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 22 2016 Remi Collet <remi@fedoraproject.org> - 2.2.3-1
|
||||
- Update to 2.2.3
|
||||
- use -msse -mfpmath=sse build options (x86-32)
|
||||
|
||||
* Fri Jun 24 2016 Remi Collet <remi@fedoraproject.org> - 2.2.2-1
|
||||
- Update to 2.2.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user