67 lines
2.8 KiB
Diff
67 lines
2.8 KiB
Diff
--- libada/Makefile.in.jj 2009-01-14 12:07:35.000000000 +0100
|
|
+++ libada/Makefile.in 2009-01-15 14:25:33.000000000 +0100
|
|
@@ -69,18 +69,40 @@ version := $(shell cat $(srcdir)/../gcc/
|
|
libsubdir := $(libdir)/gcc/$(target_noncanonical)/$(version)$(MULTISUBDIR)
|
|
ADA_RTS_DIR=$(GCC_DIR)/ada/rts$(subst /,_,$(MULTISUBDIR))
|
|
|
|
+DEFAULTMULTIFLAGS :=
|
|
+ifeq ($(MULTISUBDIR),)
|
|
+targ:=$(subst -, ,$(target))
|
|
+arch:=$(word 1,$(targ))
|
|
+ifeq ($(words $(targ)),2)
|
|
+osys:=$(word 2,$(targ))
|
|
+else
|
|
+osys:=$(word 3,$(targ))
|
|
+endif
|
|
+ifeq ($(strip $(filter-out i%86 x86_64 powerpc% ppc% s390% sparc% linux%, $(arch) $(osys))),)
|
|
+ifeq ($(shell $(CC) $(CFLAGS) -print-multi-os-directory),../lib64)
|
|
+DEFAULTMULTIFLAGS := -m64
|
|
+else
|
|
+ifeq ($(strip $(filter-out s390%, $(arch))),)
|
|
+DEFAULTMULTIFLAGS := -m31
|
|
+else
|
|
+DEFAULTMULTIFLAGS := -m32
|
|
+endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
+
|
|
# exeext should not be used because it's the *host* exeext. We're building
|
|
# a *target* library, aren't we?!? Likewise for CC. Still, provide bogus
|
|
# definitions just in case something slips through the safety net provided
|
|
# by recursive make invocations in gcc/ada/Makefile.in
|
|
LIBADA_FLAGS_TO_PASS = \
|
|
"MAKEOVERRIDES=" \
|
|
- "LDFLAGS=$(LDFLAGS)" \
|
|
+ "LDFLAGS=$(strip $(LDFLAGS) $(DEFAULTMULTIFLAGS))" \
|
|
"LN_S=$(LN_S)" \
|
|
"SHELL=$(SHELL)" \
|
|
- "GNATLIBFLAGS=$(GNATLIBFLAGS) $(MULTIFLAGS)" \
|
|
- "GNATLIBCFLAGS=$(GNATLIBCFLAGS) $(MULTIFLAGS)" \
|
|
- "GNATLIBCFLAGS_FOR_C=$(GNATLIBCFLAGS_FOR_C) $(MULTIFLAGS)" \
|
|
+ "GNATLIBFLAGS=$(strip $(GNATLIBFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
|
+ "GNATLIBCFLAGS=$(strip $(GNATLIBCFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
|
+ "GNATLIBCFLAGS_FOR_C=$(strip $(GNATLIBCFLAGS_FOR_C) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
|
"TARGET_LIBGCC2_CFLAGS=$(TARGET_LIBGCC2_CFLAGS)" \
|
|
"THREAD_KIND=$(THREAD_KIND)" \
|
|
"TRACE=$(TRACE)" \
|
|
@@ -91,7 +113,7 @@ LIBADA_FLAGS_TO_PASS = \
|
|
"exeext=.exeext.should.not.be.used " \
|
|
'CC=the.host.compiler.should.not.be.needed' \
|
|
"GCC_FOR_TARGET=$(CC)" \
|
|
- "CFLAGS=$(CFLAGS) $(WARN_CFLAGS)"
|
|
+ "CFLAGS=$(strip $(CFLAGS) $(DEFAULTMULTIFLAGS) $(WARN_CFLAGS))"
|
|
|
|
# Rules to build gnatlib.
|
|
.PHONY: gnatlib gnatlib-plain gnatlib-sjlj gnatlib-zcx gnatlib-shared oscons
|
|
--- gcc/ada/make.adb 2008-11-07 23:00:32.000000000 +0100
|
|
+++ gcc/ada/make.adb 2009-01-16 17:55:02.000000000 +0100
|
|
@@ -8039,6 +8039,7 @@ package body Make is
|
|
or else Argv (2 .. Argv'Last) = "pg"
|
|
or else (Argv (2) = 'm' and then Argv'Last > 2)
|
|
or else (Argv (2) = 'f' and then Argv'Last > 2)
|
|
+ or else (Argv'Last >= 8 and then Argv (2 .. 8) = "-param=")
|
|
then
|
|
Add_Switch (Argv, Compiler, And_Save => And_Save);
|
|
Add_Switch (Argv, Linker, And_Save => And_Save);
|