gcc/gcc5-pr64738.patch

29 lines
1.1 KiB
Diff

2015-01-23 Jakub Jelinek <jakub@redhat.com>
PR go/64738
* Makefile.am (AM_LDFLAGS): Remove -static-libgo flag.
* Makefile.in: Regenerated.
--- gotools/Makefile.am 2015-01-23 09:42:05.747471685 +0100
+++ gotools/Makefile.am 2015-01-23 21:04:36.970202637 +0100
@@ -38,7 +38,7 @@ endif
GOCFLAGS = $(CFLAGS_FOR_TARGET)
GOCOMPILE = $(GOCOMPILER) $(GOCFLAGS)
-AM_LDFLAGS = -L $(libgodir) -L $(libgodir)/.libs -static-libgo
+AM_LDFLAGS = -L $(libgodir) -L $(libgodir)/.libs
GOLINK = $(GOCOMPILER) $(AM_GOCFLAGS) $(LDFLAGS) $(AM_LDFLAGS) -o $@
cmdsrcdir = $(srcdir)/../libgo/go/cmd
--- gotools/Makefile.in 2015-01-23 09:42:05.724472081 +0100
+++ gotools/Makefile.in 2015-01-23 21:04:44.940065201 +0100
@@ -230,7 +230,7 @@ LIBGODEP = $(libgodir)/libgo.la
# Use the compiler we just built.
@NATIVE_TRUE@GOCOMPILER = $(GOC_FOR_TARGET)
GOCOMPILE = $(GOCOMPILER) $(GOCFLAGS)
-AM_LDFLAGS = -L $(libgodir) -L $(libgodir)/.libs -static-libgo
+AM_LDFLAGS = -L $(libgodir) -L $(libgodir)/.libs
GOLINK = $(GOCOMPILER) $(AM_GOCFLAGS) $(LDFLAGS) $(AM_LDFLAGS) -o $@
cmdsrcdir = $(srcdir)/../libgo/go/cmd
go_cmd_go_files = \