9.0.1-0.15
This commit is contained in:
parent
a3fcce8f5b
commit
fd99b9378d
1
.gitignore
vendored
1
.gitignore
vendored
@ -73,3 +73,4 @@
|
||||
/gcc-9.0.1-20190328.tar.xz
|
||||
/gcc-9.0.1-20190415.tar.xz
|
||||
/gcc-9.0.1-20190418.tar.xz
|
||||
/gcc-9.0.1-20190426.tar.xz
|
||||
|
24
gcc.spec
24
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20190418
|
||||
%global SVNREV 270440
|
||||
%global DATE 20190426
|
||||
%global SVNREV 270616
|
||||
%global gcc_version 9.0.1
|
||||
%global gcc_major 9
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 0.14
|
||||
%global gcc_release 0.15
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -254,7 +254,6 @@ Patch8: gcc9-foffload-default.patch
|
||||
Patch9: gcc9-Wno-format-security.patch
|
||||
Patch10: gcc9-rh1574936.patch
|
||||
Patch11: gcc9-d-shared-libphobos.patch
|
||||
Patch12: gcc9-pr89093.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -765,7 +764,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr89093~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -2957,6 +2955,22 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Apr 26 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.14
|
||||
- update from trunk and 9 branch
|
||||
- gcc 9.1-rc1
|
||||
- PRs c++/87366, c++/87554, c++/89900, c++/90108, c++/90138, c++/90171,
|
||||
c++/90190, c++/90227, c++/90236, c/89888, d/88431, d/88654, d/89293,
|
||||
d/89432, d/90086, d/90250, debug/90131, fortran/57284, fortran/90166,
|
||||
ipa/85051, libstdc++/90165, libstdc++/90220, libstdc++/90239,
|
||||
middle-end/85164, middle-end/89765, middle-end/89797,
|
||||
middle-end/90139, middle-end/90194, middle-end/90213, other/90257,
|
||||
rtl-optimization/84032, rtl-optimization/87871,
|
||||
rtl-optimization/87979, target/89929, target/89952, target/90187,
|
||||
target/90193, translation/90118, tree-optimization/88055,
|
||||
tree-optimization/90021, tree-optimization/90037,
|
||||
tree-optimization/90078, tree-optimization/90208,
|
||||
tree-optimization/90211, tree-optimization/90240
|
||||
|
||||
* Thu Apr 18 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.14
|
||||
- update from trunk
|
||||
- PRs bootstrap/89864, c++/86953, c++/89325, c++/90047, c++/90124,
|
||||
|
@ -1,118 +0,0 @@
|
||||
2019-01-29 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
|
||||
|
||||
PR target/89093
|
||||
* config/arm/arm-cpus.in: Add -mfpu=none support.
|
||||
* config/arm/arm-tables.opt: Likewise.
|
||||
* config/arm/arm.c (arm_options_perform_arch_sanity_checks): Remove
|
||||
error for no FPU.
|
||||
|
||||
* config/arm/pr-support.c: Add #pragma GCC target ("fpu=none").
|
||||
* config/arm/unwind-arm.c: Likewise.
|
||||
* unwind-c.c: Likewise, #ifdef __arm__ only.
|
||||
|
||||
* libsupc++/eh_personality.cc: Add #pragma GCC target ("fpu=none")
|
||||
for __arm__.
|
||||
|
||||
--- gcc/config/arm/arm-cpus.in
|
||||
+++ gcc/config/arm/arm-cpus.in
|
||||
@@ -128,6 +128,7 @@ define feature cmse
|
||||
|
||||
# Floating point and Neon extensions.
|
||||
# VFPv1 is not supported in GCC.
|
||||
+define feature nofp
|
||||
|
||||
# Vector floating point v2.
|
||||
define feature vfpv2
|
||||
@@ -258,6 +259,7 @@ define fgroup ARMv8m_main ARMv7m armv8 cmse
|
||||
define fgroup ARMv8r ARMv8a
|
||||
|
||||
# Useful combinations.
|
||||
+define fgroup NONE nofp
|
||||
define fgroup VFPv2 vfpv2
|
||||
define fgroup VFPv3 VFPv2 vfpv3
|
||||
define fgroup VFPv4 VFPv3 vfpv4 fp16conv
|
||||
@@ -1394,6 +1396,9 @@ end cpu cortex-r52
|
||||
# begin fpu <name>
|
||||
# isa <isa-flags-list>
|
||||
# end fpu <name>
|
||||
+begin fpu none
|
||||
+isa NONE FP_DBL
|
||||
+end fpu none
|
||||
|
||||
begin fpu vfp
|
||||
isa VFPv2 FP_DBL
|
||||
--- gcc/config/arm/arm-tables.opt
|
||||
+++ gcc/config/arm/arm-tables.opt
|
||||
@@ -353,6 +353,9 @@ Enum
|
||||
Name(arm_fpu) Type(enum fpu_type)
|
||||
Known ARM FPUs (for use with the -mfpu= option):
|
||||
|
||||
+EnumValue
|
||||
+Enum(arm_fpu) String(none) Value(TARGET_FPU_none)
|
||||
+
|
||||
EnumValue
|
||||
Enum(arm_fpu) String(vfp) Value(TARGET_FPU_vfp)
|
||||
|
||||
--- gcc/config/arm/arm.c
|
||||
+++ gcc/config/arm/arm.c
|
||||
@@ -3761,11 +3761,7 @@ arm_options_perform_arch_sanity_checks (
|
||||
if (arm_abi == ARM_ABI_IWMMXT)
|
||||
arm_pcs_default = ARM_PCS_AAPCS_IWMMXT;
|
||||
else if (TARGET_HARD_FLOAT_ABI)
|
||||
- {
|
||||
- arm_pcs_default = ARM_PCS_AAPCS_VFP;
|
||||
- if (!bitmap_bit_p (arm_active_target.isa, isa_bit_vfpv2))
|
||||
- error ("%<-mfloat-abi=hard%>: selected processor lacks an FPU");
|
||||
- }
|
||||
+ arm_pcs_default = ARM_PCS_AAPCS_VFP;
|
||||
else
|
||||
arm_pcs_default = ARM_PCS_AAPCS;
|
||||
}
|
||||
--- libgcc/config/arm/pr-support.c
|
||||
+++ libgcc/config/arm/pr-support.c
|
||||
@@ -21,6 +21,8 @@
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+
|
||||
#include "unwind.h"
|
||||
|
||||
/* We add a prototype for abort here to avoid creating a dependency on
|
||||
--- libgcc/config/arm/unwind-arm.c
|
||||
+++ libgcc/config/arm/unwind-arm.c
|
||||
@@ -21,6 +21,8 @@
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+
|
||||
#include "unwind.h"
|
||||
|
||||
/* Misc constants. */
|
||||
--- libgcc/unwind-c.c
|
||||
+++ libgcc/unwind-c.c
|
||||
@@ -24,6 +24,10 @@ a copy of the GCC Runtime Library Except
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#ifdef __arm__
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+#endif
|
||||
+
|
||||
#include "tconfig.h"
|
||||
#include "tsystem.h"
|
||||
#include "auto-target.h"
|
||||
--- libstdc++-v3/libsupc++/eh_personality.cc
|
||||
+++ libstdc++-v3/libsupc++/eh_personality.cc
|
||||
@@ -22,6 +22,10 @@
|
||||
// see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
// <http://www.gnu.org/licenses/>.
|
||||
|
||||
+#ifdef __arm__
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+#endif
|
||||
+
|
||||
#include <bits/c++config.h>
|
||||
#include <cstdlib>
|
||||
#include <bits/exception_defines.h>
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-9.0.1-20190418.tar.xz) = 7fd8b5a1d184632ae42dad7cf71d280061e96c106f23b1697823f0d6c2f8023f7e4351059d7d8faae5f6303a91cf2af760d8cd3d507c575f32a0256268c125ab
|
||||
SHA512 (gcc-9.0.1-20190426.tar.xz) = a1680dba81d9779b3579ebde62f0887a0a6dbffd23ca758ab3013543057d5cc50e415974aa063eccfee473159572e3c317f8a586feafbaf19ee4a187015bed71
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||
|
Loading…
Reference in New Issue
Block a user