4.8.1-3
This commit is contained in:
parent
c27a7db22e
commit
f9bd6769eb
2
gcc.spec
2
gcc.spec
@ -194,7 +194,6 @@ Patch10: gcc48-pr38757.patch
|
|||||||
Patch11: gcc48-libstdc++-docs.patch
|
Patch11: gcc48-libstdc++-docs.patch
|
||||||
Patch12: gcc48-no-add-needed.patch
|
Patch12: gcc48-no-add-needed.patch
|
||||||
Patch13: gcc48-pr56564.patch
|
Patch13: gcc48-pr56564.patch
|
||||||
Patch14: gcc48-pr57537.patch
|
|
||||||
|
|
||||||
Patch1000: fastjar-0.97-segfault.patch
|
Patch1000: fastjar-0.97-segfault.patch
|
||||||
Patch1001: fastjar-0.97-len1.patch
|
Patch1001: fastjar-0.97-len1.patch
|
||||||
@ -749,7 +748,6 @@ package or when debugging this package.
|
|||||||
%endif
|
%endif
|
||||||
%patch12 -p0 -b .no-add-needed~
|
%patch12 -p0 -b .no-add-needed~
|
||||||
%patch13 -p0 -b .pr56564~
|
%patch13 -p0 -b .pr56564~
|
||||||
%patch14 -p0 -b .pr57537~
|
|
||||||
|
|
||||||
%if 0%{?_enable_debug_packages}
|
%if 0%{?_enable_debug_packages}
|
||||||
cat > split-debuginfo.sh <<\EOF
|
cat > split-debuginfo.sh <<\EOF
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
2013-06-12 Jakub Jelinek <jakub@redhat.com>
|
|
||||||
|
|
||||||
PR tree-optimization/57537
|
|
||||||
* tree-vect-patterns.c (vect_recog_widen_mult_pattern): If
|
|
||||||
vect_handle_widen_op_by_const, convert oprnd1 to half_type1.
|
|
||||||
|
|
||||||
--- gcc/tree-vect-patterns.c.jj 2013-05-17 10:53:10.000000000 +0200
|
|
||||||
+++ gcc/tree-vect-patterns.c 2013-06-12 09:49:30.151854270 +0200
|
|
||||||
@@ -640,7 +640,10 @@ vect_recog_widen_mult_pattern (vec<gimpl
|
|
||||||
&& vect_handle_widen_op_by_const (last_stmt, MULT_EXPR, oprnd1,
|
|
||||||
&oprnd0, stmts, type,
|
|
||||||
&half_type0, def_stmt0))
|
|
||||||
- half_type1 = half_type0;
|
|
||||||
+ {
|
|
||||||
+ half_type1 = half_type0;
|
|
||||||
+ oprnd1 = fold_convert (half_type1, oprnd1);
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
return NULL;
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user