Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
e6d4d7c8ad
2
.gitignore
vendored
2
.gitignore
vendored
@ -88,3 +88,5 @@
|
||||
/gcc-13.0.1-20230117.tar.xz
|
||||
/gcc-13.0.1-20230127.tar.xz
|
||||
/newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz
|
||||
/gcc-13.0.1-20230208.tar.xz
|
||||
/gcc-13.0.1-20230215.tar.xz
|
||||
|
56
gcc.spec
56
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20230127
|
||||
%global gitrev 4faac89a6b542c0d94019eeadc333ef789f37c9d
|
||||
%global DATE 20230215
|
||||
%global gitrev 76b508266ac7460db2e4fe9eba298520ae1eda70
|
||||
%global gcc_version 13.0.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -136,7 +136,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.2.2.riscv64%{?dist}
|
||||
Release: %{gcc_release}.4.0.riscv64%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -286,7 +286,6 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr106746-revert.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -457,9 +456,11 @@ programs with the GNU Compiler Collection.
|
||||
%package -n libgfortran
|
||||
Summary: Fortran runtime
|
||||
Autoreq: true
|
||||
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
|
||||
%if %{build_libquadmath}
|
||||
Requires: libquadmath = %{version}-%{release}
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description -n libgfortran
|
||||
This package contains Fortran shared library which is needed to run
|
||||
@ -861,7 +862,6 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr106746-revert~
|
||||
|
||||
%patch50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3468,10 +3468,54 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 01 2023 David Abdurachmanov <davidlt@rivosinc.com> 13.0.1-0.2.0.riscv64
|
||||
* Fri Feb 17 2023 David Abdurachmanov <davidlt@rivosinc.com> 13.0.1-0.4.0.riscv64
|
||||
- Update config.{sub,guess} scripts for ISL
|
||||
- Fix annobin plugin Fedora version check
|
||||
- Package riscv_vector.h (vector intrinsics) header
|
||||
- Enable libitm for riscv64
|
||||
|
||||
* Wed Feb 15 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.4
|
||||
- update from trunk
|
||||
- PRs analyzer/108704, analyzer/108733, analyzer/108745, c++/106675,
|
||||
c++/107079, c++/108698, d/107469, fortran/69636, fortran/103259,
|
||||
fortran/103475, fortran/103779, fortran/107424, fortran/108512,
|
||||
ipa/108605, ipa/108679, libstdc++/103934, middle-end/26854,
|
||||
middle-end/106080, rtl-optimization/108681, sanitizer/108777,
|
||||
target/96373, target/100758, target/103109, target/108102,
|
||||
target/108516, target/108723, target/108738, target/108787,
|
||||
target/108790, testsuite/106120, tree-optimization/28614,
|
||||
tree-optimization/96921, tree-optimization/106722,
|
||||
tree-optimization/107561, tree-optimization/108316,
|
||||
tree-optimization/108355, tree-optimization/108520,
|
||||
tree-optimization/108571, tree-optimization/108684,
|
||||
tree-optimization/108687, tree-optimization/108688,
|
||||
tree-optimization/108691, tree-optimization/108692,
|
||||
tree-optimization/108724, tree-optimization/108782
|
||||
|
||||
* Wed Feb 8 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.3
|
||||
- update from trunk
|
||||
- PRs analyzer/108616, analyzer/108633, analyzer/108661, c++/101071,
|
||||
c++/102870, c++/107461, c++/107593, c++/107755, c++/108158,
|
||||
c++/108559, c++/108579, c++/108597, c++/108607, c++/96745, c/108150,
|
||||
c/108192, debug/106746, debug/108573, driver/108572, fortran/103506,
|
||||
fortran/108450, fortran/108451, fortran/108453, fortran/108527,
|
||||
fortran/108592, fortran/108609, fortran/95107, ipa/107300, ipa/108384,
|
||||
ipa/108509, ipa/108511, libstdc++/108636, libstdc++/108672,
|
||||
middle-end/108435, middle-end/108500, middle-end/108625,
|
||||
modula2/107234, modula2/108135, modula2/108462, modula2/108551,
|
||||
modula2/108612, rtl-optimization/108086, rtl-optimization/108463,
|
||||
rtl-optimization/108508, rtl-optimization/108596, sanitizer/108106,
|
||||
target/104921, target/107674, target/108443, target/108484,
|
||||
target/108589, target/108599, testsuite/108604, testsuite/108632,
|
||||
tree-optimization/26854, tree-optimization/106433,
|
||||
tree-optimization/106923, tree-optimization/107570,
|
||||
tree-optimization/108356, tree-optimization/108359,
|
||||
tree-optimization/108385, tree-optimization/108574,
|
||||
tree-optimization/108582, tree-optimization/108601,
|
||||
tree-optimization/108608, tree-optimization/108639,
|
||||
tree-optimization/108647, tree-optimization/108655
|
||||
- drop libgfortran dependency on libquadmath for F28+ or RHEL8+, gcc-gfortran
|
||||
still needs to depend on both libquadmath and libquadmath-devel though
|
||||
|
||||
* Sat Jan 28 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.2
|
||||
- update from trunk
|
||||
|
@ -1,63 +0,0 @@
|
||||
Revert:
|
||||
[PR106746] drop cselib addr lookup in debug insn mem
|
||||
|
||||
The testcase used to get scheduled differently depending on the
|
||||
presence of debug insns with MEMs. It's not clear to me why those
|
||||
MEMs affected scheduling, but the cselib pre-canonicalization of the
|
||||
MEM address is not used at all when analyzing debug insns, so the
|
||||
memory allocation and lookup are pure waste. Somehow, avoiding that
|
||||
waste fixes the problem, or makes it go latent.
|
||||
|
||||
2023-01-19 Alexandre Oliva <oliva@adacore.com>
|
||||
|
||||
PR debug/106746
|
||||
* sched-deps.cc (sched_analyze_2): Skip cselib address lookup
|
||||
within debug insns.
|
||||
|
||||
--- gcc/sched-deps.cc
|
||||
+++ gcc/sched-deps.cc
|
||||
@@ -2605,26 +2605,26 @@ sched_analyze_2 (class deps_desc *deps, rtx x, rtx_insn *insn)
|
||||
|
||||
case MEM:
|
||||
{
|
||||
- if (!DEBUG_INSN_P (insn))
|
||||
- {
|
||||
- /* Reading memory. */
|
||||
- rtx_insn_list *u;
|
||||
- rtx_insn_list *pending;
|
||||
- rtx_expr_list *pending_mem;
|
||||
- rtx t = x;
|
||||
+ /* Reading memory. */
|
||||
+ rtx_insn_list *u;
|
||||
+ rtx_insn_list *pending;
|
||||
+ rtx_expr_list *pending_mem;
|
||||
+ rtx t = x;
|
||||
|
||||
- if (sched_deps_info->use_cselib)
|
||||
- {
|
||||
- machine_mode address_mode = get_address_mode (t);
|
||||
-
|
||||
- t = shallow_copy_rtx (t);
|
||||
- cselib_lookup_from_insn (XEXP (t, 0), address_mode, 1,
|
||||
- GET_MODE (t), insn);
|
||||
- XEXP (t, 0)
|
||||
- = cselib_subst_to_values_from_insn (XEXP (t, 0), GET_MODE (t),
|
||||
- insn);
|
||||
- }
|
||||
+ if (sched_deps_info->use_cselib)
|
||||
+ {
|
||||
+ machine_mode address_mode = get_address_mode (t);
|
||||
+
|
||||
+ t = shallow_copy_rtx (t);
|
||||
+ cselib_lookup_from_insn (XEXP (t, 0), address_mode, 1,
|
||||
+ GET_MODE (t), insn);
|
||||
+ XEXP (t, 0)
|
||||
+ = cselib_subst_to_values_from_insn (XEXP (t, 0), GET_MODE (t),
|
||||
+ insn);
|
||||
+ }
|
||||
|
||||
+ if (!DEBUG_INSN_P (insn))
|
||||
+ {
|
||||
t = canon_rtx (t);
|
||||
pending = deps->pending_read_insns;
|
||||
pending_mem = deps->pending_read_mems;
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.0.1-20230127.tar.xz) = 437494fad0d688d8c81d1bc6827bb139894fc74af4ca2d2a71dc7332304a988c4a358af38ffc15ab7c19fd5172398d00d6447301f560517d03a5367967694906
|
||||
SHA512 (gcc-13.0.1-20230215.tar.xz) = 630b739424128b17bbde6826164f01fff7a639598881f63c95921168bb35cc7393ceaa63f423bdfb5692ab8ad5a30b99d5681837e05f1b013671373adb2b0b71
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-472b6e78b3ba918d727698f79911360b7c808247.tar.xz) = 91690321bf96460c3b3e229199a6f752ed1c27c6933d4345dc7e237dc068f604ad211bb3a0373e14d4f332bee05b6227d6933e14e0b475ffdfea8b511ab735e6
|
||||
|
Loading…
Reference in New Issue
Block a user