This commit is contained in:
Jakub Jelinek 2007-09-22 13:39:39 +00:00
parent 3b9adfc334
commit b2bb76df75
2 changed files with 12 additions and 7 deletions

View File

@ -1,30 +1,32 @@
2007-09-22 Jakub Jelinek <jakub@redhat.com>
* configure.in (MAKEINFO): Handle makeinfo version 4.10 through 4.99.
* configure: Regenerated.
gcc/
* configure.ac (MAKEINFO): Handle makeinfo version 4.10 and above.
* configure: Regenerated.
2007-09-15 Alan Modra <amodra@bigpond.net.au>
* configure.in: Correct makeinfo version check.
* configure: Regenerate.
--- configure.in.jj 2007-02-20 16:41:55.000000000 -0500
+++ configure.in 2007-09-22 09:23:30.000000000 -0400
+++ configure.in 2007-09-22 09:36:04.000000000 -0400
@@ -2159,7 +2159,7 @@ changequote(,)
# For an installed makeinfo, we require it to be from texinfo 4.2 or
# higher, else we use the "missing" dummy.
if ${MAKEINFO} --version \
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])' >/dev/null 2>&1; then
+ | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|4\.[1-9][0-9]|[5-9])' >/dev/null 2>&1; then
+ | egrep 'texinfo[^0-9]*(4\.([2-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
:
else
MAKEINFO="$MISSING makeinfo"
--- configure.jj 2007-02-20 16:41:55.000000000 -0500
+++ configure 2007-09-22 09:24:08.000000000 -0400
+++ configure 2007-09-22 09:36:25.000000000 -0400
@@ -3574,7 +3574,7 @@ case " $build_configdirs " in
# For an installed makeinfo, we require it to be from texinfo 4.2 or
# higher, else we use the "missing" dummy.
if ${MAKEINFO} --version \
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])' >/dev/null 2>&1; then
+ | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|4\.[1-9][0-9]|[5-9])' >/dev/null 2>&1; then
+ | egrep 'texinfo[^0-9]*(4\.([2-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
:
else
MAKEINFO="$MISSING makeinfo"

View File

@ -155,6 +155,7 @@ Patch38: gcc41-pr27954.patch
Patch39: gcc41-pr33423.patch
Patch40: gcc41-scanf-fmt-check.patch
Patch41: gcc41-pr33506.patch
Patch42: gcc41-makeinfo-ver.patch
# On ARM EABI systems, we do want -gnueabi to be part of the
# target triple.
@ -479,6 +480,7 @@ which are required to run programs compiled with the GNAT.
%patch39 -p0 -b .pr33423~
%patch40 -p0 -b .scanf-fmt-check~
%patch41 -p0 -b .pr33506~
%patch42 -p0 -b .makeinfo-ver~
sed -i -e 's/4\.1\.3/4.1.2/' gcc/BASE-VER gcc/version.c
sed -i -e 's/" (Red Hat[^)]*)"/" (Red Hat %{version}-%{gcc_release})"/' gcc/version.c
@ -1636,6 +1638,7 @@ fi
* Sat Sep 22 2007 Jakub Jelinek <jakub@redhat.com> 4.1.2-26
- don't ignore throw specification of function types in type hashing
(PR c++/33506)
- handle makeinfo version >= 4.10 in gcc configury
* Mon Sep 17 2007 Jakub Jelinek <jakub@redhat.com> 4.1.2-25
- fix ICE on __builtin_mem*_chk if it couldn't be folded until